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Preface

Welcome to the C-SPY® Debugging Guide . The purpose of this guide is to help
you fully use the features in the IAR C-SPY® Debugger for debugging your
application based on the Arm core.

Who should read this guide

Read this guide if you plan to develop an application using IAR Embedded Workbench
and want to get the most out of the features available in C-SPY.

REQUIRED KNOWLEDGE

To use the tools in IAR Embedded Workbench, you should have working knowledge of:

o The architecture and instruction set of the Arm core you are using (refer to the chip
manufacturer's documentation)

® The C or C++ programming language
o Application development for embedded systems
o The operating system of your host computer.

For more information about the other development tools incorporated in the IDE, refer
to their respective documentation, see Other documentation, page 29.

How to use this guide

If you are new to using IAR Embedded Workbench, we suggest that you first read the
guide Getting Started with JAR Embedded Workbench® for an overview of the tools
and the features that the IDE offers.

If you already have had some experience using IAR Embedded Workbench, but need
refreshing on how to work with the IAR Systems development tools, the tutorials which
you can find in the IAR Information Center is a good place to begin. The process of
managing projects and building, as well as editing, is described in the /DE Project
Management and Building Guide for Arm, whereas information about how to use
C-SPY for debugging is described in this guide.

This guide describes a number of topics, where each topic section contains an
introduction which also covers concepts related to the topic. This will give you a good
understanding of the features in C-SPY. Furthermore, the topic section provides
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procedures with step-by-step descriptions to help you use the features. Finally, each
topic section gives all relevant reference information.

We also recommend the Glossary which you can find in the IDE Project Management
and Building Guide for Arm if you should encounter any unfamiliar terms in the AR
Systems user and reference guides.

What this guide contains

Below is a brief outline and summary of the chapters in this guide.

C-SPY® Debugging Guide
for Arm

Note: Some of the screenshots in this guide are taken from a similar product and not
from IAR Embedded Workbench for Arm.

PART |. BASIC DEBUGGING

The IAR C-SPY Debugger introduces you to the C-SPY debugger and to the
concepts that are related to debugging in general and to C-SPY in particular. The
chapter also introduces the various C-SPY drivers. The chapter briefly shows the
difference in functionality that the various C-SPY drivers provide.

Getting started using C-SPY helps you get started using C-SPY, which includes
setting up, starting, and adapting C-SPY for target hardware.

Executing your application describes the conceptual differences between source
and disassembly mode debugging, the facilities for executing your application, and
finally, how you can handle terminal input and output.

Variables and expressions describes the syntax of the expressions and variables
used in C-SPY, as well as the limitations on variable information. The chapter also
demonstrates the various methods for monitoring variables and expressions.

Breakpoints describes the breakpoint system and the various ways to set
breakpoints.

Memory and registers shows how you can examine memory and registers.

PART 2. ANALYZING YOUR APPLICATION

Trace describes how you can inspect the program flow up to a specific state using
trace data.

The application timeline describes the Timeline window, and how to use the
information in it to analyze your application’s behavior.

Profiling describes how the profiler can help you find the functions in your
application source code where the most time is spent during execution.
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o Code coverage describes how the code coverage functionality can help you verify
whether all parts of your code have been executed, thus identifying parts which have
not been executed.

® Power debugging describes techniques for power debugging and how you can use
C-SPY to find source code constructions that result in unexpected power
consumption.

o C-RUN runtime error checking describes how to use C-RUN for runtime error
checking.

PART 3. ADVANCED DEBUGGING

® Multicore debugging describes how to debug a target with multiple cores.

e Interrupts contains detailed information about the C-SPY interrupt simulation
system and how to configure the simulated interrupts to make them reflect the
interrupts of your target hardware.

® C-SPY macros describes the C-SPY macro system, its features, the purposes of
these features, and how to use them.

® The C-SPY command line utility—cspybat describes how to use C-SPY in batch
mode.

® Flash loaders describes the flash loader, what it is and how to use it.

PART 4. ADDITIONAL REFERENCE INFORMATION
® Debugger options describes the options you must set before you start the C-SPY
debugger.

e Additional information on C-SPY drivers describes menus and features provided by
the C-SPY drivers not described in any dedicated topics.

Other documentation

User documentation is available as hypertext PDFs and as a context-sensitive online
help system in HTML format. You can access the documentation from the Information
Center or from the Help menu in the IAR Embedded Workbench IDE. The online help
system is also available via the F1 key.
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Other documentation

USER AND REFERENCE GUIDES

The complete set of IAR Systems development tools is described in a series of guides.
Information about:

o System requirements and information about how to install and register the IAR
Systems products, is available in the booklet Quick Reference (available in the
product box) and the Installation and Licensing Guide.

o Using the IDE for project management and building, is available in the IDE Project
Management and Building Guide for Arm.

o Using the IAR C-SPY® Debugger and C-RUN runtime error checking, is available
in the C-SPY® Debugging Guide for Arm.

e Programming for the IAR C/C++ Compiler for Arm and linking using the AR
ILINK Linker, is available in the [AR C/C++ Development Guide for Arm.

o Programming for the AR Assembler for Arm, is available in the /AR Assembler
Reference Guide for Arm.

o Performing a static analysis using C-STAT and the required checks, is available in
the C-STAT® Static Analysis Guide.

o Developing safety-critical applications using the MISRA C guidelines, is available
in the JAR Embedded Workbench® MISRA C:2004 Reference Guide or the [AR
Embedded Workbench® MISRA C:1998 Reference Guide.

o Using I-jet, refer to the /AR Debug probes User Guide for I-jet®, I-jet Trace, and
I-scope.

o Using JTAGjet-Trace, refer to the JTAGjet-Trace User Guide for ARM.

o Using IAR J-Link and IAR J-Trace, refer to the J-Link/J-Trace User Guide.

e Porting application code and projects created with a previous version of the IAR
Embedded Workbench for Arm, is available in the IAR Embedded Workbench®
Migration Guide.

Note: Additional documentation might be available depending on your product
installation.

THE ONLINE HELP SYSTEM
The context-sensitive online help contains information about:

IDE project management and building
Debugging using the IAR C-SPY® Debugger
The IAR C/C++ Compiler

°
°
°
o The IAR Assembler

C-SPY® Debugging Guide
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o Keyword reference information for the DLIB library functions. To obtain reference
information for a function, select the function name in the editor window and press
F1.

e C-STAT
e MISRA C

WEB SITES

Recommended web sites:

® The Arm Limited web site, www.arm.com, that contains information and news
about the Arm cores.

o The IAR Systems web site, www.iar.com, that holds application notes and other
product information.

o The web site of the C standardization working group,
www.open-std.org/jtcl/sc22/wgl4.

o The web site of the C++ Standards Committee, www.open-std.org/jtcl/sc22/wg21.
o The C++ programming language web site, isocpp.org.
This web site also has a list of recommended books about C++ programming.

o The C and C++ reference web site, en.cppreference.com.

Document conventions

When, in the IAR Systems documentation, we refer to the programming language C, the
text also applies to C++, unless otherwise stated.

When referring to a directory in your product installation, for example arm\doc, the full
path to the location is assumed, for example c¢: \Program Files\IAR
Systems\Embedded Workbench N.n\arm\doc, where the initial digit of the version
number reflects the initial digit of the version number of the IAR Embedded Workbench
shared components.

TYPOGRAPHIC CONVENTIONS
The IAR Systems documentation set uses the following typographic conventions:

Style Used for

computer * Source code examples and file paths.
* Text on the command line.
* Binary, hexadecimal, and octal numbers.

Table 1: Typographic conventions used in this guide
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Style Used for

parameter A placeholder for an actual value used as a parameter, for example
filename.h where filename represents the name of the file.

[option] An optional part of a directive, where [ and ] are not part of the actual
directive, but any [, 1, {, or } are part of the directive syntax.

{option} A mandatory part of a directive, where { and } are not part of the
actual directive, butany [, ], {, or } are part of the directive syntax.

[option] An optional part of a command.

[a]b|c] An optional part of a command with alternatives.

{a|b]|c} A mandatory part of a command with alternatives.

bold Names of menus, menu commands, buttons, and dialog boxes that
appear on the screen.

italic * A cross-reference within this guide or to another guide.

3

* Emphasis.

An ellipsis indicates that the previous item can be repeated an arbitrary
number of times.

Identifies instructions specific to the IAR Embedded Workbench® IDE
interface.

Identifies instructions specific to the command line interface.

Identifies helpful tips and programming hints.

Identifies warnings.

Table 1: Typographic conventions used in this guide (Continued)

NAMING CONVENTIONS

The following naming conventions are used for the products and tools from IAR
Systems®, when referred to in the documentation:

Brand name

Generic term

IAR Embedded Workbench® for Arm IAR Embedded Workbench®
IAR Embedded Workbench® IDE for Arm the IDE

IAR C-SPY® Debugger for Arm C-SPY, the debugger

IAR C-SPY® Simulator the simulator

IAR C/C++ Compiler™ for Arm the compiler

IAR Assembler™ for Arm the assembler

Table 2: Naming conventions used in this guide
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Brand name Generic term
IAR ILINK Linker™ ILINK, the linker
IAR DLIB Runtime Environment™ the DLIB runtime environment

Table 2: Naming conventions used in this guide (Continued)

33



Document conventions

C-SPY® Debugging Guide
34 for Arm



Part |. Basic debugging

This part of the C-SPY® Debugging Guide for Arm includes these chapters:

e The IAR C-SPY Debugger
e Getting started using C-SPY
e Executing your application
e Variables and expressions

e Breakpoints

e Memory and registers

w

.hmuhhhhi
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The IAR C-SPY Debugger

e Introduction to C-SPY

e Debugger concepts

e C-SPY drivers overview
e The IAR C-SPY Simulator

e The C-SPY hardware debugger drivers

Introduction to C-SPY

These topics are covered:

o An integrated environment
o General C-SPY debugger features

e RTOS awareness

AN INTEGRATED ENVIRONMENT

C-SPY is a high-level-language debugger for embedded applications. It is designed for
use with the IAR Systems compilers and assemblers, and is completely integrated in the
IDE, providing development and debugging within the same application. This will give
you possibilities such as:

e Editing while debugging. During a debug session, you can make corrections directly
in the same source code window that is used for controlling the debugging. Changes
will be included in the next project rebuild.

e Setting breakpoints at any point during the development cycle. You can inspect and
modify breakpoint definitions also when the debugger is not running, and
breakpoint definitions flow with the text as you edit. Your debug settings, such as
watch properties, window layouts, and register groups will be preserved between
your debug sessions.

All windows that are open in the Embedded Workbench workspace will stay open when

you start the C-SPY Debugger. In addition, a set of C-SPY -specific windows are opened.
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GENERAL C-SPY DEBUGGER FEATURES

Because IAR Systems provides an entire toolchain, the output from the compiler and
linker can include extensive debug information for the debugger, resulting in good
debugging possibilities for you.

C-SPY offers these general features:

Source and disassembly level debugging

C-SPY allows you to switch between source and disassembly debugging as required,
for both C or C++ and assembler source code.

Single-stepping on a function call level

Compared to traditional debuggers, where the finest granularity for source level
stepping is line by line, C-SPY provides a finer level of control by identifying every
statement and function call as a step point. This means that each function call—
inside expressions, and function calls that are part of parameter lists to other
functions—can be single-stepped. The latter is especially useful when debugging
C++ code, where numerous extra function calls are made, for example to object
constructors.

Code and data breakpoints

The C-SPY breakpoint system lets you set breakpoints of various kinds in the
application being debugged, allowing you to stop at locations of particular interest.
For example, you set breakpoints to investigate whether your program logic is correct
or to investigate how and when the data changes.

Monitoring variables and expressions

For variables and expressions there is a wide choice of facilities. You can easily
monitor values of a specified set of variables and expressions, continuously or on
demand. You can also choose to monitor only local variables, static variables, etc.
Container awareness

When you run your application in C-SPY, you can view the elements of library data
types such as STL lists and vectors. This gives you a very good overview and
debugging opportunities when you work with C++ STL containers.

Call stack information

The compiler generates extensive call stack information. This allows the debugger to
show, without any runtime penalty, the complete stack of function calls wherever the
program counter is. You can select any function in the call stack, and for each
function you get valid information for local variables and available registers.
Powerful macro system

C-SPY includes a powerful internal macro system, to allow you to define complex
sets of actions to be performed. C-SPY macros can be used on their own or in
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conjunction with complex breakpoints and—if you are using the simulator—the
interrupt simulation system to perform a wide variety of tasks.

Additional general C-SPY debugger features
This list shows some additional features:

Threaded execution keeps the IDE responsive while running the target application
Automatic stepping

The source browser provides easy navigation to functions, types, and variables
Extensive type recognition of variables

Configurable registers (CPU and peripherals) and memory windows

Graphical stack view with overflow detection

Support for code coverage and function level profiling

The target application can access files on the host PC using file I/O

Optional terminal I/O emulation.

RTOS AWARENESS
C-SPY supports RTOS-aware debugging.
These operating systems are currently supported:

AVIX-RT

CMX-RTX

CMX-Tiny+

eForce mC3/Compact

eSysTech X realtime kernel
Express Logic ThreadX
FreeRTOS, OpenRTOS, and SafeRTOS
Freescale MQX

Micrium uC/OS-11

Micrium uC/OS-111

Micro Digital SMX

MISPO NORTi

OSEK Run Time Interface (ORTI)
RTXC Quadros

Segger embOS

unicoi Fusion.
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RTOS plugin modules can be provided by IAR Systems, and by third-party suppliers.
Contact your software distributor or IAR Systems representative, alternatively visit the
IAR Systems web site, for information about supported RTOS modules.

A C-SPY RTOS awareness plugin module gives you a high level of control and visibility
over an application built on top of an RTOS. It displays RTOS-specific items like task
lists, queues, semaphores, mailboxes, and various RTOS system variables. Task-specific
breakpoints and task-specific stepping make it easier to debug tasks.

A loaded plugin will add its own menu, set of windows, and buttons when a debug
session is started (provided that the RTOS is linked with the application). For
information about other RTOS awareness plugin modules, refer to the manufacturer of
the plugin module. For links to the RTOS documentation, see the release notes that are
available from the Help menu.

Debugger concepts

C-SPY® Debugging Guide
for Arm

This section introduces some of the concepts and terms that are related to debugging in
general and to C-SPY in particular. This section does not contain specific information
related to C-SPY features. Instead, you will find such information in the other chapters
of this documentation. The IAR Systems user documentation uses the terms described
in this section when referring to these concepts.

These topics are covered:

C-SPY and target systems
The debugger

The target system

The application

C-SPY debugger systems
The ROM-monitor program
Third-party debuggers

C-SPY plugin modules

C-SPY AND TARGET SYSTEMS

You can use C-SPY to debug either a software target system or a hardware target system.
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This figure gives an overview of C-SPY and possible target systems:

— e e e e g e e e e e e — ==

Target system with application software
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= Provided by IAR Systems

|:| = Provided by IAR Systems or third-party vendors

THE DEBUGGER

The debugger, for instance C-SPY, is the program that you use for debugging your
applications on a target system.

THE TARGET SYSTEM

The target system is the system on which you execute your application when you are
debugging it. The target system can consist of hardware, either an evaluation board or
your own hardware design. It can also be completely or partially simulated by software.
Each type of target system needs a dedicated C-SPY driver.

THE APPLICATION

A user application is the software you have developed and which you want to debug
using C-SPY.

C-SPY DEBUGGER SYSTEMS

C-SPY consists of both a general part which provides a basic set of debugger features,
and a target-specific back end. The back end consists of two components: a processor
module—one for every microcontroller, which defines the properties of the
microcontroller, and a C-SPY driver. The C-SPY driver is the part that provides
communication with and control of the target system. The driver also provides the user
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interface—menus, windows, and dialog boxes—to the functions provided by the target
system, for instance, special breakpoints. Typically, there are three main types of C-SPY
drivers:

e Simulator driver

o ROM-monitor driver

e Emulator driver.

C-SPY is available with a simulator driver, and depending on your product package,
optional drivers for hardware debugger systems. For an overview of the available C-SPY

drivers and the functionality provided by each driver, see C-SPY drivers overview, page
43.

THE ROM-MONITOR PROGRAM

The ROM-monitor program is a piece of firmware that is loaded to non-volatile memory
on your target hardware; it runs in parallel with your application. The ROM-monitor
communicates with the debugger and provides services needed for debugging the
application, for instance stepping and breakpoints.

THIRD-PARTY DEBUGGERS

You can use a third-party debugger together with the AR Systems toolchain as long as
the third-party debugger can read ELF/DWAREF, Intel-extended, or Motorola. For
information about which format to use with a third-party debugger, see the user
documentation supplied with that tool.

C-SPY PLUGIN MODULES

C-SPY is designed as a modular architecture with an open SDK that can be used for
implementing additional functionality to the debugger in the form of plugin modules.
These modules can be seamlessly integrated in the IDE.

Plugin modules are provided by IAR Systems, or can be supplied by third-party vendors.
Examples of such modules are:

Code Coverage, which is integrated in the IDE.

The various C-SPY drivers for debugging using certain debug systems.

RTOS plugin modules for support for real-time OS aware debugging.

C-SPYLink that bridges IAR visualSTATE and IAR Embedded Workbench to make
true high-level state machine debugging possible directly in C-SPY, in addition to
the normal C level symbolic debugging. For more information, see the
documentation provided with IAR visualSTATE.

For more information about the C-SPY SDK, contact IAR Systems.
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C-SPY drivers overview
At the time of writing this guide, the IAR C-SPY Debugger for the Arm cores is
available with drivers for these target systems and evaluation boards:

Simulator

I-jet / I-jet Trace / JTAGjet / JTAGjet-Trace and JTAGjet-Trace-CM debug probes

J-Link / J-Trace probes

GDB Server

CADI (Cycle Accurate Debug Interface)

CMSIS-DAP probes

ST-LINK JTAG/SWD probes (for ST Cortex-M devices only)

TI MSP-FET probes

TI Stellaris JTAG/SWD probes using FTDI or ICDI (for Stellaris Cortex devices
only)

TI XDS probes (XDS100v2, XDS100v3, XDS110, and XDS200)

o P&E Microcomputer Systems. For information about this driver, see the file
PEMicroSettings.pdf, available in the arm\doc directory.

e Nuvoton Technology Corporation’s Nu-Link debug adapter for Nuvoton’s N76E
Series MCUs. For information about this driver, see the file NuMicro Cortex-M
IAR ICE driver user manual.pdf available in the arm\bin\Nu-Link
directory.

Note: In addition to the drivers supplied with IAR Embedded Workbench, you can also
load debugger drivers supplied by a third-party vendor; see Third-Party Driver options,
page 589.

DIFFERENCES BETWEEN THE C-SPY DRIVERS

This table summarizes the key differences between the Simulator, I-jet/JTAGjet,
J-Link/J-Trace, ST-LINK, and CMSIS-DAP:

I-jet/ J-Link/
Feature Simulator ST-LINK TIXDS CMSIS-DAP TI MSP-FET
JTAGjet )-Trace
Code Yes Yes Yes Yes Yes Yes Yes
breakpoints
Data breakpoints Yes Yes Yes Yes Yes Yes Yes
Interrupt logging' Yes Yes Yes Yes Yes — —
Data IoggingI Yes Yes Yes Yes Yes — —

Table 3: Driver differences, I-jet/JTAGjet, J-Link/J-Trace and ST-LINK
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I-jet/ J-Link/
Feature Simulator ST-LINK TI XDS CMSIS-DAP TI MSP-FET
JTAGjet )-Trace
State IoggingI — — — — Yes — Yes
Call stack trace!  Yes Yes Yes — — Yes —
Event logging' — Yes Yes Yes Yes — —
Live watch' — Yes Yes Yes Yes Yes —
Cycle counter!  Yes Yes Yes Yes Yes Yes —
Code coverage' Yes Yes Yes Yes Yes Yes —
Data coverage Yes — — — — — —
Function Yes Yes Yes Yes Yes Yes —
/instruction
profilerI
Trace' Yes Yes Yes Yes Yes Yes —
Multicore Yes Yes — — — Yes? —
debuggingI
Power debugging — Yes Yes — Yes — Yes

Table 3: Driver differences, I-jet/JTAGjet, J-Link/J-Trace and ST-LINK

1 With specific requirements or restrictions, see the respective chapter in this guide.

2 Limited support.

This table summarizes the key differences between the Simulator and other supported

hardware debugger drives:

Feature Simulator GDB Server Tl Stellaris CADI Nu-Link
Code breakpoints  Yes Yes Yes Yes Yes
Data breakpoints Yes Yes Yes — —
Interrupt logging Yes — — — _
Cycle counter! Yes — — _ _
Code z:overageI Yes — — — —
Data coverage Yes — — — —

Function/instruction Yes

pr'ofilerI

Trace!

Table 4: Driver differences, other drivers

1 With specific requirements or restrictions, see the respective chapter in this guide.
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The IAR C-SPY Simulator

The C-SPY Simulator simulates the functions of the target processor entirely in
software, which means that you can debug the program logic long before any hardware
is available. Because no hardware is required, it is also the most cost-effective solution
for many applications.

The C-SPY Simulator supports:

Instruction-level simulation
Memory configuration and validation

Interrupt simulation

Peripheral simulation (using the C-SPY macro system in conjunction with
immediate breakpoints).

Simulating hardware instead of using a hardware debugging system means that some
limitations do not apply, but that there are other limitations instead. For example:

® You can set an unlimited number of breakpoints in the simulator.

o When you stop executing your application, time actually stops in the simulator.
When you stop application execution on a hardware debugging system, there might
still be activities in the system. For example, peripheral units might still be active
and reading from or writing to SFR ports.

e Application execution is significantly much slower in a simulator compared to when
using a hardware debugging system. However, during a debug session, this might
not necessarily be a problem.

o The simulator is not cycle accurate.

e Peripheral simulation is limited in the C-SPY Simulator and therefore the simulator
is suitable mostly for debugging code that does not interact too much with
peripheral units.

The C-SPY hardware debugger drivers

C-SPY can connect to a hardware debugger using a C-SPY hardware debugger driver as
an interface.

When a debug session is started, your application is automatically downloaded and
programmed into target memory. You can disable this feature, if necessary.

COMMUNICATION OVERVIEW

There are two main communication setups, depending on the type of target system.
Many of the arm cores have built-in, on-chip debug support. Because the hardware
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debugger logic is built into the core, no ordinary ROM-monitor program or extra
specific hardware is needed to make the debugging work, other than the debug probe.
For some devices that do not have such built-in, on-chip debug support, there are instead
a ROM-monitor debugger solution that can be used.

Overview of a target system with a debug probe or emulator

Most target systems have an emulator, a debug probe or a debug adapter connected
between the host computer and the evaluation board:

C-SPY debugger
C-SPY driver

Parallel, serial, Ethernet, or
connection

’ > \ JTAG probe
i
/ JTAG cable f o

When USB connection is used, a specific USB driver must be installed before you can
use the probe over the USB port. You can find the driver on the IAR Embedded
Workbench for Arm installation media.

HARDWARE INSTALLATION

For information about the hardware installation, see the documentation supplied with
the target system from the manufacturer. The following power-up sequence is
recommended to ensure proper communication between the target board, the emulator
or debug probe, and C-SPY:

Connect the probe to the target board.
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Connect the USB cable to the debug probe.

Power up the debug probe, if it is not powered via USB.

Power up the target board, if it is not powered by the debug probe.
Start the C-SPY debugging session.

If more than one debug probe is connected to your computer, the Debug Probe
Selection dialog box is displayed. In the dialog box, select the probe to use and click
OK. For more information, see --drv_communication, page 506.

To give the probe a nickname, select the probe in the dialog box and click the button Edit
Nickname. The nickname is saved locally on your computer and will be available also
when opening other projects.

Note: The Edit Nickname button might not be available for the C-SPY driver you are
using.

Please select one of the following found probe(s)

( XD5110 (02.02.04.02) with CMSIS-DAP
{ XD5110 (02.02.04.02) with CMSIS-DAH

K

Cancel

Fltt |

Edit Nickname

USB DRIVER INSTALLATION

A USB driver is also needed. In some cases this driver is automatically installed, but for
some probes you need to manually install it.

Installing the I-jet and JTAGjet USB driver

Before you can use the I-jet or the JTAGjet interface over the USB port, the proper USB
driver must be installed. Use the USB cable to connect the computer to the I-jet,
JTAGjet, or JTAGjet-Trace probe.

Windows 7 and later

Start the Windows Device Manager.

Select Other devices, right-click on JTAGjet and select Update Driver Software.

Click Browse my computer for driver software and browse to the
arm\drivers\jet\USB.

Click Next and then Install.
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Before Windows 7

The first time that the I-jet or JTAGjet interface and the computer are connected,
Windows opens a dialog box and asks you to locate the USB driver. The drivers can be
found in the product installation in the arm\drivers\jet\USB.

Once the initial setup is completed, you do not need to install the driver again.

Installing the J-Link USB driver

Before you can use the J-Link JTAG probe over the USB port, the Segger J-Link USB
driver must be installed.

Install IAR Embedded Workbench for Arm.

Use the USB cable to connect the computer and J-Link. Do not connect J-Link to the
target board yet. The green LED on the front panel of J-Link will blink for a few
seconds while Windows searches for a USB driver.

Run the InstDrivers.exe application, which is located in the product installation in
the arm\drivers\JLink directory.

Once the initial setup is completed, you will not have to install the driver again.

Note that J-Link will continuously blink until the USB driver has established contact
with the J-Link probe. When contact has been established, J-Link will start with a steady
light to indicate that it is connected.

Installing the ST-LINK USB driver for ST-LINK ver. 2

Before you can use the ST-LINK version 2 JTAG probe over the USB port, the ST-LINK
USB driver must be installed.

Install IAR Embedded Workbench for Arm.

Use the USB cable to connect the computer and ST-LINK. Do not connect ST-LINK to
the target board yet.

Because this is the first time ST-LINK and the computer are connected, Windows will
open a dialog box and ask you to locate the USB driver. The USB driver can be found
in the product installation in the arm\drivers\ST-Link directory:
ST-Link_V2_USBdriver.exe.

Once the initial setup is completed, you will not have to install the driver again.
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Installing the TI Stellaris USB driver

Before you can use the TI Stellaris JTAG interface using FTDI or ICDI over the USB
port, the Stellaris USB driver must be installed.

Install IAR Embedded Workbench for Arm.
Use the USB cable to connect the computer to the TI board.

Because this is the first time the Stellaris JTAG interface and the computer are
connected, Windows will open a dialog box and ask you to locate the USB driver. There
are different USB drivers for FTDI and ICDI. The drivers can be found in the product
installation in the arm\drivers\StellarisFTDI and the
arm\drivers\StellarisICDI directories, respectively.

Once the initial setup is completed, you will not have to install the driver again.

Installing the TI XDS USB driver

Before you can use the TI XDS JTAG interface over the USB port, the TI XDS package
must be installed.

Install IAR Embedded Workbench for Arm.

Install the TI XDS package which can be found in the arm\drivers\ti-xds
directory. It is recommended to choose the suggested installation directory. See also 77
XDS - Setup, page 586.

Use the USB cable to connect the computer to the TI board.

Configuring the OpenOCD Server

For further information, see the gdbserv_guickstart.html file, available in the
arm\doc\infocenter directory, or refer to the manufacturer’s documentation.
Installing the TI MSP-FET USB driver

Before you can use the TI MSP-FET driver, the TI MSP-FET USB driver must be
installed.

Install IAR Embedded Workbench for Arm.

The USB driver can be found in the product installation in the
arm\drivers\ti-mspfet directory: PreinstallCDCTools.exe.

Use the USB cable to connect to the TI MSP-FET probe.
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Getting started using
C-SPY

e Setting up C-SPY
e Starting C-SPY

Adapting for target hardware

e An overview of the debugger startup

e Reference information on starting C-SPY

Setting up C-SPY

These tasks are covered:
Setting up for debugging
Executing from reset
Using a setup macro file

Selecting a device description file

Loading plugin modules

SETTING UP FOR DEBUGGING

Install a USB driver or some other communication driver if your C-SPY driver requires
it.

For more information, see:

o Installing the I-jet and JTAGjet USB driver, page 47

o [nstalling the J-Link USB driver, page 48

o [nstalling the ST-LINK USB driver for ST-LINK ver. 2, page 48

o Installing the TI Stellaris USB driver, page 49

o [nstalling the TI XDS USB driver, page 49

o Configuring the OpenOCD Server, page 49

o Installing the TI MSP-FET USB driver, page 49
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Before you start C-SPY, choose Project>Options>Debugger>Setup and select the
C-SPY driver that matches your debugger system: simulator or a hardware debugger
system.

In the Category list, select the appropriate C-SPY driver and make your settings.
For information about these options, see Debugger options, page 547.

Click OK.

Choose Tools>Options to open the IDE Options dialog box:

o Select Debugger to configure the debugger behavior

o Select Stack to configure the debugger’s tracking of stack usage.

For more information about these options, see the /DE Project Management and
Building Guide for Arm.

See also Adapting for target hardware, page 57.

EXECUTING FROM RESET

The Run to option—available on the Debugger>Setup page—specifies a location you
want C-SPY to run to when you start a debug session as well as after each reset. C-SPY
will place a temporary breakpoint at this location and all code up to this point is executed
before stopping at the location. Note that this temporary breakpoint is removed when the
debugger stops, regardless of how. If you stop the execution before the Run to location
has been reached, the execution will not stop at that location when you start the
execution again.

The default location to run to is the main function. Type the name of the location if you
want C-SPY to run to a different location. You can specify assembler labels or whatever
can be evaluated to such, for instance function names.

If you leave the check box empty, the program counter will contain the regular hardware
reset address at each reset The reset address is set by C-SPY.

If no breakpoints are available when C-SPY starts, a warning message notifies you that
single stepping will be required and that this is time-consuming. You can then continue
execution in single-step mode or stop at the first instruction. If you choose to stop at the
first instruction, the debugger starts executing with the PC (program counter) at the
default reset location instead of the location you typed in the Run to box.

Note: This message will never be displayed in the C-SPY Simulator, where breakpoints
are unlimited.
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USING A SETUP MACRO FILE

A setup macro file is a macro file that you choose to load automatically when C-SPY
starts. You can define the setup macro file to perform actions according to your needs,
using setup macro functions and system macros. Thus, if you load a setup macro file you
can initialize C-SPY to perform actions automatically.

For more information about setup macro files and functions, see Introduction to C-SPY
macros, page 413. For an example of how to use a setup macro file, see Initializing
target hardware before C-SPY starts, page 58.

To register a setup macro file:
Before you start C-SPY, choose Project>Options>Debugger>Setup.

Select Use macro file and type the path and name of your setup macro file, for
example Setup.mac. If you do not type a filename extension, the extension mac is
assumed.

SELECTING A DEVICE DESCRIPTION FILE

C-SPY uses device description files to handle device-specific information.

A default device description file—either an IAR-specific daf file or a CMSIS System
View Description file—is automatically used based on your project settings. If you want
to override the default file, you must select your device description file. Device
description files from IAR Systems are provided in the arm\ config directory and they
have the filename extension ddf.

For more information about device description files, see Adapting for target hardware,
page 57.

To override the default device description file:
Before you start C-SPY, choose Project>Options>Debugger>Setup.

Enable the use of a device description file and select a file using the Device
description file browse button.

Note: You can easily view your device description files that are used for your project.
Choose Project>Open Device Description File and select the file you want to view.
LOADING PLUGIN MODULES

On the Plugins page you can specity C-SPY plugin modules to load and make available
during debug sessions. Plugin modules can be provided by IAR Systems, and by
third-party suppliers. Contact your software distributor or IAR Systems representative,
or visit the IAR Systems web site, for information about available modules.

For more information, see Plugins, page 554.
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When you have set up the debugger, you are ready to start a debug session.
These tasks are covered:

Starting a debug session

Loading executable files built outside of the IDE
Starting a debug session with source files missing
Loading multiple images

Editing in C-SPY windows

STARTING A DEBUG SESSION

You can choose to start a debug session with or without loading the current executable
file.

To start C-SPY and download the current executable file, click the Download and
Debug button. Alternatively, choose Project>Download and Debug.

To start C-SPY without downloading the current executable file, click the Debug
without Downloading button. Alternatively, choose Project>Debug without
Downloading.

LOADING EXECUTABLE FILES BUILT OUTSIDE OF THE IDE

You can also load C-SPY with an application that was built outside the IDE, for example
applications built on the command line. To load an externally built executable file and
to set build options you must first create a project for it in your workspace.

To create a project for an externally built file:
Choose Project>Create New Project, and specify a project name.

To add the executable file to the project, choose Project>Add Files and make sure to
choose All Files in the Files of type drop-down list. Locate the executable file.

To start the executable file, click the Download and Debug button. The project can be
reused whenever you rebuild your executable file.

The only project options that are meaningful to set for this kind of project are options in
the General Options and Debugger categories. Make sure to set up the general project
options in the same way as when the executable file was built.
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STARTING A DEBUG SESSION WITH SOURCE FILES MISSING

Normally, when you use the IAR Embedded Workbench IDE to edit source files, build
your project, and start the debug session, all required files are available and the process
works as expected.

However, if C-SPY cannot automatically find the source files, for example if the
application was built on another computer, the Get Alternative File dialog box is
displayed:

Get Alternative File §|

Could nat find the following source file:
C:hprojectshtutorsTutor.c

<RNones J
| Skip |

Suggested alternative:

I If possible, don't show this dialog again

Typically, you can use the dialog box like this:

e The source files are not available: Click If possible, don’t show this dialog again
and then click Skip. C-SPY will assume that there simply is no source file available.
The dialog box will not appear again, and the debug session will not try to display
the source code.

e Alternative source files are available at another location: Specify an alternative
source code file, click If possible, don’t show this dialog again, and then click Use
this file. C-SPY will assume that the alternative file should be used. The dialog box
will not appear again, unless a file is needed for which there is no alternative file
specified and which cannot be located automatically.

If you restart the AR Embedded Workbench IDE, the Get Alternative File dialog box
will be displayed again once even if you have clicked If possible, don’t show this
dialog again. This gives you an opportunity to modify your previous settings.

For more information, see Get Alternative File dialog box, page 68.

LOADING MULTIPLE IMAGES

Normally, a debuggable application consists of exactly one file that you debug.
However, you can also load additional debug files (images). This means that the
complete program consists of several images.

Typically, this is useful if you want to debug your application in combination with a
prebuilt ROM image that contains an additional library for some platform-provided
features. The ROM image and the application are built using separate projects in the
IAR Embedded Workbench IDE and generate separate output files.
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If more than one image has been loaded, you will have access to the combined debug
information for all the loaded images. In the Images window you can choose whether
you want to have access to debug information for one image or for all images.

To load additional images at C-SPY startup:

Choose Project>Options>Debugger>Images and specify up to three additional
images to be loaded. For more information, see /mages, page 551.

Start the debug session.
To load additional images at a specific moment:

Use the __loadImage system macro and execute it using either one of the methods
described in Using C-SPY macros, page 415.

To display a list of loaded images:

Choose Images from the View menu. The Images window is displayed, see Images
window, page 67.

EDITING IN C-SPY WINDOWS

You can edit the contents of the Memory, Symbolic Memory, Registers, Register
User Groups Setup, Auto, Watch, Locals, Statics, Live Watch, and Quick Watch
windows.

Use these keyboard keys to edit the contents of these windows:

Enter Makes an item editable and saves the new value.

Esc Cancels a new value.

In windows where you can edit the Expression field and in the Quick Watch window,
you can specify the number of elements to be displayed in the field by adding a
semicolon followed by an integer. For example, to display only the three first elements

of an array named myArray, or three elements in sequence starting with the element
pointed to by a pointer, write:

myArray; 3
To display three elements pointed to by myPtr, myPtr+1, and myPtr+2, write:
myPtr;3

Optionally, add a comma and another integer that specifies which element to start with.
For example, to display elements 10-14, write:

myArray;5,10
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To display myPtr+10, myPtr+11, myPtr+12, myPtr+13, and myPtr+14, write:
myPtr;5,10

Note: For pointers, there are no built-in limits on displayed element count, and no
validation of the pointer value.

Adapting for target hardware

These tasks are covered:

o Modifying a device description file

o Initializing target hardware before C-SPY starts

e Remapping memory

e Using predefined C-SPY macros for device support

See also Memory configuration for C-SPY hardware debugger drivers, page 160.

MODIFYING A DEVICE DESCRIPTION FILE

C-SPY uses device description files provided with the product to handle several of the
target-specific adaptations, see Selecting a device description file, page 53. They contain
device-specific information such as:

e Definitions of registers in peripheral units and groups of these.

o Interrupt definitions (for Cortex-M devices only); see Interrupts, page 387.

Normally, you do not need to modify the device description file. However, if the
predefinitions are not sufficient for some reason, you can edit the file. Note, however,
that the format of these descriptions might be updated in future upgrades of the product.

Make a copy of the device description file that best suits your needs, and modify it
according to the description in the file. Reload the project to make the changes take
effect.

If you are using an I-jet/JTAGjet or I-jet Trace debug probe, and the modified device
g5  description file contains modified memory ranges, make sure to select the option Use
Factory in the Memory Configuration dialog box.

The syntax of the device description files is described in the IAR Embedded Workbench
Jor ARM device description file format guide (EWARM_DDFFormat .pdf) located in the
arm\doc directory.

For information about how to load a device description file, see Selecting a device
description file, page 53.
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INITIALIZING TARGET HARDWARE BEFORE C-SPY STARTS

You can use C-SPY macros to initialize target hardware before C-SPY starts. For
example, if your hardware uses external memory that must be enabled before code can
be downloaded to it, C-SPY needs a macro to perform this action before your
application can be downloaded.

Create a new text file and define your macro function.

By using the built-in execUserPreload setup macro function, your macro function
will be executed directly after the communication with the target system is established
but before C-SPY downloads your application.

For example, a macro that enables external SDRAM could look like this:

/* Your macro function. */
enableExternal SDRAM ()
{
__message "Enabling external SDRAM\n";
__writeMemory32(...);
}

/* Setup macro determines time of execution. */
execUserPreload()
{
enableExternal SDRAM() ;
}

Save the file with the filename extension mac.
Before you start C-SPY, choose Project>Options>Debugger and click the Setup tab.
Select the option Use Setup file and choose the macro file you just created.

Your setup macro will now be loaded during the C-SPY startup sequence.

REMAPPING MEMORY

A common feature of many Arm-based processors is the ability to remap memory. After
areset, the memory controller typically maps address zero to non-volatile memory, such
as flash. By configuring the memory controller, the system memory can be remapped to
place RAM at zero and non-volatile memory higher up in the address map. By doing
this, the exception table will reside in RAM and can be easily modified when you
download code to the target hardware.

You must configure the memory controller before you download your application code.
You can do this best by using a C-SPY macro function that is executed before the code
download takes place—execUserPreload (). The macro function
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__writeMemory32 () will perform the necessary initialization of the memory
controller.

The following example illustrates a macro used for remapping memory on the Atmel
AT91SAM7S256 chip, similar mechanisms exist in processors from other Arm vendors.

execUserPreload()
{
// REMAP command
// Writing 1 to MC_RCR (MC Remap Control Register)
// will toggle remap bit.
__writeMemory32 (0x00000001, OxXFFFFFF00, "Memory");
}

Note that the setup macro execUserReset () might have to be defined in the same way
to reinitialize the memory mapping after a C-SPY reset. This can be needed if you have
set up your hardware debugger system to do a hardware reset on C-SPY reset, for
example by adding __hwReset () to the execUserReset () macro.

For instructions on how to install a macro file in C-SPY, see Registering and executing
using setup macros and setup files, page 417. For information about the macro functions
used, see Reference information on C-SPY system macros, page 430.

USING PREDEFINED C-SPY MACROS FOR DEVICE SUPPORT

For some Arm devices, there are predefined C-SPY macros available for specific device
support, typically provided by the chip manufacturer. These macros are useful for
performing certain device-specific tasks,

You can easily access and execute these macros using the Macro Quicklaunch window.

An overview of the debugger startup

To make it easier to understand and follow the startup flow, the following figures show
the flow of actions performed by C-SPY, and by the target hardware, as well as the
execution of any predefined C-SPY setup macros. There is one figure for debugging
code located in flash and one for debugging code located in RAM.

These topics are covered:

o Debugging code in flash
o Debugging code in RAM

For more information about C-SPY system macros, see the chapter C-SPY macros
available in this guide.
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DEBUGGING CODE IN FLASH

This figure illustrates the debugger startup when debugging code in flash memory:
C-SPY Debugger C-SPY Setup Macro Target Hardware

JTAG speed is set to | — — —
the specified frequency, CPU reset |
or very low (typically = -
32 kHz) if auto speed is

selected CPU halted

|
| If the option for aut | | execuserrlashinit() |
e option for auto- r, i

| speed is selected, J[TAG
speed is set to the maxi- |
| mum reliable speed

T R Target flash loader
Flash loader loaded to _—.I execuserFlashreset () L executes from RAM
target RAM L—_— — — — — and loads application
image from host and
writes it to flash
| If the option | | execuserFlashexit O T
Verify download | L
l is selected, the flash N - - - = - —
| memory is verified for I cxecuserprelcad() | ———
| correct content KNl t—-—————— — | CPU reset |
\ﬁ execUserReset() | e
The debugger is ready to N — i CPU halted
work with the application 1 execUserSetup () |

= Optional
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DEBUGGING CODE IN RAM

This figure illustrates the debugger startup when debugging code in RAM:
C-SPY Debugger C-SPY Setup Macro Target Hardware

Debugger start

JTAG speed is set to [ — — —
the specified frequency, CPU reset |
or very low (typically — -
32 kHz) if auto speed is

selected CPU halted

|

| If the option for auto- /I execUserPreload () I‘/

| speed is selected, JTAG | SRR
speed is set to the maxi- |

| mum reliable speed |

L__T___

The application image is
loaded to target RAM

| Ifthe option '
Verify download |
is selected, the RAM ~ —
| memory is verified for | execUserReset () |
correct content et
 corectcontent | |

The debugger is ready to 1|
work with the application

r— — — —

| =Optional

-

Reference information on starting C-SPY

Reference information about:

o C-SPY Debugger main window, page 62
o [mages window, page 67

o Get Alternative File dialog box, page 68
See also:

o Tools options for the debugger in the /DE Project Management and Building Guide
for Arm.

61



Reference information on starting C-SPY

62

C-SPY Debugger main window

Menu bar

C-SPY® Debugging Guide
for Arm

When you start a debug session, these debugger-specific items appear in the main IAR
Embedded Workbench IDE window:

e A dedicated Debug menu with commands for executing and debugging your
application

o Depending on the C-SPY driver you are using, a driver-specific menu, often
referred to as the Driver menu in this documentation. Typically, this menu contains
menu commands for opening driver-specific windows and dialog boxes.

e A special debug toolbar
o Several windows and dialog boxes specific to C-SPY.

The C-SPY main window might look different depending on which components of the
product installation you are using.

These menus are available during a debug session:

Debug
Provides commands for executing and debugging the source application. Most
of the commands are also available as icon buttons on the debug toolbar.
C-SPY driver menu
Provides commands specific to a C-SPY driver. The driver-specific menu is only
available when the driver is used. For information about the driver-specific
menu commands, see Reference information on C-SPY driver menus, page 591.
Disassembly
Provides commands for controlling how the disassembler operates.



Getting started using C-SPY ___4

Debug menu

The Debug menu is available during a debug session. The Debug menu provides
commands for executing and debugging the source application. Most of the commands
are also available as icon buttons on the debug toolbar.
> Go F5
Break
Reset

Stop Debugging Ctrl=Shift+D

pa
]
M Step Over F10
3 stepinto F11
™  step Out Shift=F11
*1  Mext Statement

*]  Runto Cursor

s Autostep..,

*=  Set Mext Statement
C++ Exceptions 3
Memaory 3
Refresh
Logaging 3

These commands are available:

Go (F5)

L
Executes from the current statement or instruction until a breakpoint or program
exit is reached.
Note: If you are using symmetric multicore debugging, the Go command starts
only the core in focus.
Break
1]

Stops the application execution.

Note: If you are using symmetric multicore debugging, the Break command
stops only the core in focus.

S - Reset

Resets the target processor. Click the drop-down button to access a menu with
additional commands.

Enable Run to '1abel', where 1abel typically is main. Enables and disables
the project option Run to without exiting the debug session. This menu
command is only available if you have selected Run to in the Options dialog
box.
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Reset strategies, which contains a list of reset strategies supported by the C-SPY
driver you are using. This means that you can choose a different reset strategy
than the one used initially without exiting the debug session. Reset strategies are
only available if the C-SPY driver you are using supports alternate reset
strategies.

Stop Debugging (Ctrl+Shift+D)
Stops the debugging session and returns you to the project manager.
Step Over (F10)

Executes the next statement, function call, or instruction, without entering C or
C++ functions or assembler subroutines.

PO x

1 Step Into (F11)
Executes the next statement or instruction, or function call, entering C or C++
functions or assembler subroutines.
I.p Step Out (Shift+F11)
Executes from the current statement up to the statement after the call to the
current function.
= Next Statement
Executes directly to the next statement without stopping at individual function
calls.
._I Run to Cursor
Executes from the current statement or instruction up to a selected statement or
instruction.
s Autoste
p . . . .
Displays a dialog box where you can customize and perform autostepping, see
Autostep settings dialog box, page 91.
Set Next Statement

Moves the program counter directly to where the cursor is, without executing
any source code. Note, however, that this creates an anomaly in the program
flow and might have unexpected effects.

C++ Exceptions>Break on Throw
Specifies that the execution shall break when the target application executes a

throw statement.

To use this feature, your application must be built with the option Library
low-level interface implementation selected and the language option C++
With exceptions

C-SPY® Debugging Guide
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C++ Exceptions>Break on Uncaught Exception

Specifies that the execution shall break when the target application throws an
exception that is not caught by any matching catch statement.

To use this feature, your application must be built with the option Library
low-level interface implementation selected and the language option C++
With exceptions.

Memory>Save

Displays a dialog box where you can save the contents of a specified memory
area to a file, see Memory Save dialog box, page 170.

Memory>Restore
Displays a dialog box where you can load the contents of a file in, for example
Intel-extended or Motorola s-record format to a specified memory zone, see
Memory Restore dialog box, page 171.

Refresh
Refreshes the contents of all debugger windows. Because window updates are
automatic, this is needed only in unusual situations, such as when target memory
is modified in ways C-SPY cannot detect. It is also useful if code that is
displayed in the Disassembly window is changed.

Logging>Set Log file
Displays a dialog box where you can choose to log the contents of the Debug
Log window to afile. You can select the type and the location of the log file. You
can choose what you want to log: errors, warnings, system information, user
messages, or all of these. See Log File dialog box, page 88.

Logging>Set Terminal I/O Log file

Displays a dialog box where you can choose to log simulated target access
communication to a file. You can select the destination of the log file. See
Terminal 1/0O Log File dialog box, page 86

Disassembly menu

The Disassembly menu is available when C-SPY is running. This menu provides
commands for controlling how the disassembler operates.

Disassemble in Thumb mode
Disassemble in Arm mode
Disassemble in Current processor mode

Disassemble in Auto mode

Use the commands on the menu to select which disassembly mode to use.
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These commands are available:

Disassemble in Thumb Disassembles your application in Thumb mode.
mode

Disassemble in Arm Disassembles your application in Arm mode.
mode

Disassemble in Current Disassembles your application in the current processor
processor mode mode.

Disassemble in Auto Disassembles your application in automatic mode. This is
mode the default option.

See also Disassembly window, page 78.

Depending on the C-SPY driver you are using, these windows specific to C-SPY are
available during a debug session:

C-SPY Debugger main window

Disassembly window

Memory window

Symbolic Memory window

Registers window

Watch window

Locals window

Auto window

Live Watch window

Quick Watch window

Statics window

Call Stack window

Trace window

Function Trace window

Timeline window, see Reference information on application timeline, page 261
Terminal I/O window

Code Coverage window

Function Profiler window

Images window

Stack window
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e Symbols window.

Additional windows are available depending on which C-SPY driver you are using.

Images window

The Images window is available from the View menu.

MName Path
<All images> [Combines debug information from all images]
project] ChDocuments and Settingsihy Documentsi| AR Embedded WorkbenchDebughExeyproject! .out

exfralmage ChDocuments and Settingsi\hy Documentst| AR Embedded WorkbenchDebughExehextralmage.out

This window lists all currently loaded images (debug files).

Normally, a source application consists of exactly one image that you debug. However,
you can also load additional images. This means that the complete debuggable unit
consists of several images. See also Loading multiple images, page 55.

Requirements

None; this window is always available.

Display area

C-SPY can either use debug information from all of the loaded images simultaneously,
or from one image at a time. Double-click on a row to show information only for that
image. The current choice is highlighted.

This area lists the loaded images in these columns:

Name
The name of the loaded image.

Path
The path to the loaded image.
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Context menu

This context menu is available:

Show only 'projectl’
These commands are available:

Show all images
Shows debug information for all loaded debug images.

Show only image
Shows debug information for the selected debug image.

Related information

For related information, see:

® Loading multiple images, page 55
® Images, page 551
o _ loadlmage, page 453.

Get Alternative File dialog box

The Get Alternative File dialog box is displayed if C-SPY cannot automatically find
the source files to be loaded, for example if the application was built on another
computer.

Get Alternative File P§|

Could nat find the following source file:
C:hprojectshtutorsTutor.c

<RNones J
| Skip |

Suggested alternative:

I If possible, don't show this dialog again

See also Starting a debug session with source files missing, page 55.

Could not find the following source file

The missing source file.

Suggested alternative

Specify an alternative file.

C-SPY® Debugging Guide
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Use this file

After you have specified an alternative file, Use this file establishes that file as the alias
for the requested file. Note that after you have chosen this action, C-SPY will
automatically locate other source files if these files reside in a directory structure similar
to the first selected alternative file.

The next time you start a debug session, the selected alternative file will be preloaded
automatically.

Skip

C-SPY will assume that the source file is not available for this debug session.

If possible, don’t show this dialog again

Instead of displaying the dialog box again for a missing source file, C-SPY will use the
previously supplied response.

Related information

For related information, see Starting a debug session with source files missing, page 55.
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Executing your application

e Introduction to application execution

e Reference information on application execution

Introduction to application execution

These topics are covered:

Briefly about application execution
Source and disassembly mode debugging
Single stepping

Troubleshooting slow stepping speed
Running the application

Highlighting

Viewing the call stack

Terminal input and output

Debug logging

BRIEFLY ABOUT APPLICATION EXECUTION

C-SPY allows you to monitor and control the execution of your application. By
single-stepping through it, and setting breakpoints, you can examine details about the
application execution, for example the values of variables and registers. You can also use
the call stack to step back and forth in the function call chain.

The terminal I/O and debug log features let you interact with your application.

You can find commands for execution on the Debug menu and on the toolbar.

SOURCE AND DISASSEMBLY MODE DEBUGGING

C-SPY allows you to switch between source mode and disassembly mode debugging as
needed.

Source debugging provides the fastest and easiest way of developing your application,
without having to worry about how the compiler or assembler has implemented the
code. In the editor windows you can execute the application one statement at a time
while monitoring the values of variables and data structures.
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Disassembly mode debugging lets you focus on the critical sections of your application,
and provides you with precise control of the application code. You can open a
disassembly window which displays a mnemonic assembler listing of your application
based on actual memory contents rather than source code, and lets you execute the
application exactly one machine instruction at a time.

Regardless of which mode you are debugging in, you can display registers and memory,
and change their contents.

SINGLE STEPPING

C-SPY allows more stepping precision than most other debuggers because it is not
line-oriented but statement-oriented. The compiler generates detailed stepping
information in the form of step points at each statement, and at each function call. That
is, source code locations where you might consider whether to execute a step into or a
step over command. Because the step points are located not only at each statement but
also at each function call, the step functionality allows a finer granularity than just
stepping on statements.

There are several factors that can slow down the stepping speed. If you find it too slow,
see Troubleshooting slow stepping speed, page 74 for some tips.

The step commands

There are four step commands:

Step Into

°
o Step Over
o Next Statement
°

Step Out.

Using the Autostep settings dialog box, you can automate the single stepping. For more
information, see Autostep settings dialog box, page 91.

If your application contains an exception that is caught outside the code which would
normally be executed as part of a step, C-SPY terminates the step at the catch
statement.
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Consider this example and assume that the previous step has taken you to the £ (i)
function call (highlighted):

extern int g(int);

int f(int n)

{

value = g(n-1) + g(n-2) + g(n-3);
return value;

}
int main()

{

£(i);
value ++;

Step Into

While stepping, you typically consider whether to step into a function and continue
stepping inside the function or subroutine. The Step Into command takes you to the first
step point within the subroutine g (n-1):

extern int g(int);

int f(int n)

{

value = g(n-1) + g(n-2) + g(n-3);
return value;

}

The Step Into command executes to the next step point in the normal flow of control,
regardless of whether it is in the same or another function.

Step Over

The Step Over command executes to the next step point in the same function, without
stopping inside called functions. The command would take you to the g (n-2) function
call, which is not a statement on its own but part of the same statement as g (n-1) . Thus,
you can skip uninteresting calls which are parts of statements and instead focus on
critical parts:

extern int g(int);

int f(int n)

{

value = g(n-1) + g(n-2) + g(n-3);
return value;

}
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Next Statement

The Next Statement command executes directly to the next statement, in this case
return value, allowing faster stepping:

extern int g(int);

int f(int n)

{

value = g(n-1) + g(n-2) + g(n-3);
return value;

}

Step Out

When inside the function, you can—if you wish—use the Step Out command to step
out of it before it reaches the exit. This will take you directly to the statement
immediately after the function call:

extern int g(int);

int f(int n)

{

value = g(n-1) + g(n-2) g(n-3);
return value;

}
int main()

{

£(1i);
value ++;

}

The possibility of stepping into an individual function that is part of a more complex
statement is particularly useful when you use C code containing many nested function
calls. It is also very useful for C++, which tends to have many implicit function calls,
such as constructors, destructors, assignment operators, and other user-defined
operators.

This detailed stepping can in some circumstances be either invaluable or unnecessarily
slow. For this reason, you can also step only on statements, which means faster stepping.

TROUBLESHOOTING SLOW STEPPING SPEED

If you find that stepping speed is slow, these troubleshooting tips might speed up

stepping:

e If you are using a hardware debugger system, keep track of how many hardware
breakpoints that are used and make sure some of them are left for stepping.
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Stepping in C-SPY is normally performed using breakpoints. When C-SPY performs
a step command, a breakpoint is set on the next statement and the application
executes until it reaches this breakpoint. If you are using a hardware debugger
system, the number of hardware breakpoints—typically used for setting a stepping
breakpoint in code that is located in flash/ROM memory—is limited. If you, for
example, step into a C switch statement, breakpoints are set on each branch; this
might consume several hardware breakpoints. If the number of available hardware
breakpoints is exceeded, C-SPY switches into single stepping on assembly level,
which can be very slow.

For more information, see and Breakpoint consumers, page 123.

o Disable trace data collection, using the Enable/Disable button in both the Trace
and the Function Profiling windows. Trace data collection might slow down
stepping because the collected trace data is processed after each step. Note that it is
not sufficient to just close the corresponding windows to disable trace data
collection.

o Choose to view only a limited selection of SFR registers. You can choose between
two alternatives. Either type # SFR_name (where SFR_name reflects the name of the
SFR you want to monitor) in the Watch window, or create your own filter for
displaying a limited group of SFRs in the Registers window. Displaying many SFR
registers might slow down stepping because all registers must be read from the
hardware after each step. See Defining application-specific register groups, page
161.

o Close the Memory and Symbolic Memory windows if they are open, because the
visible memory must be read after each step and that might slow down stepping.

o Close any window that displays expressions such as Watch, Live Watch, Locals,
Statics if it is open, because all these windows read memory after each step and that
might slow down stepping.

o Close the Stack window if it is open. Choose Tools>Options>Stack and disable the
Enable graphical stack display and stack usage tracking option if it is enabled.

e If possible, increase the communication speed between C-SPY and the target
board/emulator.

RUNNING THE APPLICATION

Go

The Go command continues execution from the current position until a breakpoint or
program exit is reached.

Note: If you are using symmetric multicore debugging, the Go command starts only the
core in focus.
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Run to Cursor

The Run to Cursor command executes to the position in the source code where you
have placed the cursor. The Run to Cursor command also works in the Disassembly
window and in the Call Stack window.

HIGHLIGHTING

At each stop, C-SPY highlights the corresponding C or C++ source or instruction with
a green color, in the editor and the Disassembly window respectively. In addition, a
green arrow appears in the editor window when you step on C or C++ source level, and
in the Disassembly window when you step on disassembly level. This is determined by
which of the windows is the active window. If none of the windows are active, it is
determined by which of the windows was last active.

Tutor.c I!EEE

void init_fib{ void |

i

int i = 45;
o root[0] = root[l] = 1;

for { i=2 ; i<MAX _FIE : i++)
{

For simple statements without function calls, the whole statement is typically
highlighted. When stopping at a statement with function calls, C-SPY highlights the first
call because this illustrates more clearly what Step Into and Step Over would mean at
that time.

Occasionally, you will notice that a statement in the source window is highlighted using
a pale variant of the normal highlight color. This happens when the program counter is
at an assembler instruction which is part of a source statement but not exactly at a step
point. This is often the case when stepping in the Disassembly window. Only when the
program counter is at the first instruction of the source statement, the ordinary highlight
color is used.

VIEWING THE CALL STACK

The compiler generates extensive call frame information. This allows C-SPY to show,
without any runtime penalty, the complete function call chain at any time.

Typically, this is useful for two purposes:

o Determining in what context the current function has been called
o Tracing the origin of incorrect values in variables and in parameters, thus locating
the function in the call chain where the problem occurred.

The Call Stack window shows a list of function calls, with the current function at the
top. When you inspect a function in the call chain, the contents of all affected windows
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are updated to display the state of that particular call frame. This includes the editor,
Locals, Register, Watch, and Disassembly windows. A function would normally not
make use of all registers, so these registers might have undefined states and be displayed
as dashes (---).

In the editor and Disassembly windows, a green highlight indicates the topmost, or
current, call frame; a yellow highlight is used when inspecting other frames.

For your convenience, it is possible to select a function in the call stack and click the
Run to Cursor command to execute to that function.

Assembler source code does not automatically contain any call frame information. To
see the call chain also for your assembler modules, you can add the appropriate CFI
assembler directives to the assembler source code. For more information, see the /4R
Assembler Reference Guide for Arm.

TERMINAL INPUT AND OUTPUT

Sometimes you might have to debug constructions in your application that use stdin
and stdout without an actual hardware device for input and output. The Terminal I/O
window lets you enter input to your application, and display output from it. You can also
direct terminal I/O to a file, using the Terminal I/O Log Files dialog box.

This facility is useful in two different contexts:

e If your application uses stdin and stdout

e For producing debug trace printouts.

For more information, see Terminal 1/0 window, page 85 and Terminal 1/0 Log File
dialog box, page 86.

DEBUG LOGGING

The Debug Log window displays debugger output, such as diagnostic messages,
macro-generated output, and information about trace.

It can sometimes be convenient to log the information to a file where you can easily
inspect it, see Log File dialog box, page 88. The two main advantages are:

o The file can be opened in another tool, for instance an editor, so you can navigate
and search within the file for particularly interesting parts

o The file provides history about how you have controlled the execution, for instance,
which breakpoints that have been triggered etc.
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Current position
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Disassembly window, page 78

Call Stack window, page 83

Terminal 1/0 window, page 85

Terminal 1/0O Log File dialog box, page 86
Debug Log window, page 87

Log File dialog box, page 88

Fault exception viewer window, page 89
Report Assert dialog box, page 90
Autostep settings dialog box, page 91

See also Terminal I/O options in the IDE Project Management and Building Guide for
Arm.

The C-SPY Disassembly window is available from the View menu.

‘ Go to memory address j

‘ Toggle embedded source mode

Zone display

Disassembly

|
Goto I ! j IMemory I j IE
wvoid mainiwoid) -
L
main:
Ctext_ 5
& 0z43c: 0O=xb580 PUSH ir?. lr}
callCount = 0;
& Oxd43=: 0=4807 LDR.H r0, ??DataTabled [0x45c] : callCount
e 0=440: 0=2100 HOVS rl, #0
& O=442: 0=6001 STR rl, [x0]
InitFibiy;
& Oxdd4: 0=f7if ; pre BL-ELX
& Oz446: 0=ff00 InitFib o 0=x248
while (callCount ¢ MAX FIB
Oxdda: 0=6800 LLRE r0, [r0]
Ox44c: 0x280a CHP r0, #10 ;o O=a
Oxdde: 0O=xdald2 BGE.H Pimain_1 ; DO=456
DoForegroundProcess() ;
0x450: 0=xf7ff ; pre BL-ELX
0x452: O=zffeb EL DoForegroundProcess s O=420
0x454: 0=z=7f8 BE.H Pimain_0 s DO=448 _ILI
|
[ | 3

This window shows the application being debugged as disassembled application code.



Executing your application __¢

To change the default color of the source code in the Disassembly window:
I Choose Tools>Options>Debugger.
2 Set the default color using the Source code coloring in disassembly window option.

To view the corresponding assembler code for a function, you can select it in the editor
5  window and drag it to the Disassembly window.

See also Source and disassembly mode debugging, page 71.

Requirements

None; this window is always available.

Toolbar
The toolbar contains:

Go to
The memory location or symbol you want to view.

Zone
Selects a memory zone, see C-SPY memory zones, page 159.

Toggle Mixed-Mode

Toggles between displaying only disassembled code or disassembled code
together with the corresponding source code. Source code requires that the
corresponding source file has been compiled with debug information

Display area

The display area shows the disassembled application code.
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Context menu
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This area contains these graphic elements:

Green highlight

Yellow highlight

Red dot

Green diamond

If instruction profiling has
left-side margin appears w
been executed.

Indicates the current position, that is the next assembler
instruction to be executed. To move the cursor to any line in
the Disassembly window, click the line. Alternatively, move
the cursor using the navigation keys.

Indicates a position other than the current position, such as
when navigating between frames in the Call Stack window
or between items in the Trace window.

Indicates a breakpoint. Double-click in the gray left-side
margin of the window to set a breakpoint. For more
information, see Breakpoints, page 119.

Indicates code that has been executed—that is, code
coverage.

been enabled from the context menu, an extra column in the
ith information about how many times each instruction has

This context menu is available:

Move to PC

Run to Cursor

Code Coverage

Instruction Profiling

Toggle Breakpoint (Code)
Toggle Breakpoint (Log)
Toggle Breakpoint (Trace Start)
Toggle Breakpoint (Trace Stop)
Enable/Disable Breakpoint
Edit Breakpoint...

Set Mext Statement

Copy Window Contents
Mixed-Mode

Find in Trace

Zone

Note: The contents of this

menu are dynamic, which means that the commands on the

menu might depend on your product package.
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These commands are available:

Move to PC
Displays code at the current program counter location.

Run to Cursor
Executes the application from the current position up to the line containing the
Cursor.

Code Coverage

Displays a submenu that provides commands for controlling code coverage.
This command is only enabled if the driver you are using supports it.

Enable Toggles code coverage on or off.

Show Toggles the display of code coverage on or off.
Executed code is indicated by a green diamond.

Clear Clears all code coverage information.

Instruction Profiling

Displays a submenu that provides commands for controlling instruction
profiling. This command is only enabled if the driver you are using supports it.

Enable Toggles instruction profiling on or off.

Show Toggles the display of instruction profiling on or off.
For each instruction, the left-side margin displays
how many times the instruction has been executed.

Clear Clears all instruction profiling information.

Toggle Breakpoint (Code)

Toggles a code breakpoint. Assembler instructions and any corresponding label
at which code breakpoints have been set are highlighted in red. For more
information, see Code breakpoints dialog box, page 135.

Toggle Breakpoint (Log)

Toggles alog breakpoint for trace printouts. Assembler instructions at which log
breakpoints have been set are highlighted in red. For more information, see Log
breakpoints dialog box, page 140.
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Toggle Breakpoint (Trace Start)

Toggles a Trace Start breakpoint. When the breakpoint is triggered, the trace
data collection starts. Note that this menu command is only available if the
C-SPY driver you are using supports trace. For more information, see Trace
Start breakpoints dialog box, page 233.

Toggle Breakpoint (Trace Stop)

Toggles a Trace Stop breakpoint. When the breakpoint is triggered, the trace
data collection stops. Note that this menu command is only available if the
C-SPY driver you are using supports trace. For more information, see Trace
Stop breakpoints dialog box, page 234.

Enable/Disable Breakpoint
Enables and Disables a breakpoint. If there is more than one breakpoint at a
specific line, all those breakpoints are affected by the Enable/Disable
command.

Edit Breakpoint
Displays the breakpoint dialog box to let you edit the currently selected
breakpoint. If there is more than one breakpoint on the selected line, a submenu
is displayed that lists all available breakpoints on that line.

Set Next Statement

Sets the program counter to the address of the instruction at the insertion point.

Copy Window Contents
Copies the selected contents of the Disassembly window to the clipboard.

Mixed-Mode

Toggles between showing only disassembled code or disassembled code
together with the corresponding source code. Source code requires that the
corresponding source file has been compiled with debug information.

Find in Trace

Searches the contents of the Trace window for occurrences of the given
location—the position of the insertion point in the source code—and reports the
result in the Find in Trace window. This menu command requires support for
Trace in the C-SPY driver you are using, see Differences between the C-SPY
drivers, page 43.

Zone
Selects a memory zone, see C-SPY memory zones, page 159.
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Call Stack window

The Call Stack window is available from the View menu.

Call Stack * o X

T Fibonacci::next()

2 main

Destination for Step ‘
[_call_main + 0x9] .

Jump te main from label
plus offset

This window displays the C function call stack with the current function at the top. To
inspect a function call, double-click it. C-SPY now focuses on that call frame instead.

If the next Step Into command would step to a function call, the name of the function is
displayed in the gray bar at the top of the window. This is especially useful for implicit
function calls, such as C++ constructors, destructors, and operators.

See also Viewing the call stack, page 76.

Requirements

None; this window is always available.

Display area

Each entry in the display area is formatted in one of these ways:

function(values) *** A C/C++ function with debug information.

Provided that Show Arguments is enabled, values
is a list of the current values of the parameters, or
empty if the function does not take any parameters.

**x_if present, indicates that the function has been
inlined by the compiler. For information about
function inlining, see the AR C/C++ Development
Guide for Arm.

[label + offset] An assembler function, or a C/C++ function without
debug information.

<exception_frame> An interrupt.
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Context menu

This context menu is available:
Go to Source
Show Arguments
Run to Cursor
Copy Window Contents
Toggle Breakpoint (Code)
Toggle Breakpoint (Log)
Toggle Breakpoint (Trace Start)
Toggle Breakpoint (Trace Stop)
Enable/Disable Breakpoint

These commands are available:

Go to Source
Displays the selected function in the Disassembly or editor windows.

Show Arguments
Shows function arguments.

Run to Cursor
Executes until return to the function selected in the call stack.

Copy Window Contents
Copies the contents of the Call Stack window and stores them on the clipboard.

Toggle Breakpoint (Code)
Toggles a code breakpoint.

Toggle Breakpoint (Log)
Toggles a log breakpoint.

Toggle Breakpoint (Trace Start)

Toggles a Trace Start breakpoint. When the breakpoint is triggered, trace data
collection starts. Note that this menu command is only available if the C-SPY
driver you are using supports it.

Toggle Breakpoint (Trace Stop)
Toggles a Trace Stop breakpoint. When the breakpoint is triggered, trace data
collection stops. Note that this menu command is only available if the C-SPY
driver you are using supports it.

Enable/Disable Breakpoint
Enables or disables the selected breakpoint

C-SPY® Debugging Guide
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The Terminal I/O window is available from the View menu.

Terminal /O *
Output: Loq file: Off
A Fibonacci object was created. -
A Fibonacci object that starts at Fil
1

1 13

2

3 21

5

8 34

13

21 55

34

55 89

] 1 ¢
Input: Chl codes ][ Options...

Buffer size: 1]

Use this window to enter input to your application, and display output from it.

To use this window, you must:

I Link your application with the option Semihosted or IAR breakpoint.

C-SPY will then direct stdin, stdout and stderr to this window. If the Terminal I/O
window is closed, C-SPY will open it automatically when input is required, but not for

output.

The following possibilities for using Terminal I/O in real time apply:

Device

Description

Cortex-M

Arm7/Arm9,
including Armxxx-S,
and when using the
C-SPY J-Link/J-Trace
driver

The stdout of your application is routed via SWO. See SWO
Configuration dialog box, page 218, specifically the ITM Stimulus Port
option.

DCC can be used for Terminal I/O output by adding the file
arm\src\debugger\dcc\DCC_Write.c to your project.
DCC_write. c overrides the library function write. Functions such as
printf can then be used to output text to the Terminal I/O window.
In this case, you can disable semihosting which means that the
breakpoint it uses is freed for other purposes. To disable semihosting,
choose General Options>Library Configuration>Library
low-level interface implementation>None.

Table 5: Terminal I/O in real time

See also Terminal input and output, page 77.
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Requirements

Input

Ctrl codes

Options

None; this window is always available.

Type the text that you want to input to your application.

Opens a menu for input of special characters, such as EOF (end of file) and NUL.

0:x00-0x0f  »
O:x10-0:x1F »
ECF

Opens the IDE Options dialog box where you can set options for terminal I/O. For
reference information about the options available in this dialog box, see Terminal I/O
options in IDE Project Management and Building Guide for Arm.

Terminal I/O Log File dialog box

Requirements

C-SPY® Debugging Guide

for Arm

The Terminal I/O Log File dialog box is available by choosing Debug>Logging>Set
Terminal 1/0O Log File.

Terminal I/0 Log File

Termninal 140 Log File

™ Enable Teminal 10 log file

| il

Cancel

Use this dialog box to select a destination log file for terminal I/O from C-SPY.

See also Terminal input and output, page 77.

None; this dialog box is always available.

Terminal 10 Log Files

Controls the logging of terminal I/0. To enable logging of terminal I/O to a file, select
Enable Terminal IO log file and specify a filename. The default filename extension is
log. A browse button is available for your convenience.
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Debug Log window

The Debug Log window is available by choosing View>Messages.
Debug Log v 0 X

Log
Mon Jun 19, 2017 13:21:16: Loaded module
ton Jun 19, 2017 13:21:16: Target reset

Fl nm 3

This window displays debugger output, such as diagnostic messages, macro-generated
output, and information about trace. This output is only available during a debug
session. When opened, this window is, by default, grouped together with the other
message windows, see IDE Project Management and Building Guide for Arm.

Double-click any rows in one of the following formats to display the corresponding
source code in the editor window:

<path> (<row>) :<message>
<path> (<row>,<column>) :<message>

See also Debug logging, page 77 and Log File dialog box, page 88.

Requirements

None; this window is always available.

Context menu

This context menu is available:
Filter Level:
All
Messages
Warnings

Errors

Copy
Select All

Clear All
These commands are available:

All
Shows all messages sent by the debugging tools and drivers.

Messages
Shows all C-SPY messages.
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Log File dialog box

Requirements

Enable log file

Include

C-SPY® Debugging Guide
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Warnings

Shows warnings and errors.
Errors

Shows errors only.
Copy

Copies the contents of the window.
Select All

Selects the contents of the window.

Clear All

Clears the contents of the window.

The Log File dialog box is available by choosing Debug>Logging>Set Log File.

Log File =
7] Enable log fle
Include: W
| Ermars
| W arnings
| User
| Info
Loq file:
$PROJ_DIR$'LogFileT.log D

Use this dialog box to log output from C-SPY to a file.

None; this dialog box is always available.

Enables or disables logging to the file.

The information printed in the file is, by default, the same as the information listed in
the Debug Log window. Use the browse button, to override the default file and location
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of the log file (the default filename extension is 1og). To change the information logged,
choose between:
Errors
C-SPY has failed to perform an operation.
Warnings
An error or omission of concern.
User
Messages from C-SPY macros, that is, your messages using the __message
statement.
Info

Progress information about actions C-SPY has performed.

Fault exception viewer window

The Fault exception viewer window is available by choosing View>Fault exception
viewer. The window is automatically opened when the execution stops and a fault
exception was encountered.

Fault exception viewer x

HardFault exception.
The processor has escalated a configurable-priority exception to HardFault.

Animprecise data access error has occurred (CFSRIMPRECISERR, BFAR).
Exception occured at PC = 0x3000190, LR = 0x80001 9f

See the call stack for mare information.

Requirements

None; this window is always available.
To display exception messages in this window, the selected device must be a Cortex-M
device.

Display area

This area contains a description of the most recent fault exception that was encountered
during application execution.
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Context menu

This context menu is available:

Copy exception address
Copy exception return address
Copy selected line

Clear

Copy exception address
Copies the address that the program counter, PC, had at the time of the
exception. The address is copied to the clipboard.

Copy exception return address
Copies the address that the link register, LR, had at the time of the exception. The
address is copied to the clipboard.

Copy selected line
Copies the selected line to the clipboard.

Clear

Clears the messages displayed in the Fault exception viewer window.

Report Assert dialog box

C-SPY® Debugging Guide
for Arm

The Report Assert dialog box appears if you have a call to the assert function in your
application source code, and the assert condition is false. In this dialog box you can
choose how to proceed.

Report Assert

The following Failed:

File: C:\Documents and SettingsiMy DocumentsiIAR Embedded Workbenchiresolve.cpp
Line: 35

Expression Failed:

a

To output the assert message as text:
Add this function to your application source code:

void __aeabi_assert (char const * msg, char const *file, int line)
{
printf( "%$s:%d %s -- assertion failed\n", file, line, msg );
abort () ;
}

An assert message is displayed.
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Abort
The application stops executing and the runtime library function abort, which is part
of your application on the target system, will be called. This means that the application
itself terminates its execution.

Debug
C-SPY stops the execution of the application and returns control to you.

Ignore

The assertion is ignored and the application continues to execute.

Autostep settings dialog box

The Autostep settings dialog box is available from the Debug menu.

Autostep settings @

| Step Into [Source level] hd | [ Start ]

Delay [milliseconds): 1000 Cancel

Use this dialog box to customize autostepping.

The drop-down menu lists the available step commands, see Single stepping, page 72.

Requirements

None; this dialog box is always available.

Delay

Specify the delay between each step in milliseconds.
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Variables and expressions

o Introduction to working with variables and expressions
o Working with variables and expressions

e Reference information on working with variables and expressions

Introduction to working with variables and expressions

This section introduces different methods for looking at variables and introduces some
related concepts.

These topics are covered:

e Briefly about working with variables and expressions
o C-SPY expressions

e Limitations on variable information.

BRIEFLY ABOUT WORKING WITH VARIABLES AND
EXPRESSIONS

There are several methods for looking at variables and calculating their values. These
methods are suitable for basic debugging:

e Tooltip watch—in the editor window—provides the simplest way of viewing the
value of a variable or more complex expressions. Just point at the variable with the
mouse pointer. The value is displayed next to the variable.

o The Auto window displays a useful selection of variables and expressions in, or
near, the current statement. The window is automatically updated when execution
stops.

o The Locals window displays the local variables, that is, auto variables and function
parameters for the active function. The window is automatically updated when
execution stops.

o The Watch window allows you to monitor the values of C-SPY expressions and
variables. The window is automatically updated when execution stops.

o The Live Watch window repeatedly samples and displays the values of expressions
while your application is executing. Variables in the expressions must be statically
located, such as global variables.

o The Statics window displays the values of variables with static storage duration.
The window is automatically updated when execution stops.
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o The Macro Quicklaunch window and the Quick Watch window give you precise
control over when to evaluate an expression.

e The Symbols window displays all symbols with a static location, that is, C/C++
functions, assembler labels, and variables with static storage duration, including
symbols from the runtime library.

These additional methods for looking at variables are suitable for more advanced
analysis:

o The Data Log window and the Data Log Summary window display logs of
accesses to up to four different memory locations you choose by setting data log
breakpoints. Data logging can help you locate frequently accessed data. You can
then consider whether you should place that data in more efficient memory.

o The Event Log window and the Event Log Summary window display event logs
produced when the execution passes specific positions in your application code. The
Timeline window graphically displays these event logs correlated to a common
time-axis. Event logging can help you to analyze program flow and inspect data
correlated to a certain position in your application code.

The Cortex ITM communication channels are used for passing events from a running
application to the C-SPY Event log system. There are predefined preprocessor

macros that you can use in your application source code. An Event log will be

generated every time such macros are passed during program execution. You can
pass a value with each event. Typically, this value can be either an identifier or the
content of a variable or a register (for example, the stack pointer). The value can be
written in 8, 16, or 32-bit format. Using a smaller size will reduce the bandwidth
needed on the SWO wire. Events can be generated with or without an associated PC
(program counter) value, the PC value makes it possible for the debugger to correlate
the event to the executed code.

For more information about these windows, see The application timeline, page 253.

C-SPY EXPRESSIONS

C-SPY expressions can include any type of C expression, except for calls to functions.
The following types of symbols can be used in expressions:

C/C++ symbols
Assembler symbols (register names and assembler labels)

C-SPY macro functions

C-SPY macro variables.



Variables and expressions °

Expressions that are built with these types of symbols are called C-SPY expressions and
there are several methods for monitoring these in C-SPY. Examples of valid C-SPY
expressions are:

i+ 3

i = 42

myVar = cVar

cVar = myVar + 2

#asm_label

#R2

#PC

my_macro_func(19)

If you have a static variable with the same name declared in several different functions,
use the notation function: : variable to specify which variable to monitor.

C/C++ symbols

C symbols are symbols that you have defined in the C source code of your application,
for instance variables, constants, and functions (functions can be used as symbols but
cannot be executed). C symbols can be referenced by their names. Note that C++
symbols might implicitly contain function calls which are not allowed in C-SPY
symbols and expressions.

Note: Some attributes available in C/C++, like volatile, are not fully supported by
C-SPY. For example, this line will not be accepted by C-SPY:

sizeof (unsigned char volatile __memattr *)
However, this line will be accepted:

sizeof (unsigned char __memattr *)

Assembler symbols

Assembler symbols can be assembler labels or registers, for example the program
counter, the stack pointer, or other CPU registers. If a device description file is used, all
memory-mapped peripheral units, such as I/O ports, can also be used as assembler
symbols in the same way as the CPU registers. See Modifying a device description file,
page 57.

Assembler symbols can be used in C-SPY expressions if they are prefixed by #.

Example What it does
#PC++ Increments the value of the program counter.
myVar = #SP Assigns the current value of the stack pointer register to your

C-SPY variable.

Table 6: C-SPY assembler symbols expressions

95



Introduction to working with variables and expressions

96

C-SPY® Debugging Guide
for Arm

Example What it does
myVar = #label Sets myVar to the value of an integer at the address of 1abel.
myptr = &#label7 Sets myptr to an int * pointer pointing at label7.

Table 6: C-SPY assembler symbols expressions

In case of a name conflict between a hardware register and an assembler label, hardware
registers have a higher precedence. To refer to an assembler label in such a case, you
must enclose the label in back quotes * (ASCII character 0x60). For example:

Example What it does
#PC Refers to the program counter.
# PC’ Refers to the assembler label PC.

Table 7: Handling name conflicts between hardware registers and assembler labels

Which processor-specific symbols are available by default can be seen in the Registers
window, using the CPU Registers register group. See Registers window, page 180.

C-SPY macro functions

Macro functions consist of C-SPY macro variable definitions and macro statements
which are executed when the macro is called.

For information about C-SPY macro functions and how to use them, see Briefly about
the macro language, page 415.

C-SPY macro variables

Macro variables are defined and allocated outside your application, and can be used in
a C-SPY expression. In case of a name conflict between a C symbol and a C-SPY macro
variable, the C-SPY macro variable will have a higher precedence than the C variable.
Assignments to a macro variable assign both its value and type.

For information about C-SPY macro variables and how to use them, see Reference
information on the macro language, page 420.

Using sizeof

According to standard C, there are two syntactical forms of sizeof:

sizeof (type)
sizeof expr

The former is for types and the latter for expressions.

Note: In C-SPY, do not use parentheses around an expression when you use the sizeof
operator. For example, use sizeof x+2 instead of sizeof (x+2).
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LIMITATIONS ON VARIABLE INFORMATION

The value of a C variable is valid only on step points, that is, the first instruction of a
statement and on function calls. This is indicated in the editor window with a bright
green highlight color. In practice, the value of the variable is accessible and correct more
often than that.

When the program counter is inside a statement, but not at a step point, the statement or
part of the statement is highlighted with a pale variant of the ordinary highlight color.

Effects of optimizations

The compiler is free to optimize the application software as much as possible, as long
as the expected behavior remains. The optimization can affect the code so that
debugging might be more difficult because it will be less clear how the generated code
relates to the source code. Typically, using a high optimization level can affect the code
in a way that will not allow you to view a value of a variable as expected.

Consider this example:

myFunction ()
{
int i = 42;

x = computer(i); /* Here, the value of i is known to C-SPY */

}

From the point where the variable i is declared until it is actually used, the compiler
does not need to waste stack or register space on it. The compiler can optimize the code,
which means that C-SPY will not be able to display the value until it is actually used. If
you try to view the value of a variable that is temporarily unavailable, C-SPY will
display the text:

Unavailable

If you need full information about values of variables during your debugging session,
you should make sure to use the lowest optimization level during compilation, that is,
None.

Working with variables and expressions

These tasks are covered:

o Using the windows related to variables and expressions

o Viewing assembler variables
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See also Analyzing your application s timeline, page 255.

USING THE WINDOWS RELATED TO VARIABLES AND
EXPRESSIONS

Where applicable, you can add, modify, and remove expressions, and change the display
format in the windows related to variables and expressions.

To add a value you can also click in the dotted rectangle and type the expression you
want to examine. To modify the value of an expression, click the Value field and modify
its content. To remove an expression, select it and press the Delete key.

For text that is too wide to fit in a column—in any of the these windows, except the
g  Trace window—and thus is truncated, just point at the text with the mouse pointer and
tooltip information is displayed.

Right-click in any of the windows to access the context menu which contains additional
commands. Convenient drag-and-drop between windows is supported, except for in the
Locals window, Data logging windows, and the Quick Watch window where it is not
relevant.

VIEWING ASSEMBLER VARIABLES

An assembler label does not convey any type information at all, which means C-SPY
cannot easily display data located at that label without getting extra information. To
view data conveniently, C-SPY by default treats all data located at assembler labels as
variables of type int. However, in the Watch, Live Watch, and Quick Watch
windows, you can select a different interpretation to better suit the declaration of the
variables.

C-SPY® Debugging Guide
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In this figure, you can see four variables in the Watch window and their corresponding
declarations in the assembler source file to the left:

. f) + x Watch1
HAME main — | Expression Yalue Location Type
= asmvarl 42 0x00000080 int
PUBLIC _ iar program start asrrvard 456 0=00000084 int
astrvard 55 O0=00000088 <8-bit unsigned>

SECTION .intvec : CODE (2}
CODES2

<clickto ... Default Format

__iar program start Binary Format
B main Octal Format

v Decimal Format

SECTION .text : CODE (2) Hexadecimal Format

Char Format
asmvarl: DC32 42

asmvar2: DC32 456 Show As b Asls
asmvar3: DC8 55 8-bit Signed
asmvard: DC8 10 Saveto File...
16-bit Signed
copes2z 16-bit Unsigned
=  main NOE 32-bit Signed
B main 32-bit Unsigned
64-bit Signed
EID 64-bit Unsigned
float
double

Note that asmvar4 is displayed as an int, although the original assembler declaration
probably intended for it to be a single byte quantity. From the context menu you can
make C-SPY display the variable as, for example, an 8-bit unsigned variable. This has
already been specified for the asmvar3 variable.

Reference information on working with variables and expressions

Reference information about:

Auto window, page 100

Locals window, page 102
Watch window, page 104

Live Watch window, page 106
Statics window, page 109
Quick Watch window, page 112
Symbols window, page 115

Resolve Symbol Ambiguity dialog box, page 116

929



Reference information on working with variables and expressions

100

Auto window

Requirements

Context menu
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See also:

® Reference information on trace, page 211 for trace-related reference information

® Macro Quicklaunch window, page 488

The Auto window is available from the View menu.

Auto * o X
Expression Yalue Location Type
# MextCounter MNextCounter (0x40E) woid ...
filh 1 Memory : OxFEF74  uint3Z2_t
# GetFib GetFib (0x141) uint32_t (...
callCount 3 Memory : 0xFEFAS  signed int

This window displays a useful selection of variables and expressions in, or near, the
current statement. Every time execution in C-SPY stops, the values in the Auto window
are recalculated. Values that have changed since the last stop are highlighted in red.

See also Editing in C-SPY windows, page 56.

None; this window is always available.

This context menu is available:

Remove

Rermove All

Default Format
Binary Format

Octal Format
Decimal Format
Hexadecimal Format

Char Format
Show As 3
Save to File...
Options...
Note: The contents of this menu are dynamic and depend on which features that your

combination of software and hardware supports. However, the list of menu commands
below is complete and covers all possible commands.
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These commands are available:

Remove
Removes the selected expression from the window.

Remove All

Removes all expressions listed in the window.

Default Format,

Binary Format,

Octal Format,

Decimal Format,

Hexadecimal Format,

Char Format
Changes the display format of expressions. The display format setting affects
different types of expressions in different ways. Your selection of display format
is saved between debug sessions. These commands are available if a selected
line in the window contains a variable.

The display format setting affects different types of expressions in these ways:

Variables The display setting affects only the selected variable, not
other variables.

Array elements The display setting affects the complete array, that is, the
same display format is used for each array element.

Structure fields All elements with the same definition—the same field
name and C declaration type—are affected by the
display setting.

Show As

Displays a submenu that provides commands for changing the default type
interpretation of variables. The commands on this submenu are mainly useful
for assembler variables—data at assembler labels—because these are, by
default, displayed as integers. For more information, see Viewing assembler
variables, page 98.

Options
Displays the IDE Options dialog box where you can set various options, for
example the Update interval option. The default value of this option is 1000
milliseconds, which means the Live Watch window will be updated once every
second during program execution.

Save to File
Saves content to a file in a tab-separated format.
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The Locals window is available from the View menu.

Locals * o X

Location
Memory : 0xFEF72

Yariable  Value
i 1244

Type
signed int

This window displays the local variables and parameters for the current function. Every
time execution in C-SPY stops, the values in the window are recalculated. Values that
have changed since the last stop are highlighted in red.

See also Editing in C-SPY windows, page 56.

None; this window is always available.

This context menu is available:

Remove

Rermove All

Default Format
Binary Format

Octal Format
Decimal Format
Hexadecimal Format

Char Format
Show As 3
Save to File...
Options...
Note: The contents of this menu are dynamic and depend on which features that your

combination of software and hardware supports. However, the list of menu commands
below is complete and covers all possible commands.

These commands are available:

Remove

Removes the selected expression from the window.

Remove All
Removes all expressions listed in the window.
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Default Format,

Binary Format,

Octal Format,

Decimal Format,

Hexadecimal Format,

Char Format
Changes the display format of expressions. The display format setting affects
different types of expressions in different ways. Your selection of display format
is saved between debug sessions. These commands are available if a selected
line in the window contains a variable.

The display format setting affects different types of expressions in these ways:

Variables The display setting affects only the selected variable, not
other variables.

Array elements The display setting affects the complete array, that is, the
same display format is used for each array element.

Structure fields All elements with the same definition—the same field
name and C declaration type—are affected by the
display setting.

Show As

Displays a submenu that provides commands for changing the default type
interpretation of variables. The commands on this submenu are mainly useful
for assembler variables—data at assembler labels—because these are, by
default, displayed as integers. For more information, see Viewing assembler
variables, page 98.

Options
Displays the IDE Options dialog box where you can set various options, for
example the Update interval option. The default value of this option is 1000
milliseconds, which means the Live Watch window will be updated once every
second during program execution.

Save to File
Saves content to a file in a tab-separated format.
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The Watch window is available from the View menu.

Watch 1 *
Expression Yalue Location Type
callCount 2 Memory : 0xFEFAS signed int
= Fib <array> Memory : 0xFEF20 uint3z2_t10]
e 0] 1 Memory : OxFEFR0 uint3z_t
1] 1 Memory : 0xFEFa4 uint3z2_t
[2] 2 Memory : 0xFEFRE uint3z2_t
[3] 3 0xFEF8C uint32_t
[4] 5 v : 0xFEF90 uint32_t
[5] a v : OXFEF94 uint3z2_t
[6] 13 0xFEF28 uint32_t
[71 21 0xFEF2C uint32_t
[8] 34 0xFEFAD uint32_t
19 55 v : OXFEFA4 uint3z2_t

Use this window to monitor the values of C-SPY expressions or variables. You can open
up to four instances of this window, where you can view, add, modify, and remove
expressions. Tree structures of arrays, structs, and unions are expandable, which means
that you can study each item of these.

Every time execution in C-SPY stops, the values in the Watch window are recalculated.
Values that have changed since the last stop are highlighted in red.

Be aware that expanding very huge arrays can cause an out-of-memory crash. To avoid
this, expansion is automatically performed in steps of 5000 elements.

See also Editing in C-SPY windows, page 56.

None; this window is always available.
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Context menu

This context menu is available:
Remove
Rermove All
Default Format
Binary Format
Octal Format
Decimal Format
Hexadecimal Format

Char Format
Show As 3
Save to File...

Options...

Note: The contents of this menu are dynamic and depend on which features that your
combination of software and hardware supports. However, the list of menu commands
below is complete and covers all possible commands.

These commands are available:

Remove
Removes the selected expression from the window.

Remove All

Removes all expressions listed in the window.

Default Format,

Binary Format,

Octal Format,

Decimal Format,

Hexadecimal Format,

Char Format
Changes the display format of expressions. The display format setting affects
different types of expressions in different ways. Your selection of display format
is saved between debug sessions. These commands are available if a selected
line in the window contains a variable.

The display format setting affects different types of expressions in these ways:

Variables The display setting affects only the selected variable, not
other variables.

Array elements The display setting affects the complete array, that is, the
same display format is used for each array element.
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Structure fields All elements with the same definition—the same field
name and C declaration type—are affected by the
display setting.

Show As

Displays a submenu that provides commands for changing the default type
interpretation of variables. The commands on this submenu are mainly useful
for assembler variables—data at assembler labels—because these are, by
default, displayed as integers. For more information, see Viewing assembler
variables, page 98.

Options
Displays the IDE Options dialog box where you can set various options, for
example the Update interval option. The default value of this option is 1000
milliseconds, which means the Live Watch window will be updated once every
second during program execution.

Save to File
Saves content to a file in a tab-separated format.

The Live Watch window is available from the View menu.

Live Watch * o X
Expression Yalue Location Type
= GetFib GetFib (0x141) uint3zZ_t(_ne..

------ GetFib (0x141) Memory:Oxl41 uint32_t{int_f.

This window repeatedly samples and displays the value of expressions while your
application is executing. Variables in the expressions must be statically located, such as
global variables.

The following possibilities for live watch apply:

Device

Cortex-M Access to memory or setting breakpoints is always possible during
execution.

Armxxx-S Setting hardware breakpoints is always possible during execution.

Table 8: Live watch for the different devices
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Device

Arm7/Arm9, including Memory accesses must be made by your application. By adding a small
Armxxx-S, program—a DCC handler—that communicates with the debugger
and when using the through the DCC unit to your application, memory can be read/written
C-SPY J-Link/J-Trace  during execution. Software breakpoints can also be set by the DCC
driver handler.
Just add the files JLINKDCC_Process . ¢ and
JLINKDCC_HandleDataAbort.s located in
arm\src\debugger\dcc to your project and call the
JLINKDCC_Process function regularly, for example every
millisecond.
In your local copy of the cstartup file, modify the interrupt vector
table so that data aborts will call the
JLINKDCC_HandleDataAbort handler. See also —jlink_dcc_timeout,
page 524.

Table 8: Live watch for the different devices

See also Editing in C-SPY windows, page 56.

Requirements

This window is available for all combinations of C-SPY driver and device, except for
the C-SPY Stellaris driver and the C-SPY I-jet driver when using a Cortex-A device.

Display area
This area contains these columns:

Expression

The name of the variable. The base name of the variable is followed by the full
name, which includes module, class, or function scope. This column is not
editable.

Value
The value of the variable. Values that have changed are highlighted in red.

Dragging text or a variable from another window and dropping it on the Value
column will assign a new value to the variable in that row.

This column is editable.

Location
The location in memory where this variable is stored.

Type
The data type of the variable.
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This context menu is available:
Remove

Rermove All

Default Format
Binary Format

Octal Format
Decimal Format
Hexadecimal Format

Char Format
Show As 3
Save to File...

Options...

Note: The contents of this menu are dynamic and depend on which features that your
combination of software and hardware supports. However, the list of menu commands
below is complete and covers all possible commands.

These commands are available:

Remove
Removes the selected expression from the window.

Remove All

Removes all expressions listed in the window.

Default Format,

Binary Format,

Octal Format,

Decimal Format,

Hexadecimal Format,

Char Format
Changes the display format of expressions. The display format setting affects
different types of expressions in different ways. Your selection of display format
is saved between debug sessions. These commands are available if a selected
line in the window contains a variable.

The display format setting affects different types of expressions in these ways:

Variables The display setting affects only the selected variable, not

other variables.

Array elements The display setting affects the complete array, that is, the

same display format is used for each array element.
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All elements with the same definition—the same field
name and C declaration type—are affected by the
display setting.

Structure fields

Show As

Displays a submenu that provides commands for changing the default type
interpretation of variables. The commands on this submenu are mainly useful
for assembler variables—data at assembler labels—because these are, by
default, displayed as integers. For more information, see Viewing assembler
variables, page 98.

Options
Displays the IDE Options dialog box where you can set various options, for
example the Update interval option. The default value of this option is 1000
milliseconds, which means the Live Watch window will be updated once every
second during program execution.

Save to File
Saves content to a file in a tab-separated format.

Statics window

The Statics window is available from the View menu.

Statics * o X
Yariable Yalue Location Type Module =
= fibStat <UsingClassesifibStat <class> v:0xFB140  class Fibonacci UsingClasses

L mCurrent 2 v:0xFB140  uint_fastd_t

= msFib <FibonacciByClass\FibonaccizmsFib>  size=100

<Faw>
_Mylmpl

<class>
<class>
<class>

v :0xFEB134
OxFB134
OxFB134
OxFB134

class vector<uinti2_t>»
class vector<uinti2_t»

wectoruint32_tx:_Impl

FibonacciByClass |z

class _Wector_wvalue<allocator...

=class> 0xFE134 class _ClasslUtil:_AllocHolder...

OxADED 0xFB134  woid __near®

0xA270 v:0xFB136  woid __near®

0xA270 Memory :0xFB138  woid__near®

o] Memory : OxFROED  uint3Z2_t

o] Memory : OxFRAOE4  uint3Z2_t b

This window displays the values of variables with static storage duration that you have
selected. Typically, that is variables with file scope but it can also be static variables in
functions and classes. Note that volatile declared variables with static storage
duration will not be displayed.

Every time execution in C-SPY stops, the values in the Statics window are recalculated.
Values that have changed since the last stop are highlighted in red.

Click any column header (except for Value) to sort on that column.
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See also Editing in C-SPY windows, page 56.

To select variables to monitor:

In the window, right-click and choose Select statics from the context menu. The
window now lists all variables with static storage duration.

Either individually select the variables you want to display, or choose one of the Select
commands from the context menu.

When you have made your selections, choose Select statics from the context menu to
toggle back to normal display mode.

None; this window is always available.

This area contains these columns:

Expression

The name of the variable. The base name of the variable is followed by the full
name, which includes module, class, or function scope. This column is not
editable.

Value
The value of the variable. Values that have changed are highlighted in red.

Dragging text or a variable from another window and dropping it on the Value
column will assign a new value to the variable in that row.

This column is editable.

Location
The location in memory where this variable is stored.

Type
The data type of the variable.

Module
The module of the variable.
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Context menu

This context menu is available:
v Default Format
Binary Format
Octal Format
Decimal Format
Hexadecimal Format

Char Format
Show As 3
Save to File...

v Select Statics
Select All
Select None
Select All in ‘Tutor'

Select None in ‘Tutor'

These commands are available:

Default Format,
Binary Format,

Octal Format,
Decimal Format,
Hexadecimal Format,
Char Format

Changes the display format of expressions. The display format setting affects
different types of expressions in different ways. Your selection of display format
is saved between debug sessions. These commands are available if a selected
line in the window contains a variable.

The display format setting affects different types of expressions in these ways:

Variables The display setting affects only the selected variable, not
other variables.

Array elements The display setting affects the complete array, that is, the
same display format is used for each array element.

Structure fields All elements with the same definition—the same field
name and C declaration type—are affected by the
display setting.

Save to File
Saves the content of the Statics window to a log file.
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Select Statics
Selects all variables with static storage duration; this command also enables all
Select commands below. Select the variables you want to monitor. When you
have made your selections, select this menu command again to toggle back to
normal display mode.

Select All
Selects all variables.

Select None
Deselects all variables.

Select All in module
Selects all variables in the selected module.

Select None in module

Deselects all variables in the selected module.

The Quick Watch window is available from the View menu and from the context menu
in the editor window.

Quick Watch * O X

(A imestatus] -

Expression Yalue Location  Type
TimerStatus() 'Timer disabled® macro string

Use this window to watch the value of a variable or expression and evaluate expressions
at a specific point in time.

In contrast to the Watch window, the Quick Watch window gives you precise control
over when to evaluate the expression. For single variables this might not be necessary,
but for expressions with possible side effects, such as assignments and C-SPY macro
functions, it allows you to perform evaluations under controlled conditions.

See also Editing in C-SPY windows, page 56.

To evaluate an expression:

In the editor window, right-click on the expression you want to examine and choose
Quick Watch from the context menu that appears.

The expression will automatically appear in the Quick Watch window.
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Alternatively:

In the Quick Watch window, type the expression you want to examine in the
Expressions text box.

Click the Recalculate button to calculate the value of the expression.

For an example, see Using C-SPY macros, page 415.

None; this window is always available.

This context menu is available:
Remove

Rermove All

Default Format
Binary Format

Octal Format
Decimal Format
Hexadecimal Format

Char Format
Show As 3
Save to File...
Options...
Note: The contents of this menu are dynamic and depend on which features that your

combination of software and hardware supports. However, the list of menu commands
below is complete and covers all possible commands.

These commands are available:

Remove

Removes the selected expression from the window.

Remove All
Removes all expressions listed in the window.
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Default Format,

Binary Format,

Octal Format,

Decimal Format,

Hexadecimal Format,

Char Format
Changes the display format of expressions. The display format setting affects
different types of expressions in different ways. Your selection of display format
is saved between debug sessions. These commands are available if a selected
line in the window contains a variable.

The display format setting affects different types of expressions in these ways:

Variables The display setting affects only the selected variable, not
other variables.

Array elements The display setting affects the complete array, that is, the
same display format is used for each array element.

Structure fields All elements with the same definition—the same field
name and C declaration type—are affected by the
display setting.

Show As

Displays a submenu that provides commands for changing the default type
interpretation of variables. The commands on this submenu are mainly useful
for assembler variables—data at assembler labels—because these are, by
default, displayed as integers. For more information, see Viewing assembler
variables, page 98.

Options
Displays the IDE Options dialog box where you can set various options, for
example the Update interval option. The default value of this option is 1000
milliseconds, which means the Live Watch window will be updated once every
second during program execution.

Save to File
Saves content to a file in a tab-separated format.

C-SPY® Debugging Guide
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Symbols window

The Symbols window is available from the View menu after you have enabled the

Symbols plugin module.
]
Symbal | Location | Full Mame |"
call_count 0x00102228 call_count
do_foreground_process  0x000003C8  do_foreground_process()
exit 0x000005E4  exit
get_fib 0x0000028C  get_fib(int)
init_fibh 0x00000248  init_fib()
main 0x000003E2  mainf)
next_counter 0x000003BC  next_counter()
put_fib 0x000002B8  put_fib{unsigned int)
putchar 0x00000464 putchar
root 0x00102200 root v

This window displays all symbols with a static location, that is, C/C++ functions,
assembler labels, and variables with static storage duration, including symbols from the
runtime library.

To enable the Symbols plugin module, choose Project>Options>Debugger>Select
plugins to load>Symbols.

Requirements

None; this window is always available.

Display area
This area contains these columns:

Symbol
The symbol name.

Location

The memory address.

Full name

The symbol name; often the same as the contents of the Symbol column but
differs for example for C++ member functions.

Click the column headers to sort the list by symbol name, location, or full name.
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Context menu

This context menu is available:

Functions
Variables
Labels

These commands are available:
Functions

Toggles the display of function symbols on or off in the list.
Variables

Toggles the display of variables on or off in the list.

Labels
Toggles the display of labels on or off in the list.

Resolve Symbol Ambiguity dialog box

The Resolve Symbol Ambiguity dialog box appears, for example, when you specify a
symbol in the Disassembly window to go to, and there are several instances of the same
symbol due to templates or function overloading.

Resolve Symbol Ambiguity

Ambiguous symbol: foo

Fleaze select one symbal:

faofvoid)

fon<T: Camcel

Requirements

None; this window is always available.

Ambiguous symbol

Indicates which symbol that is ambiguous.

C-SPY® Debugging Guide
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Please select one symbol

A list of possible matches for the ambiguous symbol. Select the one you want to use.
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Breakpoints

e Introduction to setting and using breakpoints
e Setting breakpoints

e Reference information on breakpoints

Introduction to setting and using breakpoints

These topics are covered:

Reasons for using breakpoints

Briefly about setting breakpoints

Breakpoint types

Breakpoint icons

Breakpoints in the C-SPY simulator

Breakpoints in the C-SPY hardware debugger drivers

Breakpoint consumers

Breakpoints options dialog box

REASONS FOR USING BREAKPOINTS

C-SPY® lets you set various types of breakpoints in the application you are debugging,
allowing you to stop at locations of particular interest. You can set a breakpoint at a code
location to investigate whether your program logic is correct, or to get trace printouts.
In addition to code breakpoints, and depending on what C-SPY driver you are using,
additional breakpoint types might be available. For example, you might be able to set a
data breakpoint, to investigate how and when the data changes.

You can let the execution stop under certain conditions, which you specify. You can also
let the breakpoint trigger a side effect, for instance executing a C-SPY macro function,
by transparently stopping the execution and then resuming. The macro function can be
defined to perform a wide variety of actions, for instance, simulating hardware behavior.

All these possibilities provide you with a flexible tool for investigating the status of your
application.
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BRIEFLY ABOUT SETTING BREAKPOINTS

You can set breakpoints in many various ways, allowing for different levels of
interaction, precision, timing, and automation. All the breakpoints you define will
appear in the Breakpoints window. From this window you can conveniently view all
breakpoints, enable and disable breakpoints, and open a dialog box for defining new
breakpoints. The Breakpoint Usage window also lists all internally used breakpoints,
see Breakpoint consumers, page 123.

Breakpoints are set with a higher precision than single lines, using the same mechanism
as when stepping; for more information about the precision, see Single stepping, page
72.

You can set breakpoints while you edit your code even if no debug session is active. The
breakpoints will then be validated when the debug session starts. Breakpoints are
preserved between debug sessions.

Note: For most hardware debugger systems it is only possible to set breakpoints when
the application is not executing.

BREAKPOINT TYPES

Depending on the C-SPY driver you are using, C-SPY supports different types of
breakpoints.

Code breakpoints

Code breakpoints are used for code locations to investigate whether your program logic
is correct or to get trace printouts. Code breakpoints are triggered when an instruction is
fetched from the specified location. If you have set the breakpoint on a specific machine
instruction, the breakpoint will be triggered and the execution will stop, before the
instruction is executed.

Log breakpoints

Log breakpoints provide a convenient way to add trace printouts without having to add
any code to your application source code. Log breakpoints are triggered when an
instruction is fetched from the specified location. If you have set the breakpoint on a
specific machine instruction, the breakpoint will be triggered and the execution will
temporarily stop and print the specified message in the C-SPY Debug Log window.

Trace Start and Stop breakpoints

Trace Start and Stop breakpoints start and stop trace data collection—a convenient way
to analyze instructions between two execution points.

C-SPY® Debugging Guide
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Data breakpoints

Data breakpoints are primarily useful for variables that have a fixed address in memory.
If you set a breakpoint on an accessible local variable, the breakpoint is set on the
corresponding memory location. The validity of this location is only guaranteed for
small parts of the code. Data breakpoints are triggered when data is accessed at the
specified location. The execution will usually stop directly after the instruction that
accessed the data has been executed.

Data Log breakpoints

Data log breakpoints are triggered when a specified variable is accessed. A log entry is
written in the SWO Trace window (Trace window in the simulator) for each access. A
log message can also be displayed in the Data Log window. Data logs can also be
displayed on the Data Log graph in the Timeline window, if that window is enabled.
However, these log messages require that you have set up trace data in the SWO
Configuration dialog box, see SWO Configuration dialog box, page 218.

You can set data log breakpoints using the Breakpoints window, the Memory window,
and the editor window.

Using a single instruction, the microcontroller can only access values that are four bytes
or less. If you specify a data log breakpoint on a memory location that cannot be
accessed by one instruction, for example a double or a too large area in the Memory
window, the result might not be what you intended.

Immediate breakpoints

The C-SPY Simulator lets you set immediate breakpoints, which will halt instruction
execution only temporarily. This allows a C-SPY macro function to be called when the
simulated processor is about to read data from a location or immediately after it has
written data. Instruction execution will resume after the action.

This type of breakpoint is useful for simulating memory-mapped devices of various
kinds (for instance serial ports and timers). When the simulated processor reads from a
memory-mapped location, a C-SPY macro function can intervene and supply
appropriate data. Conversely, when the simulated processor writes to a memory-mapped
location, a C-SPY macro function can act on the value that was written.

JTAG watchpoints

The C-SPY J-Link/J-Trace driver can take advantage of the JTAG watchpoint
mechanism in Arm7/9 cores.

The watchpoints are implemented using the functionality provided by the Arm
EmbeddedICE™ macrocell. The macrocell is part of every Arm core that supports the
JTAG interface. The EmbeddedICE watchpoint comparator compares the address bus,
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data bus, CPU control signals and external input signals with the defined watchpoint in
real time. When all defined conditions are true, the program will break.

The watchpoints are implicitly used by C-SPY to set code breakpoints or data
breakpoints in the application. When setting breakpoints in read/write memory, only one
watchpoint is needed by the debugger. When setting breakpoints in read-only memory,
one watchpoint is needed for each breakpoint. Because the macrocell only implements
two hardware watchpoints, the maximum number of breakpoints in read-only memory
is two.

For a more detailed description of the Arm JTAG watchpoint mechanism, refer to these
documents from Arm Limited:

o ARMT7TDMI (rev 3) Technical Reference Manual: chapter 5, Debug Interface, and
appendix B, Debug in Depth

e Application Note 28, The ARM7TDMI Debug Architecture.

Flash breakpoints

Software code breakpoints (breakpoints that rely on writing breakpoint instructions into
memory) can be set in flash memory or other non-volatile executable memory using the
flash breakpoint mechanism. This involves programming of the flash memory using a
flash loader in the same way as is done when downloading an application.

This breakpoint type is only available for the C-SPY I-jet driver.

BREAKPOINT ICONS

A breakpoint is marked with an icon in the left margin of the editor window, and the icon
varies with the type of breakpoint:

Tutor.c |

unsigned int get_fib({ int nr |
i

| if{(nr> ) es (nr <= WX FIB) )
l Log breakpoint l {
'

Log @ Ltilities,c:37.5
Memory:0x6a [Fetch ]

’O return { 0 ):
'

l Code breakpoint l

l Toeltip information l o

Disabled code
breakpeint

If the breakpoint icon does not appear, make sure the option Show bookmarks is
selected, see Editor options in the IDE Project Management and Building Guide for
Arm.
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Just point at the breakpoint icon with the mouse pointer to get detailed tooltip
information about all breakpoints set on the same location. The first row gives user
breakpoint information, the following rows describe the physical breakpoints used for
implementing the user breakpoint. The latter information can also be seen in the
Breakpoint Usage window.

Note: The breakpoint icons might look different for the C-SPY driver you are using.

BREAKPOINTS IN THE C-SPY SIMULATOR

The C-SPY simulator supports all breakpoint types and you can set an unlimited amount
of breakpoints.

BREAKPOINTS IN THE C-SPY HARDWARE DEBUGGER
DRIVERS

Using the C-SPY drivers for hardware debugger systems you can set various breakpoint
types. The amount of breakpoints you can set depends on the number of hardware
breakpoints available on the target system or whether you have enabled software
breakpoints, in which case the number of breakpoints you can set is unlimited.

When software breakpoints are enabled, the debugger will first use any available
hardware breakpoints before using software breakpoints. Exceeding the number of
available hardware breakpoints, when software breakpoints are not enabled, causes the
debugger to single step. This will significantly reduce the execution speed. For this
reason you must be aware of the different breakpoint consumers.

For information about the characteristics of breakpoints for the different target systems,
see the manufacturer’s documentation.

BREAKPOINT CONSUMERS

A debugger system includes several consumers of breakpoints.

User breakpoints

The breakpoints you define in the breakpoint dialog box or by toggling breakpoints in
the editor window often consume one physical breakpoint each, but this can vary greatly.
Some user breakpoints consume several physical breakpoints and conversely, several

user breakpoints can share one physical breakpoint. User breakpoints are displayed in

the same way both in the Breakpoint Usage window and in the Breakpoints window,
for example Data @[R] callCount.
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C-SPY itself
C-SPY itself also consumes breakpoints. C-SPY will set a breakpoint if:

o The debugger option Run to has been selected, and any step command is used.
These are temporary breakpoints which are only set during a debug session. This
means that they are not visible in the Breakpoints window.

o The linker option Semihosted or IAR breakpoint has been selected.
In the DLIB runtime environment, C-SPY will set a system breakpoint on the

__DebugBreak label.

These types of breakpoint consumers are displayed in the Breakpoint Usage window,
for example, C-SPY Terminal I/0 & libsupport module.

C-SPY plugin modules

For example, modules for real-time operating systems can consume additional
breakpoints. Specifically, by default, the Stack window consumes one physical
breakpoint.

To disable the breakpoint used by the Stack window:

I Choose Tools>Options>Stack.
2 Deselect the Stack pointer(s) not valid until program reaches: label option.

To disable the Stack window entirely, choose Tools>Options>Stack and make sure all
options are deselected.

BREAKPOINTS OPTIONS

For the following C-SPY drivers it is possible to set some driver-specific breakpoint
options before you start C-SPY:

GDB Server

I-jet/JTAGjet

J-Link/J-Trace

CMSIS-DAP

ST-LINK

TI XDS.

For more information, see Breakpoints options dialog box, page 148.

C-SPY® Debugging Guide
124 for Arm



Breakpoints °

Setting breakpoints

These tasks are covered:

Various ways to set a breakpoint

Toggling a simple code breakpoint

Setting breakpoints using the dialog box

Setting a data breakpoint in the Memory window
Setting breakpoints using system macros

Setting a breakpoint on an exception vector

Setting breakpoints in __ramfunc declared functions

Useful breakpoint hints.

VARIOUS WAYS TO SET A BREAKPOINT
You can set a breakpoint in various ways:

o Toggling a simple code breakpoint.

o Using the New Breakpoints dialog box and the Edit Breakpoints dialog box
available from the context menus in the editor window, Breakpoints window, and
in the Disassembly window. The dialog boxes give you access to all breakpoint
options.

o Setting a data breakpoint on a memory area directly in the Memory window.

o Using predefined system macros for setting breakpoints, which allows automation.

The different methods offer different levels of simplicity, complexity, and automation.

TOGGLING A SIMPLE CODE BREAKPOINT

Toggling a code breakpoint is a quick method of setting a breakpoint. The following
methods are available both in the editor window and in the Disassembly window:

o Click in the gray left-side margin of the window

o Place the insertion point in the C source statement or assembler instruction where
!’ you want the breakpoint, and click the Toggle Breakpoint button in the toolbar

o Choose Edit>Toggle Breakpoint

o Right-click and choose Toggle Breakpoint from the context menu.

SETTING BREAKPOINTS USING THE DIALOG BOX

The advantage of using a breakpoint dialog box is that it provides you with a graphical
interface where you can interactively fine-tune the characteristics of the breakpoints.
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You can set the options and quickly test whether the breakpoint works according to your
intentions.

All breakpoints you define using a breakpoint dialog box are preserved between debug
sessions.

You can open the dialog box from the context menu available in the editor window,
Breakpoints window, and in the Disassembly window.

To set a new breakpoint:
Choose View>Breakpoints to open the Breakpoints window.

In the Breakpoints window, right-click, and choose New Breakpoint from the context
menu.

On the submenu, choose the breakpoint type you want to set.
Depending on the C-SPY driver you are using, different breakpoint types are available.
In the breakpoint dialog box that appears, specify the breakpoint settings and click OK.

The breakpoint is displayed in the Breakpoints window.
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To modify an existing breakpoint:

In the Breakpoints window, editor window, or in the Disassembly window, select the
breakpoint you want to modify and right-click to open the context menu.

| UsingClasses.cpp * | IAR Information Center | FibonacciByClass.cpp | ¥
mainf) fur
fibl = 1; // Call to Fibonacci::Fibonacci(fast
// Fibonacci::operator=
// and the Fibonacci destructor.
G _' Call to Fibopgeei::operator+,
Cut rator=
Eci destructor.
Copy
/4 Extrac
for (uint loggle Breakpoint (Code) =
= Toggle Breakpoint (Log)
bool ew ]
= cout << Toggle Breakpoint (Trace Start) setw(Z) << fibl.nex
Toggle Breakpoint (Trace Stop)
= FTE W ;
= /* :ie Enable/disable Breakpoint = pumbsr of
L #/ Set Data Breakpoint for 'fibl' —
if (1% Set Data Log Breakpoint for ‘fibl'
=] { . ; . B
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Options...

If there are several breakpoints on the same source code line, the breakpoints will be
listed on a submenu.

On the context menu, choose the appropriate command.
In the breakpoint dialog box that appears, specify the breakpoint settings and click OK.

The breakpoint is displayed in the Breakpoints window.

SETTING A DATA BREAKPOINT IN THE MEMORY WINDOW

You can set breakpoints directly on a memory location in the Memory window.
Right-click in the window and choose the breakpoint command from the context menu
that appears. To set the breakpoint on a range, select a portion of the memory contents.

The breakpoint is not highlighted in the Memory window; instead, you can see, edit,
and remove it using the Breakpoints window, which is available from the View menu.
The breakpoints you set in the Memory window will be triggered for both read and
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write accesses. All breakpoints defined in this window are preserved between debug
sessions.

Note: Setting breakpoints directly in the Memory window is only possible if the driver
you use supports this.

SETTING BREAKPOINTS USING SYSTEM MACROS

You can set breakpoints not only in the breakpoint dialog box but also by using built-in
C-SPY system macros. When you use system macros for setting breakpoints, the
breakpoint characteristics are specified as macro parameters.

Macros are useful when you have already specified your breakpoints so that they fully
meet your requirements. You can define your breakpoints in a macro file, using built-in
system macros, and execute the file at C-SPY startup. The breakpoints will then be set
automatically each time you start C-SPY. Another advantage is that the debug session
will be documented, and that several engineers involved in the development project can
share the macro files.

Note: If you use system macros for setting breakpoints, you can still view and modify
them in the Breakpoints window. In contrast to using the dialog box for defining
breakpoints, all breakpoints that are defined using system macros are removed when you
exit the debug session.

C-SPY macro for breakpoints Simulator I-jet/JTAGjet )-Link/J-Trace CMSIS-DAP CADI

__setCodeBreak Yes Yes Yes Yes Yes
__setDataBreak Yes Yes — Yes —
__setLogBreak Yes Yes Yes Yes —
__setDataLogBreak Yes Yes — — —
__setSimBreak Yes — — — —
__setTraceStartBreak Yes Yes — — —
__setTraceStopBreak Yes Yes — — —
__clearBreak Yes Yes Yes Yes Yes

Table 9: C-SPY macros for breakpoints

GDB ST-LINK and TI Stellaris /
C-SPY macro for breakpoints PE micro Nu-Link
Server TI MSP-FET TI XDS
__setCodeBreak Yes Yes Yes Yes Yes
__setDataBreak — — — — —
__setLogBreak Yes Yes Yes Yes Yes

Table 10: C-SPY macros for breakpoints
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GDB ST-LINK and TI Stellaris /
C-SPY macro for breakpoints PE micro Nu-Link

Server TI MSP-FET TI XDS
__setDatalogBreak — — — — —
__setSimBreak — — — — —
__setTraceStartBreak — — — — —
__setTraceStopBreak — — — — —
__clearBreak Yes Yes Yes Yes Yes

Table 10: C-SPY macros for breakpoints (Continued)

For information about each breakpoint macro, see Reference information on C-SPY
system macros, page 430.

Setting breakpoints at C-SPY startup using a setup macro file

You can use a setup macro file to define breakpoints at C-SPY startup. Follow the
procedure described in Using C-SPY macros, page 415.

SETTING A BREAKPOINT ON AN EXCEPTION VECTOR

You can set breakpoints on exception vectors for ARM9, Cortex-R4, and Cortex-M3
devices. Use the Vector Catch dialog box to set a breakpoint directly on a vector in the
interrupt vector table, without using a hardware breakpoint. For more information, see
Vector Catch dialog box, page 151.

For the C-SPY I-jet/JTAGjet driver and the C-SPY J-Link/J-Trace driver, it is also
possible to set breakpoints directly on a vector already in the options dialog box, see
J-Link/J-Trace - Setup, page 572.

This procedure applies to the C-SPY I-jet/JTAGjet driver, and the C-SPY J-Link/J-Trace
driver.

To set a breakpoint on an exception vector:

Select the correct device. Before starting C-SPY, choose Project>Options and select
the General Options category. Choose the appropriate core or device from one of the
Processor variant drop-down lists available on the Target page.

Start C-SPY.

Choose C-SPY driver>Vector Catch. By default, vectors are selected according to
your settings on the Breakpoints options page, see Breakpoints options dialog box,
page 148.

In the Vector Catch dialog box, select the vector you want to set a breakpoint on, and
click OK. The breakpoint will only be triggered at the beginning of the exception.
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SETTING BREAKPOINTS IN _ RAMFUNC DECLARED
FUNCTIONS

To set abreakpointina__ramfunc declared function, the program execution must have
reached the main function. The system startup code moves all __ramfunc declared
functions from their stored location—normally flash memory—to their RAM location,
which means the __ramfunc declared functions are not in their proper place and
breakpoints cannot be set until you have executed up to the main function. Use the
Restore software breakpoints option to solve this problem, see Breakpoints options
dialog box, page 148, specifically the Restore software breakpoints option.

In addition, breakpoints in __ramfunc declared functions added from the editor have
to be disabled prior to invoking C-SPY and prior to exiting a debug session.

For information about the __ramfunc keyword, see the [AR C/C++ Development
Guide for Arm.

USEFUL BREAKPOINT HINTS

Below are some useful hints related to setting breakpoints.

Tracing incorrect function arguments

If a function with a pointer argument is sometimes incorrectly called with a NULL
argument, you might want to debug that behavior. These methods can be useful:

e Set a breakpoint on the first line of the function with a condition that is true only
when the parameter is 0. The breakpoint will then not be triggered until the
problematic situation actually occurs. The advantage of this method is that no extra
source code is needed. The drawback is that the execution speed might become
unacceptably low.

® You can use the assert macro in your problematic function, for example:

int MyFunction(int * MyPtr)
{

assert (MyPtr != 0); /* Assert macro added to your source

code. */

/* Here comes the rest of your function. */
}
The execution will break whenever the condition is true. The advantage is that the
execution speed is only very slightly affected, but the drawback is that you will get a
small extra footprint in your source code. In addition, the only way to get rid of the
execution stop is to remove the macro and rebuild your source code.
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e Instead of using the assert macro, you can modify your function like this:

int MyFunction (int * MyPtr)
{

if (MyPtr == 0)

MyDummyStatement; /* Dummy statement where you set a
breakpoint. */

/* Here comes the rest of your function. */
}
You must also set a breakpoint on the extra dummy statement, so that the execution
will break whenever the condition is true. The advantage is that the execution speed
is only very slightly affected, but the drawback is that you will still get a small extra
footprint in your source code. However, in this way you can get rid of the execution
stop by just removing the breakpoint.

Performing a task and continuing execution

You can perform a task when a breakpoint is triggered and then automatically continue
execution.

You can use the Action text box to associate an action with the breakpoint, for instance
a C-SPY macro function. When the breakpoint is triggered and the execution of your
application has stopped, the macro function will be executed. In this case, the execution
will not continue automatically.

Instead, you can set a condition which returns 0 (false). When the breakpoint is
triggered, the condition—which can be a call to a C-SPY macro that performs a task—
is evaluated and because it is not true, execution continues.

Consider this example where the C-SPY macro function performs a simple task:

__var my_counter;

count ()

{
my_counter += 1;
return 0;

}

To use this function as a condition for the breakpoint, type count () in the Expression
text box under Conditions. The task will then be performed when the breakpoint is
triggered. Because the macro function count returns 0, the condition is false and the
execution of the program will resume automatically, without any stop.
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Reference information on breakpoints

Reference information about:

Breakpoints window, page 132

Breakpoint Usage window, page 134

Code breakpoints dialog box, page 135

JTAG Watchpoints dialog box, page 137

Log breakpoints dialog box, page 140

Data breakpoints dialog box, page 141

Data Log breakpoints dialog box (C-SPY hardware drivers), page 146
Data Log breakpoints dialog box (C-SPY hardware drivers), page 146
Breakpoints options dialog box, page 148

Immediate breakpoints dialog box, page 150

Vector Catch dialog box, page 151

Flash breakpoints dialog box, page 152

Enter Location dialog box, page 153

Resolve Source Ambiguity dialog box, page 155.
See also:

® Reference information on C-SPY system macros, page 430

® Reference information on trace, page 211.

Breakpoints window

The Breakpoints window is available from the View menu.

Breakpoints x
Type Location Extra

@ Code UsingClasses.cpp:39.3

0 Log UsingClasses.cpp:39.10

This window lists all breakpoints you define.

Use this window to conveniently monitor, enable, and disable breakpoints; you can also
define new breakpoints and modify existing breakpoints.

C-SPY® Debugging Guide
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Display area

Context menu

Breakpoints °

None; this window is always available.

This area lists all breakpoints you define. For each breakpoint, information about the
breakpoint type, source file, source line, and source column is provided.

This context menu is available:

Go to Source
Edit...

Delete
Enable

Enable All
Disable All
Delete All

MNew Breakpoint 3

These commands are available:

Go to Source

Moves the insertion point to the location of the breakpoint, if the breakpoint has
a source location. Double-click a breakpoint in the Breakpoints window to
perform the same command.

Edit
Opens the breakpoint dialog box for the breakpoint you selected.
Delete
Deletes the breakpoint. Press the Delete key to perform the same command.

Enable
Enables the breakpoint. The check box at the beginning of the line will be
selected. You can also perform the command by manually selecting the check
box. This command is only available if the breakpoint is disabled.

Disable

Disables the breakpoint. The check box at the beginning of the line will be
deselected. You can also perform this command by manually deselecting the
check box. This command is only available if the breakpoint is enabled.

Enable All
Enables all defined breakpoints.
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Disable All
Disables all defined breakpoints.

Delete All
Deletes all defined breakpoints.

New Breakpoint
Displays a submenu where you can open the breakpoint dialog box for the
available breakpoint types. All breakpoints you define using this dialog box are
preserved between debug sessions.

Breakpoint Usage window

Requirements

C-SPY® Debugging Guide
for Arm

The Breakpoint Usage window is available from the menu specific to the C-SPY driver
you are using.

Breakpoint Usage x
# Breakpaint

71 Memory : 0x3C3F [Fetch 1

=1 Memory : 0x4D75 [Fetch 1

- C-SPY Terminal I/0 && library support module

This window lists all breakpoints currently set in the target system, both the ones you
have defined and the ones used internally by C-SPY. The format of the items in this
window depends on the C-SPY driver you are using.

The window gives a low-level view of all breakpoints, related but not identical to the list
of breakpoints displayed in the Breakpoints window.

C-SPY uses breakpoints when stepping. Use the Breakpoint Usage window for:

o Identifying all breakpoint consumers

o Checking that the number of active breakpoints is supported by the target system

o Configuring the debugger to use the available breakpoints in a better way, if
possible.

For more information, see Breakpoints in the C-SPY hardware debugger drivers, page
123.

None; this window is always available.
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Display area

For each breakpoint in the list, the address and access type are displayed. Each
breakpoint in the list can also be expanded to show its originator.

Code breakpoints dialog box

The Code breakpoints dialog box is available from the context menu in the editor
window, Breakpoints window, and in the Disassembly window.

& Code

Break At:

Breakpoint type
[F] Overide defautt

Software )
Action

Expression:

@ Hardware

Condtions

Expression:

@ Condition true Skip count: o
_) Condition changed

This figure reflects the C-SPY simulator.
Use the Code breakpoints dialog box to set a code breakpoint, see Setting breakpoints
using the dialog box, page 125.

Requirements

None; this dialog box is always available.

Break At
Specify the code location of the breakpoint in the text box. Alternatively, click the Edit

button to open the Enter Location dialog box, see Enter Location dialog box, page 153.

Breakpoint type

Overrides the default breakpoint type. Select the Override default check box and
choose between the Software and Hardware options.

You can specify the breakpoint type for these C-SPY drivers:

o The C-SPY I-jet/JTAGjet driver
o The C-SPY CMSIS-DAP driver
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The C-SPY GDB Server driver
The C-SPY J-Link/J-Trace driver
The C-SPY TI MSP-FET driver
The C-SPY TI XDS driver.

Determines whether there should be a size—in practice, a range—of locations where the
breakpoint will trigger. Each fetch access to the specified memory range will trigger the
breakpoint. Select how to specify the size:
Auto

The size will be set automatically, typically to 1.

Manual
Specify the size of the breakpoint range in the text box.

Note: This option might not be supported by the combination of C-SPY driver and
device that you are using.

Specify a valid C-SPY expression, which is evaluated when the breakpoint is triggered
and the condition is true. For more information, see Useful breakpoint hints, page 130.

Specify simple or complex conditions:

Expression
Specify a valid C-SPY expression, see C-SPY expressions, page 94.

Condition true
The breakpoint is triggered if the value of the expression is true.

Condition changed
The breakpoint is triggered if the value of the expression has changed since it
was last evaluated.

Skip count

The number of times that the breakpoint condition must be fulfilled before the
breakpoint starts triggering. After that, the breakpoint will trigger every time the
condition is fulfilled.
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JTAG Watchpoints dialog box

The JTAG Watchpoints dialog box is available from the driver-specific menu.

JTAG Watchpoints [ %]
Break Condition
& Nomal: 'Watchpoint 0 OF ‘W atchpoint 1
" Range: “Watchpoint 0 AMD NOT YWatchpoint 1

€ Chaine  Watchpoint 1 AND THEM “watchpaint 0 Cancel |
V' ‘watchpoint 0
— Addre: —dccess Type— —Data Extern [0]; — Mode
Value: [main -] by © AnySize vae [La0000000 |
& OpFech | o & ay || G Ay
Mask IDxFFFFFFFF -] ¢ Read " Halfword  Mask IDRDDDDDDDD -|| co ' User
.  wiord 1
Address Bus Pattern C wiite Data Bus Pattern " Non User

IDDDDDD‘I 0000000000000070101100000 C R :

—dccess Type— —Data Extern [1]; -~ Mode

Value [0:00000000  ~ & fny ; :”P 52 \ae [D:00000000 <[
I 5 ~

E10pFeich [l k| |Gy

Mask IDxFFFFFFFF VI € Fead pe SHETEE py 2l IDxFFFFFFFF vl 0 (ke
o
Address Bus Pattem )it Diata Bus Pattemn g 1 o ser

IDDDDDDDDDDDDDDDDDDDDDDDDDDDDDDDD S E IDDDDDDDDDDDDDDDDDDDDDDDDDDDDDDDD

Use this dialog box to directly control the two hardware watchpoint units. If the number
of needed watchpoints (including implicit watchpoints used by the breakpoint system)
exceeds two, an error message will be displayed when you click the OK button. This
check is also performed for the C-SPY Go button.

To cause a trigger for accesses in the range 0x20-0xFF:

I Set Break Condition to Range.
2 Set the address value of watchpoint 0 to 0 and the mask to 0xFF.

3 Set the address value of watchpoint 1 to 0 and the mask to 0x1F.

Requirements
The J-Link/J-Trace driver
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Specify the address to watch for.

Value Specify an address or a C-SPY expression that evaluates to
an address. Alternatively, you can select an address you
have previously watched for from the drop-down list. For
detailed information about C-SPY expressions, see C-SPY
expressions, page 94.

Mask Qualifies each bit in the value. A zero bit in the mask will
cause the corresponding bit in the value to be ignored in the
comparison. To match any address, enter 0. Note that the
mask values are inverted with respect to the notation used in
the Arm hardware manuals.

Address Bus Pattern Shows the bit pattern to be used by the address comparator.
Ignored bits as specified in the mask are shown as x.

Selects the access type of the data to watch for:

Any Matches any access type.

OP Fetch Matches an operation code (instruction) fetch.
Read Reads from location.

Write Writes to location.

R/W Reads from or writes to location.

Specifies the data to watch for. For size, choose between:

Any Size Matches data accesses of any size.
Byte Matches byte size accesses.
Halfword Matches halfword size accesses.
Word Matches word size accesses.
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You can specity a value to watch for. Choose between:

Value Specify a value or a C-SPY expression. Alternatively, you
can select a value you have previously watched for from the
drop-down list. For detailed information about C-SPY
expressions, see C-SPY expressions, page 94.

Mask Qualifies each bit in the value. A zero bit in the mask will
cause the corresponding bit in the value to be ignored in the
comparison. To match any address, enter 0. Note that the
mask values are inverted with respect to the notation used in
the Arm hardware manuals.

Data Bus Pattern Shows the bit pattern to be used by the address comparator.
Ignored bits as specified in the mask are shown as x.

Extern
Defines the state of the external input. Choose between:
Any Ignores the state.
0 Defines the state as low.
1 Defines the state as high.
Mode

Selects which CPU mode that must be active for a match. Choose between:

User Selects the CPU mode USER.

Non User Selects one of the CPU modes SYSTEM SVC, UND,
ABORT, IRQ, or FIQ.

Any Ignores the CPU mode.

Break Condition
Selects how the defined watchpoints will be used. Choose between:
Normal Uses the two watchpoints individually (OR).

Range Combines both watchpoints to cover a range where
watchpoint O defines the start of the range and watchpoint 1
the end of the range. Selectable ranges are restricted to
being powers of 2.
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Chain Makes a trigger of watchpoint 1 and watchpoint 0. A
program break will then occur when watchpoint O is
triggered.

Log breakpoints dialog box

The Log breakpoints dialog box is available from the context menu in the editor
window, Breakpoints window, and in the Disassembly window.
8 1o

Break At

C:htutorsTutor.c.47.3

Meszage: C-Spy macro "'__message' style
"depth ="', call_count

Conditions
Expression:

(%) Condition true
(O Condition changed

This figure reflects the C-SPY simulator.

Use the Log breakpoints dialog box to set a log breakpoint, see Setting breakpoints
using the dialog box, page 125.

Requirements

None; this dialog box is always available.

Trigger at

Specify the code location of the breakpoint. Alternatively, click the Edit button to open
the Enter Location dialog box, see Enter Location dialog box, page 153.

Message

Specify the message you want to be displayed in the C-SPY Debug Log window. The
message can either be plain text, or—if you also select the option C-SPY macro
" __message" style—a comma-separated list of arguments.

C-SPY® Debugging Guide
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C-SPY macro "__message" style

Select this option to make a comma-separated list of arguments specified in the Message
text box be treated exactly as the arguments to the C-SPY macro language statement
__message, see Formatted output, page 423.

Conditions
Specify simple or complex conditions:
Expression
Specify a valid C-SPY expression, see C-SPY expressions, page 94.
Condition true
The breakpoint is triggered if the value of the expression is true.

Condition changed

The breakpoint is triggered if the value of the expression has changed since it
was last evaluated.

Data breakpoints dialog box

The Data breakpoints dialog box is available from the context menu in the editor

window, Breakpoints window, the Memory window, and in the Disassembly window.
Data

Break at:

Edit...

Access Type Size
@ Auto

@ Read/write - M | 1
) Read ~) Manual
=) Wiite Action

Expression:
Condtions

Expression:

@ Condition true Skip count: 0
_) Condition changed

This figure reflects the C-SPY simulator.

Use the Data breakpoints dialog box to set a data breakpoint, see Setting breakpoints
using the dialog box, page 125. Data breakpoints never stop execution within a single
instruction. They are recorded and reported after the instruction is executed.
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One of these alternatives:

The C-SPY simulator

The C-SPY I-jet/JTAGjet driver

The C-SPY J-Link/J-Trace driver

The C-SPY ST-LINK driver

The C-SPY CMSIS-DAP driver

The C-SPY GDB Server driver

The C-SPY TI MSP-FET driver

The C-SPY TI Stellaris driver

The C-SPY TI XDS driver and a Cortex-M device.

Specify the data location of the breakpoint in the text box. Alternatively, click the Edit
button to open the Enter Location dialog box, see Enter Location dialog box, page 153.

Selects the type of memory access that triggers the breakpoint:

Read/Write
Reads from or writes to location.

Read
Reads from location.

Write
Writes to location.

Determines whether there should be a size—in practice, a range—of locations where the
breakpoint will trigger. Each fetch access to the specified memory range will trigger the
breakpoint. Select how to specify the size:

Auto
The size will automatically be based on the type of expression the breakpoint is
set on. For example, if you set the breakpoint on a 12-byte structure, the size of
the breakpoint will be 12 bytes.

Manual

Specity the size of the breakpoint range in the text box.
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For data breakpoints, this can be useful if you want the breakpoint to be triggered on
accesses to data structures, such as arrays, structs, and unions.

Action

Specify a valid C-SPY expression, which is evaluated when the breakpoint is triggered
and the condition is true. For more information, see Useful breakpoint hints, page 130.

Conditions

Specify simple or complex conditions:

Expression

Specity a valid C-SPY expression, see C-SPY expressions, page 94.

Condition true
The breakpoint is triggered if the value of the expression is true.

Condition changed

The breakpoint is triggered if the value of the expression has changed since it
was last evaluated.

Skip count

The number of times that the breakpoint condition must be fulfilled before the
breakpoint starts triggering. After that, the breakpoint will trigger every time the
condition is fulfilled.

Trigger range

Shows the requested range and the effective range to be covered by the trace. The range
suggested is either within or exactly the area specified by the Break At and the Size

options.
Extend to cover Extends the breakpoint so that a whole data structure is
requested range covered. For data structures that do not fit the size of the

possible breakpoint ranges supplied by the hardware
breakpoint unit, for example three bytes, the breakpoint
range will not cover the whole data structure. Note that the
breakpoint range will be extended beyond the size of the
data structure, which might cause false triggers at adjacent
data.

The Trigger range option is available for all C-SPY hardware drivers that support data
breakpoints.
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Enables matching of the accessed data. Use the Match data options in combination with
the access types for data. This option can be useful when you want a trigger when a
variable has a certain value.

Value

Mask

Specify a data value.

Specity which part of the value to match (word, halfword, or byte).
For Cortex-M, the data mask is limited to one of these exact values:
OxFFFFFFFF, which means that the complete word must match.

0xFFFF, which means that the match can be either the upper or lower 16-bit part
of a word or halfword.

0xFF, which means that the match can be either the upper, middle, or lower 8-bit
part of a word, halfword, or byte. For example, for the data 0xvv, any 32-bit
access matching a xxxxxxVV, xxxxVVxx, xxVVxxxX, OI VVxxxxxx pattern, and
any 16-bit access matching xxVVv or vvxx, and an 8-bit access with exact match
triggers the breakpoint.

The Match data options are only available for I-jet, [-jet Trace, JTAGjet, J-Link/J-Trace
and ST-LINK, and when using an Arm7/9 or a Cortex-M device.

Note: For Cortex-M devices, only one breakpoint with Match data can be set. Such a
breakpoint uses two hardware breakpoints.

Note: The Match Data options are not available for Cortex-MO0, Cortex-M1, and
Cortex-MO+.
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Data Log breakpoints dialog box

The Data Log breakpoints dialog box is available from the context menu in the
Breakpoints window.

Data Log

Break at:
myVar

Access Type
~) Readfwrite

This figure reflects the C-SPY simulator.

Use the Data Log breakpoints dialog box to set a maximum of four data log breakpoints
on memory addresses, see Setting breakpoints using the dialog box, page 125.

See also Data Log breakpoints, page 121 and Getting started using data logging, page
258.

Requirements
The C-SPY simulator.

Break At
Specify a memory location as a variable (with static storage duration) or as an address.
Access Type
Selects the type of access to the variable that generates a log entry:
Read/Write
Read and write accesses from or writes to location of the variable.
Read
Read accesses from the location of the variable.
Write

Write accesses to location of the variable.
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Data Log breakpoints dialog box (C-SPY hardware drivers)

Requirements

Trigger at

Access Type

C-SPY® Debugging Guide
for Arm

The Data Log breakpoints dialog box is available from the context menu in the editor
window, Breakpoints window, the Memory window, and in the Disassembly window.

Data Log

Trigger at:
Edit ...

Access type Size

-]
@ Read/Wite ° ’:ﬂm |
) Read ~) Manual
) Write Trigger range

Requested:

Effective:

[T Bdtend to cover requested range

Use the Data Log breakpoints dialog box to set a maximum of four data log breakpoints.
You can set a data log breakpoint on 8-, 16-, and 32-bit variables.

See also Data Log breakpoints, page 121 and Getting started using data logging, page
258.

One of these alternatives:

o The C-SPY I-jet/JTAGjet driver

® The C-SPY J-Link/J-Trace driver

o The C-SPY ST-LINK driver

® The C-SPY TI XDS driver and a Cortex-M device.

Specify the data location of the breakpoint. Alternatively, click the Edit button to open
the Enter Location dialog box, see Enter Location dialog box, page 153.

Selects the type of memory access that triggers the breakpoint:

Read/Write
Reads from or writes to location.
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Read

Reads from location; except for Cortex-M3, revision 1 devices.

Write
Writes to location; except for Cortex-M3, revision 1 devices.

Size

Determines whether there should be a size—in practice, a range—of locations where the
breakpoint will trigger. Each fetch access to the specified memory range will trigger the
breakpoint. Select how to specify the size:

Auto
The size will automatically be based on the type of expression the breakpoint is
set on. For example, if you set the breakpoint on a 12-byte structure, the size of
the breakpoint will be 12 bytes.

Manual

Specity the size of the breakpoint range in the text box.

Trigger range

Shows the requested range and the effective range to be covered by the trace. The range
suggested is either within or exactly the area specified by the Trigger at and the Size

options.
Extend to cover Extends the breakpoint so that a whole data structure is
requested range covered. For data structures that do not fit the size of the

possible breakpoint ranges supplied by the hardware
breakpoint unit, for example three bytes, the breakpoint
range will not cover the whole data structure. Note that the
breakpoint range will be extended beyond the size of the
data structure, which might cause false triggers at adjacent
data.
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Breakpoints options dialog box
The Breakpoints option page is available in the Options dialog box. Choose
Project>Options, select the category specific to the debugger system you are using, and
click the Breakpoints tab.

Breakpoints

o ™ Restore software breakpoints at

e [olman

~

Catch exceptions

r r [~ CORERESET [~ STATERR
r r [~ MMERR [~ BUSERR
r r [~ NOCPERR [~ INTERR
r [~ CHRERR [~ HARDERR

Use this dialog box to set driver-specific breakpoint options.

Requirements

One of these alternatives:

The C-SPY CMSIS-DAP driver
The C-SPY GDB Server driver
The C-SPY I-jet/JTAGjet driver
The C-SPY J-Link/J-Trace driver
The C-SPY ST-LINK driver

The C-SPY TI XDS driver

Default breakpoint type
Selects the type of breakpoint resource to be used when setting a breakpoint. Choose
between:

Auto Uses a software breakpoint. If this is not possible, a
hardware breakpoint will be used. The debugger will use
read/write sequences to test for RAM; in that case, a
software breakpoint will be used. The Auto option works
for most applications. However, there are cases when the
performed read/write sequence will make the flash memory
malfunction. In that case, use the Hardware option.
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Hardware Uses hardware breakpoints. If it is not possible, no
breakpoint will be set.

Software Uses software breakpoints. If it is not possible, no
breakpoint will be set.

Restore software breakpoints at

Restores software breakpoints that were overwritten during system startup.

This can be useful if you have an application that is copied to RAM during startup and
is then executing in RAM. This can, for example, be the case if youuse the initialize
by copy linker directive for code in the linker configuration file or if you have any
__ramfunc declared functions in your application.

In this case, all breakpoints will be destroyed during the RAM copying when the C-SPY
debugger starts. By using the Restore software breakpoints at option, C-SPY will
restore the destroyed breakpoints.

Use the text field to specify the location in your application at which point you want
C-SPY to restore the breakpoints. The default location is the label _call_main.

Catch exceptions

Sets a breakpoint directly on a vector in the interrupt vector table, without using a
hardware breakpoint. This option is available for Arm9/10/11 and all Cortex devices.
The settings you make will work as default settings for the project. However, you can
override these default settings during the debug session by using the Vector Catch
dialog box, see Setting a breakpoint on an exception vector, page 129.

The settings you make will be preserved during debug sessions.

This option is supported by the C-SPY I-jet/JTAGjet driver and the C-SPY
J-Link/J-Trace driver.
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Immediate breakpoints dialog box

Requirements

Trigger at

Access Type

Action
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The Immediate breakpoints dialog box is available from the context menu in the editor
window, Breakpoints window, the Memory window, and in the Disassembly window.

Immediate

Trigger at:
Edit...
Access Type Action
@ Read Expression:
) Write

In the C-SPY simulator, use the Immediate breakpoints dialog box to set an immediate
breakpoint, see Setting breakpoints using the dialog box, page 125. Immediate
breakpoints do not stop execution at all; they only suspend it temporarily.

The C-SPY simulator.

Specify the data location of the breakpoint. Alternatively, click the Edit button to open
the Enter Location dialog box, see Enfer Location dialog box, page 153.

Selects the type of memory access that triggers the breakpoint:
Read

Reads from location.

Write

Writes to location.

Specify a valid C-SPY expression, which is evaluated when the breakpoint is triggered
and the condition is true. For more information, see Useful breakpoint hints, page 130.
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Vector Catch dialog box

The Vector Catch dialog box is available from the C-SPY driver menu.

Stop at beginning of exceptior:
[~ CORERESET - Reset Vector

™ MMERR - Memary Management Fault Cancel

I~ WOCPERF - Coprocessor Access Erar —I
™ CHRERR - Checking Eror

[~ STATERR - State Errar

[ BUSERR - Bus Emor

I~ INTERR - Interrupt Service Emors

™ HARDERR - Hard Fault

Use this dialog box to set a breakpoint directly on a vector in the interrupt vector table,
without using a hardware breakpoint. You can set breakpoints on vectors for
Arm9/10/11 and all Cortex devices. Note that the settings you make here will not be
preserved between debug sessions.

This figure reflects a Cortex-M device. If you are using another device, the contents of
this dialog box might look different.

Note: For the C-SPY I-jet/JTTAGjet driver and the C-SPY J-Link/J-Trace driver, it is also
possible to set breakpoints directly on a vector already in the options dialog box, see
J-Link/J-Trace - Setup, page 572.

Requirements

One of these alternatives:

o The C-SPY I-jet/JTAGjet driver
o The C-SPY J-Link/J-Trace driver
e The C-SPY CMSIS-DAP driver.
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Flash breakpoints dialog box
The Flash breakpoints dialog box is available from the context menu in the editor
window, the Breakpoints window, the Memory window, and in the Disassembly
window.

@ Flash

Break at:

Edit,..

Action

Expression:

Conditions
Expression:

@ Condition true Skip count: 0

_) Condition changed

Use the Flash breakpoints dialog box to set a flash breakpoint.

Requirements
The C-SPY I-jet/JTAGjet driver.

Break At
Specify the code location of the breakpoint in the text box. Alternatively, click the Edit
button to open the Enter Location dialog box, see Enter Location dialog box, page 153.
Action
Specify a valid C-SPY expression, which is evaluated when the breakpoint is triggered
and the condition is true. For more information, see Useful breakpoint hints, page 130.
Conditions

Specify simple or complex conditions:

Expression
Specify a valid C-SPY expression, see C-SPY expressions, page 94.

Condition true
The breakpoint is triggered if the value of the expression is true.
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Condition changed
The breakpoint is triggered if the value of the expression has changed since it
was last evaluated.

Skip count

The number of times that the breakpoint condition must be fulfilled before the
breakpoint starts triggering. After that, the breakpoint will trigger every time the
condition is fulfilled.

Enter Location dialog box

The Enter Location dialog box is available from the breakpoints dialog box, either
when you set a new breakpoint or when you edit a breakpoint.

Enter Location @

Type Expression:
@ Expreszion

Absolute address

Source location

[ (0] 3 ]| Cancel |

Use the Enter Location dialog box to specify the location of the breakpoint.

Note: This dialog box looks different depending on the Type you select.

Type
Selects the type of location to be used for the breakpoint, choose between:
Expression
A C-SPY expression, whose value evaluates to a valid code or data location.

A code location, for example the function main, is typically used for code
breakpoints.

A data location is the name of a variable and is typically used for data
breakpoints. For example, my_var refers to the location of the variable my_var,
and arr [3] refers to the location of the fourth element of the array arr. For
static variables declared with the same name in several functions, use the syntax
my_func::my_static_variable to refer to a specific variable.

For more information about C-SPY expressions, see C-SPY expressions, page
94.
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Absolute address

An absolute location on the form zone: hexaddress or simply hexaddress
(for example Memory: 0x42). zone refers to C-SPY memory zones and
specifies in which memory the address belongs, see C-SPY memory zones, page
159.

Source location

A location in your C source code using the syntax:
{filename} .row.column.

filename specifies the filename and full path.
row specifies the row in which you want the breakpoint.
column specifies the column in which you want the breakpoint.

For example, {C:\src\prog.c}.22.3

sets a breakpoint on the third character position on row 22 in the source file
prog.c. Note that in quoted form, for example in a C-SPY macro, you must
instead write {C:\\src\\prog.c}.22.3.

Note that the Source location type is usually meaningful only for code locations
in code breakpoints. Depending on the C-SPY driver you are using, Source
location might not be available for data and immediate breakpoints.



Resolve Source Ambiguity dialog box
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The Resolve Source Ambiguity dialog box appears, for example, when you try to set a
breakpoint on templates and the source location corresponds to more than one function.

Resolve Source Ambiguity

The zource location coresponds to multiple functions.
‘which onefz] do you mean?

woid foo(T, T #|[with T=unsigned long]
woid foo(T, T #|[with T=double]

™ Automatically choose all

If you check. this item, the dialog will not be shown again
unless you re-enable it in the Tools->Dptions dialog, on
the Debugger page.

All

=

Cancel

To resolve a source ambiguity, perform one of these actions:

o In the text box, select one or several of the listed locations and click Selected.

The breakpoint will be set on the source locations that you have selected in the text box.

o Click AllL
All

The breakpoint will be set on all listed locations.
Selected
Cancel

No location will be used.

Automatically choose all

Determines that whenever a specified source location corresponds to more than one

function, all locations will be used.

Note that this option can also be specified in the IDE Options dialog box, see Debugger

options in the IDE Project Management and Building Guide for Arm.

155



Reference information on breakpoints

C-SPY® Debugging Guide
156  for Arm



Memory and registers

e Introduction to monitoring memory and registers
e Monitoring memory and registers

e Reference information on memory and registers

Introduction to monitoring memory and registers

These topics are covered:

e Briefly about monitoring memory and registers
o C-SPY memory zones
o Memory configuration for the C-SPY simulator

o Memory configuration for C-SPY hardware debugger drivers

BRIEFLY ABOUT MONITORING MEMORY AND REGISTERS

C-SPY provides many windows for monitoring memory and registers, each of them
available from the View menu:

o The Memory window

Gives an up-to-date display of a specified area of memory—a memory zone—and
allows you to edit it. Data coverage along with execution of your application is
highlighted with different colors. You can fill specified areas with specific values and
you can set breakpoints directly on a memory location or range. Y ou can open several
instances of this window, to monitor different memory areas. The content of the
window can be regularly updated while your application is executing.

o The Symbolic Memory window

Displays how variables with static storage duration are laid out in memory. This can
be useful for better understanding memory usage or for investigating problems
caused by variables being overwritten, for example by buffer overruns.

o The Stack window

Displays the contents of the stack, including how stack variables are laid out in
memory. In addition, integrity checks of the stack can be performed to detect and
warn about problems with stack overflow. For example, the Stack window is useful
for determining the optimal size of the stack. You can open up to two instances of
this window, each showing different stacks or different display modes of the same
stack.
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o The Registers window

Gives an up-to-date display of the contents of the processor registers and SFRs, and
allows you to edit them. Except for the hardwired group of CPU registers, additional
registers are defined in the device description file. These registers are the
device-specific memory-mapped control and status registers for the peripheral units
on the Arm devices. Because of the large amount of registers—memory-mapped
peripheral unit registers and CPU registers—it is inconvenient to show all registers
concurrently in the Registers window. Instead you can divide registers into
application-specific groups. You can choose to load either predefined register groups
or define your own groups. You can open several instances of this window, each
showing a different register group.

o The SFR Setup window

Displays the currently defined SFRs that C-SPY has information about, both
factory-defined (retrieved from the device description file) and custom-defined
SFRs. If required, you can use the Edit SFR dialog box to customize the SFR
definitions.

To view the memory contents for a specific variable, simply drag the variable to the
Memory window or the Symbolic memory window. The memory area where the
variable is located will appear.

Reading the value of some registers might influence the runtime behavior of your
application. For example, reading the value of a UART status register might reset a
pending bit, which leads to the lack of an interrupt that would have processed a received
byte. To prevent this from happening, make sure that the Registers window containing
any such registers is closed when debugging a running application.
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C-SPY MEMORY ZONES

In C-SPY, the term zone is used for a named memory area. A memory address, or
location, is a combination of a zone and a numerical offset into that zone. The Arm
architecture has only one zone, Memory, which covers the whole Arm memory range.
0x00000000

OxXFFFFFFFF

Default zone Memory

Memory zones are used in several contexts, most importantly in the Memory and
Disassembly windows, and in C-SPY macros. In the windows, use the Zone box to
choose which memory zone to display.

For normal memory, the default zone Memory can be used, but certain I/O registers
might require to be accessed as 8, 16, 32, or 64 bits to give correct results. By using
different memory zones, you can control the access width used for reading and writing
in, for example, the Memory window. When using the zone Memory, the debugger
automatically selects the most suitable access width.

Note: For the C-SPY I-jet/JTAGjet driver, you can specify the automatic selection of
access width in the Edit Memory Range dialog box; see Edit Memory Range dialog
box, for C-SPY hardware debugger drivers, page 197.

MEMORY CONFIGURATION FOR THE C-SPY SIMULATOR

To simulate the target system properly, the C-SPY simulator needs information about
the memory configuration. By default, C-SPY uses a configuration based on
information retrieved from the device description file.

The C-SPY simulator provides various mechanisms to improve the configuration
further:

o If the default memory configuration does not specify the required memory address
ranges, you can specify the memory address ranges shall be based on:
o The zones predefined in the device description file

o The section information available in the debug file
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o Or, you can define your own memory address ranges, which you typically might
want to do if the files do not specify memory ranges for the specific device that
you are using, but instead for a family of devices (perhaps with various amounts
of on-chip RAM).

o For each memory address range, you can specify an access type. If a memory access
occurs that does not agree with the specified access type, C-SPY will regard this as
an illegal access and warn about it. In addition, an access to memory that is not
defined is regarded as an illegal access. The purpose of memory access checking is
to help you to identify memory access violations.

For more information, see Memory Configuration dialog box, for the C-SPY simulator,
page 190.

MEMORY CONFIGURATION FOR C-SPY HARDWARE
DEBUGGER DRIVERS

To handle memory as efficiently as possible during debugging, C-SPY needs
information about the memory configuration. By default, C-SPY uses a configuration
based on information retrieved from the device description file.

You should make sure the memory address ranges match the memory available on your
device. Providing C-SPY with information about the memory layout of the target system
is helpful in terms of both performance and functionality:

o Reading (and writing) memory (if your debug probe is connected through a USB
port) can be fast, but is usually the limiting factor when C-SPY needs to update
many debugger windows. C-SPY can cache memory contents to speed up
performance, provided it has correct information about the target memory.

® You can inform C-SPY that the content of certain memory address ranges will not
be changed during a debug session. C-SPY can keep a copy of that memory
readable even when the target system does not normally allow reading (such as
when it is executing).

Note that if you specify the cache type ROM/Flash, C-SPY treats such memory as
constant during the whole debug session (which improves efficiency, when updating
some C-SPY windows). If your application modifies flash memory during runtime,
do not use the ROM/Flash cache type.

® You can prevent C-SPY from accessing memory outside specified memory address
ranges, which can be important for certain hardware.

The Memory Configuration dialog box is automatically displayed the first time you
start the C-SPY driver for a given project, unless the device description file contains a
memory description which is explicitly tagged as correct and complete. Subsequent
starts will not display the dialog box unless you have made project changes that might
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cause the memory configuration to change, for example if you have selected another
device description file.

For more information, see Memory Configuration dialog box, in C-SPY hardware
debugger drivers, page 194.

Monitoring memory and registers
These tasks are covered:

o Defining application-specific register groups, page 161
® Monitoring stack usage, page 162

DEFINING APPLICATION-SPECIFIC REGISTER GROUPS

Defining application-specific register groups minimizes the amount of registers
displayed in the Registers windows and makes the debugging easier.

I Choose View>Registers>Register User Groups Setup during a debug session.

Register User Groups Setup x
Group Farmat

- regCroupOne

- R4 Hexadecimal

Hexadecimal
Hexadecimal
Hexadecimal
Hexadecimal
Hexadecimal
Hexadecimal
Hexadecimal
Binary

=l regGroupTwo

Hexadecimal
Binary
Binary
Hexadecimal
<click to add reg>

<click to add group>

Right-clicking in the window displays a context menu with commands. For information
about these commands, see Register User Groups Setup window, page 183.

2 Click on <click to add group> and specify the name of your group, for example
My Timer Group and press Enter.
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3 Underneath the group name, click on <click to add reg> and type the name of a

register, and press Enter. You can also drag a register name from another window in the
IDE. Repeat this for all registers that you want to add to your group.

As an optional step, right-click any registers for which you want to change the integer
base, and choose Format from the context menu to select a suitable base.

When you are done, your new group is now available in the Registers windows.

If you want to define more application-specific groups, repeat this procedure for each
group you want to define.

Note: If a certain SFR that you need cannot be added to a group, you can register your
own SFRs. For more information, see SFR Setup window, page 185.

MONITORING STACK USAGE
These are the two main use cases for the Stack window:

o Monitoring stack memory usage

o Monitoring the stack memory content.

In both cases, C-SPY retrieves information about the defined stack size and its allocation
from the definition in the linker configuration file of the section holding the stack. If you,
for some reason, have modified the stack initialization in the system startup code,
cstartup, you should also change the section definition in the linker configuration file
accordingly; otherwise the Stack window cannot track the stack usage. For more
information about this, see the [AR C/C++ Development Guide for Arm.

To monitor stack memory usage:

Before you start C-SPY, choose Tools>Options. On the Stack page:

o Select Enable graphical stack display and stack usage tracking. This option also
enables the option Warn when exceeding stack threshold. Specify a suitable
threshold value.

e Notice also the option Warn when stack pointer is out of bounds. Any such
warnings are displayed in the Debug Log window.
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1DE Options @
- Common Fonts
i Key Bindings |¥] Enable graphical stack display and stack usage tragiking
-~ Language 90 % stack usage threshold
- Editor Wam when exceeding stack threshold
i Messages
Project [¥] Wam when stack peirter is out of bounds
. iotr(a Code Cantrol Stack potisie ast =i uetil i reaches:
. Dabuzaer
.. Stack main
Wamings
@ Log
) Log and alett
[ Limit stack display to 50 byles

2 Start C-SPY.

When your application is first loaded, and upon each reset, the memory for the stack area
is filled with the dedicated byte value 0xCD before the application starts executing.

Choose View>Stack>Stack 1 to open the Stack window.

Notice that you can open up to two Stack windows, each showing a different stack—if
several stacks are available—or the same stack with different display settings.

Start executing your application.

Whenever execution stops, the stack memory is searched from the end of the stack until
a byte whose value is not 0xCD is found, which is assumed to be how far the stack has
been used. The light gray area of the stack bar represents the unused stack memory area,
whereas the dark gray area of the bar represents the used stack memory.
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For this example, you can see that only 44% of the reserved memory address range was
used, which means that it could be worth considering decreasing the size of memory:

Used stack memary, Unused stack memary,
Stack pointer J in dark gray in light gray
=i )\ [ : 2
) I |
. 36 bytes used out of 80 (44%) -
jrocationjjglala Stack range: Memony:0:3FBO0 - Memory:0x4000 Frame

OxF0O
0x3FFB 0Oxdl
0x3FFC 0x40180000

Toeltip informartion with facts
about used stack memory

4 m | +

Note: Although this is a reasonably reliable way to track stack usage, there is no
guarantee that a stack overflow is detected. For example, a stack can incorrectly grow
outside its bounds, and even modify memory outside the stack area, without actually
modifying any of the bytes near the end of the stack range. Likewise, your application
might modify memory within the stack area by mistake.

To monitor the stack memory content:

I Before you start monitoring stack memory, you might want to disable the option
Enable graphical stack display and stack usage tracking to improve performance
during debugging.

2 Start C-SPY.
3 Choose View>Stack>Stack 1 to open the Stack window.

Notice that you can access various context menus in the display area from where you
can change display format, etc.

4 Start executing your application.
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Whenever execution stops, you can monitor the stack memory, for example to see
function parameters that are passed on the stack:

Current stack pointer |

.

Stack 1 *x
Stack ||
Location Data YWariable YWalue Type Frame
0x3FDE 0x0001 p.mHandle 1 int [0] _dwrite
0x3FED Ox3FES p.mBuffer 0x3FEB "‘n' unsigned charconst® [0] __chwrite
0x3FE2 0x0001 p.msize 1 size_t [0] __dwrite
0x3FE4 0x0001 p.mBetunst. 1 size_t [0] __dwrite

0x3FE6 0x72

0x3FE7 0Oxdl

0x3FE8 0x000A000A
0x3FEC 0xCDCD4048
0x3FF0 0xCDCDCDCD
0x3FF4 0xCDCDCDCD
0x3FF8 0x0000CDCD
0x3FFC 0x401441D2

Reference information on memory and registers

Reference information about:

Memory window, page 166

Memory Save dialog box, page 170

Memory Restore dialog box, page 171

Fill dialog box, page 172

Symbolic Memory window, page 173

Stack window, page 176

Registers window, page 180

Register User Groups Setup window, page 183

SFR Setup window, page 185

Edit SFR dialog box, page 188

Memory Configuration dialog box, for the C-SPY simulator, page 190
Edit Memory Range dialog box, for the C-SPY simulator, page 192
Memory Configuration dialog box, in C-SPY hardware debugger drivers, page 194

Edit Memory Range dialog box, for C-SPY hardware debugger drivers, page 197
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Memory window

The Memory window is available from the View menu.

Available zones Context menu button

‘ Live update

Memory 1 \\\ / x

;
e 9w
£f £f £f £f ff

000feefd £f £f £f ££f ££f ££f ££ ££  ........ -
000feefl f£f £f £f £ff £f £f ££f £f  ........
R 000fef00 48 65 6c 6c 6 20 57 6f Hello Wo
Mem ory DO0fef0s 72 62 64 21 00 00 68 6a rld!

000feflD Bc 74 7a 4c 00 OO OO OO .
Bddieszes 000fefld OO0 OO OO OO OO OO OO OO0
000fef20 OO0 OO OO OO OO OO OO OO0
000fef2f ﬁﬁfrOO 00 00 cd cd cd cd
DDDfeﬁ}G” cd cd cd cd cd cd cd cd
DDQEéfBS 3c 01 00 ed £f £f £f £f
_,GﬁDfef4D £ff £f £f £f £f £f £f £f
000fef4d £f £f £f ££f ££f ££f ££ ££  ........

Go to location

Data coverage
information

Q00fefs0 f£f £f£-ff £f £f £f £f ££f . .......

Mem ory contents Mem ory contents in ASCII format

This window gives an up-to-date display of a specified area of memory—a memory
zone—and allows you to edit it. You can open several instances of this window, which
is very convenient if you want to keep track of several memory or register zones, or
monitor different parts of the memory.

To view the memory corresponding to a variable, you can select it in the editor window
g5  anddrag it to the Memory window.

See also Editing in C-SPY windows, page 56.

Requirements

None; this window is always available.

Toolbar
The toolbar contains:
Go to
The memory location or symbol you want to view.
Zone

Selects a memory zone, see C-SPY memory zones, page 159.

Context menu button
Displays the context menu.

C-SPY® Debugging Guide
for Arm



Memory and registers __4

Update Now

Updates the content of the Memory window while your application is
executing. This button is only enabled if the C-SPY driver you are using has
access to the target system memory while your application is executing.

Live Update

Updates the contents of the Memory window regularly while your application
is executing. This button is only enabled if the C-SPY driver you are using has
access to the target system memory while your application is executing. To set
the update frequency, specify an appropriate frequency in the IDE
Options>Debugger dialog box.

Display area

The display area shows the addresses currently being viewed, the memory contents in
the format you have chosen, and—provided that the display mode is set to 1x Units—
the memory contents in ASCII format. You can edit the contents of the display area, both
in the hexadecimal part and the ASCII part of the area.

Data coverage is displayed with these colors:

Yellow Indicates data that has been read.
Blue Indicates data that has been written
Green Indicates data that has been both read and written.

Note: Data coverage is not supported by all C-SPY drivers. Data coverage is supported
by the C-SPY Simulator.
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Context menu

This context menu is available:

Copy
Paste

Zone 3

v lxUnits
2x Units
4x Units
8x Units

v Little Endian
Big Endian

Data Coverage 3

Find...

Replace...

Mermory Fill...
Memory Save...

Mermory Restore...
Set Data Breakpoint

Set Data Log Breakpoint

These commands are available:

Copy, Paste

Standard editing commands.

Zone
Selects a memory zone, see C-SPY memory zones, page 159.

1x Units

Displays the memory contents as single bytes.
2x Units

Displays the memory contents as 2-byte groups.
4x Units

Displays the memory contents as 4-byte groups.
8x Units

Displays the memory contents as 8-byte groups.

Little Endian
Displays the contents in little-endian byte order.

C-SPY® Debugging Guide
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Big Endian
Displays the contents in big-endian byte order.

Data Coverage
Choose between:

Enable toggles data coverage on or off.
Show toggles between showing or hiding data coverage.
Clear clears all data coverage information.

These commands are only available if your C-SPY driver supports data
coverage.

Find
Displays a dialog box where you can search for text within the Memory

window; read about the Find dialog box in the IDE Project Management and
Building Guide for Arm.

Replace

Displays a dialog box where you can search for a specified string and replace
each occurrence with another string; read about the Replace dialog box in the
IDE Project Management and Building Guide for Arm.

Memory Fill

Displays a dialog box, where you can fill a specified area with a value, see Fill
dialog box, page 172.

Memory Save

Displays a dialog box, where you can save the contents of a specified memory
area to a file, see Memory Save dialog box, page 170.

Memory Restore
Displays a dialog box, where you can load the contents of a file in Intel-hex or
Motorola s-record format to a specified memory zone, see Memory Restore
dialog box, page 171.

Set Data Breakpoint

Sets breakpoints directly in the Memory window. The breakpoint is not
highlighted; you can see, edit, and remove it in the Breakpoints dialog box. The
breakpoints you set in this window will be triggered for both read and write
access. For more information, see Setting a data breakpoint in the Memory
window, page 127.
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Set Data Log Breakpoint

Sets a breakpoint on the start address of a memory selection directly in the
Memory window. The breakpoint is not highlighted; you can see, edit, and
remove it in the Breakpoints dialog box. The breakpoints you set in this
window will be triggered by both read and write accesses; to change this, use the
Breakpoints window. For more information, see Data Log breakpoints, page
121 and Getting started using data logging, page 258.

Memory Save dialog box

The Memory Save dialog box is available by choosing Debug>Memory>Save or from

Requirements

Zone

Start address

End address

File format

C-SPY® Debugging Guide
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the context menu in the Memory window.

Memory Save

Zone:

==l

Memory 7 I [ Save

]

Start address: End address:
0x30 0xFF

File format:

Iintel-exhended - I

Filename:
C:\Documents\IAR Embedded Workbench'memory.hex

Close

=

Use this dialog box to save the contents of a specified memory area to a file.

None; this dialog box is always available.

Selects a memory zone, see C-SPY memory zones, page 159.

Specify the start address of the memory range to be saved.

Specify the end address of the memory range to be saved.

Selects the file format to be used, which is Intel-extended by default.



Filename

Save

Memory and registers __4

Specify the destination file to be used; a browse button is available for your convenience.

Saves the selected range of the memory zone to the specified file.

Memory Restore dialog box

Requirements

Zone

Filename

Restore

The Memory Restore dialog box is available by choosing Debug>Memory>Restore
or from the context menu in the Memory window.

Merory Restore @
Zone:
| Memory - | [ Restore ]
Close
Filename:
C:'\Documents\TAR \memory . hex l:l

Use this dialog box to load the contents of a file in Intel-extended or Motorola S-record
format to a specified memory zone.

None; this dialog box is always available.

Selects a memory zone, see C-SPY memory zones, page 159.

Specify the file to be read; a browse button is available for your convenience.

Loads the contents of the specified file to the selected memory zone.
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Fill dialog box

Requirements

Start address

Length

Zone

Value

Operation

C-SPY® Debugging Guide
172 for Arm

The Fill dialog box is available from the context menu in the Memory window.

Fill =
Start address: Length: Zone:
01010 004 Memory -
Walue: Operation
O=FF @ Copy AND
XOR oR
[ (0] 8 ] | Cancel |

Use this dialog box to fill a specified area of memory with a value.

None; this dialog box is always available.

Type the start address—in binary, octal, decimal, or hexadecimal notation.

Type the length—in binary, octal, decimal, or hexadecimal notation.

Selects a memory zone, see C-SPY memory zones, page 159.

Type the 8-bit value to be used for filling each memory location.

These are the available memory fill operations:

Copy
Value will be copied to the specified memory area.

AND
An AND operation will be performed between Value and the existing contents of
memory before writing the result to memory.

XOR

An XOR operation will be performed between Value and the existing contents of
memory before writing the result to memory.
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OR

An OR operation will be performed between Value and the existing contents of
memory before writing the result to memory.

Symbolic Memory window
The Symbolic Memory window is available from the View menu during a debug

session.

Symbolic Memory x
Go to: hd |Data v||Pre\c'ious|[ Mext ]
Location Data “ariable  Value Type 0

0x21 0x0000 callCount O int

Ox23 0x0001  Fib[0] 1 unsigned int

0x25 0x0001  Fib[1] 1 unsigned int =
0x27 0x0002  Fik[2] 2 unsigned int 3
0x29 0x0003  Fib[3] 3 unsigned int

0x2B 0x0005  Fib[4] 5| unsigned int

0x2D 0x0008  Fib[E] a unsigned int

0x2F 0x000D  Fib[E] 13 unsigned int

Ox3l 0x0015  Fib[7] 21 unsigned int

Ox33 0x0022  Fib[8] 34 unsigned int -

This window displays how variables with static storage duration, typically variables
with file scope but also static variables in functions and classes, are laid out in memory.
This can be useful for better understanding memory usage or for investigating problems
caused by variables being overwritten, for example buffer overruns. Other areas of use
are spotting alignment holes or for understanding problems caused by buffers being
overwritten.

To view the memory corresponding to a variable, you can select it in the editor window
g5  anddrag it to the Symbolic Memory window.

See also Editing in C-SPY windows, page 56.

Requirements

None; this window is always available.

Toolbar

The toolbar contains:

Go to
The memory location or symbol you want to view.

Zone
Selects a memory zone, see C-SPY memory zones, page 159.
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Previous
Highlights the previous symbol in the display area.

Next
Highlights the next symbol in the display area.

Display area
This area contains these columns:

Location

The memory address.

Data
The memory contents in hexadecimal format. The data is grouped according to
the size of the symbol. This column is editable.

Variable
The variable name; requires that the variable has a fixed memory location. Local
variables are not displayed.

Value
The value of the variable. This column is editable.

Type

The type of the variable.
There are several different ways to navigate within the memory space:

Text that is dropped in the window is interpreted as symbols
The scroll bar at the right-side of the window

°
°
o The toolbar buttons Next and Previous
°

The toolbar list box Go to can be used for locating specific locations or symbols.

Note: Rows are marked in red when the corresponding value has changed.

C-SPY® Debugging Guide
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This context menu is available:
MNext Symbol

Previous Symbol

1x Units
v 2xUnits
4x Units

Add to Watch
Add to Live Watch

v Default Format
Binary Format
Octal Format
Decimal Format
Hexadecimal Format

Char Format

These commands are available:
Next Symbol

Highlights the next symbol in the display area.
Previous Symbol

Highlights the previous symbol in the display area.
1x Units

Displays the memory contents as single bytes. This applies only to rows which
do not contain a variable.

2x Units

Displays the memory contents as 2-byte groups.
4x Units

Displays the memory contents as 4-byte groups.
Add to Watch

Adds the selected symbol to the Watch window.
Add to Live Watch

Adds the selected symbol to the Live Watch window.
Default format

Displays the memory contents in the default format.

Binary format
Displays the memory contents in binary format.
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Octal format

Displays the memory contents in octal format.

Decimal format

Displays the memory contents in decimal format.

Hexadecimal format

Displays the memory contents in hexadecimal format.

Char format

Displays the memory contents in char format.

Stack window

The Stack window is available from the View menu.

I Current stack pointer ‘ I Used memory stack, in gray ‘
B - — The graphical
) Stack 1 N\ /./-/ ® graphic
Stack view | - = stack bar with
SR ses ) S
: B information
Location Data Yariable Value Type Frame
OXOFEF72| 0x04DC | 1244 signedint [0] InitFik
D +2 0x04DC ——
Cu.rrent stack +4 0xCDOO Unused stack
(oA +6 0%0432 memory, in
+8 0x0000 light gray
+10 0x0408 :
+12 0xCDOO

This window is a memory window that displays the contents of the stack. The graphical
stack bar shows stack usage.

This window retrieves information about the stack size and placement from the
definition in the linker configuration file of the sections holding the stacks. The sections
are described in the /AR C/C++ Development Guide for Arm. For applications that set
up the stacks using other mechanisms, you can to override the default mechanism. Use
one of the C-SPY command line option variants, see --proc_stack stack, page 532.

Note: By default, this window uses one physical breakpoint. For more information, see
Breakpoint consumers, page 123.

For information about options specific to the Stack window, see the IDE Project
Management and Building Guide for Arm.

Requirements

None; this window is always available.

C-SPY® Debugging Guide
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Toolbar
The toolbar contains:

Stack
Selects which stack to view. This applies to cores with multiple stacks.

The graphical stack bar
Displays the state of the stack graphically.
The left end of the stack bar represents the bottom of the stack, in other words, the
position of the stack pointer when the stack is empty. The right end represents the end

of the memory address range reserved for the stack. The graphical stack bar turns red
when the stack usage exceeds a threshold that you can specify.

To enable the stack bar, choose Tools>Options>Stack>Enable graphical stack
display and stack usage tracking. This means that the functionality needed to detect
and warn about stack overflows is enabled.

Place the mouse pointer over the stack bar to get tooltip information about stack usage.

Display area
This area contains these columns:

Location
Displays the location in memory. The addresses are displayed in increasing
order. The address referenced by the stack pointer, in other words the top of the
stack, is highlighted in a green color.

Data
Displays the contents of the memory unit at the given location. From the Stack
window context menu, you can select how the data should be displayed; as a 1-,
2-, or 4-byte group of data.

Variable
Displays the name of a variable, if there is a local variable at the given location.
Variables are only displayed if they are declared locally in a function, and
located on the stack and not in registers.

Value
Displays the value of the variable.

Type

Displays the data type of the variable.
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Context menu

C-SPY® Debugging Guide
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Frame

Displays the name of the function that the call frame corresponds to.

This context menu is available:

v Show Variables
Show Offsets
1x Units
2x Units

v dxUnits

Default Format
Binary Format

Octal Format
Decimal Format
Hexadecimal Format

Char Format

Options...

These commands are available:

Show variables

Displays separate columns named Variables, Value, and Frame in the Stack
window. Variables located at memory addresses listed in the Stack window are
displayed in these columns.

Show offsets

Displays locations in the Location column as offsets from the stack pointer.
When deselected, locations are displayed as absolute addresses.

1x Units
Displays the memory contents as single bytes.
2x Units

Displays the memory contents as 2-byte groups.

4x Units
Displays the memory contents as 4-byte groups.
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Default Format,

Binary Format,

Octal Format,

Decimal Format,

Hexadecimal Format,

Char Format
Changes the display format of expressions. The display format setting affects
different types of expressions in different ways. Your selection of display format
is saved between debug sessions. These commands are available if a selected
line in the window contains a variable.

The display format setting affects different types of expressions in these ways:

Variables The display setting affects only the selected variable, not
other variables.

Array elements The display setting affects the complete array, that is, the
same display format is used for each array element.

Structure fields All elements with the same definition—the same field
name and C declaration type—are affected by the
display setting.

Options

Opens the IDE Options dialog box where you can set options specific to the
Stack window, see the IDE Project Management and Building Guide for Arm.
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Registers window

Requirements

C-SPY® Debugging Guide
for Arm

The Registers windows are available from the View menu.

Reqgisters 2 x
<find register> -
Current CPU Registers Yalue Access it

RO 0x00000000 Readyrite
R1 0x00000248 Readyrite
R2 0x00000000 FeadvWrite
R3 0x1FFE00O4 FeadvWrite
R4 0x00000000 Eeadyrite E
RS 0x00000000 FeadvWrite
Ré& 0x00000000 Readyrite
R7 0x00000000 Readyrite
R2 0x00000000 FeadvWrite
R9 0x00000000 FeadvWrite
R10 0x00000000 Readyrite
R11 0x00000000 Readyrite
Ri12 0x00000000 Readyrite
+ APSR 0x60000000 FeadvWrite
+ IPSR 0x00000000 Readyrite
+ EPSR 0x01000000 FeadvWrite
BPC 0x00000020 Eeadyrite -

These windows give an up-to-date display of the contents of the processor registers and
special function registers, and allows you to edit the content of some of the registers.
Optionally, you can choose to load either predefined register groups or your own
user-defined groups.

You can open up to four instances of this window, which is very convenient if you want
to keep track of different register groups.

See also Editing in C-SPY windows, page 56.

To enable predefined register groups:

Select a device description file that suits your device, see Selecting a device description

file, page 53.

Display the register groups that are defined in the device description file in the
Registers window by right-clicking in the window and choosing View Group from the
context menu.

For information about creating your own user-defined register groups, see Defining
application-specific register groups, page 161.

None; this window is always available.
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Toolbar

The toolbar contains:

<find register>
Specify the name of a register that you want to find. Press the Enter key and the
first register group where this register is found is displayed. User-defined
register groups are not searched. The register search box has a history depth of
20 search entries.

Display area

Displays registers and their values. Some registers are expandable, which means that the
register contains interesting bits or subgroups of bits.

If you drag a numerical value, a valid expression, or a register name from another part
of the IDE to an editable value cell in a Registers window, the value will be changed to
that of what you dragged. If you drop a register name somewhere else in the window,
the window contents will change to display the first register group where this register is
found.

Register group name

The name of the register.

Value

The current value of the register. Every time C-SPY stops, a value that has
changed since the last stop is highlighted. Some of the registers are editable. To
edit the contents of an editable register, click it and modify its value. Press Esc
to cancel the change.

To change the display format of the value, right-click on the register and choose
Format from the context menu.

Access

The access type of the register. Some of the registers are read-only, some of the
registers are write-only.
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Context menu
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For the C-SPY Simulator (and some C-SPY hardware debugger drivers), these
additional support registers are available in the CPU Registers group:

CYCLECOUNTER Cleared when an application is started or reset and is
incremented with the number of used cycles during

execution.
CCSTEP Shows the number of used cycles during the last performed
C/C++ source or assembler step.
CCTIMERI1 and Two trip counts that can be cleared manually at any given
CCTIMER2 time. They are incremented with the number of used cycles

during execution.

This context menu is available:

View Group 3
View User Group 3
Format 3

Open User Groups Setup Window

Save to File...

These commands are available:

View Group
Selects which predefined register group to display, by default CPU Registers.
By default, there are two register groups in the debugger: If some of your SFRs
are missing, you can register your own SFRs in a Custom group, see SFR Setup
window, page 185.

Current CPU Registers contains the registers that are available in the current
processor mode.

CPU Registers contains both the current registers and their banked counterparts
available in other processor modes.

Additional register groups are predefined in the device description files—
available in the arm\config directory—that make all SFR registers available
in the Registers windows. The device description file contains a section that
defines the special function registers and their groups.

View User Group
Selects which user-defined register group to display. For information about
creating your own user-defined register groups, see Defining
application-specific register groups, page 161.
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Format
Changes the display format for the contents of the register you clicked on. The
display format setting affects different types of registers in different ways. Your
selection of display format is saved between debug sessions.

Open User Groups Setup Window
Opens a window where you can create your own user-defined register groups,
see Register User Groups Setup window, page 183.

Save to File
Opens a standard save dialog box to save the contents of the window to a

tab-separated text file.

Register User Groups Setup window
The Register User Groups Setup window is available from the View menu or from the

context menu in the Registers windows.

Register User Groups Setup

Group Farmat
= regCroupine

Hexadecimal
Hexadecimal
Hexadecimal
Hexadecimal
Hexadecimal
Hexadecimal
Hexadecimal
Hexadecimal
Binary

- regCroupTwo

Hexadecimal
Binary

Binary
Hexadecimal

<click to add reg>
<click to add group>

Use this window to define your own application-specific register groups. These register
groups can then be viewed in the Registers windows.

Defining application-specific register groups means that the Registers windows can
display just those registers that you need to watch for your current debugging task. This
makes debugging much easier.

Requirements

None; this window is always available.
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Display area

Context menu
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This area contains these columns:

Group

The names of register groups and the registers they contain. Clickingon <click
to add group> or <click to add reg> and typing the name of a register
group or register, adds new groups and registers, respectively. You can also drag
a register name from another window in the IDE. Click a name to change it.

A dimmed register name indicates that it is not supported by the selected device.

Format

Shows the display format for the register’s value. To change the display format
of the value, right-click on the register and choose Format from the context
menu. The selected format is used in all Registers windows.

This context menu is available:
Format 3
Rermove
Clear Group

Remove All Groups

Save to File...

These commands are available:

Format
Changes the display format for the contents of the register you clicked on. The
display format setting affects different types of registers in different ways. Your
selection of display format is saved between debug sessions.

Remove
Removes the register or group you clicked on.

Clear Group

Removes all registers from the group you clicked on.

Remove All Groups
Deletes all user-defined register groups from your project.

Save to File

Opens a standard save dialog box to save the contents of the window to a
tab-separated text file.
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SFR Setup window
The SFR Setup window is available from the Project menu.
SFR Setup *®
MName Address Zone  Size Access =
+  MyOwnSFR Ox20004000 Mermory g Fead only
+ MyHideSFR 0x20004004 Mermory 16 Maone
Tik2_CR1 O=40000000 termany 32 Feadfifrite
o TIMZ_CR2 0x40000004 Merory 32 Fead only
TIM2_SMCR O=40000008 termany 32 Feadfifrite
Tik2_DIER O=4000000C termany 32 Feadfifrite
TIM2_5R 0x40000010 Merory a2 Eeadhirite
Tik2_EGR 0=40000014 termary 32 Feadpdfrite -

This window displays the currently defined SFRs that C-SPY has information about.
You can choose to display only factory-defined or custom-defined SFRs, or both. If
required, you can use the Edit SFR dialog box to customize the SFR definitions, see
Edit SFR dialog box, page 188. For factory-defined SFRs (that is, retrieved from the ddf
file in use), you can only customize the access type.

To quickly find an SFR, drag a text or hexadecimal number string and drop in this
window. If what you drop starts with a 0 (zero), the Address column is searched,
otherwise the Name column is searched.

Any custom-defined SFRs are added to a dedicated register group called Custom, which
you can choose to display in the Registers window. Your custom-defined SFRs are
saved in projectCustomSFR. sfr. This file is automatically loaded in the IDE when
you start C-SPY with a project whose name matches the prefix of the filename of the
sfr file.

You can only add or modify SFRs when the C-SPY debugger is not running.

Requirements

None; this window is always available.
Display area
This area contains these columns:

Status
A character that signals the status of the SFR, which can be one of:

blank, a factory-defined SFR.
C, a factory-defined SFR that has been modified.

+, a custom-defined SFR.
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?, an SFR that is ignored for some reason. An SFR can be ignored when a
factory-defined SFR has been modified, but the SFR is no longer available, or it
is located somewhere else or with a different size. Typically, this might happen
if you change to another device.

Name
A unique name of the SFR.

Address

The memory address of the SFR.
Zone

Selects a memory zone, see C-SPY memory zones, page 159.
Size

The size of the register, which can be any of 8, 16, 32, or 64.

Access

The access type of the register, which can be one of Read/Write, Read only,
Write only, or None.

You can click a name or an address to change the value. The hexadecimal 0x prefix for
the address can be omitted, the value you enter will still be interpreted as hexadecimal.
For example, if you enter 4567, you will get 0x4567.

You can click a column header to sort the SFRs according to the column property.
Color coding used in the display area:

o Green, which indicates that the corresponding value has changed

o Red, which indicates an ignored SFR.

C-SPY® Debugging Guide
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Context menu

This context menu is available:

v

Show All
Show Custom SFRs only
Show Factory SFRs only

Add...

Edit...

Delete

Delete/Revert All Custom SFRs
Save Custom SFRs...

& bits
16 bits
32 bits

64 bits

Read/Write
Read only
Write only

MNone

These commands are available:

Show All

Shows all SFR.

Show Custom SFRs only

Shows all custom-defined SFRs.

Show Factory SFRs only
Shows all factory-defined SFRs retrieved from the ddf file.

Add

Edit

Memory and registers __4

Displays the Edit SFR dialog box where you can add a new SFR, see Edit SFR

dialog box, page 188.

Displays the Edit SFR dialog box where you can edit an SFR, see Edit SFR

dialog box, page 188.

Delete

Delete/revert All Custom SFRs

Deletes an SFR. This command only works on custom-defined SFRs.

Deletes all custom-defined SFRs and reverts all modified factory-defined SFRs

to their factory settings.
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Edit SFR dialog box

Requirements

Name

C-SPY® Debugging Guide
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Save Custom SFRs

Opens a standard save dialog box to save all custom-defined SFRs.
8|16|32|64 bits

Selects display format for the selected SFR, which can be 8, 16, 32, or 64 bits.

Note that the display format can only be changed for custom-defined SFRs.
Read/Write|Read only|Write only|None

Selects the access type of the selected SFR, which can be Read/Write, Read
only, Write only, or None. Note that for factory-defined SFRs, the default
access type is indicated.

The Edit SFR dialog box is available from the context menu in the SFR Setup window.

Edit SFR (=23
SFR
M ame:
MyOwnSFR Carcel
Address: Zone:
0400004567 Memary -
Size Access
@ 8 bits @ Read wiite
16 bitz Fiead only
32 bitz write: only
B4 bits MHone

Definitions of the SFRs are retrieved from the device description file in use. Use this
dialog box to either modify these factory-defined definitions or define new SFRs. See
also SFR Setup window, page 185.

None; this dialog box is always available.

Specify the name of the SFR that you want to add or edit.
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Address
Specify the address of the SFR that you want to add or edit. The hexadecimal 0x prefix
for the address can be omitted, the value you enter will still be interpreted as
hexadecimal. For example, if you enter 4567, you will get 0x4567.

Zone
Selects the memory zone for the SFR you want to add or edit. The list of zones is
retrieved from the ddf file that is currently used.

Size
Selects the size of the SFR. Choose between 8, 16, 32, or 64 bits. Note that the display
format can only be changed for custom-defined SFRs.

Access

Selects the access type of the SFR. Choose between Read/Write, Read only, Write
only, or None. Note that for factory-defined SFRs, the default access type is indicated.
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Memory Configuration dialog box, for the C-SPY simulator

The Memory Configuration dialog box is available from the C-SPY driver menu.

Memory Configuration @

Usze ranges based on “
@ Device description file
() Debug file segment information [only shown while debugging)

Zone Name Start End Type Size s
Memory CODE FLRSH 0x00000000 Ox003FFFFF Read only 4 Mbytes
Memory CODE FLRSH 0x00800000 Ox00SFFFFF Read only 2 Mbytes
Memory CODE FLRSH 0x01000000 0x01007FFF Read only 3Z kbytes E
Memory LOCRL RRM PEZ 0xFESDOO00O OxFESFFFFF Read/Write 152 kbytes
Memory LOCRL RAM PE1 OxFEBDOOOO OxFEBFFFFF Read/Write 152 kbytes

[T Use marual ranges

Ignored Zone Start End Type Size Hew...

Edit...
Delete

Drelete Al

Memory access checking
Check for: Action:

[ Access type violation Log violations

(@ Log and stop execution

Use this dialog box to specify which set of memory address ranges to be used by C-SPY
during debugging.

See also Memory configuration for the C-SPY simulator, page 159.

Requirements
The C-SPY simulator.

Use ranges based on
Specify if the memory configuration should be retrieved from a predefined
configuration. Choose between:

Device description file

Retrieves the memory configuration from the device description file that you
have specified. See Selecting a device description file, page 53.

This option is used by default.

C-SPY® Debugging Guide
for Arm
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Debug file segment information
Retrieves the memory configuration from the debug file, which has retrieved it
from the linker configuration file. This information is only available during a
debug session. The advantage of using this option is that the simulator can catch
memory accesses outside the linked application.

Memory information is displayed in these columns:

Zone

The memory zone, see C-SPY memory zones, page 159.
Name

The name of the memory address range.
Start

The start address for the memory address range, in hexadecimal notation.
End

The end address for the memory address range, in hexadecimal notation.
Type

The access type of the memory address range.
Size

The size of the memory address range.

Use manual ranges

Specify your own ranges manually via the Edit Memory Range dialog box. To open
this dialog box, click New to specify a new memory address range, or select an existing
memory address range and click Edit to modify it. For more information, see Edit
Memory Range dialog box, for the C-SPY simulator, page 192.

The ranges you define manually are saved between debug sessions.

An X in the column Ignored means that C-SPY has detected that the specified manual
range is illegal, for example because it overlaps another range. C-SPY will not use such
an area.

Memory access checking

Check for determines what to check for:
o Access type violation.
Action selects the action to be performed if an access violation occurs. Choose between:

o Log violations

o Log and stop execution.
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Any violations are logged in the Debug Log window.

Buttons

These buttons are available for the manual ranges:

New
Opens the Edit Memory Range dialog box, where you can specify a new
memory address range and associate an access type with it, see Edit Memory
Range dialog box, for the C-SPY simulator, page 192.

Edit
Opens the Edit Memory Range dialog box, where you can edit the selected
memory address range. See Edit Memory Range dialog box, for the C-SPY
simulator, page 192.

Delete
Deletes the selected memory address range definition.

Delete All

Deletes all defined memory address range definitions.

Edit Memory Range dialog box, for the C-SPY simulator

The Edit Memory Range dialog box is available from the Memory Configuration
dialog box.

Edit Memary Range &J

Memory range
Zone:
Memary T Cancel

Start address: End address:
OxFFFFEFOO OxFFFFEFD3

4 bytes

Access type:
Rk

ROM/Flazh
@ SFR

%

Use this dialog box to specify your own memory address ranges, and their access types.

See also Memory Configuration dialog box, for the C-SPY simulator, page 190

C-SPY® Debugging Guide
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Requirements
The C-SPY simulator.

Memory range
Defines the memory address range specific to your device:

Zone
Selects a memory zone, see C-SPY memory zones, page 159.

Start address

Specity the start address for the memory address range, in hexadecimal
notation.

End address
Specify the end address for the memory address range, in hexadecimal notation.

Access type
Selects an access type for the memory address range. Choose between:
o RAM, for read/write memory
o ROM/Flash, for read-only memory
o SFR, for SFR read/write memory.
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Memory Configuration dialog box, in C-SPY hardware debugger drivers

The Memory Configuration dialog box is available from the C-SPY driver menu.

Memory Configuration [ %]
It iz impartant for C-5PY that the target memory is described fully and accurately. Your project settings normally specify
this, az follows.

Cancel |

r— Factory ranges
Selected device description file in Project Options:

C:\Program Filesh|AR Embedded Workbench &.0%arm\COMFIGYdebuggertSTAS TM 32015248 ddf

It specifies the following default memory ranges:

Zone | Hame | Start | End | Type | Size

Hemory Fla=sh 0xz08000000 0=z0801FFFF Fead only 128 kbytes

Hemory Periph Oxz40000000 0=SFFFFFFF SFR 512 Hbytes

Hemory RAH Oxzz20000000 0x20003FFF RFead-Write 16 kbytes

Hemory Sy=st ... OxzEOOOO0OOO 0=FFFFFFFF SFR 512 Hbytes

Hemory ExztDew OxzAO0000000 0=zDFFFFFFF SFR 1024 Mbytes
r~ Used ranges

Thiz iz the memory configuration that will be used. You can modify this as needed.

Zone | Start | End | Cache Type | Size | Comment Mew...
Hemory 0x08000000 0=z0801FFFF ROM-Fla=zh 128 kbytes =
Memory O=z20000000 0=20003FFF RAM 16 kbytes i
Hemory Ox22000000 0x23FFFFFF RAH 32 Mbytes bit-banding e |
Hemory Oxz40000000 0=SFFFFFFF Tncached SFR 512 Hbytes

Hemory OxzAO0000000 0=zDFFFFFFF Tncached SFR 1024 Mbytes Use Factary |
Hemory OxzEOOOO0OOO 0=FFFFFFFF Tncached SFR 512 Hbytes

4] |

O=08000000-0=0801£f£f££
128 kbytes (ROM-Flash)

C-SPY uses a default memory configuration based on information retrieved from the
device description file that you select, or if memory configuration is missing in the
device description file, tries to provide a usable factory default. See Selecting a device
description file, page 53.

Use this dialog box to verify, and if needed, modify the memory areas so that they match
the memory available on your device. Providing C-SPY with information about the

C-SPY® Debugging Guide
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memory layout of the target system is helpful both in terms of performance and
functionality:

o Reading (and writing) memory (if your debug probe is connected through a USB
port) can be fast, but is usually the limiting factor when C-SPY needs to update
many debugger windows. Caching memory can speed up the performance, but then
C-SPY needs information about the target memory.

o If C-SPY has been informed that the content of certain memory areas will be
changed during a debug session, C-SPY can keep a copy of that memory readable
even when the target does not normally allow reading (such as when executing).

o C-SPY can prevent accesses to areas without any memory at all, which can be
important for certain hardware.

The Memory Configuration dialog box is automatically displayed the first time you
start the C-SPY driver for a given project, unless the device description file contains a
memory description which is already specified as correct and complete. Subsequent
starts will not display the dialog box unless you have made project changes that might
cause the memory configuration to change, for example if you have selected another
device description file.

You can only change the memory configuration when C-SPY is not running.

See also Memory configuration for C-SPY hardware debugger drivers, page 160.

Requirements
One of these alternatives:

o The C-SPY CMSIS-DAP driver
o The C-SPY I-jet/JTAGjet driver.

Factory ranges

Identifies which device description file that is currently selected and lists the default
memory address ranges retrieved from the file in these columns:

Zone

The memory zone, see C-SPY memory zones, page 159.
Name

The name of the memory address range.
Start

The start address for the memory address range, in hexadecimal notation.

End

The end address for the memory address range, in hexadecimal notation.
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Used ranges

Graphical bar

Buttons
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Type

The access type of the memory address range.
Size

The size of the memory address range.

These columns list the memory address ranges that will be used by C-SPY. The columns
are normally identical to the factory ranges, unless you have added, removed, or
modified ranges.

Zone

Selects a memory zone, see C-SPY memory zones, page 159.
Start

The start address for the memory address range, in hexadecimal notation.
End

The end address for the memory address range, in hexadecimal notation.
Cache Type

The cache type of the memory address range.
Size

The size of the memory address range.
Comment

Memory area information.

Use the buttons to override the default memory address ranges that are retrieved from
the device description file.

A graphical bar that visualizes the entire theoretical memory address range for the
device. Defined ranges are highlighted in green.

These buttons are available for manual ranges:

New
Opens the Edit Memory Range dialog box, where you can specify a new
memory address range and associate a cache type with it, see Edit Memory
Range dialog box, for C-SPY hardware debugger drivers, page 197.
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Edit
Opens the Edit Memory Range dialog box, where you can edit the selected
memory address area. See Edit Memory Range dialog box, for C-SPY hardware
debugger drivers, page 197.

Remove
Removes the selected memory address range definition.

Use Factory

Restores the list of used ranges to the factory ranges.

Edit Memory Range dialog box, for C-SPY hardware debugger drivers

The Edit Memory Range dialog box is available from the Memory Configuration
dialog box.

Edit Memary Range &J

Memory range
Zone:

II\"Iemor_l,l—VI Cancel

Start address: End address:
0«0 Ox1FFFF
128 kbytes

Cache type: Extra attributes

@ RaM Access width [3,16,32)

ROM/Flash
Uncached/SFR

Use this dialog box to specify the memory address ranges, and assign a cache type to
each range.

See also Memory configuration for C-SPY hardware debugger drivers, page 160.

Requirements

One of these alternatives:

o The C-SPY CMSIS-DAP driver
o The C-SPY I-jet/JTAGjet driver.
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Memory range

Cache type
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Defines the memory address range specific to your device:
Zone

Selects a memory zone, see C-SPY memory zones, page 159.

Start address

Specify the start address for the memory address range, in hexadecimal
notation.

End address

Specity the end address for the memory address range, in hexadecimal notation.

Selects a cache type to the memory address range. Choose between:

RAM

When the target CPU is not executing, all read accesses from memory are loaded
into the cache. For example, if two Memory windows show the same part of

memory, the actual memory is only read once from the hardware to update both
windows. If you modify memory from a C-SPY window, your data is written to

cache only. Before any target execution, even stepping a single machine

instruction, the RAM cache is flushed so that all modified bytes are written to

the memory on your hardware.

ROM/Flash

This memory is assumed not to change during a debug session. Any code within
such a range that is downloaded when you start a debug session (or technically,
any such code that is part of the application being debugged) is stored in the
cache and remains there. Other parts of such ranges are loaded into the cache
from memory on demand, but are then kept during the debug session. Note that

C-SPY will not allow you to modify such memory from C-SPY windows.

Even though flash memory is normally used as a fixed read-only memory, there
are applications that modify parts of flash memory at runtime. For example,
some part of flash memory might be used for a file system or simply to store
non-volatile information. To reflect this in C-SPY, you should choose the RAM

cache type for those instead. Then C-SPY will assume that those parts can
change at any time during execution.
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SFR/Uncached

A range of this type is completely uncached. All read or write commands from
a C-SPY window will access the hardware immediately. Typically, this type is
useful for special function registers, which can have all sorts of unusual
behavior, such as having different values at every read access. This can in turn
have side-effects on other registers when they are written, not containing the
same value as was previously written, etc.

If you do not have the appropriate information about your device, you can specify an
entire memory as SFR/Uncached. This is not incorrect, but might make C-SPY slower
when updating windows. In fact, this caching type is sometimes used by the default
when there is no memory address range information available.

If required, you can disable caching; choose C-SPY driver>Disable Debugger Cache.

Extra attributes

Provides extra attributes.

Access width [8,16,32]
Forces C-SPY to use 8, 16, or 32 bits when accessing memory in this range.
Specity 8, 16 or 32 in the text box.

This option might not be available in the C-SPY driver you are using.
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Part 2. Analyzing your
application

This part of the C-SPY® Debugging Guide for Arm includes these chapters:
e Trace

e The application timeline

e Profiling

e Code coverage

e Power debugging

o C-RUN runtime error checking

.hmuhhhhi
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e Introduction to using trace
e Collecting and using trace data

e Reference information on trace

Introduction to using trace

These topics are covered:

o Reasons for using trace

e Briefly about trace

o Requirements for using trace

See also:

Getting started using data logging, page 258
Getting started using event logging, page 260
Power debugging, page 311

Getting started using interrupt logging, page 395

Profiling, page 291

REASONS FOR USING TRACE

By using trace, you can inspect the program flow up to a specific state, for instance an
application crash, and use the trace data to locate the origin of the problem. Trace data
can be useful for locating programming errors that have irregular symptoms and occur
sporadically.

Reasons for using the trace triggers and filters

By using trace trigger and filter conditions, you can select the interesting parts of your
source code and use the trace buffer in the trace probe more efficiently. Trace triggers—
Trace Start and Trace Stop breakpoints—specify for example a code section for which
you want to collect trace data. A trace filter specifies conditions that, when fulfilled,
activate the trace data collection during execution.
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BRIEFLY ABOUT TRACE

Your target system must be able to generate trace data. Once generated, C-SPY can
collect it and you can visualize and analyze the data in various windows and dialog
boxes.

C-SPY supports collecting trace data from these target systems:

o Devices with support for ETM (Embedded Trace Macrocell) —ETM trace

o Devices with support for the SWD (Serial Wire Debug) interface using the SWO
(Serial Wire Output) communication channel—SWO trace

® The C-SPY simulator.

Depending on your target system, different types of trace data can be generated.

ETM trace

ETM (Embedded Trace Macrocell) real-time trace is a continuously collected sequence
of every executed instruction for a selected portion of the execution. It is only possible
to collect as much data as the trace buffer can hold. The trace buffer can be located either
in the debug probe or on-chip (ETB). The trace buffer collects trace data in real time,

but the data is not displayed in the C-SPY windows until after the execution has stopped.

PTM trace

PTM (Program Trace Macrocell) is an alternative implementation of the trace logic used
in some Arm Cortex cores. The functionality is the same as ETM trace. Throughout this
document, the term ETM also applies to PTM unless otherwise stated.

ETB trace

ETB (Embedded Trace Buffer) trace is an on-chip trace buffer. The trace buffer has a
designated memory area with a predefined size.

MTB trace

MTB trace (Micro Trace Buffer) is a simplified trace variant that uses an on-chip trace
buffer. For MTB trace, the trace buffer shares the RAM memory with your application
code.

MTB trace gives access to instruction trace on devices based on the Cortex-MO+ core.

SWO trace

SWO trace is a sequence of events of various kinds, generated by the on-chip debug
hardware. The events are transmitted in real time from the target system over the SWO
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communication channel. This means that the C-SPY windows are continuously updated
while the target system is executing. The most important events are:

o PC sampling

The hardware can sample and transmit the value of the program counter at regular
intervals. This is not a continuous sequence of executed instructions (like ETM
trace), but a sparse regular sampling of the pc. A modern Arm CPU typically
executes millions of instructions per second, while the PC sampling rate is usually
counted in thousands per second.

o Interrupt logs

The hardware can generate and transmit data related to the execution of interrupts,
generating events when entering and leaving an interrupt handler routine.

e Datalogs

Using Data Log breakpoints, the hardware can be configured to generate and
transmit events whenever a certain variable, or simply an address range, is accessed
by the CPU.

The SWO channel has limited throughput, so it is usually not possible to use all the
above features at the same time, at least not if either the frequency of PC sampling, of
interrupts, or of accesses to the designated variables is high.

If you use the SWO communication channel on a trace probe, the data will be collected
in the trace buffer and displayed after the execution has stopped.

Trace features in C-SPY

In C-SPY, you can use the trace-related windows Trace, Function Trace, Timeline, and
Find in Trace. In the C-SPY simulator, you can also use the Trace Expressions window.
Depending on your C-SPY driver, you can set various types of trace breakpoints and
triggers to control the collection of trace data.

If you use the C-SPY I-jet/JTTAGjet driver, the C-SPY J-Link/J-Trace driver, the C-SPY
ST-LINK driver, or the C-SPY TI XDS driver, you have access to windows such as the
Interrupt Log, Interrupt Log Summary, Data Log, and Data Log Summary windows.

When you are debugging, two buttons labeled ETM and SWO, respectively, are visible
on the IDE main window toolbar. If any of these buttons is green, it means that the
corresponding trace hardware is generating trace data. Just point at the button with the
mouse pointer to get detailed tooltip information about which C-SPY features that have
requested trace data generation. This is useful, for example, if your SWO
communication channel often overflows because too many of the C-SPY features are
currently using trace data. Clicking on the buttons opens the corresponding setup dialog
boxes.
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In addition, several other features in C-SPY also use trace data, features such as the
Profiler, Code coverage, and Instruction profiling.

REQUIREMENTS FOR USING TRACE

The C-SPY simulator supports trace-related functionality, and there are no specific
requirements.

Note: The specific set of debug components you are using (hardware, a debug probe,
and a C-SPY driver) determine which trace features in C-SPY that are supported.

Requirements for using ETM trace
ETM trace is available for some Arm devices.
To use ETMvV3 trace, or earlier, you need one of these combinations:

o An I-jet, I-jet Trace, JTAGjet, or JTAGjet-Trace in-circuit debugging probe and a
device that supports ETM via ETB. The debug probe reads ETM data from the ETB
buffer. Make sure to use the C-SPY I-jet/JTAGjet driver.

o An I-jet Trace or JTAGjet-Trace in-circuit debugging probe and a device that
supports ETM. Make sure to use the C-SPY I-jet/JTAGjet driver.

o A J-Link or J-Trace debug probe and a device that supports ETM via ETB. The
debug probe reads ETM data from the ETB buffer. Make sure to use the C-SPY
J-Link/J-Trace driver.

o A J-Trace debug probe and a device that supports ETM. Make sure to use the
C-SPY J-Link/J-Trace driver.

To use ETMv4 trace, you need one of these combinations:

o An I-jet or I-jet Trace in-circuit debugging probe and a device that supports ETM
via ETB. The debug probe reads ETM data from the ETB buffer. Make sure to use
the C-SPY I-jet/JTAGjet driver.

o An I-jet Trace in-circuit debugging probe and a device that supports ETM. Make
sure to use the C-SPY I-jet/JTTAGjet driver.

For more information, see the /AR Debug probes User Guide for I-jet, I-jet Trace, and
I-scope, the JTAGjet-Trace User Guide for ARM and the IAR J-Link and IAR-J-Trace
User Guide, respectively.

Requirements for using MTB (Micro Trace Buffer) trace

To use MTB trace, you need a device with MTB and one of these alternatives:

o An I-jet or JTAGjet in-circuit debugging probe
o The C-SPY CMSIS-DAP driver and a device that supports CMSIS-DAP
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o A J-Link debug probe

Requirements for using SWO trace

To use SWO trace you need an I-jet or I-jet Trace in-circuit debugging probe, a J-Link,
J-Trace, an ST-LINK, or a TI XDS debug probe that supports the SWO communication
channel and a device that supports the SWD/SWO interface.

Requirements for using the trace triggers and trace filters

The trace triggering and trace filtering features are available for ETM, ETB, and PTM
trace, but not for SWO or MTB trace.

Different processors, cores, and debug probes might limit the number of available trace
triggers and filters.

Collecting and using trace data
These tasks are covered:
Getting started with ETM trace
Getting started with SWO trace
Setting up concurrent use of ETM and SWO
Trace data collection using breakpoints

Searching in trace data

Browsing through trace data.

GETTING STARTED WITH ETM TRACE
I Before you start C-SPY:

e For your device, the trace port must be set up. For some devices this is done
automatically when the trace logic is enabled. However, for some devices, typically
Atmel and ST devices based on Arm 7 or Arm 9, you need to set up the trace port
explicitly. You do this by means of a C-SPY macro file. You can find examples of
such files (ETM_init*.mac) in the example projects. To use a macro file, choose
Project>Options>Debugger>Setup>Use macro files. Specify your macro file; a
browse button is available for your convenience.

Note that the pins used on the hardware for the trace signals cannot be used by your
application.

2 Start C-SPY and choose ETM Trace Settings from the C-SPY driver menu. In the
ETM Trace Settings dialog box that appears, check if you need to change any of the
default settings.
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Open the Trace window—available from the driver-specific menu—and click the
Activate button to enable collecting trace data.

Click the Edit Settings button to open the ETM Trace Settings dialog box. Make sure
that the ETM registers and pins were properly initialized and that the debug probe
receives the Trace Clock (TCLK). The dialog box displays the trace clock frequency
which is received by the debug probe. Click Cancel to close the dialog box.

Start the execution. When the execution stops, for instance because a breakpoint is
triggered, trace data is displayed in the Trace window. For more information about the
window, see Trace window, page 222.

GETTING STARTED WITH SWO TRACE

To get started using SWO trace:
Before you start C-SPY, choose Project>Options>C-SPY driver.

Click the Setup tab or the Connection tab, respectively, and choose Interface>SWD.

After you have started C-SPY, choose SWO Trace Windows Settings from the C-SPY
driver menu. In the dialog box that appears, make your settings for controlling the
output in the Trace window.

To see statistical trace data, select the option Force>PC samples, see SWO Trace
Window Settings dialog box, page 216.

To configure the hardware’s generation of trace data, click the SWO Configuration
button available in the SWO Configuration dialog box. For more information, see
SWO Configuration dialog box, page 218.

Note specifically these settings:

o The value of the CPU clock option must reflect the frequency of the CPU clock
speed at which the application executes. Note also that the settings you make are
preserved between debug sessions.

o To decrease the amount of transmissions on the communication channel, you can
disable the Timestamp option. Alternatively, set a lower rate for PC Sampling or
use a higher SWO clock frequency.

Open the SWO Trace window—available from the C-SPY driver menu—and click the
Activate button to enable trace data collection.

Start the execution. The Trace window is continuously updated with trace data. For
more information about this window, see Trace window, page 222.
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SETTING UP CONCURRENT USE OF ETM AND SWO

If you have a JTAGjet-Trace or a J-Trace debug probe for Cortex-M3, you can use ETM
trace and SWO trace concurrently.

In this case, if you activate the ETM trace and the SWO trace, SWO trace data will also
be collected in the ETM trace buffer, instead of being streamed via the SWO channel.
This means that the SWO trace data will not be displayed until the execution has
stopped, instead of being continuously updated live in the SWO Trace window.

TRACE DATA COLLECTION USING BREAKPOINTS

A convenient way to collect trace data between two execution points is to start and stop
the data collection using dedicated breakpoints. Choose between these alternatives:

o In the editor or Disassembly window, position your insertion point, right-click, and
toggle a Trace Start or Trace Stop breakpoint from the context menu.

e In the Breakpoints window, choose Trace Start, Trace Stop, or Trace Filter.

o The C-SPY system macros __setTraceStartBreak and
__setTraceStopBreak can also be used.

For more information about these breakpoints, see Trace Start breakpoints dialog box,
page 233 and Trace Stop breakpoints dialog box, page 234, respectively.

Using the trace triggers and trace filters:

Use the Trace Start dialog box to set a start condition—a start trigger—to start
collecting trace data.

Use the Trace Stop dialog box to set a stop condition—a stop trigger—to stop
collecting trace data.

Optionally, set additional conditions for the trace data collection to continue. Then set
one or more trace filters, using the Trace Filter dialog box.

If needed, set additional trace start or trace stop conditions.
Enable the Trace window and start the execution.
Stop the execution.

You can view the trace data in the Trace window and in browse mode also in the
Disassembly window, where also the trace marks for your trace triggers and trace
filters are visible.

If you have set a trace filter, the trace data collection is performed while the condition
is true plus some further instructions. When viewing the trace data and looking for a
certain data access, remember that the access took place one instruction earlier.

209



Collecting and using trace data

210

C-SPY® Debugging Guide
for Arm

SEARCHING IN TRACE DATA

When you have collected trace data, you can perform searches in the collected data to
locate the parts of your code or data that you are interested in, for example, a specific
interrupt or accesses of a specific variable.

You specify the search criteria in the Find in Trace dialog box and view the result in the
Find in Trace window.

Note: The Find in Trace dialog box depends on the C-SPY driver you are using.

The Find in Trace window is very similar to the Trace window, showing the same
columns and data, but only those rows that match the specified search criteria.
Double-clicking an item in the Find in Trace window brings up the same item in the
Trace window.

To search in your trace data:

On the Trace window toolbar, click the Find button.
In the Find in Trace dialog box, specify your search criteria.
Typically, you can choose to search for:

e A specific piece of text, for which you can apply further search criteria
® An address range

o A combination of these, like a specific piece of text within a specific address range.
For more information about the various options, see Find in Trace dialog box, page 250.

When you have specified your search criteria, click Find. The Find in Trace window
is displayed, which means you can start analyzing the trace data. For more information,
see Find in Trace window, page 251.

BROWSING THROUGH TRACE DATA

To follow the execution history, simply look and scroll in the Trace window.
Alternatively, you can enter browse mode.

To enter browse mode, double-click an item in the Trace window, or click the Browse
toolbar button.

The selected item turns yellow and the source and disassembly windows will highlight
the corresponding location. You can now move around in the trace data using the up and
down arrow keys, or by scrolling and clicking; the source and Disassembly windows
will be updated to show the corresponding location. This is like stepping backward and
forward through the execution history.

Double-click again to leave browse mode.
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Reference information on trace
Reference information about:

ETM Trace Settings dialog box, page 212

ETM Trace Settings dialog box (J-Link/J-Trace), page 214

SWO Trace Window Settings dialog box, page 216

SWO Configuration dialog box, page 218

Trace window, page 222

Function Trace window, page 231

Trace Start breakpoints dialog box, page 233 (simulator)

Trace Stop breakpoints dialog box, page 234 (simulator)

Trace Start breakpoints dialog box (I-jet/JTAGjet and CMSIS-DAP), page 235
Trace Stop breakpoints dialog box (I-jet/JTAGjet and CMSIS-DAP), page 237
Trace Filter breakpoints dialog box (I-jet/JTAGjet), page 239

Trace Start breakpoints dialog box (J-Link/J-Trace), page 240

Trace Stop breakpoints dialog box (J-Link/J-Trace), page 243

Trace Filter breakpoints dialog box (J-Link/J-Trace), page 245

Trace Expressions window, page 248

Find in Trace dialog box, page 250

Find in Trace window, page 251.

Trace Save dialog box, page 252
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ETM Trace Settings dialog box

Requirements

Port width

Port mode

C-SPY® Debugging Guide
for Arm

The ETM Trace Settings dialog box is available from the C-SPY driver menu.

ETM Trace Settings &J

Properties Capture

Port width: [] 5top on buffer ful

[4 Bits v] [] stall processor on FIFO full

Port mode:

[Normal, full-rate docking '] D

Data Trace Status

[ Collect data values Trace dock frequency: MNone(ETE)
[ Collect data addresses Try Settings ]

Limit data tracing to address range

0x00000000 OxFFFFFFFF

[ OK ] [ Cancel

%

Use this dialog box to configure ETM trace generation and collection.
See also:

® Requirements for using ETM trace, page 206
o Getting started with ETM trace, page 207.

One of these alternatives:

o The C-SPY CMSIS-DAP driver
o The C-SPY I-jet/JTAGjet driver.

Specifies the trace bus width, which can be set to 1, 2, 4, 8, or 16 bits. The value must
correspond with what is supported by the hardware and the debug probe.

For the lower values, the risk of FIFO buffer overflow increases, unless you are using
the Stall processor on FIFO full option.

Specifies the used trace clock rate:

o Normal, full-rate clocking
o Normal, half-rate clocking

o Multiplexed



Data Trace

Capture

Status
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e Demultiplexed

e Demultiplexed, half-rate clocking.

Selects what type of trace data you want C-SPY to collect. Data trace is only available
for Arm7/Arm9/Arm11-based devices with ETM data trace. Choose between:
Collect data values

Collects data values.

Collect data addresses

Collects data addresses.

Limit data tracing to address range

Collects the specified type of data within the address range you specify in the
First and Last text boxes.

Normally, trace collection starts or stops when execution starts or stops, or when a Trace
Start or Trace Stop breakpoint is triggered. To change this, choose between:
Stop on buffer full

Stops collecting trace data when the probe buffer is full.

Stall processor on FIFO full

Stalls the processor in case the FIFO buffer fills up. The trace FIFO buffer on
the CPU might in some situations become full—FIFO buffer overflow—which
means trace data will be lost. This can be the case when the CPU is executing
several branch instructions close to each other in time, such as in tight loops.

Suppress PC capture

Disables PC trace. Depending on your hardware, data trace might still be
available.

Shows the ETM status.

Trace clock frequency

Shows the frequency of the trace clock to help you determine if the trace
hardware is properly configured. Typically, this depends on the settings of Port
Width and Port Mode.
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Apply settings

Applies the settings you made in this dialog box. The trace clock frequency will
be updated.

ETM Trace Settings dialog box (J-Link/}-Trace)

Requirements

Trace port width

The ETM Trace Settings dialog box is available from the C-SPY driver menu.

ETM Trace Settings E

Trace port width

1 Bit [ stall processor on FIFO Ful

C zEits ¥ | Broadeast all branch addresses

&+ 4 Eits Cancel |
r Cycle accurate bracing

| & Bits

= 16 Eits

™| St timestamp
Trace port {CPU core) speed

| 1000000 Hz

Trace port mode

INormaIJ half-rate clocking j

Trace buffer size

I 000100000

Use this dialog box to configure ETM trace generation and collection.

See also:

® Requirements for using ETM trace, page 206
o Getting started with ETM trace, page 207.

The C-SPY J-Link/J-Trace driver.

Specifies the trace bus width, which can be set to 1, 2, 4, 8, or 16 bits. The value must
correspond with what is supported by the hardware and the debug probe. For
Cortex-M3, 1, 2, and 4 bits are supported by the J-Trace debug probe. For Arm7/9, only
4 bits are supported by the J-Trace debug probe.

For the lower values, the risk of FIFO buffer overflow increases, unless you are using
the Stall processor on FIFO full option.

Trace port mode

C-SPY® Debugging Guide
214 for Arm

Specifies the used trace clock rate:

o Normal, full-rate clocking

o Normal, half-rate clocking
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o Multiplexed
o Demultiplexed
e Demultiplexed, half-rate clocking.

Note: For the J-Trace driver, the available alternatives depend on the device you are
using.

Trace buffer size

Specify the size of the trace buffer. By default, the number of trace frames is 0OxFFFF.
For Arm7/9 the maximum number is 0xFFFFF, and for Cortex-M3 the maximum
number is 0x3FFFFF.

For ARM7/9, one trace frame corresponds to 2 bytes of the physical J-Trace buffer size.
For Cortex-M3, one trace frame corresponds to approximately 1 byte of the buffer size.

Note: The Trace buffer size option is only available for the J-Trace driver.

Cycle accurate tracing

Emits trace frames synchronous to the processor clock even when no trace data is
available. This makes it possible to use the trace data for real-time timing calculations.
However, if you select this option, the risk for FIFO buffer overflow increases.

Note: This option is only available for Arm7/9 devices.

Broadcast all branches
Makes the processor send more detailed address trace information. However, if you
select this option, the risk for FIFO buffer overflow increases.

Note: This option is only available for Arm7/9 devices. For Cortex, this option is always
enabled.

Stall processor on FIFO full

Stalls the processor in case the FIFO buffer fills up. The trace FIFO buffer on the CPU
might in some situations become full—FIFO buffer overflow—which means trace data
will be lost. This can be the case when the CPU is executing several branch instructions
close to each other in time, such as in tight loops.

Show timestamp

Makes the Trace window display seconds instead of cycles in the Index column. To
make this possible you must also specify the appropriate speed for your CPU in the
Trace port (CPU core) speed text box.

Note: This option is only available when you use the J-Trace driver with Arm7/9
devices.
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SWO Trace Window Settings dialog box

Requirements

Force

C-SPY® Debugging Guide
for Arm

The SWO Trace Window Settings dialog box is available from the C-SPY driver
menu, alternatively from the SWO Trace window toolbar.

SWO Trace Window Settings g|
Generate: Force:
CPL  (Cydes per instruction) [ Time Stamps

ancel
[JExc  (Exception overhead) 5
[CsLEER (Sleep cydes) [Jinterrupt Logs

sy (Load store unit cydes)

[CJFoLD  (Folded instructions) [ SWO Configuration...

Use this dialog box to specify what to display in the SWO Trace window.

Note that you also need to configure the generation of trace data, click SWO
Configuration. For more information, see SWO Configuration dialog box, page 218.

One of these alternatives:

o The C-SPY I-jet/JTAGjet driver and an I-jet or I-jet Trace in-circuit debugging
probe

o The C-SPY J-Link/J-Trace driver and a J-Link/J-Trace JTAG/SWD probe
o The C-SPY ST-LINK driver and an ST-LINK JTAG/SWD probe
o The C-SPY TI XDS driver and a TI XDS probe.

Enables data generation, if it is not already enabled by other features using SWO trace
data. The Trace window displays all generated SWO data. Other features in C-SPY, for
example Profiling, can also enable SWO trace data generation. If no other feature has
enabled the generation, use the Force options to generate SWO trace data.

The generated data will be displayed in the Trace window. Choose between:

Time Stamps

Enables timestamps for various SWO trace packets, that is sent over the SWO
communication channel. Use the resolution drop-down list to choose the
resolution of the timestamp value. For example, 1 to count every cycle, or 16 to
count every 16th cycle. Note that the lowest resolution is only useful if the time
between each event packet is long enough. 16 is useful if using alow SWO clock
frequency.

This option does not apply to I-jet.
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PC samples

Enables sampling the program counter register, PC, at regular intervals. To
choose the sampling rate, see SWO Configuration dialog box, page 218,
specifically the option PC Sampling.

Interrupt Logs

Forces the generation of interrupt logs to the SWO Trace window. For
information about other C-SPY features that also use trace data for interrupts,
see Interrupts, page 387.

ITM Log
Forces the generation of ITM logs to the SWO Trace window.

This option applies to I-jet only.

Generate

Enables trace data generation for these events. The generated data will be displayed in
the Trace window. The value of the counters are displayed in the Comment column in
the SWO Trace window. Choose between:

CPI
Enables generation of trace data for the CPI counter.
EXC

Enables generation of trace data for the EXC counter.

SLEEP
Enables generation of trace data for the SLEEP counter.

LSU

Enables generation of trace data for the LSU counter.

FOLD
Enables generation of trace data for the FOLD counter.

SWO Configuration

Displays the SWO Configuration dialog box where you can configure the hardware’s
generation of trace data. See SWO Configuration dialog box, page 218.

This button is not available when you are using I-jet.
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SWO Configuration dialog box

The SWO Configuration dialog box is available from the C-SPY driver menu,
alternatively from the SWO Trace Window Settings dialog box.

SWO Configuration ? *
PL Sampling Data Log Events Interupt Log
In uze by: In uze by: In uze by:
OM: S0 Trace Window Forced PC Sampling OM: Timeline “Window Data Graph OM: Timeline “Window Interrupt Graph
OM: Data Log OM: S0 Trace Window Forced Interupt Logs
Divider: | 8192 OFC only
(®) PC + data value + baze addr
4394 zamples/second at 72 MHz (O Data value + exact addr
Clock setup ITH Stimuluz Ports
Enabled . il 24 23 16 15 8 7 a
pabielpots: ITTTTTI T I T I T T I T I T 10 0T AT
EPU clack: 72 MHz il 24 23 16 15 8 7 a
ToTeminal l/OWindow: [TTTTTTTIITTITTITTICTTTTITITTICTITITITITTI
Swio ler:
2wiprescait gl T Lo Fie 3 24 23 16 15 g 7 0
o Loghie: ITTT T T OO T I T I T T I T I T T I T IT 1]

36000 kHz

$PROJ_DIR$MTHM log

Power 5ampling
Force PC Sampling
Collect power zamples only at PC samples

Cancel

This figure reflects the C-SPY I-jet/JTAGjet driver.

Use this dialog box to configure the serial-wire output communication channel and the
hardware’s generation of trace data.

See also Getting started with SWO trace, page 208.

Requirements
One of these alternatives:
o The C-SPY I-jet/JTAGjet driver and an I-jet or I-jet Trace in-circuit debugging
probe
The C-SPY J-Link/J-Trace driver and a J-Link/J-Trace JTAG/SWD probe
The C-SPY ST-LINK driver and an ST-LINK JTAG/SWD probe
o The C-SPY TI XDS driver and a TI XDS probe.

C-SPY® Debugging Guide
218 for Arm



PC Sampling

Data Log Events
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Controls the behavior of the sampling of the program counter. You can specify:

In use by

Rate

Lists the features in C-SPY that can use trace data for PC sampling. ON
indicates features currently using trace data. OFF indicates features currently
not using trace data.

Use the drop-down list to choose the sampling rate, that is, the number of
samples per second. The highest possible sampling rate depends on the SWO
clock value and on how much other data that is sent over the SWO
communication channel. The higher values in the list will not work if the SWO
communication channel is not fast enough to handle that much data.

This option does not apply to I-jet.

Divider

Select a divider, that, applied to the CPU clock speed, determines the rate of PC
samples. The highest possible sampling rate depends on the SWO clock value
and on how much other data that is sent over the SWO communication channel.
The smaller values in the list will not work if the SWO communication channel
is not fast enough to handle that much data.

This option applies to I-jet only.

Specifies what to log when a Data Log breakpoint is triggered. These items are
available:

In use by

Lists the features in C-SPY that can use trace data for Data Log Events. ON
indicates features currently using trace data. OFF indicates features currently
not using trace data.

PC only

Logs the value of the program counter.

PC + data value + base addr

Logs the value of the program counter, the value of the data object, and its base
address.

Data value + exact addr

Logs the value of the data object and the exact address of the data object that
was accessed.
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Interrupt Log

Lists the features in C-SPY that can use trace data for Interrupt Logs. ON indicates
features currently using trace data. OFF indicates features currently not using trace data.

For more information about interrupt logging, see Interrupts, page 387.

Override project default

Overrides the CPU clock and the SWO clock default values on the
Project>Options>J-Link/J-Trace>Setup page, on the
Project>Options>ST-Link>Communication page, or on the
Project>Options>TI XDS>Communication page, respectively.

This option does not apply to I-jet.

Override project settings

CPU clock

SWO clock

C-SPY® Debugging Guide
for Arm

Overrides the CPU clock and the SWO prescaler default values on the
Project>Options>I-jet>Setup page.

This option only applies to I-jet.

Specify the exact clock frequency used by the internal processor clock, HCLK, in MHz.
The value can have decimals.

This value is used for configuring the SWO communication speed.

For J-Link, ST-LINK, and TI XDS, this value is also used for calculating timestamps.

Specify the clock frequency of the SWO communication channel in kHz. Choose
between:

Autodetect
Automatically uses the highest possible frequency that the J-Link debug probe
can handle. When it is selected, the Wanted text box displays that frequency.

Wanted

Manually selects the frequency to be used, if Autodetect is not selected. The
value can have decimals. Use this option if data packets are lost during
transmission.

Actual

Displays the frequency that is actually used. This can differ a little from the
wanted frequency.
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This option does not apply to I-jet.

SWO prescaler

Specify the clock prescaler of the SWO communication channel. The prescaler, in turn,
determines the SWO clock frequency. If data packets are lost during transmission, try
using a higher prescaler value. Choose between:

Auto

Automatically uses the highest possible frequency that the I-jet debugging probe
can handle.

1,2,5,10,20,50,100
The prescaler value.

This option applies to I-jet only.

Timestamps

Selects the resolution of the timestamp value. For example, 1 to count every cycle, or 16
to count every 16th cycle. Note that the lowest resolution is only useful if the time
between each event packet is long enough.

This option does not apply to I-jet.

ITM Stimulus Ports

Selects which ports you want to redirect and to where. The ITM Stimulus Ports are used
for sending data from your application to the debugger host without stopping the
program execution. There are 32 such ports. Choose between:

Enabled ports

Enables the ports to be used. Only enabled ports will actually send any data over
the SWO communication channel to the debugger.

Port 0 is used by the terminal I/O library functions.
Ports 1-4 are used by the ITM macros for the Event Log window.
Port 5 is used for an optional PC value added to the ITM macro.

To Terminal I/O window
Specifies the ports to use for routing data to the Terminal I/O window.

To Log File

Specifies the ports to use for routing data to a log file. To use a different log file
than the default one, use the browse button.
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Power Sampling

Trace window

Requirements

C-SPY® Debugging Guide
for Arm

The stdout and stderr of your application can be routed via SWO to the C-SPY
Terminal I/O window, instead of via semihosting. To achieve this, choose
Project>Options>General Options>Library Configuration>Library low-level
interface implementation>stdout/stderr>Via SWO. This will significantly improve
the performance of stdout/stderr, compared to when semihosting is used.

This can be disabled if you deselect the port settings in the Enabled ports and To
Terminal 1/O options.

Force PC Sampling
Forces PC sampling, even when no other C-SPY features have requested it. This
makes it possible to associate PC values with power samples.

Collect power samples only at PC samples

Collects power samples only at PC samples, so that every power sample can be
associated with a program counter position.

The Trace window is available from the C-SPY driver menu.
This window displays the collected trace data.

Note: There are three different trace windows—ETM Trace, SWO Trace, and just
Trace for the C-SPY simulator. The windows look slightly different.

The content of the Trace window depends on the C-SPY driver you are using and the
trace support of your debug probe.

See also Collecting and using trace data, page 207.

One of these alternatives:

The C-SPY Simulator

A CMSIS-DAP probe

An I-jet or I-jet Trace in-circuit debugging probe
A JTAGjet debug probe

A J-Link/J-Trace JTAG/SWD probe

An ST-LINK JTAG/SWD probe

A TI XDS probe.
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Trace toolbar
The toolbar in the Trace window and in the Function Trace window contains:

Enable/Disable

Enables and disables collecting and viewing trace data in this window. This
button is not available in the Function Trace window.

[}

Clear trace data

X

Clears the trace buffer. Both the Trace window and the Function Trace window
are cleared.

Toggle source

=

Toggles the Trace column between showing only disassembly or disassembly
together with the corresponding source code.

Browse

(5]

Toggles browse mode on or off for a selected item in the Trace window.

Find

]

Displays a dialog box where you can perform a search, see Find in Trace dialog
box, page 250.

Save

o

In the ETM Trace and SWO Trace windows this button displays the Trace
Save dialog box, see Trace Save dialog box, page 252.

In the C-SPY I-jet/JTTAG-jet driver and in the C-SPY simulator, this button
displays a standard Save As dialog box where you can save the collected trace
data to a text file, with tab-separated columns.

g Edit Settings
In the C-SPY simulator, this button is not enabled.
In the ETM Trace window this button displays the Trace Settings dialog box,

see ETM Trace Settings dialog box (J-Link/J-Trace), page 214 and ETM Trace
Settings dialog box, page 212.

In the SWO Trace window this button displays the SWO Trace Window
Settings dialog box, see SWO Trace Window Settings dialog box, page 216.

Edit Expressions (C-SPY simulator only)

FI:'

Opens the Trace Expressions window, see Trace Expressions window, page
248.
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Progress bar

When a large amount of trace data has been collected, there might be a delay
before all of it has been processed and can be displayed. The progress bar
reflects that processing.

Display area (in the C-SPY simulator)

This area displays a collected sequence of executed machine instructions. In addition,
the window can display trace data for expressions.

Trace =
X B Q)@ - |FE
Cycles Trace callCount i
1797 0x592: LDR.N Rl... =)
1798 0x594: STR RO... 7
4 1799 0x596: BX LE 7
1 1800 0x5%=: LDR.N RO... 7
1801 0x5a0: LDR RO... 7
[ 1802 0x5a2: BL Ge... 7

This area contains these columns for the C-SPY simulator:

The leftmost column contains identifying icons to simplify navigation within
the buffer:

The yellow diamond indicates the trace execution point, marking when
target execution has started.

The right green arrow indicates a call instruction.
The left green arrow indicates a return instruction.

The dark green bookmark indicates a navigation bookmark.

v'.ﬁ.‘?

The red arrow indicates an interrupt.
| The violet bar indicates the results of a search.
Cycles
The number of cycles elapsed to this point.

Trace

The collected sequence of executed machine instructions. Optionally, the
corresponding source code can also be displayed.

C-SPY® Debugging Guide
for Arm
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Each expression you have defined to be displayed appears in a separate column.
Each entry in the expression column displays the value affer executing the
instruction on the same row. You specity the expressions for which you want to
collect trace data in the Trace Expressions window, see Trace Expressions

window, page 248.

A red-colored row indicates that the previous row and the red row are not consecutive.
This means that there is a gap in the collected trace data, for example because trace data
has been lost due to an overflow.

Display area (for ETM trace in the C-SPY hardware debugger drivers)

This area displays a collected sequence of executed machine instructions and other trace

data.
ETM Trace b
CYE] [ .
Timestamp Address Exec Trace Except | *
113528 ex@e21828a Thumb  SUBS RE, R4, #1 i
> 113538 8xee2182sc Thumb  BL arm_powz ; ex21ezbz
axeaz2182b2
113534 exee218zbs Thumb  MOVs R4, RE
113536 exee218zbe Thumb  MP R4, #1
» 113538 @x88212478 Thumb  PUsH {R7, LR} SysTick
> 113548 8x8e21247a Thumb  BL HAL_IncTick ; 8x212484
113542 8x8e212484 Thumb  LDR.N Re, [PC, #8xE] 3 uwTick
113544 8x88212486 Thumb  LDR re, [Re]
i::: 113545 8x8e212483 Thumb  ADDS RE, RE, #1
113548 8xee21248a Thumb  LDR.N R1, [PC, #8x4] 3 uwTick
113558 8xee21248c Thumb  STR re, [R1]
£ 113552 @2xee21248e Thumb  BX LR
¥ 113554 @xee21247e Thumb BL SysTickHandler 3 ex218393 -
e [ | +

Data trace is only available for the C-SPY CMSIS-DAP driver or the C-SPY
I-jet/JTAGjet driver, when using Arm7/Arm9/Arm11-based devices with ETM data

trace.

This area contains these columns. Note that some columns depend on the C-SPY driver,
the CPU, and the probe you are using.
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Cycles

The leftmost column contains identifying icons to simplify navigation within
the buffer:

The yellow diamond indicates the trace execution point, marking when
target execution has started.

[} The right green arrow indicates a call instruction.
{:] The left green arrow indicates a return instruction.

B The dark green bookmark indicates a navigation bookmark.
e The red arrow indicates an interrupt.

| The violet bar indicates the results of a search.

The number of cycles according to the internal JTAGjet-Trace timestamp.

Address

The address of the instruction associated with the trace frame.

Opcode

Exec

Trace

Except

Access

The operation code of the instruction associated with the trace frame. After the
hexadecimal value, extra information can be displayed:

x2 if two instructions were executed

¢ if the instruction was read from the I-Cache.

The execution mode—Arm, Thumb, or NoExec.

The collected sequence of executed machine instructions. Optionally, the
corresponding source code can also be displayed.

The type of exception, when it occurs.

The access type of the instruction associated with the trace frame. DMA stands
for DMA transfer. The address and data information shows which transfer that
was performed.

Data address

The data trace address.



Trace __o

Data value

The data trace value.

Comment
Additional information.
A red-colored row indicates that the previous row and the red row are not consecutive.

This means that there is a gap in the collected trace data, for example because trace data
has been lost due to an overflow.

Display area (for SWO trace)

This area contains these columns for SWO trace:

Index
An index number for each row in the trace buffer. Simplifies the navigation
within the buffer.

This column is only available for JTAGjet-Trace.

SWO Packet
The contents of the captured SWO packet, displayed as a hexadecimal value.

Cycles
The approximate number of cycles from the start of the execution until the
event.

For J-Link, this number is reported by the CPU.

For I-jet, this number corresponds to the internal I-jet/JTAGjet-Trace
timestamp.

Event

The event type of the captured SWO packet. If the column displays Overflow,
the data packet could not be sent, because too many SWO features use the SWO
channel at the same time. To decrease the amount of transmissions on the
communication channel, point at the SWO button—on the IDE main window
toolbar—with the mouse pointer to get detailed tooltip information about which
C-SPY features that have requested trace data generation. Disable some of the
features.

Value
The event value, if any.

Trace

If the event is a sampled pC value, the disassembled instruction is displayed in
this column. Optionally, the corresponding source code can also be displayed.
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Context menu

C-SPY® Debugging Guide
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Comment

Additional information. This includes the values of the selected Trace Events
counters, or the number of the comparator (hardware breakpoint) used for the
Data Log breakpoint.

A red-colored row indicates that the previous row and the red row are not consecutive.
This means that there is a gap in the collected trace data, for example because trace data
has been lost due to an overflow.

If the display area seems to show garbage, make sure you specified a correct value for
the CPU clock in the SWO Configuration dialog box.

This context menu is available:
v Enable

Clear
Embed Source

Browse
Find »
Find All...

MNavigate 3
Bookmarks 3

Timestamp 3

Save...

Note: The contents of this menu are dynamic and depend on which features that your
combination of software and hardware supports. However, the list of menu commands
below is complete and covers all possible commands. Note that the shortcuts to the
submenu commands do not use the Ctrl key.

These commands are available:

Enable

Enables and disables collecting and viewing trace data in this window.

Clear
Clears the trace buffer. Both the Trace window and the Function Trace window
are cleared.

Embed source

Toggles the Trace column between showing only disassembly or disassembly
together with the corresponding source code.
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Browse
Toggles browse mode on or off for a selected item in the Trace window.
Find>Find (F)
Displays a dialog box where you can perform a search in the Trace window, see
Find in Trace dialog box, page 250. The contents of the window will scroll to
display the first match.
Find>Find Next (G)

Finds the next occurrence of the specified string.

Find>Find Previous (Shift+G)
Finds the previous occurrence of the specified string.

Find>Clear (Shift+F)
Removes all search highlighting in the window.

Find All

Displays a dialog box where you can perform a search in the Trace window, see
Find in Trace dialog box, page 250. The search results are displayed in the Find
in Trace window—available by choosing the View>Messages command, see
Find in Trace window, page 251.

Navigate>After Current Loop (L)
Identifies the selected program counter and scans the trace data forward,
collecting program counters, until it finds the same address again. It has now
detected a loop. (Loops longer than 1000 instructions are not detected.) Then it
navigates forward until it finds a program counter that is not part of the collected
set. This is useful for navigating out of many iterations of an idle or polling loop.
Navigate>Before Current Loop (Shift+L)
Behaves as After Current Loop, but navigates backward out of the loop.
Navigate>After Current Function (U)
Navigates to the next unmatched return instruction. This is similar to stepping

out of the current function.

Navigate>Before Current Function (Shift+U)

Navigates to the closest previous unmatched call instruction.

Navigate>Next Statement (S)

Navigates to the next instruction that belongs to a different C statement than the
starting point. It skips function calls, i.e. it tries to reach the next statement in
the starting frame.
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Navigate>Previous Statement (Shift+S)
Behaves as Next statement, but navigates backward to the closest previous
different C statement.
Navigate>Next on Same Address (A)
Navigates to the next instance of the starting program counter address, typically
to the next iteration of a loop.
Navigate>Previous on Same Address (Shift+A)
Navigates to the closest previous instance of the starting program counter
address.
Navigate>Next Interrupt (I)
Navigates to the next interrupt entry. (To then find the matching interrupt exit,
follow up with After Current Function.)
Navigate>Previous Interrupt (Shift+I)
Navigates to the closest previous interrupt entry.
Navigate>Next Execution Start Point (E)
Navigates to the next point where the CPU was started, for example places
where the application stopped at breakpoints, or was stepped.
Navigate>Previous Execution Start Point (Shift+E)
Navigates to the closest previous point where the CPU was started.
Navigate>Next Discontinuity (D)
Navigates to the next discontinuity in the trace data.
Navigate>Previous Discontinuity (Shift+D)
Navigates to the closest previous discontinuity in the trace data.

Bookmarks>Toggle (+)
Adds a new navigation bookmark or removes an existing bookmark.

Bookmarks>Goto Next (B)
Navigates to the next navigation bookmark.

Bookmarks>Goto Previous (Shift+B)

Navigates to the closest previous navigation bookmark.

Bookmarks>Clear All
Removes all navigation bookmarks.

Bookmarks>location (0-9)

At the bottom of the submenu, the ten most recently defined bookmarks are
listed, with a shortcut key each from 0-9.

C-SPY® Debugging Guide
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Sets the selected row as a reference “zero” point in the collected sequence of
trace data. The count of rows in the Trace window will show this row as 0 and

recalculate the timestamps of all other rows in relation to this timestamp.

Timestamp>Go to Zero Point (Shift+Z)

Navigates to the reference “zero” point in the collected sequence of trace data
(if you have set one).

Timestamp>Clear Zero Point

Save

Removes the reference “zero” point from the trace data and restores the original

timestamps of all rows.

In the ETM Trace and SWO Trace windows this command displays the Trace

Save dialog box, see Trace Save dialog box, page 252.

In the C-SPY I-jet/JTAG-jet driver and in the C-SPY simulator, this command
displays a standard Save As dialog box where you can save the collected trace

data to a text file, with tab-separated columns.

Open Trace Expressions Window

Function Trace window

Opens the Trace Expressions window, see Trace Expressions window, page

248.

The Function Trace window is available from the C-SPY driver menu during a debug

session.

Function Trace

(@)X
#

33
34
50
51
63
73
76
=151

Cycles
78

79
109
110
130
145
151
166

Trace

OxFFEQOOS5F :
OxFFEOD4ED:
OxFFEOQDSG2 :
0xFFEQD419:
0xFFEQD400:
OxFFEQOO43A:
0xFFEQD400:
OxFFEOD442 :

main
InitUart

main + 3
InitFib
GetFil
InitFikb + 33
GetFil
InitFib + 41

m

This window displays a subset of the trace data displayed in the Trace window. Instead

of displaying all rows, the Function Trace window shows:

o The functions called or returned to, instead of the traced instruction

o The corresponding trace data.
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One of these alternatives:

The C-SPY Simulator

An I-jet or I-jet Trace in-circuit debugging probe
A JTAGjet debug probe

A J-Link/J-Trace JTAG/SWD probe

An ST-LINK JTAG/SWD probe

A TI XDS probe.

For information about the toolbar, see Trace window, page 222.

There are two sets of columns available, and which set is used in your debugging system
depends on the debug probe and which trace sources that are available:

o The available columns are the same as in the Trace window, see Trace window, page
222.

o For the simulator, I-jet Trace, and I-jet and depending on the trace source, these

columns are available:

Cycles
The number of cycles elapsed to this point according to the timestamp in the
debug probe.

Address

The address of the executed instruction.

Call/Return
The function that was called or returned to.
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Trace Start breakpoints dialog box

Requirements

Trigger at

4

The Trace Start dialog box is available from the context menu that appears when you
right-click in the Breakpoints window.

Edit Breakpoint @
o Trace Start

Break at:

Edit...

Use this dialog box to set a Trace Start breakpoint where you want to start collecting
trace data. If you want to collect trace data only for a specific range, you must also set a
Trace Stop breakpoint where you want to stop collecting data.

See also Trace Stop breakpoints dialog box, page 234 and Trace data collection using
breakpoints, page 209.

To set a Trace Start breakpoint:

In the editor or Disassembly window, right-click and choose Trace Start from the
context menu.

Alternatively, open the Breakpoints window by choosing View>Breakpoints.
In the Breakpoints window, right-click and choose New Breakpoint>Trace Start.

Alternatively, to modify an existing breakpoint, select a breakpoint in the Breakpoints
window and choose Edit on the context menu.

In the Break at text box, specify an expression, an absolute address, or a source
location. Click OK.

When the breakpoint is triggered, the trace data collection starts.

The C-SPY simulator.

Specify the code location of the breakpoint. Alternatively, click the Edit button to open

the Enter Location dialog box, see Enfer Location dialog box, page 153.
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4

Requirements
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The Trace Stop dialog box is available from the context menu that appears when you
right-click in the Breakpoints window.

Edit Breakpoint @
° Trace Stop

Break at:

Edit...

Use this dialog box to set a Trace Stop breakpoint where you want to stop collecting
trace data. If you want to collect trace data only for a specific range, you might also need
to set a Trace Start breakpoint where you want to start collecting data.

See also Trace Start breakpoints dialog box, page 233 and Trace data collection using
breakpoints, page 209.

To set a Trace Stop breakpoint:

In the editor or Disassembly window, right-click and choose Trace Stop from the
context menu.

Alternatively, open the Breakpoints window by choosing View>Breakpoints.
In the Breakpoints window, right-click and choose New Breakpoint>Trace Stop.

Alternatively, to modify an existing breakpoint, select a breakpoint in the Breakpoints
window and choose Edit on the context menu.

In the Break at text box, specify an expression, an absolute address, or a source
location. Click OK.

When the breakpoint is triggered, the trace data collection stops.

The C-SPY simulator.
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Trigger at

Specify the code location of the breakpoint. Alternatively, click the Edit button to open
the Enter Location dialog box, see Enfer Location dialog box, page 153.

Trace Start breakpoints dialog box (I-jet/JTAGjet and CMSIS-DAP)

The Trace Start dialog box is available from the context menu that appears when you
right-click in the Breakpoints window. You can also right-click in the editor window or
the Disassembly window, and then choose Toggle Breakpoint (Trace Start).

Trigger at:
Edit
Access type Cize)
ReadAwrite ':1Ut0 |
Read anual
Wiite Trigger range
Fetch Requested:
Match data Effective:
Enable
Extend to cover requested range
Walue:
Mask:

Use this dialog box to set the conditions that determine when to start collecting trace
data. When the trace condition is triggered, the trace data collection is started.

Requirements
One of these alternatives:

o The C-SPY CMSIS-DAP driver
o The C-SPY I-jet/JTAGjet driver.

Trigger at

Specify the starting point of the code section for which you want to collect trace data.
You can specify a variable name, an address, or a cycle counter value.

Access Type

Selects the type of memory access that triggers the breakpoint:

Read/Write
Reads from or writes to location.
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Match data

Size

Trigger range
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Read

Reads from location.

Write
Writes to location.

Fetch
Accesses at execution address.

Any accesses of the specified type will activate the trace data collection.

Enables matching of the accessed data. Choose between:

Value Specify a data value.
Mask Specify which part of the value to match (word, halfword,
or byte).

Use the Match data options in combination with the Read/Write, Read, or Write access
types for data. This option can be useful when you want a trigger when a variable has a
certain value.

Note: The Match data options are only available when using a Cortex-M device. For
Cortex-M devices, only one breakpoint with Match data can be set. Such a breakpoint
uses two breakpoint resources.

Controls the size of the address range, that when reached, will trigger the start of the
trace data collection. Choose between:
Auto

Sets the size automatically. This can be useful if Trigger at contains a variable.

Manual
Specify the size of the breakpoint range manually.

Shows the requested range and the effective range to be covered by the trace data
collection. The range suggested is either within or exactly the area specified by the
Trigger at and the Size options.



Trace Stop breakpoints dialog box (I-jet/JTAGjet and CMSIS-DAP)

Requirements

Trigger at

Extend to cover requested range

Trace __o

Extends the range so that a whole data structure is covered. For data structures
that do not fit the size of the possible ranges supplied by the hardware breakpoint
unit, for example three bytes, the range will not cover the whole data structure.
Note that the range will be extended beyond the size of the data structure, which

might cause false triggers at adjacent data.

This option is not enabled for Arm7/9 devices because the range for such

devices will always cover the whole data structure.

The Trace Stop dialog box is available from the context menu that appears when you
right-click in the Breakpoints window. You can also right-click in the editor window or

the Disassembly window, and then choose Toggle Breakpoint (Trace Stop).

Trigger at:

Access type

Readfwiite
Read
Write
Fetch

Match data
Enable

Walue:

Mask:

Size
Auto
Manual

Trigger range
Fequested:

Effective:

Extend to cover requested range

Use this dialog box to set the conditions that determine when to stop collecting trace

data. When the trace condition is triggered, the trace data collection is stopped.

One of these alternatives:

o The C-SPY CMSIS-DAP driver
o The C-SPY I-jet/JTAGjet driver.

Specify the end point of the code section for which you want to collect trace data. You

can specify a variable name, an address, or a cycle counter value.

237



Reference information on trace

238

Access Type

Match data

Size
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Selects the type of memory access that triggers the breakpoint:

Read/Write
Reads from or writes to location.

Read
Reads from location.

Write
Writes to location.

Fetch
Accesses at execution address.

Any accesses of the specified type will activate the trace data collection.

Enables matching of the accessed data. Choose between:

Value Specify a data value.
Mask Specity which part of the value to match (word, halfword,
or byte).

Use the Match data options in combination with the Read/Write, Read, or Write access
types for data. This option can be useful when you want a trigger when a variable has a
certain value.

Note: The Match data options are only available when using a Cortex-M device. For
Cortex-M devices, only one breakpoint with Match data can be set. Such a breakpoint
uses two breakpoint resources.

Controls the size of the address range, that when reached, will trigger the start of the
trace data collection. Choose between:

Auto

Sets the size automatically. This can be useful if Trigger at contains a variable.

Manual
Specify the size of the breakpoint range manually.
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Trigger range

Shows the requested range and the effective range to be covered by the trace data
collection. The range suggested is either within or exactly the area specified by the
Trigger at and the Size options.

Extend to cover requested range

Extends the range so that a whole data structure is covered. For data structures
that do not fit the size of the possible ranges supplied by the hardware breakpoint
unit, for example three bytes, the range will not cover the whole data structure.
Note that the range will be extended beyond the size of the data structure, which
might cause false triggers at adjacent data.

This option is not enabled for Arm7/9 devices because the range for such
devices will always cover the whole data structure.

Trace Filter breakpoints dialog box (I-jet/JTAGjet)

The Trace Filter dialog box is available from the context menu that appears when you
right-click in the Breakpoints window. You can also right-click in the editor window or
the Disassembly window, and then choose Toggle Breakpoint (Trace Filter).

o Trace Fitter

Start:

<100 Edit ...
End:

200 Edit ...

Use this dialog box to set the conditions that determine when to start collecting trace

data. When the trace condition is triggered, the trace data collection is started.
Requirements

One of these alternatives:

o The C-SPY CMSIS-DAP driver
o The C-SPY I-jet/JTAGjet driver.
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Start

Specify the start location of the code section for which you want to collect trace data.
Alternatively, click the Edit button to open the Enter Location dialog box, see Enter

Location dialog box, page 153.

End

Specify the end location of the code section for which you want to collect trace data.
Alternatively, click the Edit button to open the Enter Location dialog box, see Enter

Location dialog box, page 153.

Trace Start breakpoints dialog box (J-Link/J-Trace)

The Trace Start dialog box is available from the context menu that appears when you
right-click in the Breakpoints window. You can also right-click in the editor window or
the Disassembly window, and then choose Toggle Breakpoint (Trace Start).

3 Trace Start |
Trigger at:
|:0800CEDE Edit |
—Access ype — Size
; & Auto[1]
L [
‘s EZZSM[“E  Manual
 Wite ~ Trigger range
' OP-Fetch Fequested:
" Cycle IDHDSDDEBDB - 0x0800CEDE
— Match data Effective:
] Bl IDRDSDDEBDB - 0x0800CEDE
Wl 0%00000000 [~ Extend to cover requested range
alue: I
Link. condition
Mask: IDxFFFFFFFF i  AND
rverse & on

()8 I Cancel |

Use this dialog box to set the conditions that determine when to start collecting trace
data. When the trace condition is triggered, the trace data collection is started.

Requirements

The C-SPY J-Link/J-Trace driver.

Trigger at

Specify the starting point of the code section for which you want to collect trace data.
You can specify a variable name, an address, or a cycle counter value.

C-SPY® Debugging Guide
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Size

Controls the size of the address range, that when reached, will trigger the start of the
trace data collection. Choose between:

Auto
Sets the size automatically. This can be useful if Trigger at contains a variable.

Manual

Specity the size of the breakpoint range manually.

Trigger range

Shows the requested range and the effective range to be covered by the trace data
collection. The range suggested is either within or exactly the area specified by the
Trigger at and the Size options.

Extend to cover requested range

Extends the range so that a whole data structure is covered. For data structures
that do not fit the size of the possible ranges supplied by the hardware breakpoint
unit, for example three bytes, the range will not cover the whole data structure.
Note that the range will be extended beyond the size of the data structure, which
might cause false triggers at adjacent data.

This option is not enabled for Arm7/9 devices because the range for such
devices will always cover the whole data structure.

Access Type
Selects the type of memory access that triggers the breakpoint:

Read/Write
Reads from or writes to location.

Read

Reads from location.

Write
Writes to location.

OP-fetch
Accesses at execution address.

Cycle
The number of counter cycles at a specific point in time, counted from where the
execution started. This option is only available for Cortex-M devices.

Any accesses of the specified type will activate the trace data collection.
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Link condition
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Enables matching of the accessed data. Use the Match data options in combination with
the Read/Write, Read, or Write access types for data. This option can be useful when
you want a trigger when a variable has a certain value.

Value Specify a data value.
Mask Specify which part of the value to match (word, halfword,
or byte).

The Match data options are only available for J-Link/J-Trace and when using a
Cortex-M device.

Note: For Cortex-M devices, only one breakpoint with Match data can be set. Such a
breakpoint uses two breakpoint resources.

Specifies how trace conditions are combined, using AND and OR. When combining a
condition that has the link condition AND with a condition that has the link condition
OR, AND has precedence. The option Inverse inverts the trace condition and is
individual for each trace filter condition. If one trace start or stop condition is inverted,
all others will be too. An inverted trace start or stop condition means that the trace data
collection is performed everywhere except for this section of the application code.

For Arm7/9 devices, trace filters are combined using the OR algorithm. Use the Inverse
option to invert the trace filter; all trace filters are affected. The trace filter will be
combined with the start and stop triggers, if any, using the AND algorithm.
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Trace Stop breakpoints dialog box (J-Link/}J-Trace)
The Trace Stop dialog box is available from the context menu that appears when you
right-click in the Breakpoints window. You can also right-click in the editor window or
the Disassembly window, and then choose Toggle Breakpoint (Trace Stop).

New Breakpoint [ %]

2 Trace Stop |
Trigger at:
|ux0300c550 Edit |
—Access lype —Size
; &~ Auta[1)
L [
Readfwiite  Mamsl
 Fead -
= wiite — Trigger range
' OP-Fetch Fequested:
" Cycle IDHDSDDEBED - 0x0800CEED

—Match data Effective:

I Encble IDRDBDDEBED - 0x0800CEED

Walue: IUHUUUUDDDD ™ Extend to cover requested range
Link condition

Mask: IDxFFFFFFFF C AND
[ Inverse

* 0p

ok I Cancel |

When the trace condition is triggered, the trace data collection is performed for some
further instructions, and then the collection is stopped.

Requirements
The C-SPY J-Link/J-Trace driver.

Trigger at
Specify the stopping point of the code section for which you want to collect trace data.
You can specify a variable name, an address, or a cycle counter value.

Size

Controls the size of the address range, that when reached, will trigger the stop of the
trace data collection. Choose between:

Auto

Sets the size automatically. This can be useful if Trigger at contains a variable.

Manual
Specify the size of the breakpoint range manually.
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Shows the requested range and the effective range to be covered by the trace data
collection. The range suggested is either within or exactly the area specified by the
Trigger at and the Size options.

Extend to cover requested range

Extends the range so that a whole data structure is covered. For data structures
that do not fit the size of the possible ranges supplied by the hardware breakpoint
unit, for example three bytes, the range will not cover the whole data structure.
Note that the range will be extended beyond the size of the data structure, which
might cause false triggers at adjacent data.

This option is not enabled for Arm7/9 devices because the range for such
devices will always cover the whole data structure.

Selects the type of memory access that triggers the breakpoint:

Read/Write
Reads from or writes to location.

Read

Reads from location.

Write
Writes to location.

OP-fetch
Acceses at execution address.

Cycle
The number of counter cycles at a specific point in time, counted from where the
execution started. This option is only available for Cortex-M devices.

Any accesses of the specified type will stop the trace data collection.

Enables matching of the accessed data. Use the Match data options in combination with
the Read/Write, Read, or Write access types for data. This option can be useful when
you want a trigger when a variable has a certain value.

Value Specify a data value.
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Mask Specify which part of the value to match (word, halfword,
or byte).

The Match data options are only available for J-Link/J-Trace and when using a
Cortex-M device.

Note: For Cortex-M devices, only one breakpoint with Match data can be set. Such a
breakpoint uses two breakpoint resources.

Link condition

Specifies how trace conditions are combined, using AND and OR. When combining a
condition that has the link condition AND with a condition that has the link condition
OR, AND has precedence. The option Inverse inverts the trace condition and is
individual for each trace filter condition. If one trace start or stop condition is inverted,
all others will be too. An inverted trace start or stop condition means that the trace data
collection is performed everywhere except for this section of the application code.

For Arm7/9 devices, trace filters are combined using the OR algorithm. Use the Inverse
option to invert the trace filter; all trace filters are affected. The trace filter will be
combined with the start and stop triggers, if any, using the AND algorithm.

Trace Filter breakpoints dialog box (J-Link/J-Trace)

The Trace Filter dialog box is available from the context menu that appears when you
right-click in the Breakpoints window. You can also right-click in the editor window or
the Disassembly window, and then choose Toggle Breakpoint (Trace Filter).

2 Trace Filer |
Trigger at:
IEriticaISecEntr Edit |
—Access lype —Size
: & futn (4]
o [+
‘s EZZSMNE  Manual
 Wite ~ Trigger range
~ DP-Fetch Requested:
" Cycle IUK2DDDD450 - 020000453
— Match data Effective:
™ Enable IDx2DDDD450 - 020000453
Wl IDHDDDUUUUD [ Extend to cover requested range
alue:
Link. condition
Mask: IDxFFFFFFFF i  AND
rverse & 0R

()8 I Cancel |
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When the trace condition is triggered, the trace data collection is performed for some
further instructions, and then the collection is stopped.

The C-SPY J-Link/J-Trace driver.

Specify the code location of the breakpoint. Alternatively, click the Edit button to open
the Enter Location dialog box, see Enfer Location dialog box, page 153.

Controls the size of the address range where filtered trace is active. Choose between:

Auto
Sets the size automatically. This can be useful if Trigger at contains a variable.

Manual
Specify the size of the breakpoint range manually.

Shows the requested range and the effective range to be covered by the trace data
collection. The range suggested is either within or exactly the area specified by the
Trigger at and the Size options.

Extend to cover requested range

Extends the range so that a whole data structure is covered. For data structures
that do not fit the size of the possible ranges supplied by the hardware breakpoint
unit, for example three bytes, the range will not cover the whole data structure.
Note that the range will be extended beyond the size of the data structure, which
might cause false triggers at adjacent data.

This option is not enabled for Arm7/9 devices because the range for such
devices will always cover the whole data structure.

Selects the type of memory access that triggers the breakpoint:
Read/Write

Reads from or writes to location.

Read

Reads from location.
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Link condition
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Write

Writes to location.

OP-fetch
Accesses at execution address.

Cycle

The number of counter cycles at a specific point in time, counted from where the
execution started. This option is only available for Cortex-M devices.

Enables matching of the accessed data. Use the Match data options in combination with
the Read/Write, Read, or Write access types for data. This option can be useful when
you want a trigger when a variable has a certain value.

Value Specify a data value.
Mask Specify which part of the value to match (word, halfword,
or byte).

The Match data options are only available for J-Link/J-Trace and when using a
Cortex-M device.

Note: For Cortex-M devices, only one breakpoint with Match data can be set. Such a
breakpoint uses two breakpoint resources.

Specifies how trace conditions are combined, using AND and OR. When combining a
condition that has the link condition AND with a condition that has the link condition
OR, AND has precedence. The option Inverse inverts the trace condition and is
individual for each trace filter condition. If one trace start or stop condition is inverted,
all others will be too. An inverted trace start or stop condition means that the trace data
collection is performed everywhere except for this section of the application code.

For Arm7/9 devices, trace filters are combined using the OR algorithm. Use the Inverse
option to invert the trace filter; all trace filters are affected. The trace filter will be
combined with the start and stop triggers, if any, using the AND algorithm.
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The Trace Expressions window is available from the Trace window toolbar.

Trace Expressions x
Expression Farmat
i Default
dec Default
R4 Default
CYCLECOUNTER Default

Use this window to specify, for example, a specific variable (or an expression) for which
you want to collect trace data.

The C-SPY simulator.

Use the display area to specify expressions for which you want to collect trace data:

Expression
Specify any expression that you want to collect data from. You can specify any
expression that can be evaluated, such as variables and registers.

Format
Shows which display format that is used for each expression. Note that you can
change display format via the context menu.

Each row in this area will appear as an extra column in the Trace window.
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Context menu

This context menu is available:
Move Up
Mowve Down

Rermove

Default
Binary

Octal
Decimal
Hexadecimal

Char

These commands are available:

Move Up
Moves the selected expression upward in the window.

Move Down
Moves the selected expression downward in the window.

Remove

Removes the selected expression from the window.

Default Format,

Binary Format,

Octal Format,

Decimal Format,

Hexadecimal Format,

Char Format
Changes the display format of expressions. The display format setting affects
different types of expressions in different ways. Your selection of display format
is saved between debug sessions. These commands are available if a selected
line in the window contains a variable.

The display format setting affects different types of expressions in these ways:

Variables The display setting affects only the selected variable, not
other variables.

Array elements The display setting affects the complete array, that is, the
same display format is used for each array element.

Structure fields All elements with the same definition—the same field
name and C declaration type—are affected by the
display setting.
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The Find in Trace dialog box is available by clicking the Find button on the Trace
window toolbar or by choosing Edit>Find and Replace>Find.

Note that the Edit>Find and Replace>Find command is context-dependent. It displays
the Find in Trace dialog box if the Trace window is the current window or the Find
dialog box if the editor window is the current window.

Find in Trace @

| Text search =

Match case
| Match whole word
Only search in one column

Address range

Use this dialog box to specify the search criteria for advanced searches in the trace data.

The search results are displayed in the Find in Trace window—available by choosing
the View>Messages command, see Find in Trace window, page 251.

See also Searching in trace data, page 210.

One of these alternatives:

The C-SPY Simulator

The C-SPY I-jet/JTAGjet driver
The C-SPY J-Link/J-Trace driver
The C-SPY CMSIS-DAP driver
The C-SPY ST-LINK driver

The C-SPY TI XDS driver.

Specify the string you want to search for. To specify the search criteria, choose between:

Match Case

Searches only for occurrences that exactly match the case of the specified text.
Otherwise int will also find INT and Int and so on.
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Match whole word

Searches only for the string when it occurs as a separate word. Otherwise int
will also find print, sprintf and so on.

Only search in one column
Searches only in the column you selected from the drop-down list.

Address Range

Specify the address range you want to display or search. The trace data within the
address range is displayed. If you also have specified a text string in the Text search
field, the text string is searched for within the address range.

Find in Trace window

The Find in Trace window is available from the View>Messages menu. Alternatively,
it is automatically displayed when you perform a search using the Find in Trace dialog
box or perform a search using the Find in Trace command available from the context
menu in the editor window.

Find in Trace x
Cycles Trace callCount  *
3811 0xB0002b6: LDR.N RO, [PC, #0Oxc] ; callCount [u]
3943 0xB0002b6: LDR.N RO, [PC, #0Oxc] ; callCount [u)
4276 0xB000296: LDR.N RO, [PC, #0Ox2c] ; callCount [u]
4281 0xB0002%9c: LDR.N Rl, [PC, #0x24] ; callCount [u)
4362 0xB0002b6: LDR.N RO, [PC, #0Oxc] ; callCount 1 |E
4494 0xB0002b6: LDR.N RO, [PC, #0Oxc] ; callCount 1
4626 0xB0002b6: LDR.N RO, [PC, #0Oxc] ; callCount 1
4758 0xB0002b6: LDR.N RO, [PC, #0Oxc] ; callCount 1 -

This window displays the result of searches in the trace data. Double-click an item in the
Find in Trace window to bring up the same item in the Trace window.

Before you can view any trace data, you must specify the search criteria in the Find in
Trace dialog box, see Find in Trace dialog box, page 250.

See also Searching in trace data, page 210.

Requirements

One of these alternatives:

The C-SPY Simulator

The C-SPY I-jet/JTAGjet driver
The C-SPY J-Link/J-Trace driver
The C-SPY CMSIS-DAP driver
The C-SPY ST-LINK driver.
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Display area

Trace Save dialog box

Requirements

Index Range

Append to file

The Find in Trace window looks like the Trace window and shows the same columns
and data, but only those rows that match the specified search criteria.

The Trace Save dialog box is available from the driver-specific menu, and from the
Trace window and the SWO Trace window.

Index Range————————
Start: ID Cancel |

End: |?535 [~ Append to file

™ Use tab-separated format

File: ITraceIog.txt |

One of these alternatives:

o The C-SPY J-Link/J-Trace driver
o The C-SPY ST-LINK driver
e The C-SPY TI XDS driver.

Saves a range of frames to a file. Specify a start index and an end index (as numbered in
the index column in the Trace window).

Appends the trace data to an existing file.

Use tab-separated format

File

C-SPY® Debugging Guide
for Arm

Saves the content in columns that are tab-separated, instead of separated by white
spaces.

Specify a file for the trace data.
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e Introduction to analyzing your application’s timeline
e Analyzing your application’s timeline

e Reference information on application timeline

Introduction to analyzing your application’s timeline

These topics are covered:

e Briefly about analyzing the timeline

o Requirements for timeline support
See also:

o Trace, page 203

BRIEFLY ABOUT ANALYZING THE TIMELINE

C-SPY can provide information for various aspects of your application, collected when
the application is running. This can help you to analyze the application’s behavior.

You can view the timeline information in different representations:

o Asdifferent graphs that correlate with the running application in relation to a shared
time axis.

® As detailed logs

o As summaries of the logs.

Depending on the capabilities of your hardware, the debug probe, and the C-SPY driver
you are using, timeline information can be provided for:

Call stack Can be represented in the Timeline window, as a graph that displays the
sequence of function calls and returns collected by the trace system. You
get timing information between the function invocations.

Note that there is also a related Call Stack window and a Function
Trace window, see Call Stack window, page 83 and Function Trace
window, page 231, respectively.
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Data logging Based on data logs collected by the trace system for up to four different
variables or address ranges, specified by means of Data Log
breakpoints. Choose to display the data logs:

o In the Timeline window, as a graph of how the values change over
time.
e In the Data Log window and the Data Log Summary window.
Event Based on event logs produced when the execution passes specific
logging positions in your application code. Choose to display the event logs:
e In the Timeline window, as a graph of the timing of the events.
e In the Event Log window and the Event Log Summary window.

Event logs can help you to analyze the application flow and inspect data
correlated to a certain position in your application code.

Interrupt Based on interrupt logs collected by the trace system. Choose to display
logging the interrupt logs:

o In the Timeline window, as a graph of the interrupt events during
the execution of your application.

e In the Interrupt Log window and the Interrupt Log Summary
window.

Interrupt logging can, for example, help you locate which interrupts you
can fine-tune to make your application more efficient. For more
information, see the chapter Interrupts.

Power Based on logged power measurement samples generated by the debug
logging probe or associated hardware. Choose to display the power logs:

e In the Timeline window, as a graph of the power measurement
samples.

e In the Power Log window.

Power logs can be useful for finding peaks in the power consumption
and by double-clicking on a value you can see the corresponding source
code. The precision depends on the frequency of the samples, but there
is a good chance that you find the source code sequence that caused the
peak.

For more information, see the chapter Power debugging, page 311.

C-SPY® Debugging Guide
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State logging Based on logged activity—state changes—for peripheral units and
clocks, as well as for CPU modes generated by the debug probe or
associated hardware. Choose to display the state logs:

e In the Timeline window, as a graph of the state changes.

o In the State Log window and in the State Log Summary window.
The information is useful for tracing the activity on the target system.

For more information, see the chapter Power debugging, page 311.

REQUIREMENTS FOR TIMELINE SUPPORT

Depending on the capabilities of the hardware, the debug probe, and the C-SPY driver
you are using, timeline information is supported for:

Target system Call Stack Dat:f Statfe Eveth Intel:'rupt Pow'er
logging  logging logging  logging logging
C-SPY simulator Yes Yes — — Yes —
CMSIS-DAP Yes? — — — — —
I-jet Yes? Yes — Yes Yes Yes
JTAGjet Yes? — — — — —
JTAGjet-Trace Yes — — — — —
J-Link Yes? Yes — Yes Yes Yes
J-Trace Yes Yes! — Yes! Yes! —
ST-LINK — Yes — Yes Yes —
TI MSP-FET — — Yes — — Yes
TI XDS — Yes Yes Yes Yes Yes

Table 11: Support for timeline information
1 Very limited when ETM trace is enabled.
2 Requires ETB/MTB.

For more information about requirements related to trace data, see Requirements for
using trace, page 206.

Analyzing your application’s timeline

These tasks are covered:
o Displaying a graph in the Timeline window, page 256
® Navigating in the graphs, page 257
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® Analyzing performance using the graph data, page 257
o Getting started using data logging, page 258
o Getting started using event logging, page 260

See also:

® Debugging in the power domain, page 318
o Using the interrupt system, page 392

DISPLAYING A GRAPH IN THE TIMELINE WINDOW

The Timeline window can display several graphs; follow this example procedure to
display any of these graphs. For an overview of the graphs and what they display, see
Briefly about analyzing the timeline, page 253.

Choose C-SPY driver>SWO Configuration to open the SWO Configuration dialog
box. Make sure the CPU clock option is set to the same value as the CPU clock value
set by your application. This is necessary to set the SWO clock and to obtain a correct
data transfer to the debug probe.

If you are using the C-SPY simulator, choose Simulator>Simulated Frequency to set
up a frequency that matches the simulated hardware.

Choose Timeline from the C-SPY driver menu to open the Timeline window.

In the Timeline window, right-click in the window and choose Select graphs from the
context menu to select which graphs to be displayed.

In the Timeline window, right-click in the graph area and choose Enable from the
context menu to enable a specific graph.

For the Data Log graph, you must set a Data Log breakpoint for each variable you want
a graphical representation of in the Timeline window. See Data Log breakpoints
dialog box (C-SPY hardware drivers), page 146.

For the Event graph, you must add a preprocessor macro to your application source
code where you want events to be generated. See Getting started using event logging,
page 260.

Click Go on the toolbar to start executing your application. The graphs that you have
enabled appear.
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NAVIGATING IN THE GRAPHS

After you have performed the steps in Displaying a graph in the Timeline window, page
256, you can use any of these alternatives to navigate in the graph:

e Right-click and from the context menu choose Zoom In or Zoom Out.
Alternatively, use the + and — keys. The graph zooms in or out depending on which
command you used.

e Right-click in the graph and from the context menu choose Navigate and the
appropriate command to move backwards and forwards on the graph. Alternatively,
use any of the shortcut keys: arrow keys, Home, End, and Ctrl+End.

o Double-click on a sample of interest to highlight the corresponding source code in
the editor window and in the Disassembly window.

o Click on the graph and drag to select a time interval, which will correlate to the
running application. The selection extends vertically over all graphs, but appears
highlighted in a darker color for the selected graph. Press Enter or right-click and
from the context menu choose Zoom>Zoom to Selection. The selection zooms in.
Use the navigation keys in combination with the Shift key to extend the selection.

ANALYZING PERFORMANCE USING THE GRAPH DATA

The Timeline window provides a set of tools for analyzing the graph data.

In the Timeline window, right-click and choose Time Axis Unit from the context
menu. Select which unit to be used on the time axis; choose between Seconds and
Cycles. If Cycles is not available, the graphs are based on different clock sources.

Execute your application to display a graph, following the steps described in
Displaying a graph in the Timeline window, page 256.
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3 Whenever execution stops, point at the graph with the mouse pointer to get detailed
tooltip information for that location.

— } }

IRQTI at level 1
CPU Clock (5 MHz)

t1: 20148.00 us (100740 cycles)
t2: 20859.20 us (104296 cycles) |

T(t2 - t1): 711.20 us (3556 cycles)

L | BN

—| '7
— =
I = U
IR
Tl
=
0.020s 0.021s 0.022s 0.023s 0.0;

Note that if you have enabled several graphs, you can move the mouse pointer over the
different graphs to get graph-specific information.

4  Click in the graph and drag to select a time interval. Point in the graph with the mouse
pointer to get timing information for the selection.

Start time of

S 127
selection in
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' _ periodically
R t + .
. y - . . occurring events.

e time fmess 5s 0.00020s 0.00025s L §

of the selection

GETTING STARTED USING DATA LOGGING

I To set up for data logging, choose C-SPY driver>Configuration. In the dialog box, set
up the serial-wire output communication channel for trace data. Note specifically the
CPU clock option. You can set a default value for the CPU clock on the
Project>Options>C-SPY driver page. In the SWO Configuration dialog box, you
can override the default value.

C-SPY® Debugging Guide
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If you are using the C-SPY simulator you can ignore this step.
To set a data log breakpoint, use one of these methods:

o In the Breakpoints window, right-click and choose New Breakpoint>Data Log to
open the breakpoints dialog box. Set a breakpoint on the memory location that you
want to collect log information for. This can be specified either as a variable or as an
address.

o Inthe Memory window, select a memory area, right-click and choose Set Data Log
Breakpoint from the context menu. A breakpoint is set on the start address of the
selection.

e In the editor window, select a variable, right-click and choose Set Data Log
Breakpoint from the context menu. The breakpoint will be set on the part of the
variable that the microcontroller can access using one instruction.

You can set up to four data log breakpoints. For more information about data log
breakpoints, see Data Log breakpoints, page 121.

Choose C-SPY driver>Data Log to open the Data Log window. Optionally, you can
also choose:

o C-SPY driver>Data Log Summary to open the Data Log Summary window

o C-SPY driver>Timeline to open the Timeline window to view the Data Log graph.

From the context menu, available in the Data Log window, choose Enable to enable
the logging.

In the SWO Configuration dialog box, you can notice in the Data Log Events area
that Data Logs are enabled. Choose which level of logging you want:

e PC only
o PC + data value + base address

e Data value + exact address
If you are using the C-SPY simulator you can ignore this step.
Start executing your application program to collect the log information.

To view the data log information, look in the Data Log window, the Data Log
Summary window, or the Data graph in the Timeline window.

If you want to save the log or summary to a file, choose Save to log file from the
context menu in the window in question.

To disable data logging, choose Disable from the context menu in each window where
you have enabled it.
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GETTING STARTED USING EVENT LOGGING

To specify the position in your application source code that you want to generate events
for, use the predefined preprocessor macros in arm_itm.h (located in arm\inc\c). In
your application source code, write (for example):

#include <arm_itm.h>
void func (void)
{
ITM_EVENT8_WITH_PC(1,25);
ITM_EVENT32_WITH_PC(2,
}

get_PSP());

The first line sends an event with the value 25 to channel 1. The second line sends an
event with the current value of the stack pointer to channel 2, which means that C-SPY
can display the stack pointer at a code position of your choice. When these source lines
are passed during program execution, events will be generated and visualized by C-SPY,
which means that you can further analyze them.

To view event information, you can choose between these alternatives:

o Choose C-SPY driver>Timeline to open the Timeline window and choose Enable
from the context menu. You can now view events for each channel as a graph (Event
graph). See also Timeline window—Events graph, page 277.

o Choose C-SPY driver>Event Log to open the Event Log window and choose
Enable from the context menu. You can now view the events for each channel as
numbers. See also Event Log window, page 282.

o Choose C-SPY driver>Event Log Summary to open the Event Log Summary
window and choose Enable from the context menu. You will now get a summary of
all events. See also Event Log Summary window, page 284.

Note: Whenever the Events graph or the Event Log window is enabled, you can at any
time enable also the Event Log Summary window to get a summary. However, if you
have enabled the Event Log Summary window, but not the Event Log window or the
Event graph in the Timeline window, you can get a summary but not detailed
information about events.

Select the graph and right-click to view the context menu. Here you can choose to:

o Change the radix (you can choose between displaying values in hexadecimal or in
decimal format). Note that this setting affects also the Event Log window and the
Event Log Summary window.

Show the numerical value of the variables

Show the value of the events

Select the style of the graph (as bars, levels, or linear)
Select the size of the graph (S, M, or L)
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Go to source.

4 Start executing your application program to collect the log information.

To view the event information, look at either the Event Log window, the Event Log
Summary window, or the event graph for the specific channel in the Timeline
window.

6 If you want to save the log or summary to a file, choose Save to log file from the
context menu in the window.

7 To disable event logging, choose Disable from the context menu in each window
where you have enabled it.

Reference information on application timeline
Reference information about:

Timeline window—Call Stack graph, page 262
Timeline window—Data Log graph, page 267
Data Log window, page 271

Data Log Summary window, page 274
Timeline window—Events graph, page 277
Event Log window, page 282

Event Log Summary window, page 284
Viewing Range dialog box, page 288

See also:

Timeline window—Interrupt Log graph, page 408
Interrupt Log window, page 402

Interrupt Log Summary window, page 406
Timeline window—Power graph, page 327
Power Log window, page 323

Timeline window—State Log graph, page 333
State Log window, page 328

State Log Summary window, page 330
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Timeline window—Call Stack graph

The Timeline window is available from the C-SPY driver menu during a debug session.

I Timing information

Timeline =
1] -
W W Wi W W
[putchar]| [putchar]| [putchar]| [putchar]| [putchar]| 3
) |?Springboa| |?Springboa| |?Springboa| |?Springboa| |?Springboa|
putch [_printf 517
?Spring [printf 537 |
_Printf | [nmiHandler::??INTVEC 16 1
printf | [nmiHandler:??INTVEC 16 ;
main 87 / <
a. 9999225__.-": 8.000024s 8.008026s a. B__B’BBZSS 8.008030s 8.008032s
] [T G
Commaon time axis ] { Selection for current graph
This window displays trace data represented as different graphs, in relation to a shared
time axis.
The Call Stack graph displays the sequence of function calls and returns collected by the
trace system.
Note: There is a limit on the number of saved logs. When this limit is exceeded, the
oldest entries in the buffer are erased.
Requirements

One of these alternatives:

The C-SPY simulator

ETB/ETM and one of the C-SPY CMSIS-DAP driver, the C-SPY I-jet/JTAGjet
driver, or the C-SPY J-Link/J-Trace driver

The C-SPY I-jet/JTAGjet driver and a JTAGjet Trace debug probe
The C-SPY J-Link/J-Trace driver and a J-Trace debug probe

C-SPY® Debugging Guide
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Display area for the Call Stack graph
Each function invocation is displayed as a horizontal bar which extends from the time
of entry until the return. Called functions are displayed above its caller. The horizontal
bars use four different colors:

Medium green for normal C functions with debug information

Light green for functions known to the debugger only through an assembler label

Medium yellow for normal interrupt handlers, with debug information

Light yellow for interrupt handlers known to the debugger only through an
assembler label

The timing information represents the number of cycles spent in, or between, the
function invocations.

At the bottom of the window, there is a shared time axis that uses seconds or cycles as
the time unit.

Click in the graph to display the corresponding source code.

Context menu

This context menu is available:

MNavigate 3
Auto Scroll

Zoom 3
Call Stack

v Enable

Show Timing

Go to Source

Save to File...
MNavigation 3
Select Graphs 3
Time Axis Unit 3

Note: The contents of this menu are dynamic and depend on which features that your
combination of software and hardware supports. However, the list of menu commands
below is complete and covers all possible commands.

These commands are available:

Navigate
Commands for navigating the graph(s). Choose between:

Next moves the selection to the next relevant point in the graph. Shortcut key:
right arrow.
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Previous moves the selection backward to the previous relevant point in the
graph. Shortcut key: left arrow.

First moves the selection to the first data entry in the graph. Shortcut key:
Home.

Last moves the selection to the last data entry in the graph. Shortcut key: End.

End moves the selection to the last data in any displayed graph, in other words
the end of the time axis. Shortcut key: Ctrl+End.

Auto Scroll

Zoom

Toggles automatic scrolling on or off. When on, the most recently collected data
is automatically displayed when you choose Navigate>End.

Commands for zooming the window, in other words, changing the time scale.
Choose between:

Zoom to Selection makes the current selection fit the window. Shortcut key:
Return.

Zoom In zooms in on the time scale. Shortcut key: +
Zoom Out zooms out on the time scale. Shortcut key: —

10ns, 100ns, 1us, etc makes an interval of 10 nanoseconds, 100 nanoseconds, 1
microsecond, respectively, fit the window.

1ms, 10ms, etc makes an interval of 1 millisecond or 10 milliseconds,
respectively, fit the window.

10m, 1h, etc makes an interval of 10 minutes or 1 hour, respectively, fit the
window.

Call Stack

Enable

A heading that shows that the Call stack-specific commands below are available.

Toggles the display of the graph on or off. If you disable a graph, that graph will
be indicated as OFF in the window. If no data has been collected for a graph, no
data will appear instead of the graph.

Show Timing

Toggles the display of the timing information on or off.

Go To Source

C-SPY® Debugging Guide
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Save to File
Saves all contents (or the selected contents) of the Call Stack graph to a file. The
menu command is only available when C-SPY is not running.
Navigation>After Current Loop (L)
Identifies the selected program counter and scans the trace data forward,
collecting program counters, until it finds the same address again. It has now
detected a loop. (Loops longer than 1000 instructions are not detected.) Then it
navigates forward until it finds a program counter that is not part of the collected
set. This is useful for navigating out of many iterations of an idle or polling loop.
Navigation>Before Current Loop (Shift+L)
Behaves as After Current Loop, but navigates backward out of the loop.

Navigation>After Current Function (U)
Navigates to the next unmatched return instruction. This is similar to stepping
out of the current function.

Navigation>Before Current Function (Shift+U)
Navigates to the closest previous unmatched call instruction.

Navigation>Next Statement (S)
Navigates to the next instruction that belongs to a different C statement than the
starting point. It skips function calls, i.e. it tries to reach the next statement in
the starting frame.

Navigation>Previous Statement (Shift+S)
Behaves as Next statement, but navigates backward to the closest previous
different C statement.

Navigation>Next on Same Address (A)
Navigates to the next instance of the starting program counter address, typically
to the next iteration of a loop.

Navigation>Previous on Same Address (Shift+A)
Navigates to the closest previous instance of the starting program counter
address.

Navigation>Next Interrupt (I)
Navigates to the next interrupt entry. (To then find the matching interrupt exit,
follow up with After Current Function.)

Navigation>Previous Interrupt (Shift+I)
Navigates to the closest previous interrupt entry.
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Navigation>Next Execution Start Point (E)
Navigates to the next point where the CPU was started, for example places
where the application stopped at breakpoints, or was stepped.
Navigation>Previous Execution Start Point (Shift+E)
Navigates to the closest previous point where the CPU was started.
Navigation>Next Discontinuity (D)
Navigates to the next discontinuity in the trace data.
Navigation>Previous Discontinuity (Shift+D)
Navigates to the closest previous discontinuity in the trace data.
Select Graphs
Selects which graphs to be displayed in the Timeline window.
Time Axis Unit
Selects the unit used in the time axis; choose between Seconds and Cycles.
If Cycles is not available, the graphs are based on different clock sources. In that
case you can view cycle values as tooltip information by pointing at the graph
with your mouse pointer.
Profile Selection

Enables profiling time intervals in the Function Profiler window. Note that this
command is only available if the C-SPY driver supports PC Sampling. For more
information, see Selecting a time interval for profiling information, page 297.
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Timeline window—Data Log graph

Requirements

The Timeline window is available from the C-SPY driver menu during a debug session.

[ Graph in Levels style ] [ Graph in Linear style ]

N
Y

Tmeine \ \ x
\ /—\
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| 0x10 —— ox0n 0x10 ox10

8.80398s 8.608399s *  9.0e4008s 8.80401s 9.80402s
1 / ll »
= -

A

Commaon time axis ]

This window displays trace data represented as different graphs, in relation to a shared
time axis.

The Data Log graph displays the data logs collected by the trace system, for up to four
different variables or address ranges specified as Data Log breakpoints.

Note: There is a limit on the number of saved logs. When this limit is exceeded, the
oldest entries in the buffer are erased.

One of these alternatives:

o The C-SPY simulator
o The C-SPY I-jet/JTAGjet driver

o The C-SPY J-Link/J-Trace driver. Data logs are very limited when using the J-Trace
probe and when ETM trace is enabled.

o The C-SPY ST-LINK driver

o The C-SPY TI XDS driver and a TI XDS debug probe with an SWD interface
between the debug probe and the target system.

267



Reference information on application timeline

268

Display area for the Data Log graph
Where:

Context menu
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The label area at the left end of the graph displays the variable name or the address
for which you have specified the Data Log breakpoint.

The graph itself displays how the value of the variable changes over time. The label
area also displays the limits, or range, of the Y-axis for a variable. You can use the
context menu to change these limits. The graph is a graphical representation of the
information in the Data Log window, see Data Log window, page 271.

The graph can be displayed either as a thin line between consecutive logs or as a
rectangle for every log (optionally color-filled).

A red vertical line indicates overflow, which means that the communication channel
failed to transmit all data logs from the target system. A red question mark indicates
a log without a value.

At the bottom of the window, there is a shared time axis that uses seconds or cycles as
the time unit.

This context menu is available:

<

MNavigate 3
Auto Scroll

Zoom 3

Data Log
Enable
Clear

o

Viewing Range...

Size 3
Style 3
Solid Graph

Show Numerical Values
Hexadecimal

Go to Source

Select Graphs 3
Time Axis Unit 3

Note: The contents of this menu are dynamic and depend on which features that your
combination of software and hardware supports. However, the list of menu commands
below is complete and covers all possible commands.
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These commands are available:
Navigate

Commands for navigating the graph(s). Choose between:

Next moves the selection to the next relevant point in the graph. Shortcut key:
right arrow.

Previous moves the selection backward to the previous relevant point in the
graph. Shortcut key: left arrow.

First moves the selection to the first data entry in the graph. Shortcut key:
Home.

Last moves the selection to the last data entry in the graph. Shortcut key: End.

End moves the selection to the last data in any displayed graph, in other words
the end of the time axis. Shortcut key: Ctrl+End.
Auto Scroll

Toggles automatic scrolling on or off. When on, the most recently collected data
is automatically displayed when you choose Navigate>End.

Zoom

Commands for zooming the window, in other words, changing the time scale.
Choose between:

Zoom to Selection makes the current selection fit the window. Shortcut key:
Return.

Zoom In zooms in on the time scale. Shortcut key: +
Zoom Out zooms out on the time scale. Shortcut key: —

10ns, 100ns, 1us, etc makes an interval of 10 nanoseconds, 100 nanoseconds, 1
microsecond, respectively, fit the window.

1ms, 10ms, etc makes an interval of 1 millisecond or 10 milliseconds,
respectively, fit the window.

10m, 1h, etc makes an interval of 10 minutes or 1 hour, respectively, fit the
window.

Data Log
A heading that shows that the Data Log-specific commands below are available.

Enable

Toggles the display of the graph on or off. If you disable a graph, that graph will
be indicated as OFF in the window. If no data has been collected for a graph, no
data will appear instead of the graph.
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Clear

Deletes the log information. Note that this will happen also when you reset the
debugger.

Variable

The name of the variable for which the Data Log-specific commands below
apply. This menu command is context-sensitive, which means it reflects the
Data Log graph you selected in the Timeline window (one of up to four).

Viewing Range
Displays a dialog box, see Viewing Range dialog box, page 288.
Size

Determines the vertical size of the graph; choose between Small, Medium, and
Large.

Style
Selects the style of the graph. Choose between:

Bars, displays a vertical bar for each log

Columns, displays a column for each log

Levels, displays the graph with a rectangle for each log, optionally color-filled
Linear, displays the graph as a thin line between consecutive logs

Note that all styles are not available for all graphs.

Solid Graph

Displays the graph as a color-filled solid graph instead of as a thin line.
Show Numerical Value

Shows the numerical value of the variable, in addition to the graph.
Hexadecimal

Toggles between displaying the selected value in decimal or hexadecimal

format. Note that this setting also affects the log window.
Go To Source

Displays the corresponding source code in an editor window, if applicable.
Select Graphs

Selects which graphs to be displayed in the Timeline window.
Time Axis Unit

Selects the unit used in the time axis; choose between Seconds and Cycles.

C-SPY® Debugging Guide
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If Cycles is not available, the graphs are based on different clock sources. In that
case you can view cycle values as tooltip information by pointing at the graph
with your mouse pointer.

Data Log window
The Data Log window is available from the C-SPY driver menu.

Time | Program Counter | 11 Address 52 Address 2

. lG6Es === W 0=0000 @ 0=2004
0.160us O=FFEOOD49 = @ 0=x2000
24 .480us O0=FFEOOOBS R 0=0000 @ 0=2006
24 .720us O0=FFEOOOBF W O0=0042 @ 0=2004
24 .760us O=FFEOOOCE R 0O=0042 @ 0=2006
24 .960us O=FFEOODOE4 W O=00004444 @ 0=2000
FE FEfGes O=FFE00104 R 0O=0042 @ O=2004+7
79.000us — W O0=0084 @ 0=2004
100.800us O=FFEOO104 R 0=0084 @ 0=2006
101.040us O=FFEOO10E W 0=00CA @ 0=2004
JFE Edfus Overflow \
136.880us O=FFEOO10E - @ 0=2004 3
White rows indicate Grey rows indicate

read accesses write accesses

Use this window to log accesses to up to four different memory locations or areas.

Note: There is a limit on the number of saved logs. When this limit is exceeded, the
oldest entries in the buffer are erased.

See also Getting started using data logging, page 258.

Requirements

A Cortex-M device and one of these alternatives:

® The C-SPY simulator

o The C-SPY I-jet/JTAGjet driver and an I-jet in-circuit debugging probe with an
SWD interface between the debug probe and the target system

o The C-SPY J-Link/J-Trace driver and a J-Link or J-Trace debug probe with an SWD
interface between the debug probe and the target system

For J-Trace, this window is available when ETM trace is disabled. When debugging,
this window only displays a limited amount of the collected trace data when ETM is
enabled. The entire trace data is displayed when the execution is stopped.
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o The C-SPY ST-LINK driver and a ST-LINK debug probe with an SWD interface
between the debug probe and the target system
o The C-SPY CMSIS-DAP driver

o The C-SPY TI XDS driver and a TT XDS debug probe with an SWD interface
between the debug probe and the target system.

Display area

Each row in the display area shows the time, the program counter, and, for every tracked
data object, its value and address. All information is cleared on reset. The information
is displayed in these columns:

Time
For the I-jet in-circuit debugging probe, the time for the data access is based on
a dedicated 48-MHz clock.

The time for the data access for the C-SPY J-Link driver, the C-SPY ST-LINK
driver, and the simulator, based on the clock frequency. For the C-SPY J-Link
driver, the C-SPY ST-LINK driver, and the C-SPY TI XDS driver, this is
specified in the SWO Configuration dialog box.

If the time is displayed in italics, the target system has not been able to collect a
correct time, but instead had to approximate it.

This column is available when you have selected Show time from the context
menu.

Cycles
The number of cycles from the start of the execution until the event.

If a cycle is displayed in italics, the target system has not been able to collect a
correct time, but instead had to approximate it.

This column is available when you have selected Show cycles from the context
menu.

Program Counter*
Displays one of these:

An address, which is the content of the pc, that is, the address of the instruction
that performed the memory access.

---, the target system failed to provide the debugger with any information.

Overflow in red, the communication channel failed to transmit all data from the
target system.

C-SPY® Debugging Guide
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Value
Displays the access type and the value (using the access size) for the location or
area you want to log accesses to. For example, if zero is read using a byte access
it will be displayed as 0x00, and for a long access it will be displayed as
0x00000000.

To specify what data you want to log accesses to, use the Data Log breakpoint
dialog box. See Data Log breakpoints dialog box, page 145 and Data Log
breakpoints dialog box (C-SPY hardware drivers), page 146.

Address
The actual memory address that is accessed. For example, if only a byte of a
word is accessed, only the address of the byte is displayed. The address is
calculated as base address + offset, where the base address is retrieved from the
Data Log breakpoint dialog box and the offset is retrieved from the logs. If the
log from the target system does not provide the debugger with an offset, the
offset contains + 2. If you want the offset to be displayed (for the C-SPY
I-jet/JTAGjet driver, the C-SPY J-Link driver, the C-SPY ST-LINK driver, and
the C-SPY TI XDS driver), select the Value + exact addr option in the SWO
Configuration dialog box.

* You can double-click a line in the display area. If the value of the pc for that line is
available in the source code, the editor window displays the corresponding source code
(this does not include library source code).

Context menu

This context menu is available:
v Enable

Clear
v Hexadecimal

Save to File...
v Show Time
Show Cycles

These commands are available:

Enable
Enables the logging system. The system will log information also when the
window is closed.

Clear

Deletes the log information. Note that this will happen also when you reset the
debugger.
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Hexadecimal
Toggles between displaying the selected value in decimal or hexadecimal
format. Note that this setting also affects the log window.

Save to File
Displays a standard file selection dialog box where you can select the
destination file for the log information. The entries in the log file are separated
by TaB and LF characters. An X in the Approx column indicates that the
timestamp is an approximation.

Show Time
Displays the Time column.

If the Time column is displayed by default in the C-SPY driver you are using,
this menu command is not available.

Show Cycles
Displays the Cycles column.

If the Cyeles column is not supported in the C-SPY driver you are using, this
menu command is not available.

Data Log Summary window

The Data Log Summary window is available from the C-SPY driver menu.

x

Data
tVarl
tVar2
tvar3

DataLog Summary

Requirements

C-SPY® Debugging Guide
for Arm

Total Accesses Read Accesses Write Accesses Unknown Accesses
42 8 25 17

66 17 49 8

32 32 2] 2]

Approximative time count: 16
Overflow count: 8
Current time: 4301.52 us

This window displays a summary of data accesses to specific memory location or areas.

See also Getting started using data logging, page 258.

A Cortex-M device and one of these alternatives:

® The C-SPY simulator

o The C-SPY I-jet/JTAGjet driver and an I-jet in-circuit debugging probe with an
SWD interface between the debug probe and the target system



Display area

The application timeline °

o The C-SPY J-Link/J-Trace driver and a J-Link or J-Trace debug probe with an SWD
interface between the debug probe and the target system

For J-Trace, this window is available when ETM trace is disabled. When debugging,
this window only displays a limited amount of the collected trace data when ETM is
enabled. The entire trace data is displayed when the execution is stopped.

o The C-SPY ST-LINK driver and a ST-LINK debug probe with an SWD interface
between the debug probe and the target system
o The C-SPY CMSIS-DAP driver

o The C-SPY TI XDS driver and a TI XDS debug probe with an SWD interface
between the debug probe and the target system.

Each row in this area displays the type and the number of accesses to each memory
location or area in these columns. Summary information is listed at the bottom of the
display area.

Data
The name of the data object you have selected to log accesses to. To specify
what data object you want to log accesses to, use the Data Log breakpoint
dialog box. SeeData breakpoints dialog box, page 141 and Data Log
breakpoints dialog box (C-SPY hardware drivers), page 146.

Total Accesses
The total number of accesses.
If the sum of read accesses and write accesses is less than the total accesses, the
target system for some reason did not provide valid access type information for
all accesses.

Read Accesses
The total number of read accesses.

Write Accesses

The total number of write accesses.

Unknown Accesses

The number of unknown accesses, in other words, accesses where the access
type is not known.

Approximative time count
The information displayed depends on the C-SPY driver you are using.

For some C-SPY drivers, this information is not displayed or the value is always
zero. In this case, all logs have an exact time stamp.
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For other C-SPY drivers, a non-zero value is displayed. The value represents the
amount of logs with an approximative time stamp. This might happen if the
bandwidth in the communication channel is too low compared to the amount of
data packets generated by the CPU or if the CPU generated packets with an
approximative time stamp.

Overflow count

The information displayed depends on the C-SPY driver you are using.

For some C-SPY drivers, this information is not displayed or the value is always
zZero.

For other C-SPY drivers, the number represents the amount of overflows in the
communication channel which can cause logs to be lost. If this happens, it
indicates that logs might be incomplete. To solve this, make sure not to use all
C-SPY log features simultaneously or check used bandwidth for the
communication channel.

Current time|cycles

The information displayed depends on the C-SPY driver you are using.
For some C-SPY drivers, the value is always zero or not visible at all.

For other C-SPY drivers, the number represents the current time or cycles—the
number of cycles or the execution time since the start of execution.

This context menu is available:

v

v

Enable
Clear

Save to File...

Show Time

Show Cycles

These commands are available:

Enable

Clear

Enables the logging system. The system will log information also when the
window is closed.

Deletes the log information. Note that this will happen also when you reset the
debugger.
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Save to File
Displays a standard file selection dialog box where you can select the
destination file for the log information. The entries in the log file are separated
by TaB and LF characters. An X in the Approx column indicates that the
timestamp is an approximation.

Show Time
Displays the Time column.
If the Time column is displayed by default in the C-SPY driver you are using,
this menu command is not available.

Show Cycles
Displays the Cycles column.

If the Cycles column is not supported in the C-SPY driver you are using, this
menu command is not available.

Timeline window—Events graph

The Timeline window is available from the C-SPY driver menu during a debug session.

[ Cwerflow l
r."
/ x
J/  OFF
— oFF
T T T T
0x19 me |/ 019 0x19
1 1 1 1
0.55 / 1.0s 1.5s 2.0s 2 5s 3 0s
7 m ] b

[ Commaon time axis

This window displays trace data represented as different graphs, in relation to a shared
time axis.

277



Reference information on application timeline

278

Requirements

The Events graph displays the events produced when the execution passes specific
positions in your application code.

Note: There is a limit on the number of saved logs. When this limit is exceeded, the
oldest entries in the buffer are erased.

One of these alternatives:

o The C-SPY I-jet/JTAGijet driver and an I-jet debug probe

o The C-SPY J-Link/J-Trace driver. For the J-Trace debug probe, event logging is
very limited when ETM trace is enabled.

o The C-SPY ST-LINK driver
o The C-SPY TI XDS driver.

Display area for the Events graph

C-SPY® Debugging Guide
for Arm

Where:

o The label area at the left end of the graph displays the name of the channel.

o For each channel, there will be a vertical line that indicates when the event occurred.
Optionally, you can choose to display the event value that was passed with the
event.

o The graph can be displayed in different styles: as a thin line between consecutive
logs, as a rectangle for every log (optionally color-filled), or as vertical bars.

o A red vertical line indicates overflow, which means that the communication channel
failed to transmit all data logs from the target system.

At the bottom of the window, there is a shared time axis that uses seconds or cycles as
the time unit.

See also Getting started using event logging, page 260.
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Context menu

This context menu is available:

MNavigate 3
¥ Auto Scroll
| Zoom 3
Events
v Enable
| Clear
Eval:
Size 2
Style 3
|' ¥ Show Numerical Values
_\-" Signed
Hexadecimal
Go to Source
Select Graphs 3
Time Axis Unit 3

These commands are available:

Navigate
Commands for navigating the graph(s). Choose between:

Next moves the selection to the next relevant point in the graph. Shortcut key:
right arrow.

Previous moves the selection backward to the previous relevant point in the
graph. Shortcut key: left arrow.

First moves the selection to the first data entry in the graph. Shortcut key:
Home.

Last moves the selection to the last data entry in the graph. Shortcut key: End.

End moves the selection to the last data in any displayed graph, in other words
the end of the time axis. Shortcut key: Ctrl+End.

Auto Scroll

Toggles automatic scrolling on or off. When on, the most recently collected data
is automatically displayed when you choose Navigate>End.
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Zoom
Commands for zooming the window, in other words, changing the time scale.
Choose between:
Zoom to Selection makes the current selection fit the window. Shortcut key:
Return.
Zoom In zooms in on the time scale. Shortcut key: +
Zoom Out zooms out on the time scale. Shortcut key: —
10ns, 100ns, 1us, etc makes an interval of 10 nanoseconds, 100 nanoseconds, 1
microsecond, respectively, fit the window.
1ms, 10ms, etc makes an interval of 1 millisecond or 10 milliseconds,
respectively, fit the window.
10m, 1h, etc makes an interval of 10 minutes or 1 hour, respectively, fit the
window.
Events
A heading that shows that the Events-specific commands below are available.
Enable
Toggles the display of the graph on or off. If you disable a graph, that graph will
be indicated as OFF in the window. If no data has been collected for a graph, no
data will appear instead of the graph.
Clear
Deletes the log information. Note that this will happen also when you reset the
debugger.
Variable

The name of the channel for which the Events-specific commands below apply.
This menu command is context-sensitive, which means it reflects the channel in
the Events graph you selected in the Timeline window (one of up to four).
Viewing Range
Displays a dialog box, see Viewing Range dialog box, page 288.
Size
Determines the vertical size of the graph; choose between Small, Medium, and
Large.
Style
Selects the style of the graph. Choose between:

Bars, displays a vertical bar for each log
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Columns, displays a column for each log

Levels, displays the graph with a rectangle for each log, optionally color-filled
Linear, displays the graph as a thin line between consecutive logs

Note that all styles are not available for all graphs.

Show Numerical Value
Shows the numerical value of the variable, in addition to the graph.
Signed
Toggles between displaying the selected value as a signed or unsigned number.
Note that this setting also affects the log window.
Hexadecimal
Toggles between displaying the selected value in decimal or hexadecimal

format. Note that this setting also affects the log window.

Go To Source
Displays the corresponding source code in an editor window, if applicable.

Select Graphs
Selects which graphs to be displayed in the Timeline window.

Time Axis Unit

Selects the unit used in the time axis; choose between Seconds and Cycles.

If Cycles is not available, the graphs are based on different clock sources. In that
case you can view cycle values as tooltip information by pointing at the graph
with your mouse pointer.
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Event Log window

Requirements

Display area
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The Event Log window is available from the C-SPY driver menu.

x

Evant Log

Cycles Program Counter cho Chi Ch2 Ch3 =
215162 --- 1

226325 --- Bx2

237438 --- 1

248535 6x00000094 Bx47de
259648 --- 1

278745 --- 8x2

281988 --- 1 |=
384118 --- b

315223 --- Bx2

This window displays the events produced when the execution passes specific positions
in your application code. The Cortex ITM communication channels are used for passing
the events from a running application to the C-SPY Events system.

Note: There is a limit on the number of saved logs. When this limit is exceeded, the
oldest entries in the buffer are erased.

See also Getting started using event logging, page 260.

A Cortex device and one of these alternatives:

The C-SPY I-jet/JTAGjet driver and an I-jet or I-jet Trace in-circuit debugging
probe with an SWD interface between the debug probe and the target system

The C-SPY J-Link/J-Trace driver and a J-Link or J-Trace debug probe with an SWD
interface between the debug probe and the target system

The C-SPY ST-LINK driver and an ST-LINK debug probe with an SWD interface
between the debug probe and the target system

The C-SPY TI XDS driver and a TI XDS debug probe with an SWD interface
between the debug probe and the target system.

Each row in the display area shows the events in these columns:

Cycles

The number of cycles from the start of the execution until the event. This
information is cleared at reset.

If a cycle is displayed in italics, the target system has not been able to collect a
correct time, but instead had to approximate it.
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This column is available when you have selected Show cycles from the context
menu.

Program Counter
An address, which is the content of the pc, that is, the address of the instruction
that performed the memory access.

---, the target system failed to provide the debugger with any information.

Overflow in red, the communication channel failed to transmit all data from the
target system.

ITM1

ITM2

IT™M3

ITM4
The Cortex ITM communication channels for which the events are logged. For
each event, the event value is displayed.

Add a preprocessor macro to your application source code where you want

events to be generated. See Getting started using event logging, page 260.

Context menu

This context menu is available:

E\-" Enable
Clear
Eval:

v | Signed
Hexadecimal

Save to File...

| Show Time
: v | Show Cycles

These commands are available:

Enable

Enables the logging system. The system will log information also when the
window is closed.

Clear

Deletes the log information. Note that this will happen also when you reset the
debugger.
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Variable
The name of the channel for which the Events-specific commands below apply.
This menu command is context-sensitive, which means it reflects the channel in
the Events graph you selected in the Timeline window (one of up to four).

Signed
Toggles between displaying the selected value as a signed or unsigned number.
Note that this setting also affects the log window.

Hexadecimal
Toggles between displaying the selected value in decimal or hexadecimal
format. Note that this setting also affects the log window.

Save to File
Displays a standard file selection dialog box where you can select the
destination file for the log information. The entries in the log file are separated
by TaB and LF characters. An X in the Approx column indicates that the
timestamp is an approximation.

Show Time
Displays the Time column.
If the Time column is displayed by default in the C-SPY driver you are using,
this menu command is not available.

Show Cycles
Displays the Cycles column.

If the Cyecles column is not supported in the C-SPY driver you are using, this
menu command is not available.

Event Log Summary window

Ewent Log Summary

The Event Log Summary window is available from the C-SPY driver menu.

Channel
cho
Chi
Cch2
ch3

Approximative time count: 0
Overflow count: 0
Current time: 6507.580us

C-SPY® Debugging Guide

for Arm

Count | Average Value MinValue Max Value Average Interval MinInterval Max Interval

3 13 13 13 506.726us 444.280us 1189.986us
7 Bx2 Bx2 Bx2 889.368us B8B8.400us B889.6208us
2]

;! Bx47de Bx47de Bx47de
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This window displays a summary of events produced when the execution passes specific
positions in your application code. The Cortex ITM communication channels are used
for passing the events from a running application to the C-SPY Event system.

See also Getting started using event logging, page 260.

Requirements
A Cortex device and one of these alternatives:
o The C-SPY I-jet/JTAGjet driver and an I-jet or I-jet Trace in-circuit debugging
probe with an SWD interface between the debug probe and the target system

o The C-SPY J-Link/J-Trace driver and a J-Link or J-Trace debug probe with an SWD
interface between the debug probe and the target system

o The C-SPY ST-LINK driver and an ST-LINK debug probe with an SWD interface
between the debug probe and the target system

o The C-SPY TI XDS driver and a TI XDS debug probe with an SWD interface
between the debug probe and the target system.

Display area

Each row displays the type and the number of accesses to each location in your
application code in these columns. Summary information is listed at the bottom of the
display area.

Channel

The name of the communication channel for which events are generated.
Count

The number of logged events.
Average Value

The average value of all received event values.
Min Value

The smallest value of all received event values.
Max Value

The largest value of all received event values.
Average Interval

The average time (in cycles) between events.

Min Interval
The shortest time (in cycles) between two events.
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Max Interval

The longest time (in cycles) between two events.

Approximative time count

The information displayed depends on the C-SPY driver you are using.

For some C-SPY drivers, this information is not displayed or the value is always
zero. In this case, all logs have an exact time stamp.

For other C-SPY drivers, a non-zero value is displayed. The value represents the
amount of logs with an approximative time stamp. This might happen if the
bandwidth in the communication channel is too low compared to the amount of
data packets generated by the CPU or if the CPU generated packets with an
approximative time stamp.

Overflow count

The information displayed depends on the C-SPY driver you are using.

For some C-SPY drivers, this information is not displayed or the value is always
zero.

For other C-SPY drivers, the number represents the amount of overflows in the
communication channel which can cause logs to be lost. If this happens, it
indicates that logs might be incomplete. To solve this, make sure not to use all
C-SPY log features simultaneously or check used bandwidth for the
communication channel.

Current time|cycles

The information displayed depends on the C-SPY driver you are using.
For some C-SPY drivers, the value is always zero or not visible at all.

For other C-SPY drivers, the number represents the current time or cycles—the
number of cycles or the execution time since the start of execution.
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Context menu

This context menu is available:

E\-" Enable
Clear
Eval:

v | Signed
Hexadecimal

Save to File...

Show Time

v | Show Cycles

These commands are available:

Enable
Enables the logging system. The system will log information also when the
window is closed.

Clear
Deletes the log information. Note that this will happen also when you reset the
debugger.

Variable
The name of the channel for which the Events-specific commands below apply.
This menu command is context-sensitive, which means it reflects the channel in
the Events graph you selected in the Timeline window (one of up to four).

Signed
Toggles between displaying the selected value as a signed or unsigned number.
Note that this setting also affects the log window.

Hexadecimal
Toggles between displaying the selected value in decimal or hexadecimal
format. Note that this setting also affects the log window.

Save to File
Displays a standard file selection dialog box where you can select the
destination file for the log information. The entries in the log file are separated
by TaB and LF characters. An X in the Approx column indicates that the
timestamp is an approximation.

Show Time
Displays the Time column.

If the Time column is displayed by default in the C-SPY driver you are using,
this menu command is not available.
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Show Cycles
Displays the Cycles column.

If the Cycles column is not supported in the C-SPY driver you are using, this
menu command is not available.

Viewing Range dialog box
The Viewing Range dialog box is available from the context menu that appears when
you right-click in any graph in the Timeline window that uses the linear, levels or
columns style.

Viewing Range P§|

Range for power:
(& Auto {currently 0 - 70)
O Factory (5 - 200)
O Custom

Lowest value: Highest value:

Scale:

O Linear
(%) Logarithmic

[ ok |[ Cancel ]

Use this dialog box to specify the value range, that is, the range for the Y-axis for the
graph.

Requirements

One of these alternatives:

The C-SPY Simulator

The C-SPY I-jet/JTAG;jet driver
The C-SPY J-Link/J-Trace driver
The C-SPY ST-LINK driver

The C-SPY TI XDS driver.

C-SPY® Debugging Guide
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Range for ...
Selects the viewing range for the displayed values:

Auto

Uses the range according to the range of the values that are actually collected,
continuously keeping track of minimum or maximum values. The currently
computed range, if any, is displayed in parentheses. The range is rounded to
reasonably even limits.

Factory

For the Power Log graph: Uses the range according to the properties of the
measuring hardware (only if supported by the product edition you are using).

For the other graphs: Uses the range according to the value range of the variable,
for example 0-65535 for an unsigned 16-bit integer.

Custom

Use the text boxes to specify an explicit range.

Scale

Selects the scale type of the Y-axis:

e Linear

o Logarithmic.
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Profiling

e Introduction to the profiler
e Using the profiler

e Reference information on the profiler

Introduction to the profiler

These topics are covered:

o Reasons for using the profiler
e Briefly about the profiler

o Requirements for using the profiler

REASONS FOR USING THE PROFILER

Function profiling can help you find the functions in your source code where the most
time is spent during execution. You should focus on those functions when optimizing
your code. A simple method of optimizing a function is to compile it using speed
optimization. Alternatively, you can move the data used by the function into more
efficient memory. For detailed information about efficient memory usage, see the /4R
C/C++ Development Guide for Arm.

Alternatively, you can use filtered profiling, which means that you can exclude, for
example, individual functions from being profiled. To profile only a specific part of your
code, you can select a time interval—using the Timeline window—for which C-SPY
produces profiling information.

Instruction profiling can help you fine-tune your code on a very detailed level, especially
for assembler source code. Instruction profiling can also help you to understand where
your compiled C/C++ source code spends most of its time, and perhaps give insight into
how to rewrite it for better performance.

BRIEFLY ABOUT THE PROFILER

Function profiling information is displayed in the Function Profiler window, that is,
timing information for the functions in an application. Profiling must be turned on
explicitly using a button on the window’s toolbar, and will stay enabled until it is turned
off.
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Instruction profiling information is displayed in the Disassembly window, that is, the
number of times each instruction has been executed.

Profiling sources

The profiler can use different mechanisms, or sources, to collect profiling information.
Depending on the available trace source features, one or more of the sources can be used
for profiling:

Trace (calls)

The full instruction trace (ETM trace) is analyzed to determine all function calls and
returns. When the collected instruction sequence is incomplete or discontinuous, as
sometimes happens when using ETM trace, the profiling information is less accurate.

Select this profiling source (or Trace (flat)) to activate ETM trace for code coverage.
Trace (flat) / Sampling

Each instruction in the full instruction trace (ETM trace) or each PC Sample (from

SWO trace) is assigned to a corresponding function or code fragment, without regard
to function calls or returns. This is most useful when the application does not exhibit
normal call/return sequences, such as when you are using an RTOS, or when you are
profiling code which does not have full debug information.

Select this profiling source (or Trace (calls)) to activate ETM trace for code coverage.

Power sampling

Some debug probes support sampling of the power consumption of the development
board, or components on the board. Each sample is associated with a PC sample and
represents the power consumption (actually, the electrical current) for a small time
interval preceding the time of the sample. When the profiler is set to use Power
Sampling, additional columns are displayed in the Profiler window. Each power sample
is associated with a function or code fragment, just as with regular PC Sampling. Note
that this does not imply that all the energy corresponding to a sample can be attributed
to that function or code fragment. The time scales of power samples and instruction
execution are vastly different; during one power measurement, the CPU has typically
executed many thousands of instructions. Power Sampling is a statistics tool.

REQUIREMENTS FOR USING THE PROFILER

The C-SPY simulator support the profiler; there are no specific requirements.



Profiling °

To use the profiler in your hardware debugger system, you need one of these
alternatives:

® An I-jet or I-jet Trace in-circuit debugging probe, a JTAGjet, a J-Link, a J-Trace,
ST-LINK debug probe with an SWD/SWO interface between the probe and the
target system, which must be based on a Cortex-M device

o A JTAGjet-Trace in-circuit debugging probe and an Arm device with ETM trace.
® A J-Trace debug probe and an Arm7/9 or Cortex-M device with ETM trace.

This table lists the C-SPY driver profiling support:

Target system Trace (calls) Trace (flat) Sampling Power
C-SPY simulator Yes Yes — —
CMSIS-DAP Yes Yes — —
I-jet Yes Yes Yes' Yes
I-jet Trace Yes Yes Yes! Yes
JTAGjet/[]TAGjet-Trace  Yes Yes — —
J-Link Yes Yes Yes' —
J-Link Ultra Yes Yes Yes' Yes?
J-Trace Yes Yes Yes' —
GDB Server —_ — — —
ST-LINK — — Yes! —
Tl Stellaris — — — —
TI XDS — — Yes' —
TI MSP-FET — — — Yes

Table 12: C-SPY driver profiling support
1 Only for Cortex-M devices supporting SWO.
2 Requires SWO trace.

Using the profiler

These tasks are covered:

Getting started using the profiler on function level

°
e Analyzing the profiling data

o Getting started using the profiler on instruction level
°

Selecting a time interval for profiling information
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GETTING STARTED USING THE PROFILER ON FUNCTION
LEVEL

To display function profiling information in the Function Profiler window:

Build your application using these options:

Category Setting
C/C++ Compiler Output>Generate debug information
Linker Output>Include debug information in output

Table 13: Project options for enabling the profiler

To set up the profiler for function profiling:

e If youuse ETM trace, make sure that the Cycle accurate tracing option is selected
in the Trace Settings dialog box.

o If you use the SWD/SWO interface, no specific settings are required.

When you have built your application and started C-SPY, choose C-SPY

driver>Function Profiler to open the Function Profiler window, and click the

Enable button to turn on the profiler. Alternatively, choose Enable from the context
menu that is available when you right-click in the Function Profiler window.

Start executing your application to collect the profiling information.

Profiling information is displayed in the Function Profiler window. To sort, click on
the relevant column header.

When you start a new sampling, you can click the Clear button—alternatively, use the
context menu—to clear the data.

ANALYZING THE PROFILING DATA
Here follow some examples of how to analyze the data.

The first figure shows the result of profiling using Source: Trace (calls). The profiler
follows the program flow and detects function entries and exits.
o For the InitFib function, Flat Time 231 is the time spent inside the function itself.

e For the InitFib function, Acc Time 487 is the time spent inside the function itself,
including all functions InitFib calls.

o For the InitFib/GetFib function, Acc Time 256 is the time spent inside GetFib (but
only when called from InitFib), including any functions GetFib calls.
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o Further down in the data, you can find the GetFib function separately and see all of
its subfunctions (in this case none).

mi=]

Function Calls Flat Time  FlatTime (%)  Acc. Time  Acc. Time (%) =
= rnain 1 165 3.58 4356 94 .39
| DoForegroundProcess 10 3704
InitFik 1 487
PutFib 10 3174 68.78 3174 68.78
MextCounter 10 100 A il 7 100 il
= InitFib 1 3D 5.01 187 10.55
fo GetFib 16 (256 )
GetFib 28 4186 9.01 4186 9.01
=  DoForegroundProcess 10 270 5.85 3704 80.26
MextCounter 10
PutFil 10
= <Cther> 0 98.a5
HiE i 1 - —
A=l Source: Trace (calls)
Source: Trace (flat)
L I | »

The second figure shows the result of profiling using Source: Trace (flat). In this case,
the profiler does not follow the program flow, instead the profiler only detects whether
the pC address is within the function scope. For incomplete trace data, the data might
contain minor errors.
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For the InitFib function, Flat Time 231 is the time (number of hits) spent inside the
function itself.

X
FCSamp... PCSamples .. -

<ldle> 0 0.00

<Mo function> 5 0.21

DoForegroundProcess 20 3.85

GetFib 260 11.12

InitFiky 141 5.03 =

MextCounter &0 2.57

PutFib 230 9.84

__crain, Tmain 4 0.17

TAAn

__dwrite v Enable

__exit -

__iar_close_ttio ear

_!ar_copy_.ln.ltS Filtering 3

__iar_data_init3

__iar_get_ttio Source; alls’

_iar_lookup_tich @e: Trace (flat)

__iar_sh_stdout [ -

| 4 I 2

To secure valid data when using a debug probe, make sure to use the maximum trace
buffer size and set a breakpoint in your code to stop the execution before the buffer is
full.

GETTING STARTED USING THE PROFILER ON INSTRUCTION
LEVEL

To display instruction profiling information in the Disassembly window:

When you have built your application and started C-SPY, choose View>Disassembly
to open the Disassembly window, and choose Instruction Profiling>Enable from the
context menu that is available when you right-click in the left-hand margin of the
Disassembly window.

Make sure that the Show command on the context menu is selected, to display the
profiling information.

Start executing your application to collect the profiling information.
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4 When the execution stops, for instance because the program exit is reached or a
breakpoint is triggered, you can view instruction level profiling information in the
left-hand margin of the window.

Disassembly x
Disassembly i
__enable_interrupt() ; |
0xB0002ae: Oxb662 CPSIE i
0xB000200: Oxe00l B.N 0xB00020bE
DoForegroundProcess() ;
0xB0002k2: OxEf7ff Oxffed EL DoForegroundProces
while (callCount = MAX FIE)
0xB0002b6: 0x4803 LOR.N RO, [PC, #0xc]
0xB000208 : 0xG800 LOR RO, [RO]
0xB0002ba: O0x280a CMP RO, #10
0xB0002bc: Oxd3f9 BCC.N 0xB000202
0xB0002be: Oxbdol POF {RO, PC}
0xB0002c0: O0x40013804 DC32 USART1_DR &
'l 1 +

For each instruction, the number of times it has been executed is displayed.

Instruction profiling attempts to use the same source as the function profiler. If the
function profiler is not on, the instruction profiler will try to use first trace and then PC
sampling as source. You can change the source to be used from the context menu that is
available in the Function Profiler window.

SELECTING A TIME INTERVAL FOR PROFILING
INFORMATION

Normally, the profiler computes its information from all PC samples it receives,
accumulating more and more information until you explicitly clear the profiling
information. However, you can choose a time interval for which the profiler computes
the PC samples. This function is supported by the I-jet and I-jet Trace in-circuit
debugging probes, the JTAGjet debug probe, the J-Link probe, the J-Trace probe, the
ST-LINK probe, and the TI XDS probe.

To select a time interval:
I Choose Function Profiler from the C-SPY driver menu.

2  In the Function Profiler window, right-click and choose Source: Sampling from the
context menu.

Execute your application to collect samples.

4 Choose C-SPY driver>Timeline.
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5 In the Timeline window, click and drag to select a time interval.

Interrupts OFF

1. 1.

2= .=

A selected time interval l
]

—
il ||m|||||||||||“HHH““H'H HH HHHH
s 0.2= 0. 4= 0 6= R 1.0s

N

Linear 300

6 1In the selected time interval, right-click and choose Profile Selection from the context
menu.

The Function Profiler window now displays profiling information for the selected time

interval.
2o 5| | E| [lr 160000.000us - 704000.000us
Function FC Samples FC Samples (%) Fower Samples Energy (%) A
GetButtons() 791 33.10 9 30.82 19
Dyl D0usfvoic %) 463 19.37 7 15.38 12
GLCD_SPI_TranserByte(lntd.. 353 4 3.3z 1z
memcrmp 325 4 14 .64 21
I FTN A T
= GLCD_Backlight(IntdLh 108 2 677 19
= GLCD_SendCmd(GLCD_Cm.. 43 i 0.a0 -
& GLCD_SPI_SendBlockiplntd... 19 2 4.00 11
5 GLCD_SetWindow(lnt32L, Int.. 0 1] 0.00 -
E GLCD_SetReset(Boolean) 0 0 0.00 -
'S

el 7 Click the Full/Time-interval profiling button to toggle the Full profiling view.

Reference information on the profiler

Reference information about:
e Function Profiler window, page 299
See also:

e Disassembly window, page 78
® ETM Trace Settings dialog box (J-Link/J-Trace), page 214
® ETM Trace Settings dialog box, page 212
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o SWO Trace Window Settings dialog box, page 216
o SWO Configuration dialog box, page 218

Function Profiler window

The Function Profiler window is available from the C-SPY driver menu.

Function Profiler *®
©cEE
Function Calls Flat Time  FlatTime (%)  Acc. Time  Acc. Time (%) i
+# DoForegroundFrocess 49 5770 31.14 7198 38.84
GetFib 0 0 0.00 0 0.00
InitFik 0 0 0.00 0 0.00 |
Initlart 0 0 0.00 0 0.00 3
PutFib 4 1332 7.19 1332 7.19
# UanReceiveHandler 4 96 0.52 1428 et
friin 0 0 0.00 0 0.00

This window displays function profiling information.

When Trace(flat) is selected, a checkbox appears on each line in the left-side margin of
the window. Use these checkboxes to include or exclude lines from the profiling.
Excluded lines are dimmed but not removed.

See also Using the profiler, page 293.

Requirements

One of these alternatives:

The C-SPY Simulator

The C-SPY I-jet/JTAG;jet driver
The C-SPY J-Link/J-Trace driver
The C-SPY CMSIS-DAP driver
The C-SPY ST-LINK driver

The C-SPY TI XDS driver.

Toolbar

The toolbar contains:
m Enable/Disable

Enables or disables the profiler.
ﬁl Clear
Clears all profiling data.
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E Save

Opens a standard Save As dialog box where you can save the contents of the
window to a file, with tab-separated columns. Only non-expanded rows are
included in the list file.

|E Graphical view
= Overlays the values in the percentage columns with a graphical bar.

Progress bar

Displays a backlog of profiling data that is still being processed. If the rate of
incoming data is higher than the rate of the profiler processing the data, a
backlog is accumulated. The progress bar indicates that the profiler is still
processing data, but also approximately how far the profiler has come in the
process. Note that because the profiler consumes data at a certain rate and the
target system supplies data at another rate, the amount of data remaining to be
processed can both increase and decrease. The progress bar can grow and shrink
accordingly.

tosl Time-interval mode

Toggles between profiling a selected time interval or full profiling. This toolbar
button is only available if PC Sampling is supported by the debug probe.

For information about which views that are supported in the C-SPY driver you
are using, see Requirements for using the profiler, page 292.

Status field

Displays the range of the selected time interval, in other words, the profiled
selection. This field is yellow when Time-interval profiling mode is enabled.
This field is only available if PC Sampling is supported by the debug probe
(SWO trace).

For information about which views that are supported in the C-SPY driver you
are using, see Requirements for using the profiler, page 292.

Display area

The content in the display area depends on which source that is used for the profiling
information:

o For the Trace (calls) source, the display area contains one line for each function
compiled with debug information enabled. When some profiling information has
been collected, it is possible to expand rows of functions that have called other
functions. The child items for a given function list all the functions that have been
called by the parent function and the corresponding statistics.

o For the Sampling and Trace (flat) sources, the display area contains one line for
each C function of your application, but also lines for sections of code from the

C-SPY® Debugging Guide
300 for Arm



Profiling °

runtime library or from other code without debug information, denoted only by the
corresponding assembler labels. Each executed pC address from trace data is treated
as a separate sample and is associated with the corresponding line in the Profiling
window. Each line contains a count of those samples.

For information about which views that are supported in the C-SPY driver you are using,
see Requirements for using the profiler, page 292.

More specifically, the display area provides information in these columns:

Function (All sources)
The name of the profiled C function.

For Sampling source, also sections of code from the runtime library or from
other code without debug information, denoted only by the corresponding
assembler labels, is displayed.

Calls (Trace (calls))
The number of times the function has been called.

Flat time (Trace (calls))

The time expressed in cycles spent inside the function.

Flat time (%) (Trace (calls))
Flat time expressed as a percentage of the total time.

Acc. time (Trace (calls))
The time expressed in cycles spent inside the function and everything called by
the function.
Acc. time (%) (Trace (calls))
Accumulated time expressed as a percentage of the total time.
PC Samples (Trace (flat) and Sampling)
The number of PC samples associated with the function.
PC Samples (%) (Trace (flat) and Sampling)
The number of PC samples associated with the function as a percentage of the
total number of samples.
Power Samples (Power Sampling)
The number of power samples associated with that function.
Energy (%) (Power Sampling)

The accumulated value of all measurements associated with that function,
expressed as a percentage of all measurements.
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Avg Current [mA] (Power Sampling)

The average measured value for all samples associated with that function.
Min Current [mA] (Power Sampling)

The minimum measured value for all samples associated with that function.

Max Current [mA] (Power Sampling)
The maximum measured value for all samples associated with that function.

This context menu is available:
v Enable

Clear

v Source: Trace (calls)

Source: Trace (flat)

Save to File...

Show Source

The contents of this menu depend on the C-SPY driver you are using.
These commands are available:

Enable

Enables the profiler. The system will collect information also when the window
is closed.

Clear
Clears all profiling data.

Filtering

Selects which part of your code to profile. Choose between:
Check All—Excludes all lines from the profiling.
Uncheck All—Includes all lines in the profiling.
Load—Reads all excluded lines from a saved file.

Save—Saves all excluded lines to a file. Typically, this can be useful if you are
a group of engineers and want to share sets of exclusions.

These commands are only available when using one of the modes Trace (flat) or
Sampling.
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Source*

Selects which source to be used for the profiling information. See also Profiling
sources, page 292. Choose between:

Sampling—the instruction count for instruction profiling represents the number
of samples for each instruction.

Trace (calls)—the instruction count for instruction profiling is only as complete
as the collected trace data.

Trace (flat)—the instruction count for instruction profiling is only as complete
as the collected trace data.
Power Sampling

Toggles power sampling information on or off. This command is supported by
the I-jet and I-jet Trace in-circuit debugging probes, the JTAGjet, the J-Link, and
the J-Link Ultra debug probes.

Save to File
Saves all profiling data to a file.

Show Source

Opens the editor window (if not already opened) and highlights the selected
source line.

* The available sources depend on the C-SPY driver you are using.
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e Introduction to code coverage

e Reference information on code coverage.

Introduction to code coverage

These topics are covered:

o Reasons for using code coverage
e Briefly about code coverage

o Requirements and restrictions for using code coverage.

REASONS FOR USING CODE COVERAGE

The code coverage functionality is useful when you design your test procedure to verify
whether all parts of the code have been executed. It also helps you identify parts of your
code that are not reachable.

BRIEFLY ABOUT CODE COVERAGE

The Code Coverage window reports the status of the current code coverage analysis for
C code. For every program, module, and function, the analysis shows the percentage of
code that has been executed since code coverage was turned on up to the point where the
application has stopped. In addition, all statements that have not been executed are
listed. The analysis will continue until turned off.

Note: Assembler code is not covered by the code coverage analysis. To view assembler
code, use the Disassembly window.

REQUIREMENTS AND RESTRICTIONS FOR USING CODE
COVERAGE

Code coverage is supported by the C-SPY Simulator and there are no specific
requirements or restrictions.

To use code coverage in your hardware debugger system, consider these requirements
and restrictions:

o When SWO trace is used: code coverage information is based on trace samples
only. This means that a function must be executed several times before 100% code
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coverage is reached. Also, no code coverage information is collected while single

stepping.

o When ETM trace is used: the only restriction is the size of the trace buffer. For
efficient use of the trace buffer, you can limit the trace data collection using the trace

start and trace stop breakpoints.

Reference information on code coverage

Reference information about:
o Code Coverage window, page 306.
See also Single stepping, page 72.

Code Coverage window

C-SPY® Debugging Guide
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Code Coverage

@[c](c/e)(&](&)

The Code Coverage window is available from the View menu.

x

—§ SirmulatingSerialPortinput 50.00%%
=% SerialPortinterrupt 50.00%
. @ DoForegroundPracess 100.00%
4 |nitlart 0.00%
¢ UartReceiveHandler 75.00%
< 1-1:65 addr(IxB0002A0)
- @9 main 2857%
—; Ltilities 50.00%
+0 GetFib 0.00%
+0 InitFik 0.00%
=% PutFib 91.67%

This window reports the status of the current code coverage analysis. For every program,
module, and function, the analysis shows the percentage of code that has been executed
since code coverage was turned on up to the point where the application has stopped. In

addition, all statements that have not been executed are listed. The analysis will continue
until turned off.

An asterisk (*) in the title bar indicates that C-SPY has continued to execute, and that
the Code Coverage window must be refreshed because the displayed information is no
longer up to date. To update the information, use the Refresh button.
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Display area

Code coverage ___4

To get started using code coverage:

Before using the code coverage functionality you must build your application using
these options:

Category Setting

C/C++ Compiler Output>Generate debug information

Linker Output>Include debug information in output
Debugger Plugins>Code Coverage

Table 14: Project options for enabling code coverage

After you have built your application and started C-SPY, to activate ETM trace for
code coverage, choose C-SPY driver>Function Profiler to open the Function
Profiler window. Right-click in the window and choose Trace (flat) or Trace (calls)
from the context menu. Then choose View>Code Coverage to open the Code
Coverage window.

Click the Activate button, alternatively choose Activate from the context menu, to
switch on code coverage.

Start the execution. When the execution stops, for instance because the program exit is
reached or a breakpoint is triggered, click the Refresh button to view the code
coverage information.

One of these alternatives:

The C-SPY Simulator

The C-SPY I-jet/JTAGjet driver
The C-SPY J-Link/J-Trace driver
The C-SPY CMSIS-DAP driver
The C-SPY ST-LINK driver

The C-SPY TI XDS driver.

The code coverage information is displayed in a tree structure, showing the program,
module, function, and statement levels. The window displays only source code that was
compiled with debug information. Thus, startup code, exit code, and library code is not
displayed in the window. Furthermore, coverage information for statements in inlined
functions is not displayed. Only the statement containing the inlined function call is
marked as executed. The plus sign and minus sign icons allow you to expand and
collapse the structure.
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o

ﬁl Clear

These icons give you an overview of the current status on all levels:

Red diamond Signifies that 0% of the modules or functions has been
executed.

Green diamond Signifies that 100% of the modules or functions has been
executed.

Red and green diamond  Signifies that some of the modules or functions have been
executed.

Yellow diamond Signifies a statement that has not been executed.

The percentage displayed at the end of every program, module, and function line shows
the amount of statements that has been covered so far, that is, the number of executed
statements divided with the total number of statements.

For statements that have not been executed (yellow diamond), the information displayed
is the column number range and the row number of the statement in the source window,
followed by the address of the step point:

<column_start>-<column_end>:row address.

A statement is considered to be executed when one of its instructions has been executed.
When a statement has been executed, it is removed from the window and the percentage
is increased correspondingly.

Double-clicking a statement or a function in the Code Coverage window displays that
statement or function as the current position in the editor window, which becomes the
active window. Double-clicking a module on the program level expands or collapses the
tree structure.

This context menu is available:
v Activate
Clear
Refresh
Auko-refresh

Save As...

These commands are available:

Activate
Switches code coverage on and off during execution.

Clears the code coverage information. All step points are marked as not
executed.
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c Refresh

Updates the code coverage information and refreshes the window. All step
points that have been executed since the last refresh are removed from the tree.

g Auto-refresh

Toggles the automatic reload of code coverage information on and off. When
turned on, the code coverage information is reloaded automatically when
C-SPY stops at a breakpoint, at a step point, and at program exit.

Save As
Saves the current code coverage result in a text file.
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Power debugging

e Introduction to power debugging
e Optimizing your source code for power consumption
e Debugging in the power domain

e Reference information on power debugging.

Introduction to power debugging

These topics are covered:

e Reasons for using power debugging
e Briefly about power debugging

o Requirements and restrictions for power debugging.

REASONS FOR USING POWER DEBUGGING

Long battery lifetime is a very important factor for many embedded systems in almost
any market segment: medical, consumer electronics, home automation, etc. The power
consumption in these systems does not only depend on the hardware design, but also on
how the hardware is used. The system software controls how it is used.

For examples of when power debugging can be useful, see Optimizing your source code
for power consumption, page 313.

BRIEFLY ABOUT POWER DEBUGGING

Power debugging is based on the ability to sample the power consumption—more
precisely, the power being consumed by the CPU and the peripheral units—and
correlate each sample with the application’s instruction sequence and hence with the
source code and various events in the program execution.

Traditionally, the main software design goal has been to use as little memory as possible.
However, by correlating your application’s power consumption with its source code you
can get insight into how the software affects the power consumption, and thus how it can
be minimized.
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Measuring power consumption

The debug probe measures the voltage drop across a small resistor in series with the
supply power to the device. The voltage drop is measured by a differential amplifier and
then sampled by an AD converter.

The TI MSP-FET and TI XDS 110 debug probes use EnergyTraceTM Technology
support to measure the power supplied to a target microcontroller. A software-controlled
DC-DC converter generates the target power supply. The time density of the DC-DC
converter charge pulses equals the power consumption of the target microcontroller. A
built-in on-the-fly calibration circuit defines the energy equivalent of a single DC-DC
charge pulse.

Power debugging using C-SPY

C-SPY provides an interface for configuring your power debugging and a set of
windows for viewing the power values:

o The Power Setup window is where you can specify a threshold and an action to be
executed when the threshold is reached. This means that you can enable or disable
the power measurement or you can stop the application’s execution and determine
the cause of unexpected power values.

o The Power Log window displays all logged power values. This window can be used
for finding peaks in the power logging and because the values are correlated with
the executed code, you can double-click on a value in the Power Log window to get
the corresponding code. The precision depends on the frequency of the samples, but
there is a good chance that you find the source code sequence that caused the peak.

o The Power graph in the Timeline window displays power values on a time scale.
This provides a convenient way of viewing the power consumption in relation to the
other information displayed in the window. The Timeline window is correlated to
both the Power Log window, the source code window, and the Disassembly
window, which means you are just a double-click away from the source code that
corresponds to the values you see on the timeline.

o The Function Profiler window combines the function profiling with the power
logging to display the power consumption per function—power profiling. You will
get a list of values per function and also the average values together with max and
min values. Thus, you will find the regions in the application that you should focus
when optimizing for power consumption.
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REQUIREMENTS AND RESTRICTIONS FOR POWER
DEBUGGING

To use the features in C-SPY for power debugging, you need one of these:

o An I-jet or I-jet Trace in-circuit debugging probe. Note that power debugging is not
possible when using I-jet Trace with ETM.

For more accurate power debugging, you can connect the I-scope probe between the
I-jet/I-jet Trace probe and the target board. I-scope adds detailed current and voltage
measurement capability.

o A J-Link Ultra debug probe and a Cortex-M device with SWO.

o A TIMSP-FET debug probe, featuring the EnergyTraceTM technology provided by
Texas Instruments, and a TI MSP-FET device. The probe outputs voltage, current,
and energy information.

e A TI XDS110 debug probe, featuring the EnergyTraceTM technology provided by

Texas Instruments, and a Texas Instruments device. The probe outputs voltage,
current, and energy information.

Optimizing your source code for power consumption

This section gives some examples where power debugging can be useful and thus
hopefully help you identify source code constructions that can be optimized for low
power consumption.

These topics are covered:

Waiting for device status

Software delays

DMA versus polled I/O

Low-power mode diagnostics

CPU frequency

Detecting mistakenly unattended peripherals
Peripheral units in an event-driven system

Finding conflicting hardware setups

Analog interference

WAITING FOR DEVICE STATUS

One common construction that could cause unnecessary power consumption is to use a
poll loop for waiting for a status change of, for example a peripheral device.

313



Optimizing your source code for power consumption

Constructions like this example execute without interruption until the status value
changes into the expected state.

while (USBD_GetState() < USBD_STATE_CONFIGURED) ;
while ((BASE_PMC->PMC_SR & MC_MCKRDY) != PMC_MCKRDY) ;

To minimize power consumption, rewrite polling of a device status change to use
interrupts if possible, or a timer interrupt so that the CPU can sleep between the polls.

SOFTWARE DELAYS

A software delay might be implemented as a for or while loop like for example:

i = 10000; /* A software delay */
do i--;
while (i != 0);

Such software delays will keep the CPU busy with executing instructions performing
nothing except to make the time go by. Time delays are much better implemented using
a hardware timer. The timer interrupt is set up and after that, the CPU goes down into a
low power mode until it is awakened by the interrupt.

DMA VERSUS POLLED 1I/O

DMA has traditionally been used for increasing transfer speed. For MCUs there are
plenty of DMA techniques to increase flexibility, speed, and to lower power
consumption. Sometimes, CPUs can even be put into sleep mode during the DMA
transfer. Power debugging lets you experiment and see directly in the debugger what
effects these DMA techniques will have on power consumption compared to a
traditional CPU-driven polled solution.

LOW-POWER MODE DIAGNOSTICS

Many embedded applications spend most of their time waiting for something to happen:
receiving data on a serial port, watching an I/O pin change state, or waiting for a time
delay to expire. If the processor is still running at full speed when it is idle, battery life
is consumed while very little is being accomplished. So in many applications, the core
is only active during a very small amount of the total time, and by placing it in a
low-power mode during the idle time, the battery life can be extended considerably.

A good approach is to have a task-oriented design and to use an RTOS. In a task-oriented
design, a task can be defined with the lowest priority, and it will only execute when there
is no other task that needs to be executed. This idle task is the perfect place to implement
power management. In practice, every time the idle task is activated, it sets the core into
a low-power mode. Many microprocessors and other silicon devices have a number of
different low-power modes, in which different parts of the core can be turned off when
they are not needed. The oscillator can for example either be turned off or switched to a
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lower frequency. In addition, individual peripheral units, timers, and the CPU can be
stopped. The different low-power modes have different power consumption based on
which peripherals are left turned on. A power debugging tool can be very useful when
experimenting with different low-level modes.

You can use the Function profiler in C-SPY to compare power measurements for the task
or function that sets the system in a low-power mode when different low-power modes
are used. Both the mean value and the percentage of the total power consumption can be
useful in the comparison.

CPU FREQUENCY

Power consumption in a CMOS MCU is theoretically given by the formula:
P=f* U2 * k

where £ is the clock frequency, Uis the supply voltage, and k is a constant.

Power debugging lets you verify the power consumption as a factor of the clock
frequency. A system that spends very little time in sleep mode at 50 MHz is expected to
spend 50% of the time in sleep mode when running at 100 MHz. You can use the power
data collected in C-SPY to verify the expected behavior, and if there is a non-linear
dependency on the clock frequency, make sure to choose the operating frequency that
gives the lowest power consumption.

DETECTING MISTAKENLY UNATTENDED PERIPHERALS

Peripheral units can consume much power even when they are not actively in use. If you
are designing for low power, it is important that you disable the peripheral units and not
just leave them unattended when they are not in use. But for different reasons, a
peripheral unit can be left with its power supply on; it can be a careful and correct design
decision, or it can be an inadequate design or just a mistake. If not the first case, then
more power than expected will be consumed by your application. This will be easily
revealed by the Power graph in the Timeline window. Double-clicking in the Timeline
window where the power consumption is unexpectedly high will take you to the
corresponding source code and disassembly code. In many cases, it is enough to disable
the peripheral unit when it is inactive, for example by turning off its clock which in most
cases will shut down its power consumption completely.

However, there are some cases where clock gating will not be enough. Analog
peripherals like converters or comparators can consume a substantial amount of power
even when the clock is turned off. The Timeline window will reveal that turning off the
clock was not enough and that you need to turn off the peripheral completely.
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PERIPHERAL UNITS IN AN EVENT-DRIVEN SYSTEM

Consider a system where one task uses an analog comparator while executing, but the
task is suspended by a higher-priority task. Ideally, the comparator should be turned off
when the task is suspended and then turned on again once the task is resumed. This
would minimize the power being consumed during the execution of the high-priority
task.

This is a schematic diagram of the power consumption of an assumed event-driven
system where the system at the point of time t; is in an inactive mode and the current is
Iof

Power consumption

Time

v

% LR, 5} 5 4

Atty, the system is activated whereby the current rises to I; which is the system’s power
consumption in active mode when at least one peripheral device turned on, causing the
current to rise to I. At t,, the execution becomes suspended by an interrupt which is
handled with high priority. Peripheral devices that were already active are not turned off,
although the task with higher priority is not using them. Instead, more peripheral devices
are activated by the new task, resulting in an increased current I, between t, and t; where
control is handed back to the task with lower priority.

The functionality of the system could be excellent and it can be optimized in terms of
speed and code size. But also in the power domain, more optimizations can be made.
The shadowed area represents the energy that could have been saved if the peripheral
devices that are not used between t, and t3 had been turned off, or if the priorities of the
two tasks had been changed.

If you use the Timeline window, you can make a closer examination and identify that
unused peripheral devices were activated and consumed power for a longer period than
necessary. Naturally, you must consider whether it is worth it to spend extra clock cycles
to turn peripheral devices on and off in a situation like in the example.
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FINDING CONFLICTING HARDWARE SETUPS

To avoid floating inputs, it is a common design practice to connect unused MCU I/O
pins to ground. If your source code by mistake configures one of the grounded I/O pins
as a logical 1 output, a high current might be drained on that pin. This high unexpected
current is easily observed by reading the current value from the Power graph in the
Timeline window. It is also possible to find the corresponding erratic initialization code
by looking at the Power graph at application startup.

A similar situation arises if an I/O pin is designed to be an input and is driven by an
external circuit, but your code incorrectly configures the input pin as output.

ANALOG INTERFERENCE

When mixing analog and digital circuits on the same board, the board layout and routing
can affect the analog noise levels. To ensure accurate sampling of low-level analog
signals, it is important to keep noise levels low. Obtaining a well-mixed signal design
requires careful hardware considerations. Your software design can also affect the
quality of the analog measurements.

Performing a lot of I/O activity at the same time as sampling analog signals causes many
digital lines to toggle state at the same time, which might introduce extra noise into the
AD converter.

Noise spike |

Umin=—3.12l)

Power debugging will help you investigate interference from digital and power supply
lines into the analog parts. Power spikes in the vicinity of AD conversions could be the
source of noise and should be investigated. All data presented in the Timeline window
is correlated to the executed code. Simply double-clicking on a suspicious power value
will bring up the corresponding C source code.
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These tasks are covered:

o Displaying a power profile and analyzing the result
o Detecting unexpected power usage during application execution

o Changing the graph resolution.
See also:

o Timeline window—Power graph, page 327

o Selecting a time interval for profiling information, page 297.
DISPLAYING A POWER PROFILE AND ANALYZING THE
RESULT

To view the power profile:

Choose C-SPY driver>SWO Configuration to open the SWO Configuration dialog
box. Make sure the CPU clock option is set to the same value as the CPU clock value
set by your application. This is necessary to set the SWO clock and to obtain a correct
data transfer to the debug probe.

If you are using the C-SPY simulator, you can ignore this step.
This step requires a Cortex-M3/M4 device.
Start the debugger.

Choose C-SPY driver>Power Log Setup. In the ID column, make sure to select the
alternatives for which you want to enable power logging.

Choose C-SPY driver>Timeline to open the Timeline window.

Right-click in the graph area and choose Enable from the context menu to enable the
power graph you want to view.

Choose C-SPY driver>Power Log to open the Power Log window.

Optionally, if you want to correlate power values to specific interrupts or variables,
right-click in the Interrupts or Data Logs graph area, respectively, and choose Enable
from the context menu.

For variables, you also need to set a Data Log breakpoint for each variable you want a
graphical representation of in the Timeline window. See Data Log breakpoints dialog
box (C-SPY hardware drivers), page 146.

This step requires a Cortex-M3/M4 device.
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8 Optionally, before you start executing your application you can configure the viewing
range of the Y-axis for the power graph. See Viewing Range dialog box, page 288.

9 Click Go on the toolbar to start executing your application. In the Power Log window,
all power values are displayed. In the Timeline window, you will see a graphical
representation of the power values, and, if you are using a Cortex-M3/M4 device, of
the data and interrupt logs if you enabled these graphs. For information about how to
navigate on the graph, see Navigating in the graphs, page 257.

10 To analyze power consumption (requires a Cortex-M3/M4 device):

o Double-click on an interesting power value to highlight the corresponding source
code in the editor window and in the Disassembly window. The corresponding log
is highlighted in the Power Log window. For examples of when this can be useful,
see Optimizing your source code for power consumption, page 313.

e You can identify peripheral units to disable if they are not used. You can detect this
by analyzing the power graph in combination with the other graphs in the Timeline
window. See also Detecting mistakenly unattended peripherals, page 315.

e For a specific interrupt, you can see whether the power consumption is changed in
an unexpected way after the interrupt exits, for example, if the interrupt enables a
power-intensive unit and does not turn it off before exit.

e For function profiling, see Selecting a time interval for profiling information, page
297.

DETECTING UNEXPECTED POWER USAGE DURING
APPLICATION EXECUTION

To detect unexpected power consumption:

I Choose C-SPY driver>SWO Configuration to open the SWO Configuration dialog
box. Make sure these settings are used:

o CPU clock must be set to the same value as the CPU clock value set by your
application. This is necessary to set the SWO clock and to obtain a correct data
transfer to the debug probe.

This step requires a Cortex-M3/M4 device.
2 Choose C-SPY driver>Power Log Setup to open the Power Setup window.

3 In the Power Setup window, specify a threshold value and the appropriate action, for
example Log All and Halt CPU Above Threshold.

4 Choose C-SPY driver>Power Log to open the Power Log window. If you
continuously want to save the power values to a file, choose Choose Live Log File
from the context menu. In this case you also need to choose Enable Live Logging to.

5 Start the execution.
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When the power consumption passes the threshold value, the execution will stop and
perform the action you specified.

If you saved your logged power values to a file, you can open that file in an external tool
for further analysis.

CHANGING THE GRAPH RESOLUTION

To change the resolution of a Power graph in the Timeline window:

I In the Timeline window, select the Power graph, right-click and choose Open Setup
Window to open the Power Log Setup window.

2 From the context menu in the Power Log Setup window, choose a suitable unit of
measurement.

3 In the Timeline window, select the Power graph, right-click and choose Viewing
Range from the context menu.

4 In the Viewing Range dialog box, select Custom and specify range values in the
Lowest value and the Highest value text boxes. Click OK.

5 The graph is automatically updated accordingly.

Reference information on power debugging

Reference information about:

Power Log Setup window, page 321
Power Log window, page 323.

Timeline window—Power graph, page 327.
State Log window, page 328.

State Log Summary window, page 330.

Timeline window—State Log graph, page 333.
See also:

o Trace window, page 222

o The application timeline, page 253
e Viewing Range dialog box, page 288
°

Function Profiler window, page 299.
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Power Log Setup window
The Power Log Setup window is available from the C-SPY driver menu during a debug

session.
Power Log Setup @
Sampling Frequency Max [Hz]: 200000 Wanted [Hz]: 10000 - Actual [Hz]: 200000
D MName Shunt [Chrn] Threshaold Unit Action
IT... [TrgPwr — 0 uA Log All

Use this window to configure the power measurement.

Note: To enable power logging, choose Enable from the context menu in the Power
Log window or from the context menu in the power graph in the Timeline window.

See also Debugging in the power domain, page 318.

Requirements
A debug probe with support for power debugging and one of these alternatives:
o The C-SPY I-jet/JTAGjet driver
o The C-SPY J-Link/J-Trace driver
o The C-SPY TI MSP-FET driver
o The C-SPY TI XDS driver.
Display area
This area contains these columns:
ID

A unique string that identifies the measurement channel in the probe. Select the
check box to activate the channel. If the check box is deselected, logs will not
be generated for that channel.

Name

Specity a user-defined name.

Shunt [Ohm]

This column always contains -- (two dashes) for all debug probes except
I-scope.

For I-scope, specity the resistance of the shunt.
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Threshold
Specity a threshold value in the selected unit. The action you specity will be
executed when the threshold value is reached.

Unit
Displays the selected unit for power. You can choose a unit from the context
menu.

Action

Displays the selected action for the measurement channel. Choose between:

Log All

Log Above Threshold

Log Below Threshold

Log All and Halt CPU Above Threshold
Log All and Halt CPU Below Threshold

Context menu

This context menu is available:

nA
uA
W mA

Log All
Log Above Threshold
Log Below Threshold
v Log All and Halt CPU Above Threshold
Log All and Halt CPU Below Threshold

These commands are available:

nA, uA, mA
Selects the unit for the power display. These alternatives are available for
channels that measure current.

uV, mVy, vV
Selects the unit for power display. These alternatives are available for channels
that measure voltage.

uWs, mWs, Ws

Selects the unit for power display. These alternatives are available for channels
that measure energy.

Log All
Logs all values.

C-SPY® Debugging Guide
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Log Above Threshold
Logs all values above the threshold.

Log Below Threshold
Logs all values below the threshold.

Log All and Halt CPU Above Threshold

Logs all values. If a logged value exceeds the threshold, execution is stopped.
This might take a few execution cycles.

Log All and Halt CPU Below Threshold

Logs all values. If alogged value goes below the threshold, execution is stopped.
This might take a few execution cycles.

Power Log window

The Power Log window is available from the C-SPY driver menu during a debug

session.
Power Log @
Time Program Counter ITrgPwr [uA] T
4= 5R2227 . 729%u= 0=x080019BS8 16463
4= 562483 64b6us 0=x080019BS8 16463
4= 562739 . 667us  0=x080019B2 16463
4= 562995 688us 0=x0B80019B4 16463
4= 563251 604us O0=x080019CC 27384
4= 5A3507 . 625us  0=x080019CC 27384 m

This window displays collected power values.

A row with only Time/Cycles displayed in pink denotes a logged power value for a
channel that was active during the actual collection of data but currently is disabled in
the Power Log Setup window.

Note: There is a limit on the number of saved logs. When this limit is exceeded, the
oldest entries in the buffer are erased.

See also Debugging in the power domain, page 318.

Requirements
A debug probe with support for power debugging and one of these alternatives:

The C-SPY I-jet/JTAGjet driver
The C-SPY J-Link/J-Trace driver
The C-SPY TI MSP-FET driver.

°
°
°
o The C-SPY TI XDS driver.
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Display area
This area contains these columns:
Time

The time from the application reset until the event, based on the clock frequency
specified in the SWO Configuration dialog box.

If the time is displayed in italics, the target system could not collect a correct
time, but instead had to approximate it.

This column is available when you have selected Show Time from the context
menu.

Cycles

The number of cycles from the application reset until the event. This
information is cleared at reset.

If a cycle is displayed in italics, the target system could not collect a correct
time, but instead had to approximate it.

This column is available when you have selected Show Cycles from the context
menu.

Program Counter
Displays one of these:

An address, which is the content of the pc, that is, the address of an instruction
close to where the power value was collected.

---, the target system failed to provide the debugger with any information.

Overflow in red, the communication channel failed to transmit all data from the
target system.

Idle, the power value is logged during idle mode.

Name |unit]
The power measurement value expressed in the unit you specified in the Power
Setup window.

C-SPY® Debugging Guide
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Context menu
This context menu is available:

| ¥ Enable
Clear

Save to Log File...

Choose Live Log File...
Enable Live Logging to ‘PowerLoglivelog’

Clear 'PowerLoglive.log

Show Time

| ¥ Show Cycles

Open Setup Window

These commands are available:

Enable
Enables the logging system, which means that power values are saved internally
within the IDE. The values are displayed in the Power Log window and in the
Power graph in the Timeline window (if enabled). The system will log
information also when the window is closed.

Clear
Deletes the log information. Note that this will also happen when you reset the
debugger, or if you change the execution frequency in the SWO Configuration
dialog box.

Save to File
Displays a standard file selection dialog box where you can select the
destination file for the log information. The entries in the log file are separated
by TaB and LF characters. An X in the Approx column indicates that the
timestamp is an approximation.

Choose Live Log File
Displays a standard file selection dialog box where you can choose a destination
file for the logged power values. The power values are continuously saved to that
file during execution. The content of the live log file is never automatically
cleared, the logged values are simply added at the end of the file.

Enable Live Logging to
Toggles live logging on or off. The logs are saved in the specified file.

Clear log file
Clears the content of the live log file.
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Show Time
Displays the Time column.

If the Time column is displayed by default in the C-SPY driver you are using,
this menu command is not available.

Show Cycles
Displays the Cycles column.

If the Cycles column is not supported in the C-SPY driver you are using, this
menu command is not available.

Open Setup Window
Opens the Power Log Setup window.

The format of the log file

The log file has a tab-separated format. The entries in the log file are separated by TAB
and line feed. The logged power values are displayed in these columns:

Time/Cycles
The time from the application reset until the power value was logged.

Approx
An x in the column indicates that the power value has an approximative value
for time/cycle.

PC
The value of the program counter close to the point where the power value was
logged.

Name|unit|

The corresponding value from the Power Log window, where Name and unit
are according to your settings in the Power Log Setup window.

C-SPY® Debugging Guide
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Timeline window—Power graph

The power graph in the Timeline window is available from the C-SPY driver menu
during a debug session.

OFF

Linear

] 10000 |||||””||||I|II||||||||||||

1.665s 17 s?ns T 1675 1.680= /  1.685s

[ Commaon time axis ] { Selection for current garaph ‘

The power graph displays a graphical view of power measurement samples generated
by the debug probe or associated hardware in relation to a common time axis.

Note: There is a limit on the number of saved logs. When this limit is exceeded, the
oldest entries in the buffer are erased.

For more information about the Timeline window, how to display a graph, and the other
supported graphs, see The application timeline, page 253.

See also Requirements and restrictions for power debugging, page 313.

Requirements

A debug probe with support for power debugging and one of these alternatives:

o The C-SPY I-jet/JTAGjet driver
o The C-SPY J-Link/J-Trace driver
o The C-SPY TI MSP-FET driver.

Display area
Where:
o The label area at the left end of the graph displays the name of the measurement
channel.

o The Voltage and the Current graphs show power measurement samples generated by
the debug probe or associated hardware. The Energy graph shows accumulated
energy since the last time the CPU was stopped.

o The graph can be displayed as a thin line between consecutive logs, as a rectangle
for every log (optionally color-filled), or as columns.
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State Log window

Requirements
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o The resolution of the graph can be changed.

o A red vertical line indicates overflow, which means that the communication channel
failed to transmit all interrupt logs from the target system.

At the bottom of the window, there is a common time axis that uses seconds as the time
unit.

The State Log window is available from the C-SPY driver menu.

B
Time| Source | Status | Frogram Counter | Al:tive| -
0.00 us CPULPMx off 0=21E
0.00 us CPUActive Mode On 0=21E
17= 193414 .00 us CPU Active Mode  Off = 17= 193414.00 us
17= 193414 .00 us CPULPMx On =
17= 956691.00 us CPULPMx Off 0x20026C0 763277.00 us
17= 956691.00 us CPUActve Mode  On 0=20026C0
18s 712107 .00 us CPUActve Mode  Off = 755416.00 us
18s 712107 .00 us CPULPMx On =
195 520838.00 us CPULPMx Off 0=220 808731.00 us
10~ CAA02AT NN 2w DL A ~tism hdmdde (AT Ner 230 LI

This window logs activity—state changes—for peripheral units and clocks, as well as
for CPU modes.

The information is useful for tracing the activity on the target system. When the State
Log window is open, it is updated continuously at runtime.

Note: The number of saved logs is limited. When this limit is exceeded, the entries at
the beginning of the buffer are erased.

See also Displaying a power profile and analyzing the result, page 318 and Timeline
window—State Log graph, page 333.

One of these alternatives:

o The C-SPY MSP-FET driver and a TI MSP-FET debug probe with
EnergyTrace+TM Technology provided by Texas Instruments.

o The C-SPY TI XDS driver and a TI XDS110 debug probe with EnergyTrace+TM
Technology provided by Texas Instruments, and one of the MSP432, CC13xx, or
CC26xx devices.
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Display area
This area contains these columns:
Time
The time for the state change, based on the sampling frequency.
If a time is displayed in italics, the target system has not been able to collect a
correct time, but instead had to approximate it.

Source
The name of the peripheral unit, clock, or CPU mode.

Status
The status at the given time.

Program Counter*
The address of the program counter when the status changed, or shows idle if
the log was taken during CPU idle mode, or shows --- for an unknown pc value.
Active
The active time calculated using the on and off time for the source. If it is written

in italics, it is based on at least one approximative time.

* You can double-click an address. If it is available in the source code, the editor window
displays the corresponding source code, for example for the interrupt handler (this does
not include library source code).

Context menu

This context menu is available:

v | Enable
Clear

Save to Log File...
v | Show Time
Show Cycles

These commands are available:

Enable
Enables the logging system. The system will log information also when the
window is closed.

Clear

Deletes the log information. Note that this will happen also when you reset the
debugger.
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Save to File
Displays a standard file selection dialog box where you can select the
destination file for the log information. The entries in the log file are separated
by TaB and LF characters. An X in the Approx column indicates that the
timestamp is an approximation.

Show Time
Displays the Time column.
If the Time column is always displayed by default in the C-SPY driver you are
using, this menu command is not available.

Show Cycles
Displays the Cycles column.

If the C-SPY driver you are using does not support the Cycles column, this
menu command is not available.

State Log Summary window

The State Log Summary window is available from the C-SPY driver menu.

‘ |
| Source | Countl FirstTimel Total (Time)l Total (%)l Shortestl Longestl Iin Intersal Maxlntervall
| CPU LPhx 7 17= 1934, .. 7= 502. .. 25.66 24818.00 us 2= 49273, .. 779936.00 us 3=z 2541. ..
1| CPU Active Mode 7 0.00 us 21s 74. .. 74.34 754002.00 us 17s 1934... 778820.00 us 17s 956. ..

Currenttime: 29s ...

This window displays a summary of logged activity—state changes—for peripheral
units and clocks, as well as for CPU modes.

Click a column to sort it according to the values. Click again to reverse the sort order.

At the bottom of the display area, the current time or cycles is displayed—the number
of cycles or the execution time since the start of execution.

See also Displaying a power profile and analyzing the result, page 318 and Timeline
window—State Log graph, page 333.

Requirements

One of these alternatives:

o The C-SPY MSP-FET driver and a TI MSP-FET debug probe with
EnergyTrace+TM Technology provided by Texas Instruments.

C-SPY® Debugging Guide
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o The C-SPY TI XDS driver and a TI XDS110 debug probe with EnergyTrace+TM
Technology provided by Texas Instruments, and one of the MSP432, CC13xx, or
CC26xx devices.

Display area
Each row in this area displays statistics about the specific measurement source based on
the log information in these columns; and summary information is listed at the bottom
of the display area:
Source
The name of the peripheral unit, clock, or CPU mode.
Count
The number of times the source was activated.
First time
The first time the source was activated.
Total (Time)**
The accumulated time the source has been active.
Total (%)
The accumulated time in percent that the source has been active.
Shortest
The shortest time spent with this source active.
Longest
The longest time spent with this source active.
Min interval
The shortest time between two activations of this source.
Max interval
The longest time between two activations of this source.
Approximative time count
The information displayed depends on the C-SPY driver you are using.

For some C-SPY drivers, this information is not displayed or the value is always
zero. In this case, all logs have an exact time stamp.

For other C-SPY drivers, a non-zero value is displayed. The value represents the
amount of logs with an approximative time stamp. This might happen if the
bandwidth in the communication channel is too low compared to the amount of
data packets generated by the CPU or if the CPU generated packets with an
approximative time stamp.
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Context menu
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Overflow count
The information displayed depends on the C-SPY driver you are using.

For some C-SPY drivers, this information is not displayed or the value is always
zero.

For other C-SPY drivers, the number represents the amount of overflows in the
communication channel which can cause logs to be lost. If this happens, it
indicates that logs might be incomplete. To solve this, make sure not to use all
C-SPY log features simultaneously or check used bandwidth for the
communication channel.

Current time|cycles
The information displayed depends on the C-SPY driver you are using.

For some C-SPY drivers, the value is always zero or not visible at all.

For other C-SPY drivers, the number represents the current time or cycles—the
number of cycles or the execution time since the start of execution.

*#* Calculated in the same way as for the Execution time/cycles in the State Log
window.

This context menu is available:

v | Enable
Clear

Save to Log File...

v | Show Time
Show Cycles

These commands are available:

Enable
Enables the logging system. The system will log information also when the
window is closed.

Clear
Deletes the log information. Note that this will happen also when you reset the
debugger.

Save to File

Displays a standard file selection dialog box where you can select the
destination file for the log information. The entries in the log file are separated
by TaB and LF characters. An X in the Approx column indicates that the
timestamp is an approximation.
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Show Time
Displays the Time column.

If the Time column is always displayed by default in the C-SPY driver you are
using, this menu command is not available.

Show Cycles
Displays the Cycles column.

If the C-SPY driver you are using does not support the Cycles column, this
menu command is not available.

Timeline window—State Log graph

The State Log graph in the Timeline window is available from the C-SPY driver menu
during a debug session.

|
: — 0
1 Y5
7 1
lés lés 263 A 2és ) 2;13
| NS i
Source names ‘ Commaon time axis State On/Off

The State Log graph displays a graphical view of logged activity—state changes—for
peripheral units and clocks, as well as CPU modes in relation to a common time axis.

For more information about the Timeline window, how to display a graph, and the other
supported graphs, see Reference information on application timeline, page 261.

See also, Requirements and restrictions for power debugging, page 313.

Requirements
One of the following combinations:
o The C-SPY MSP-FET driver and a TI MSP-FET debug probe with
EnergyTrace+TM Technology provided by Texas Instruments.

o The C-SPY TI XDS driver and a TI XDS110 debug probe with EnergyTrace+TM
Technology provided by Texas Instruments, and one of the MSP432, CC13xx, or
CC26xx devices.
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Context menu
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Where:

o The label area at the left end of the graph displays the name of the sources of the
status information.

o The graph itself shows the state of the peripheral units, clocks, and CPU modes
generated by the debug probe or associated hardware. The white figure indicates the
time spent in the state. This graph is a graphical representation of the information in
the State Log window, see State Log window, page 328.

At the bottom of the window, there is a shared time axis that uses seconds as the time
unit.

This context menu is available:

MNavigate 3
v Auto Scroll
Zoom 3
Call Stack
v Enable

v | Show Timing

Go to Source

Save to File...
Select Graphs 3
Time Axis Unit 3

Note: The context menu contains some commands that are common to all graphs in the
Timeline window and some commands that are specific to each graph.

These commands are available:

Navigate
Commands for navigating the graph(s). Choose between:

Next moves the selection to the next relevant point in the graph. Shortcut key:
right arrow.

Previous moves the selection backward to the previous relevant point in the
graph. Shortcut key: left arrow.

First moves the selection to the first data entry in the graph. Shortcut key:
Home.

Last moves the selection to the last data entry in the graph. Shortcut key: End.
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End moves the selection to the last data in any displayed graph, in other words
the end of the time axis. Shortcut key: Ctrl+End.

Auto Scroll

Toggles automatic scrolling on or off. When on, the most recently collected data
is automatically displayed when you choose Navigate>End.

Zoom

Commands for zooming the window, in other words, changing the time scale.
Choose between:

Zoom to Selection makes the current selection fit the window. Shortcut key:
Return.

Zoom In zooms in on the time scale. Shortcut key: +
Zoom Out zooms out on the time scale. Shortcut key: —

10ns, 100ns, 1us, etc makes an interval of 10 nanoseconds, 100 nanoseconds, 1
microsecond, respectively, fit the window.

1ms, 10ms, etc makes an interval of 1 millisecond or 10 milliseconds,
respectively, fit the window.

10m, 1h, etc makes an interval of 10 minutes or 1 hour, respectively, fit the
window.

Power Log

A heading that shows that the Power Log-specific commands below are
available.

Enable

Toggles the display of the graph on or off. If you disable a graph, that graph will
be indicated as OFF in the window. If no data has been collected for a graph, no
data will appear instead of the graph.

Viewing Range
Displays a dialog box, see Viewing Range dialog box, page 288.
Size

Determines the vertical size of the graph; choose between Small, Medium, and
Large.

Style
Selects the style of the graph. Choose between:

Bars, displays a vertical bar for each log

Columns, displays a column for each log
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Levels, displays the graph with a rectangle for each log, optionally color-filled
Linear, displays the graph as a thin line between consecutive logs
Note that all styles are not available for all graphs.

Show Numerical Value
Shows the numerical value of the variable, in addition to the graph.

Go To Source

Displays the corresponding source code in an editor window, if applicable.

Open Setup Window
Opens the Power Log Setup window.

Select Graphs
Selects which graphs to be displayed in the Timeline window.

Time Axis Unit
Selects the unit used in the time axis; choose between Seconds and Cycles.
If Cycles is not available, the graphs are based on different clock sources. In that
case you can view cycle values as tooltip information by pointing at the graph
with your mouse pointer.

Profile Selection

Enables profiling time intervals in the Function Profiler window. Note that this
command is only available if the C-SPY driver supports PC Sampling. For more
information, see Selecting a time interval for profiling information, page 297.
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Introduction to runtime error checking

Using C-RUN

Detecting various runtime errors

Reference information on runtime error checking
Compiler and linker reference for C-RUN

cspybat options for C-RUN

Note that the functionality described in this chapter requires C-RUN, which
is an add-on product to IAR Embedded Workbench.

Introduction to runtime error checking

These topics are covered:

Runtime error checking

Runtime error checking using C-RUN

The checked heap provided by the library

Using C-RUN in the IAR Embedded Workbench IDE
Using C-RUN in non-interactive mode

Requirements for runtime error checking

RUNTIME ERROR CHECKING

Runtime error checking is a way of detecting erroneous code constructions when your
application is running. This is done by instrumenting parts of the code in the application,
or by replacing C/C++ library functionality with a dedicated library that contains
support for runtime error checking.

Runtime error checking uses different methods for implementing the checks, depending
on the type of your application and in what environment it should run.
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Instrumenting the code to perform checks makes the code larger and slower. Variants of
library functions with checks will also, in general, be larger and slower than the
corresponding functions without checks.

RUNTIME ERROR CHECKING USING C-RUN
C-RUN supports three types of runtime error checking:

® Arithmetic checking, which includes checking for integer overflow and underflow,
erroneous shifts, division by zero, value-changing conversions, and unhandled cases
in switch statements. Normally, the overhead of arithmetic checking is not
particularly high, and arithmetic checking can be enabled or disabled on a module
by module basis with no complications.

® Bounds checking, which checks whether accesses via pointers are within the bounds
of the object pointed to. Bounds checking involves instrumenting the code to track
pointer bounds, with relatively high costs in both code size and speed. A global
table of bounds for indirectly accessed pointers is also needed. You can disable
tracking, or just checking, per module or function, but any configuration where
pointer bounds are not tracked by all code will usually require some source code
adaption.

® Heap checking using a checked heap, which checks for errors in the use of heap
memory. Heap checking can find incorrect write accesses to heap memory, double
free, non-matching allocation and deallocation, and, with explicit calls, leaked heap
blocks. Using the checked heap increases the memory size for each heap block,
which might mean that you must increase your heap size, and heap operations can
take significantly longer than with the normal heap. It also checks only when heap
functions are called, which means that it will not catch all heap write errors.

All checks that C-RUN can perform can be used for both C and C++ source code.

You can enable several types of C-RUN checks at the same time. Each type of check that
you enable will increase, sometimes very slightly, execution time and code size.

Sometimes, the compiler might merge several checks into one, or move a check out of
a loop, in which case the problem may be detected well in advance of the actual access.
In these cases, the C-RUN message will display the problem source location (or
locations) as separate from the current location.

Before you perform any C-RUN runtime checks, make sure to use all the compiler’s
facilities for finding problems:

o Do not use Kernighan & Ritchie function declarations; use the prototyped style
instead. Read about --require_prototypes in the IAR C/C++ Development
Guide for Arm.
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o Make sure to pay attention to any compiler warnings before you perform any
runtime checking. The compiler will not, in most cases, emit code to check for a
problem it has already warned about. For example:

unsigned char ch = 1000; /* Warning: integer truncation */

Even when integer conversion checking is enabled, the emitted code will not contain
any check for this case, and the code will simply assign the value 232 (1000 & 255)
to ch.

Note that C-RUN depends on the Arm semihosting interface (the library function
__iar_ReportCheckFailed will communicate with C-SPY via the semihosting
interface). It is only in non-interactive mode that you can use another low-level I/O
interface. See Using C-RUN in non-interactive mode, page 340.

For information about how to detect the errors, see Detecting various runtime errors,
page 343.

THE CHECKED HEAP PROVIDED BY THE LIBRARY

The library provides a replacement checked heap that you can use for checking heap
usage. The checked heap will insert guard bytes before and after the user part of a heap
block, and will also store some extra information (including a sequential allocation
number) in each block to help with reporting.

Each heap operation will normally check each involved heap block for changes to the
guard bytes, or to the contents of newly allocated heap memory. At certain times (either
triggered by a specific call, or after a configurable number of heap operations) a heap
integrity check will be performed which checks the entire heap for problems.

It is important to know that the checked heap cannot find erroneous read accesses, like
reading from a freed heap block, or reading outside the bounds of an allocated heap
block. Bounds checking can find these, as well as many erroneous write accesses that
might be missed by the checked heap because they do not write to a guard byte or an
otherwise checked byte. The checked heap also checks only when a heap operation is
used, and not at the actual point of access.

USING C-RUN IN THE IAR EMBEDDED WORKBENCH IDE

C-RUN is fully integrated in the IAR Embedded Workbench IDE and it offers:

e Detailed error information with call stack information provided for each found error
and code correlation and graphical feedback in editor windows on errors

e Error rule management to stop the execution, log, or ignore individual runtime
errors, either on project level, file level, or at specific code locations. It is possible to
load and save filter setups.
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o A bookmark in the editor window for each message which makes it easy to navigate
between the messages (using F4).

In the IDE, C-RUN provides these windows:

o The C-RUN Messages window, which lists all messages that C-RUN generates.
Each message contains a message type (reflecting the check performed), a text that
describes the problem, and a call stack. The corresponding source code statements
will be highlighted in the editor window. See C-RUN Messages window, page 364.

o The C-RUN Message Rules window, which lists all rules. See C-RUN Messages
Rules window, page 366. The rules determine which messages that are displayed in
the C-RUN Messages window.

USING C-RUN IN NON-INTERACTIVE MODE

You can run C-RUN checked programs using cspybat—C-SPY in batch mode.
cspybat can use rules and other setup configured in the Workbench IDE. C-RUN
messages in cspybat are by default reported to the host stdout, but you can redirect
them to a file.

If you instead want to use your own communication channel between your application
and the host for C-RUN messages, replace the function __iar_ReportCheckFailed
(uses the semihosting interface for the communication) with your own version and you
can use any communication interface you like. In the source file
ReportCheckFailedStdout.c (arm\src\lib\crun) you can find a variant that
reports to the application’s stdout. To use your own report function instead of the
semihosting one, use the linker option --redirect

__iar_ ReportCheckFailed=__iar_ReportCheckFailedStdout.

Note: If the module for the report function is inserted into the project, the module should
not be compiled with any C-RUN source code options.

The output from __iar_ ReportCheckFailedStdout is notin user-readable form, as
it only contains the raw data. You can use cspybat in offline mode (via the options
--rtc_filterand --rtc_filter_file) to transform the raw text into something
very similar to normal C-RUN messages.

Use the option --rtc_enable to enable C-RUN in cspybat. Note that all cspybat
options for C-RUN all begin with --rtc_*. For more information about these options,
see cspybat options for C-RUN, page 374.

REQUIREMENTS FOR RUNTIME ERROR CHECKING

To perform runtime error checking you need C-RUN, which is an add-on product to IAR
Embedded Workbench.



C-RUN runtime error checking °

Using C-RUN
These tasks are covered:

o Getting started using C-RUN runtime error checking

o Creating rules for messages

GETTING STARTED USING C-RUN RUNTIME ERROR
CHECKING

Typical use of C-RUN involves these steps:

o Determine which C-RUN checks that are needed and specify them in the C-RUN
options.

o Run your application in the IAR Embedded Workbench IDE and interactively
inspect each C-RUN message. For each message, determine if it is the result of a
real problem or not. If not, you can apply a rule to ignore that particular message, or
similar messages in the future. If the message is the result of a real problem, you
might, depending on the particular circumstances, need to correct the problem and
rerun, or you might check for other problems first.

o When finished, close C-SPY. Because the C-RUN windows stay open, now is the
time to work through the found problems. Look at the rules setup, possibly edit it,
and then save it for future runs.

o Repeat the process until all problems are taken care of.

More in detail, to perform runtime error checking and detect possible runtime errors,
follow this example of a typical process:

I To set project options for runtime checking, choose Project>Options>Runtime
Checking and select the runtime checks you want to perform, for example Bounds
checking.

Note that runtime checking must be enabled on the project level, then you must enable
each type of check you want to use. Some of the check options, such as Use checked
heap, and Enable bounds checking, must be enabled on the project level, whereas
others can be enabled on project or file level.

2 Build your application. Note that the lower optimization levels give you better
information.

Start a debug session.

4 Start executing your application program.
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C-RUN Messages

5 If C-RUN detects a possible error, the program execution stops and the corresponding
source code is highlighted in the editor window:

char *p = malloc(10);

free(p + 200);
& |_iar check leaka(); // Leakage
g return 0;

The C-RUN Messages window is displayed if it is not already open, and it provides
information about the source code construct, type of check, and the call stack
information for the source location

Default action: |Stop - Filter: Messages: 2
Messages Source File PC C
s Heap usage errar heap.c 9:3-15 0x0000B534 0

kemary leak
There were atotel of 1 heap blocks with no references.

Heap block 0 at 082000320 has no references.
The block was allocated atline 7 of heap.c. heap.c #1322
Call Stack
min R elcimessnEeland hesp.c13:3-11 Location of the source

construct, click to view

[_call_main + 0x9] details about the
I itin the editor window

source location

Call stack information
for the source location

C-SPY® Debugging Guide
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Note that detection of a problem might not occur at the actual point of access. The check
might have been moved out of a loop, or several checks for different accesses might have
been merged. In these cases, the problem source (the source for the problem access)

might not be in the current statement, and there might be more than one problem source.

6 Depending on the source code construct, you might be able to continue program
execution after the possible error has been detected. Note that some types of errors
might cause unexpected behavior during runtime because of, for example, overwritten
data or code.

7 If required, use the C-RUN Messages Rules window to specify rules to filter out
specific messages based on specific checks and source code locations, specific checks
and source files, or specific checks only. You can also specify whether a specific check
should not stop the execution, but only log instead. See Creating rules for messages,
page 343.

You can repeat this procedure for the various runtime checks you want to perform.
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CREATING RULES FOR MESSAGES

Depending on your source code, the number of messages in the C-RUN Messages
window might be very large. For better focus, you can create rules to control which
messages you want to be displayed.

To create a rule:

I Select a message in the C-RUN Messages window that you want to create a filter rule
for.

2 Right-click and choose one of the rules from the context menu.
The rule will appear in the C-RUN Rules window.
3 For an overview of all your rules, choose View>C-RUN Rules.

When a check fails, the rules determine how the message should be reported. Rules are
scanned top—down and the action from the first matching rule is taken.

Note: You can save a filter setup and then load it later in a new debug session.

Detecting various runtime errors
These tasks are covered:

Detecting implicit or explicit integer conversion

Detecting signed or unsigned overflow

Detecting bit loss or undefined behavior when shifting

Detecting division by zero

Detecting unhandled cases in switch statements

Detecting accesses outside the bounds of arrays and other objects
Detecting heap usage error

Detecting heap memory leaks

Detecting heap integrity violations

Detecting implicit or explicit integer conversion

Description Checks that an integer conversion (implicit or explicit) or a write access to a bitfield does
not change the value.

Why perform the check  Because C allows converting larger types to smaller integer types, some conversions can
unintentionally remove significant bits of the value. The check can be limited to implicit
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How to use it

How it works

Example
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integer conversions, which is useful when the loss of data caused by explicit conversion
is considered intentional.

Compiler option:
--runtime_checking integer_conversion | implicit_integer_conversion

In the IDE: Project>Options>Runtime Checking>Integer conversion
The check can be applied to one or more modules.
The check can be avoided by inserting an explicit mask:

short f(int x)
{

return x & OxFFFF; /* Will not report change of value */

The compiler inserts code to perform the check at each integer conversion and at each
write access to a bitfield, unless the compiler determines that the check cannot fail. Note
that an explicit conversion from a constant will not be checked.

Note that increment/decrement operators (++/--) and compound assignments (+=, -=,
etc) are checked as if they were written longhand (var = var op val).

For example, both ++i and i += 1 are checked as if they were written 1 = i + 1.In
this case, the addition will be checked if overflow checks are enabled, and the
assignment will be checked if conversion checks are enabled. For integer types with the
same size as int or larger, the conversion check cannot fail. But for smaller integer
types, any failure in an expression of this kind will generally be a conversion failure.
This example shows this:

signed char a = 127;

void f(void)

{
++a; /* Conversion check error (128 -> -128) */
a -=1; /* Conversion check error (-129 -> 127) */

}
The code size increases, which means that if the application has resource constraints this

check should be used module per module to minimize the overhead.

Follow the procedure described in Getting started using C-RUN runtime error checking,
page 341, but use the Integer conversion option.
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This is an example of source code that will be identified during runtime:
int i = 5,9 = 0;
char ch = 0;

void conv(void)

{
B ch = @ #100;
}

C-RUN will report either Integer conversion failureorBitfield overflow.
This is an example of the message information that will be listed:

Messages Source File

- Inte il
Conwversion changes the value from 500 (0x00000714)
to 244 (D).

i Call Stack

@ Comy arith.c12:3-15
= Friin arith.c 27:3-8
=

2

[_call_rmain + 0x4]

-

Detecting signed or unsigned overflow

Description Checks that the result of an expression is in the range of representable values for its type,
and that shift counts are valid.

Does not check for overflow in shift operations, which is handled by a separate check.
See Detecting bit loss or undefined behavior when shifting, page 347.

Why perform the check  Because the behavior of signed overflow is undefined, and because unsigned overflow
results in a truncation that can sometimes be undesirable. Although the shift operation
is not checked, shift counts are checked because if a shift count is negative or greater
than or equal to the width of the promoted left operand, the behavior of the shift
operation is undefined.

How to use it Compiler option:
--runtime_checking signed_overflow | unsiged_overflow
In the IDE: Project>Options>Runtime Checking>Integer overflow
The check can be applied to one or more modules.

The check can be avoided, for example by working in a larger type, when such a type
exists:

int f(int a, int b)

{ return (int) ((long long) a + (long long) b); }
short g(short a, short b)
{ return (short) ( a + b); } /* Integer promotion occurs */
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The compiler inserts code to perform the check at each integer operation that can
overflow (+, -, *, /, %, including unary -) and each shift operation, unless the compiler
determines that the check cannot fail.

Note that increment/decrement operators (++/--) and compound assignments (+=, -=,
etc) are checked as if they were written longhand (var = var op val).

For example, both ++1i and i += 1 are checked as if they were writteni = i + 1.In
this case, the addition will be checked if overflow checks are enabled, and the
assignment will be checked if conversion checks are enabled. For integer types with the
same size as int or larger, the conversion check cannot fail. But for smaller integer
types, any failure in an expression of this kind will generally be a conversion failure.
This example shows this:

signed char a = 127;

void f (void)

{
++a; /* Conversion check error (128 -> -128) */
a -= 1; /* Conversion check error (-129 -> 127) */

}

The code size increases, which means that if the application has resource constraints this
check should be used per module to minimize overhead.

Follow the procedure described in Getting started using C-RUN runtime error checking,
page 341, but use the Integer overflow option.

This is an example of source code that will be identified during runtime:
unsigned long ovil (void)
{
o unsigned long ul = 1 + OxTEEEEEEE;
return ul;

1

C-RUN will report either Signed ingeger overflow, Unsigned integer
overflow, or Shift count overflow. This is an example of the message
information that will be listed:

Messages Source File

; ed integer o
Fesultis greater than the largest representable number:
5 (OxB) + 2147483647 (Ox7H).

Call Stack
ol arith.c 26:17-36
main arith.c 35:3-8

[_call_rmain + 0x4]

C-RUN Messages
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Detecting bit loss or undefined behavior when shifting

Description

Why perform the check

How to use it

How it works

Example

Checks for overflow in shift operations and that shift counts are valid.

Because the behavior of signed overflow is undefined, and because unsigned overflow
results in a truncation that can sometimes be undesirable.

Overflow occurs in a left shift operation E1<<E2 if E1 is negative or if the result, defined
as E1*2%2, is not in the range of representable values for its type.

Compiler option: --runtime_checking signed_shift|unsigned_shift

In the IDE: Project>Options>Runtime Checking>Integer shift overflow

The check can be applied to one or more modules.

The check can be avoided by masking before shift:

/* Cannot overflow */

int f(int x) { return (x & O0x00007FFF) << 16; }

The compiler inserts code to perform the check for each shift operation, unless the
compiler determines that the check cannot fail.

The code size increases, which means that if the application has resource constraints this
check should be used per module to minimize the overhead.

Follow the procedure described in Getting started using C-RUN runtime error checking,
page 341, but use the Integer shift overflow option.

This is an example of source code that will be identified during runtime:

void shift (void)
{

9 1 owe= 31;
}

C-RUN will report either shift overflow or Shift count overflow. Thisisan
example of the message information that will be listed:

Source File
Fesultis greater than the largest representable number:
signed wvalue 5 (0x5) doubled 31 time(s).

Call Stack
shift arith.c 32:3-11
main arith.c 41:3-9

b [_call_main + 0x9]

C-RUN Messages
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Detecting division by zero

Description Checks for division by zero and modulo by zero. Floating-point operations are checked
for division by exactly (positive) zero.

Why perform the check  Because the behavior of integer division by zero is undefined, and because
floating-point division by exactly zero usually indicates a problem.

How to use it Compiler option: --runtime_checking division_by_ zero
In the IDE: Project>Options>Runtime Checking>Division by zero
The check can be applied to one or more modules.

How it works The compiler inserts code to perform the check at each division and modulo operation,
unless the compiler determines that the check cannot fail.

Example Follow the procedure described in Getting started using C-RUN runtime error checking,
page 341, but use the Division by zero option.

This is an example of source code that will be identified during runtime:

void diwv(void)
{

2 1=i/73:
}

C-RUN will report Division by zero. Thisis an example of the message information
that will be listed:

Messages Source File

8] ro

Division by zero.
Call Stack
- div arith.c 7:3-12
main arith.c 37:3-7

[_call_rmain + 0x4]

C-RUN Messages

Detecting unhandled cases in switch statements

Description Checks for a missing case label in a switch statement that does not have a default
label.

Why perform the check  The check is useful, for example, to detect when an enum type has been augmented with
a new value that is not yet handled in a switch statement.
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How to use it Compiler option: --runtime_checking switch
In the IDE: Project>Options>Runtime Checking>Switch
The check can be applied to one or more modules.

The check can be avoided by adding a default label.

How it works The compiler inserts an implicit default label to perform the check in each switch
statement that does not have a default label.

Example Follow the procedure described in Getting started using C-RUN runtime error checking,
page 341, but use the Switch option.

This is an example of source code that will be identified during runtime:

void sw(void)
{
& |switch(ch)
{
case O: 1
case 5: 1
}
=

break;
break;

R oL

C-RUN will report Unhandled case in switch. This is an example of the message
information that will be listed:

Messages Source File

Unhandled case in h arith.c 17
Switch to undefined case label.

Call Stack
S arith.c 22:1-1
main arith.c 39:3-6

[_call_rmain + 0x4]

C-RUN Messages

Detecting accesses outside the bounds of arrays and other objects

Description Checks that accesses through pointer expressions are within the bounds of the expected
object. The object can be of any type and can reside anywhere—globally, on the stack,
or on the heap.
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Why perform the check

How to use it

How it works
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The check is useful whenever your application reads or writes to locations it should not.
For example:

int arr[10] = {0};
int f(int 1)
{
return arr[il];
}
int g(void)
{

return £(20); /* arr([20 is out of bounds] */

Compiler option: --runtime_checking bounds
In the IDE: Project>Options>Runtime Checking>Enable bounds checking

This will enable out-of-bounds checking globally. Note that there are suboptions that
you can use to fine-tune the out-of-bounds checking globally and for each source file.

In code where pointer bounds are tracked:

o FEach transfer of a pointer value also transfers the bounds for that pointer value.

o When a pointer is initialized to point to an object of some sort, the bounds of the
pointer are set to the bounds of the object. If the object is an array, the bounds cover
the entire array. If it is a single instance, the bounds cover the single instance.

o When a pointer is initialized to an absolute address, the pointer is assumed to point
to a single object of the specified type. For example:

uint32_t * p = (uint_32_t *)0x100;

In this case, p will point to a 32-bit unsigned integer at address 0x100, with the
bounds 0x100 and 0x104.

o A null pointer is given bounds that do not cover any access, in other words, an
access through it is erroneous.

o When a pointer value is passed to a function as a parameter, the bounds are passed
as extra, hidden, parameters.

o When a pointer value is returned from a function, the returned value and the bounds
are passed in a struct as the actual return value.

o When a pointer value is stored in memory in such a way that it can be accessed via
pointers, its bounds are stored in a global bounds table. Whenever the pointer value
is accessed, the associated bounds in the global bounds table are retrieved as well.
The size of the global bounds table can be changed using Number of entries (the
linker option --bounds_table_size
number_of_records|[:number_of_buckets] | (number_of_bytes)).
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o In other cases, the bounds are kept track of in extra local variables.

For each access through a pointer expression, the calculated address and the calculated
address plus the access size is checked against the bounds. If any of the two addresses
are outside of the bounds, a C-RUN message is generated.

Functions that receive pointers in any parameters, or that return a pointer value, can exist
in two variants, one with the bounds, and one without the bounds.

Resource usage The bounds checking overhead can cause the application to no longer fit in the available
ROM or RAM. There are some ways you can try to deal with this:

e Provided that your application does not use too many indirectly accessed pointers,
you can shrink the global bounds table to reduce the amount of RAM used for it.
See --bounds_table_size, page 368 (in the IDE, Number of entries).

By default, 4-Kbyte entries that need about 190 Kbytes are used.

® You can turn off the actual bounds checks in some modules. This will reduce the
amount of code added by instrumentation to some extent.

® You can turn off pointer bounds tracking in some modules. This will eliminate the
increase in code size entirely in these modules, but will cause problems in the
interface between the code that does track pointer bounds and the code that doesn't.
See the next section for more about this.

Non-checked code Sometimes you cannot enable bounds checking in the entire application, for example if
some part of the application is an externally built library, or is written in assembler. If
you add any extra source code lines to make your code work for bounds checking, use
the preprocessor symbol __AS_BOUNDS_ _ to make the extra source code conditional.
These are some cases you should consider:

o Calling code that does not track bounds from code that does
This only affects functions with pointers as parameters or as return types.

By using #pragma no_bounds oOr #pragma default_no_bounds on your
declarations. you can specify that certain functions do not track pointer bounds. If
you call such a function from code that does not track pointer bounds, no extra hidden
parameters are passed, and any returned pointers are either considered “unsafe” (all
checked accesses via such pointers generate errors) or “safe” (accesses via such
pointers cannot fail), depending on whether the option Check pointers from
non-instrumented functions has been used or not (compiler option
--ignore_uninstrumented_pointers). If you wish to explicitly specify the
bounds on such values, use the built in operator __as_make_bounds.
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For example:

#pragma no_bounds
struct X * f1(void);

struct X *px = f1();
/* Set bounds to allow acesses to a single X struct.
(If the pointer can be NULL, you must check for that.) */
if (px)
px = __as_make_bounds (px, 1);

/* From here, any accesses via the pointer will be checked
to ensure taht they are within the struct. */

o Calling code that tracks bounds from code that does not

If you call a function that tracks bounds, and which has pointers as parameters, or
which returns a pointer, from code that does not track bounds, you will generally get
an undefined external error when linking. To enable such calls, you can use
#pragma generate_entry_without_bounds or the option Generate functions
callable from non-instrumented code (compiler option
--generate_entries_without_bounds) to direct the compiler to emit one or
more extra functions that can be called from code that does not track bounds. Each
such function will simply call the function with default bounds, which will be either
"safe" (accesses via such pointers never generate errors) or "unsafe" (accesses via
such pointers always generate errors) depending on whether the option Check
pointers from uninstrumented functions (compiler option
--ignore_uninstrumented_pointers) has been used or not.

If you want to specify more precise bounds in this case, use
#pragma define_without_bounds.

You can use this pragma directive in two ways. If the function in question is only
called from code that does not track pointer bounds, and the bounds are known or can
be inferred from other parameters, there is no need for two functions, and you can
simply modify the definition using #pragma define_without_bounds

For example:

#pragma define_without_bounds
int f2(int * p, int n)
{

p = __as_make_bounds(p, n); /* Give p bounds */

}

In the example, p is assumed to point to an array of n integers. After the assignment,
the bounds for p willbepandp + n.

If the function can be called from both code that does track pointer bounds and from
code that does not, you can instead use #pragma define_without_bounds to

C-SPY® Debugging Guide
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define an extra variant of the function without bounds information that calls the
variant with bounds information.

You cannot define both the variant without bounds and the variant with bounds in the
same translation unit.

For example:

#pragma define_without_bounds

int £3(int * p, int n)

{

return f£3(__as_make_bounds(p, n), n);
}
In the example, p is assumed to point to an array of n integers. The variant of £3
without extra bounds information defined here calls the variant of £3 with extra
bounds information ("£3 [with bounds]"), giving the pointer parameter bounds of p
andp + n.

Global variables with pointers defined in code that does not track bounds

These pointers will get either bounds that signal an error on any access, or, if the
option Check pointers from non-instrumented memory (linker option
--ignore_unistrumented_pointers) is used when linking, bounds that never
cause an error to be signaled. If you need more specific bounds, use
__as_make_bounds.

For example:

extern struct x * gptr;

int main(void)

{

/* Give gptr bounds with size N. */
gptr = __as_make_bounds (gptr, N);

}
RTOS tasks

The function that implements a task might get called with a parameter that is a
pointer. If the RTOS itself is not tracking pointer bounds, you must use

#pragma define_without_bounds and __as_make_bounds to get the correct
bounds information.

For example:

#pragma define_without_bounds

void taskl (struct Arg * p)

{
/* p points to a single Arg struct */
p = __as_make_bounds (p, 1);
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Absolute addresses
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Some limitations:

e Function pointers

Sharing a function pointer between code that tracks bounds and code that does not
can be problematic.

There is no difference in type between functions that track bounds, and functions that
do not. Functions of both kinds can be assigned to function pointers, or passed to
functions that take function pointer parameters. However, if a function whose
signature includes pointers is called in a non-matching context (a function that tracks
bounds from code that does not, or vice versa), things will not work reliably. In the
most favorable cases, this will mean confusing bounds violations, but it can cause
practically any behavior because these functions are being called with an incorrect
number of arguments.

For things to work, you must ensure that all functions whose signature includes
pointers, and which are called via function pointers, are of the right kind. For the
simple case of call-backs from a library that does not track bounds, it will usually
suffice to use #pragma no_bounds on the relevant functions.

o K&R functions

Do not use K&R functions. Use --require_prototypes and shared header files
to make sure that all functions have proper prototypes. Note that in C void £() isa
K&R function, while £ (void) is not.

e Pointers updated by code that does not track bounds

Whenever a pointer is updated by code that does not set up new bounds for the
pointer, there is a potential problem. If the new pointer value does not point into the
same object as the old pointer value, the bounds will be incorrect and an access via
this pointer in checked code will signal an error.

If you use #pragma location or the @ operator to place variables at absolute
addresses, pointers to these variables will get correct bounds, just like pointers to any
other variables.

If you use an explicit cast from an integer to a pointer, the pointer will get bounds
assuming that it points to a single object of the specified type. If you need other bounds,
use __as_make_bounds.

For example:

/* p will get bounds that assume it points to a single struct
Port at address 0x1000. */

p = (struct Port *)0x1000;

/* If it points to an array of 3 struct you can add */

p = __as_make_bounds(p, 3);
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Example Follow the procedure described in Getting started using C-RUN runtime error checking,
page 341, but use the Bounds checking option.

This is an example of source code that will be identified during runtime:

int Arr[4] = [ 0, 1,2, 3}:
int ArrI = 5;

int £(woid)
{
= int i = Brr[Arrl + 1]; // Double fail glocbal
& i += Brr[ArrI + 2];
return i;

1

C-RUN will report either Access out of bounds or Invalid function pointer.
This is an example of the message information that will be listed:

Messages Source File

; ut of bounds i

Access outside pointer bounds:
Access 0x80000038 - 0x30000040

g Bounds 0x30000020 - 0x80000030, int Ar4]; file.c 3:5-7
@ Call Stack

= f file.c 3:7-24
= main file.c 29:8-10
o [_call_main + 03]

Note: The ranges displayed for accesses and bounds include the start address but not the
end address.

Detecting heap usage error

Description Checks that the heap interface—malloc, new, free, etc—is used properly by your
application. The following improper uses are checked for:

o Using the incorrect deallocator—free, delete, etc—for an allocator—malloc,
new, etc. For example:

char * pl = (char *)malloc(23); /* Allocation using malloc. */
char * p2 = new char[23]; /* Allocation using newl[]. */
char * p3 = new int; /* Allocation using new. */
delete pl /* Error, allocated using malloc. */

free(p2) ; /* Error, allocated using newl[]. */

delete[] p3; /* Error, allocated using new. */

e Freeing a heap block more than once.

e Trying to allocate a heap block that is too large.

Why perform the check  To verify that the heap interface is used correctly.
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How to use it

How it works

Example
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Linker option: --debug_heap
In the IDE: Project>Options>Runtime Checking>Use checked heap

The checked heap will replace the normal heap for the whole application. The checked
heap requires extra heap and stack resources. Make sure that your application has at least
10 Kbytes of heap and 4 Kbytes of stack.

The limit for how large a heap block can be at allocation is by default 1 Gbyte. The limit
can be changed by the function:

size_t __iar_ set_request_report_limit(size_t wvalue) ;

The function returns the old limit. You can find the declaration of this function in
iar_dlmalloc.h. For more information, see the /AR C/C++ Development Guide for
Arm.

For any incorrect use of the heap interface, a message will be issued.

See also The checked heap provided by the library, page 339.

Follow the procedure described in Getting started using C-RUN runtime error checking,
page 341, but use the Debug heap option.

This is an example of source code that will be identified during runtime:
int main (void)

{
char *p = malloc(10);

2  [Eree(p + 200);

= iar check leaks(); // Leakage

return 0;

1

C-RUN will report either Heap integrity violation orHeap usage error. This
is an example of the message information that will be listed:

Messages Source File
= He sage errar 1]
The address 0x800004a8 does not appear to be the startofa h...
Call Stack
main heap.c11:3-21

[_call_rmain + 0x4]

C-RUN Messages
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Detecting heap memory leaks

Description Checks for heap blocks without references at a selected point in your application.

Why perform the check A leaked heap block cannot be used or freed, because it can no longer be referred to. Use
this check to detect references to heap blocks and report blocks that are seemingly
unreferenced. Note that the leak detection cannot find all possible memory leak cases, a
seemingly unreferenced heap block might actually be referenced and a seemingly
referenced heap block might actually be leaked.

How to use it Linker option: --debug_heap
In the IDE: Project>Options>Runtime Checking>Use checked heap

The checked heap will replace the normal heap for the whole application. The checked
heap requires extra heap and stack resources. Make sure that your application has at least
10 Kbytes of heap and 4 Kbytes of stack.

The leak detection check must be called manually. It can either be called at the exit of
the application or it can be used for detecting leaked heap blocks between two source
points. These functions are defined in iar_dlmalloc.h:

® void __iar_leaks_ignore_all (void) ;

Use this function to mark all currently allocated heap blocks to be ignored in
subsequent heap leakage checks.

® void __iar_leaks_ignore_block(void *block) ;

Use this function to mark a specific allocated heap block to be ignored in subsequent
heap leakage checks.

® void __iar_check_leaks(void) ;

Use this function to check for leaks.
How it works The checked heap will replace the normal heap for the whole application. The heap
leakage algorithm has three phases:
1 Scans the heap and makes a list of all allocated heap blocks.

2 Scans the statically used RAM, the stack, etc for addresses in the heap. If the
address matches one of the heap blocks in the list above, it is removed from the list.

3 Reports the remaining heap blocks in the list as leaked.

See The checked heap provided by the library, page 339.

Example Follow the procedure described in Getting started using C-RUN runtime error checking,
page 341, but use the Debug heap option.
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This is an example of source code that will be identified during runtime:

char *p = malloc(10);
p = malloc{20);

= | _iar_check leaks();
=

C-RUN will report Memory leak. This is an example of the message information that
will be listed:

Messages Source File

13
There were atotal of 1 heap blocks with no references.
Heap block 0 at 0x2000c670 has no references.

The block was allocated atline 185 of heap_leakl.c. heap_leakl.c185:13-22
Call Stack
main heap_leakl.c190:3-12

[_call_rmain + 0x4]

C-RUN Messages

Detecting heap integrity violations

Description

C-SPY® Debugging Guide
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Checks for various heap integrity violations. The check can either be manually triggered
or can be set up to be triggered at regular intervals of use of the heap interface. Integrity
problems that can be detected when you enable this check are:

e Destruction of the internal heap structure. Mostly, this is because a write access
through a pointer expression is incorrect. Use out-of-bounds checking to try to
locate the erroneous write access.

o Write accesses outside allocated memory, for example:

char * p = (char *)malloc(100); /* Memory is allocated. */

p[100] = ... /* This write access is out of bounds. */

A write access that is out-of-bounds of the heap block and that changes the guards in
front of or after the heap block will be detected. Any other write accesses will not be
detected.

o Write accesses to freed memory, for example:

char * p = (char *)malloc(...); /* Memory is allocated. */
free(p); /* Memory is freed. */

pl...] = ... /* Write access to freed memory. */

If the memory that contains the original p is allocated again before p is written to,
this error will typically not be detected. By using the delayed free list (see below),
this error can be found.
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Why perform the check  Use the checked heap if you suspect that your application, at some point, writes
erroneously in the heap, for example by misusing a heap block.

How to use it Linker option: --debug_heap
In the IDE: Project>Options>Runtime Checking>Use checked heap

The checked heap will replace the normal heap for the whole application. The checked
heap requires extra heap and stack resources. Make sure that your application has at least
10 Kbytes of heap and 4 Kbytes of stack.

For detecting heap integrity violations, you can use these functions which are defined in
iar_dlmalloc.h:

® size_t __iar_ check heap_integrity(void) ;

Use this function to verify the integrity of the heap. If any corruptions are detected,
they are reported. The return value is the number of found problems. There is a limit
on the number of corruption errors that are reported. This limit can be changed by
using the __iar_set_integrity_report_limit function. Execution is only
stopped when the final message is generated. The default number of reported
messages is 10. A call to __iar_check_heap_integrity is not guaranteed to
return to the caller if the heap is corrupt.

® size_t __iar_set_heap_check_frequency(size_t interval);

Use this function to specify how often the periodic heap integrity checks are
performed. By default, the periodic checks are turned off (interval =0). If
interval is a positive number, the integrity will be checked every interval:th
heap operation where every call to free/malloc/new/delete/realloc/etc counts
as one operation. The function returns the old interval, which means that the state can
be restored if necessary. The heap check interval can be increased or turned off when
trusted parts of your application program, and then be decreased when you run parts
of your application that are likely to contain heap errors.

® size_t __iar_set_delayed_ free_size(size_t size);
Use this function to specify the maximum size of the freed delay list. By default, the
freed delay list is turned off (size = 0). This function has no effect on the actual size

of the list, it only changes the maximum. The function returns the previous value so
it can be restored if necessary.

The freed delay list can be used to try to find locations in your application that use a
freed heap block. This can help you detect:

o Mixing up an old heap block pointer that has been freed with a new, freshly
allocated heap block pointer. Because the freed delay list will delay the actual
reuse of a freed heap block, the behavior of your application might change and
you might be able to detect the presence of this kind of problem.
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How it works

Example
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o Writes to already freed heap blocks. If a heap block is in the freed delay list, it
will get specific content, different from when it is actually freed, and a heap
integrity check can find those erroneous write accesses to the heap block.

® size_t __iar_ free_delayed_ free_size(size_t count);

Use this function to make sure that at most count elements are present in the freed
delay list. Superfluous elements are freed (the oldest ones change first). It has no
effect on the maximum size of the list; it only changes the current number of
elements. Calling this function has no effect if count is larger than the current size
of the list. The function returns the number of freed elements.

The checked heap will replace the normal heap for the whole application.

The freed delay list is a queuing mechanism for free calls. When calling free, or an

equivalent memory operation that returns memory to the heap, the recently freed pointer
is queued to be freed instead of actually being freed. If the maximum size of the delay
list is exceeded, the oldest elements above the maximum size in the freed delay list are
actually freed.

All errors that the checked heap reports, mention a heap block that is somehow corrupt.
The checked heap cannot inform about who corrupted the heap block or when it was
corrupted. You can use calls to the __iar_debug_check_heap_integrity function
to verify the integrity during application execution and narrow down the list of potential
candidates.

For example:

__iar_debug_check_heap_integrity(); /* Pre-check */

my_function(..., ..., ...);
__iar_debug_check_heap_integrity(); /* Post-check */

If the post-check reports problems that the pre-check does not, it is probable that
my_function corrupted the heap.

The checked heap consumes resources:

o The checked heap requires more ROM space than the normal heap implementation
o All heap operations require more time in the checked heap
o Each heap block in the checked heap contains additional space for bookkeeping,

which results in increased RAM usage for your application.

See The checked heap provided by the library, page 339.

Follow the procedure described in Getting started using C-RUN runtime error checking,
page 341, but use the Checked heap option.
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This is an example of source code that will be identified during runtime:
Volda cneck(volid)

{
char *p = malloc(10);

plll] = 1;

= |_iar check heap integrity()|:

b4

C-RUN will report Heap integrity violation. This is an example of the message

information that will be listed:

Source File

Messages
= ation

1 heap integrity errars were detected.
“iolation detected in heap block 1 at address 0x80000408.

heap.c?13-22

ﬁ The block was allocated atline 7 of heap.c.

@ Call Stack

= check, heap.c11:1-1
é main heap.c21:3-9
L

[_call_rmain + 0x4]

Reference information on runtime error checking
Reference information about:
® C-RUN Runtime Checking options, page 361
o C-RUN Messages window, page 364
® C-RUN Messages Rules window, page 366

C-RUN Runtime Checking options
The C-RUN Runtime Checking options determine which checks to perform at

runtime.
C-RUN Rurtime Checking
[ Enable
Uze checked heap Ingert checks for
Enable bounds checking Integer overflow
Instrumentation Including unsigned
Track pointer bounds Integer conversion
Check accesses i
Including explicit casts

Generate functions i
callable from Integer shift overflow
nondnstrumented code Including unsigned shifts
Check pointers from non- Division by zero
instrumented functions - :

Unhandled switch case
Global bounds table

Check pointers from non-
instrumented memory

1000

See also Using C-RUN, page 341.
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Enable

Enables runtime checking.

Use checked heap

Uses the checked heap, to detect heap usage errors.

Enable bounds checking

C-SPY® Debugging Guide
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Checks for accesses outside the bounds of arrays and other objects. Available checks:

Track pointer bounds

Makes the compiler add code that tracks pointer bounds. If you want to check
pointer bounds, you should enable Check accesses and then decide how
instrumented code should interact with non-instrumented code:

Check accesses Inserts code for checking accesses via pointers.

Generate functions callable When Track pointer bounds is enabled, any
from non-instrumented functions that return or receive types that
code contain pointers are modified to also

return/receive pointer bounds. Use this option
to generate an extra entry for each such
function, which can be called from unchecked

code.
Check pointers from When Track pointer bounds is enabled,
non-instrumented pointers that originate from functions that are
functions not instrumented for bounds checking are by

default given globally permissive bounds
information. Use this option to identify these
pointers; any accesses via such pointers
generate an error. In this way you can manually
replace the globally permissive bounds
information with valid counterparts; see
__as_get base, page 373, _as_get bound,
page 373, _as_make bounds, page 374.

If this option is not used and you do not specify
valid bounds information, accesses via such
pointers do not generate errors and might result
in unnoticed incorrect runtime behavior.
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Check pointers from When Track pointer bounds is enabled, each
non-instrumented time a pointer is loaded from memory, its
memory bounds are looked up in the global bounds

table. If no entry is found in the table for this
pointer, usually because the pointer was created
by non-instrumented code, it is given globally
permissive bounds. Use this option to identify
such pointers; any accesses via such pointers
generate an error. In this way you can manually
replace the globally permissive bounds
information with valid counterparts; see
__as_get base, page 373, as get bound,
page 373, as_make bounds, page 374.

If this option is not used and you do not specify
valid bounds information, accesses via such
pointers do not generate errors and might result
in unnoticed incorrect runtime behavior.

Number of entries The bounds checking system uses a separate
table to track bounds for pointers in memory.
Use this option to set the number of such
bounds that can be tracked simultaneously. The
table will use approximately 50 bytes per
pointer.

Insert checks for

Inserts checks for:

Integer overflow
Checks for signed overflow in integer operations. Use Including unsigned to
also check for unsigned overflow in integer operations.

Integer conversion
Checks for implicit integer conversions resulting in a change of value. Use
Including explicit casts to also check for explicit casts.

Integer shift overflow
Checks for overflow in shift operations. Use Including unsigned shifts to also
check for unsigned overflow in shift operations.

Division by zero
Checks for division by zero.
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Unhandled switch case

Checks for unhandled cases in switch statements

C-RUN Messages window

The C-RUN Messages window is available from the View menu.

C-RUN Messages x
Default action: |Stop Messages: 2
Messages Source File FC Care =
T Access out of bounds main.c 8:10-13

Integer

Conwversion changes the value from

o
Call Stack
inlined_cornw

test_inlined_sequence_conw

main
[_rmain + Oxd]

131072 (0x000020000)

main.c 35:10-13

main.c 35:3-14
main.c 43:3-23
main.c 71:5-32

000002612 0

Requirements

Toolbar

C-SPY® Debugging Guide
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This window displays information about runtime errors detected by a runtime check.
The window groups messages that have the same source statement, the same call stack,

and the same messages.

See also Using C-RUN, page 341.

A license for the C-RUN product.

The toolbar contains:

Default action

Sets the default action for what happens if no other rule is satisfied. Choose

between Stop, Log, and Ignore.

Filter

Filters the list of messages so that only messages that contain the text you
specify will be listed. This is useful if you want to search the message text, call

stack entries, or filenames.



C-RUN runtime error checking °

Display area
The display area shows all detected errors since the last reset.
More specifically, the display area provides information in these columns:

Message

Information about the detected runtime error. Each message consists of a
headline, detailed information about the error, and call stack information for the
error location. Note that ranges displayed for accesses and bounds include the
start address but not the end address.

Source File

The name of the source file in which a runtime error was detected, or otherwise
a relevant location, for example variable definitions.

PC
The value of pc when the runtime error was detected.

Core

The CPU core that executed the check, in case you have a multicore
environment.

Context menu

This context menu is available:

Add Rule for 'Heap integrity violation' at ‘heap.c 10:3-30"
Add Rule for 'Heap integrity violation' in 'heap.c'
Add Rule for 'Heap integrity viclation'

Clear All

Save to File...

These commands are available:
Add Rule for ... at range

Adds a rule that matches this particular runtime check at this particular location.
Add Rule for ... in filename

Adds a rule that matches all runtime checks of this kind in the specified file.
Add Rule for

Adds a rule that matches all runtime checks of this kind.

Clear All

Clears the window from all content.

365



Reference information on runtime error checking

366

Save to File

Opens a dialog box where you can choose to save content to a file, either in text
or XML format.

C-RUN Messages Rules window

The C-RUN Messages Rules window is available from the View menu.

C-RUN Message Rules

Requirements

Display area

C-SPY® Debugging Guide
for Arm

*| check Source File Action
Mermory leak heap.c19:3-21 Ignare W
Heap us ace errar Neap.c a ||:] nare
Heap usage error Ignare W
* Stop W

This window displays the rules that control how messages are reported in the C-RUN
Messages window. When a potential error is detected, it is matched against these rules
(from top to bottom) and the action taken is determined by the first rule that matches. At
the bottom, there is always a catch-all rule that matches all messages. This rule can be
modified using Default action in the C-RUN Messages window.

* is used as wildcard.

See also Using C-RUN, page 341.

A license for the C-RUN product.

The display area provides information in these columns:

Check
The name of the runtime error that this rule matches.

Source File
The name of the source file and possibly the location in the file to match.

Action
The action to take for errors that match the rule:

e Stop stops the execution and logs the error.

o Log logs the error but continues the execution.
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o Ignore neither logs nor stops.

Context menu

This context menu is available:
Stop
Log
v | Ignore

Move Up

Mowve Down

Delete
Delete All

Save to File...

Load from File...

These commands are available:

Stop/Log/Ignore
Selects the action to take when a message matches the selected rule.

Move Up/Down
Moves the selected rule up/down one step.

Delete

Deletes the selected rule.

Delete All
Deletes all rules.

Save to File
Opens a dialog box where you can choose to save rules, see Load from File.
See also --rtc_rules, page 376.

Load from File

Opens a dialog box where you can choose to load rules from a file.

Compiler and linker reference for C-RUN

Reference information about:
--bounds_table_size, page 368 (linker option)
--debug_heap, page 369 (linker option)

--generate_entries_without _bounds, page 369 (compiler option)

--ignore_uninstrumented_pointers, page 369 (compiler option)
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--ignore_uninstrumented_pointers, page 370 (linker option)
--runtime_checking, page 370 (compiler option)
#pragma default no_bounds, page 371

#pragma define_with_bounds, page 371

#pragma define_without _bounds, page 371
#pragma disable_check, page 372

#pragma generate_entry without_bounds, page 372
#pragma no_arith_checks, page 373

#pragma no_bounds, page 373

__as_get base, page 373

__as_get bound, page 373

__as_make_bounds, page 374

--bounds_table_size

Syntax --bounds_table_size recordsl|:buckets] | (bytes)
Parameters
records The number of records.
:buckets The number of buckets.

(bytes) The number of bytes, within parentheses.

For use with The linker.
Description Use this linker option to specify the size of the global bounds table, which is used for
tracking the bounds of pointers in memory.

You can specify the number of records in the table (the number of pointers it can keep
bounds for). If you do, you can also specify the number of buckets (a power of two),
which will affect the speed of lookups. If not specified, the number of buckets is a power
of two that is at least 6 times the number of records.

Alternatively, you can specify the total number of bytes to use for records and buckets.

See also Detecting accesses outside the bounds of arrays and other objects, page 349.

Project>Options>Runtime Checking>Number of entries

C-SPY® Debugging Guide
368 for Arm



--debug_heap

Syntax
For use with
Description

See also

C-RUN runtime error checking °

--debug_heap
The linker.
Use this linker option to use the checked heap.

The checked heap provided by the library, page 339.
Project>Options>Runtime Checking>Use checked heap

--generate_entries_without_bounds

Syntax
For use with

Description

See also

--generate_entries_without_bounds
The compiler.

Use this compiler option to generate extra functions for use from non-instrumented
code. This option requires that out-of-bounds checking is enabled.
Detecting accesses outside the bounds of arrays and other objects, page 349.

Project>Options>Runtime Checking>Generate functions callable from
non-instrumented code

--ignore_uninstrumented_pointers

Syntax
For use with

Description

See also

--ignore_uninstrumented_pointers
The compiler.

Use this compiler option to disable checking of accesses via pointers from
non-instrumented functions.
Detecting accesses outside the bounds of arrays and other objects, page 349.

Project>Options>Runtime Checking>Check pointers from non-instrumented
functions
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--ignore_uninstrumented_pointers

Syntax
For use with

Description

See also

--runtime_checking

Syntax

Parameters

For use with

Description

C-SPY® Debugging Guide
for Arm

--ignore_uninstrumented_pointers
The linker.

Use this linker option to disable checking of accessing via pointers in memory for which
no bounds have been set.

Detecting accesses outside the bounds of arrays and other objects, page 349.

Project>Options>Runtime Checking>Check pointers from non-instrumented
memory

--runtime_checking param , param,

param is one of:

signed_overflow | Checks for signed or unsigned overflow in
unsigned_overflow integer operations.
integer_conversion | Checks for implicit or explicit integer

implicit_integer_conversion  conversions resulting in a change of value.

division_by_zero Checks for division by zero.

signed_shift | Checks for bit loss or

unsigned shift implementation-dependent results when
shifting.

switch Checks for unhandled cases in switch
statements.

bounds Checks for accesses outside the bounds of

arrays and other objects.

bounds_no_checks Tracks pointer bounds, but performs no checks.
See also #pragma disable_check =
bounds.

The compiler.

Use this compiler option to enable runtime error checking.
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See also Introduction to runtime error checking, page 337.
To set related options, choose:
Project>Options>Runtime Checking

#pragma default_no_bounds

Syntax #pragma default_no_bounds [=on|=off]

Parameters
on Makes the default for all functions declared from this point

be as if they were declared with #pragma no_bounds.

of f Turns off the default.

Description Use this pragma directive to apply #pragma no_bounds to a whole set of functions,
for example around a header file declaring the interface to unchecked code.

See also Detecting accesses outside the bounds of arrays and other objects, page 349.

#pragma define_with_bounds

Syntax #pragma define_with_bounds

Description You can only use this pragma directive on a function that is declared with
#pragma no_bounds (or equivalent). The function will then be instrumented to track
pointer bounds, but not to perform any bounds checks. Any calls to the function will be
to the version without extra bounds information.

This is useful for writing a checking version of a function based on the non-checking
version.

#pragma define_without_bounds

Syntax #pragma define_without_bounds

Description Use this pragma directive to define the version of a function that does not have extra
bounds information. The code of the function is still instrumented to track pointer
bounds (and checks are also inserted, unless #pragma disable_check = bounds is
used).
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This can be useful for functions that are exclusively called from code that does not track
pointer bounds, and where the bounds can be inferred from other arguments, or in some
other way.

Example /* p points to an array of n integers */
void fun(int * p, int n)
{
/* Set up bounds for p. */

p = __as_make_bounds (p, n);
}
#pragma disable_check
Syntax #pragma disable_check = bounds
Parameters
bounds Does not check accesses against bounds.
Description Use this pragma directive to specify that the immediately following function does not

check accesses against bounds. If compiled with bounds checking, the function will be
instrumented to track bounds, but will perform no checks.

#pragma generate_entry_without_bounds

Syntax #pragma generate_entry_without_bounds

Description Use this pragma directive to enable generation of an extra entry without bounds for the
immediately following function. This extra entry (function) can be called from code
which is not instrumented for bounds checking. It takes no extra hidden parameters, and
does not add any information about bounds for returned pointers. Any pointers passed
into such a function are given bounds that will cause an error for any access. If you use
--ignore_uninstrumented_pointers, the given bounds will not cause errors.

It is an error to use this pragma directive on a function where no such entry can be
generated. This includes functions that take a variable number of arguments, and
functions that take one or more function pointers to functions that take or return values
that contain pointers.

It is not an error to use this pragma directive on a function that does not need such an
entry (because it takes no pointers, or because it is declared with #pragma
no_bounds). In this case, no extra entry is generated.

C-SPY® Debugging Guide
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See also Detecting accesses outside the bounds of arrays and other objects, page 349.

#pragma no_arith_checks

Syntax #pragma no_arith_checks

Description Use this pragma directive to specify that no C-RUN arithmetic checks will be performed
in the function that follows.

#pragma no_bounds

Syntax #pragma no_bounds

Description Use this pragma directive to specify that the immediately following function is not
instrumented for bounds checking. No extra hidden bounds parameters will be passed
when this function is called, and it will not return bounds for pointers, if any, in its return

value.

See also Detecting accesses outside the bounds of arrays and other objects, page 349.

__as_get_base

Syntax __as_get_base(ptr)

Parameters
ptr A pointer.

Description Use this operator to create a pointer of the same type as ptr, representing the base of
the area pointed to by ptr.

Example base = __as_get_base (my_ptr) ;

__as_get_bound

Syntax __as_get_bound (ptr)

Parameters
ptr A pointer.
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Description Use this operator to create a pointer of the same type as ptr, representing the upper
bound of the area pointed to by ptr.

Example bound = __as_get_bound(ptr) ;

__as_make_bounds

Syntax __as_make_bounds (ptr, number)
__as_make_bounds (ptr, base, bound)

Parameters
ptr A pointer that has no bounds.

number The number of elements.
base The start of the object pointed to.

bound The end of the object pointed to.

Description Use this operator to create a pointer with bounds information. Use the first syntax to
create the bounds ptrup to ptr+ sizefor ptr. The second syntax has explicit bounds.
base is a pointer to the first element of the area. bound is a pointer to just beyond the
area. Except that each expression will be evaluated only once, the two-parameter variant
is equivalent to __as_make_bounds (ptr, ptr, ptr + size).

Example /* Starting here, p points to a single element */
p = __as_make_bounds(p, 1);

/* Call fun with a pointer with the specified bounds */
fun(__as_make_bounds (g, start, end));

cspybat options for C-RUN

Reference information about:
--rtc_enable, page 375
--rtc_output, page 375
--rtc_raw_to_txt, page 375

--rtc_rules, page 376

C-SPY® Debugging Guide
374  for Arm



C-RUN runtime error checking °

--rtc_enable
Syntax --rtc_enable
Note that this option must be placed before the - -backend option on the command line.

For use with cspybat

Description Use this option to enable C-RUN run-time checking in cspybat. This option is
automatically enabled if any of the other —rtc_* options are used.

This option is not available in the IDE.

--rtc_output

Syntax --rtc_output file

Note that this option must be placed before the --backend option on the command line.

Parameters
file The file for output messages.
For use with cspybat
Description Use this option to specify to cspybat a file for the C-RUN message output, in text

(filename extension txt) or XML (filename extension xm1) format.

m  This option is not available in the IDE.

--rtc_raw_to_txt
Syntax --rtc_raw_to_txt=file
Note that this option must be placed before the - -backend option on the command line.

For use with cspybat

Description Use this option to make cspybat act as a runtime checking messages filter. The option
reads a file and transforms each message into a properly formatted message (as in the
C-RUN Messages window). The only limitation is that call stack information cannot be
provided.
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--rtc_rules

C-SPY® Debugging Guide

for Arm

Syntax

Parameters

For use with
Description

See also

This option is not available in the IDE.

--rtc_rules file

Note that this option must be placed before the - -backend option on the command line.

file The rules input file.

cspybat
Use this option to specify the name of the C-RUN rules file to cspybat.

C-RUN Messages Rules window, page 366 for information about Save to File.

This option is not available in the IDE.



Part 3. Advanced
debugging

This part of the C-SPY® Debugging Guide for Arm includes these chapters:

e Multicore debugging

e Interrupts

e C-SPY macros

e The C-SPY command line utility—cspybat

e The flash loading mechanism

.hmuhhhhi
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Multicore debugging

e Introduction to multicore debugging
e Debugging multiple cores

e Reference information on multicore debugging

Introduction to multicore debugging

These topics are covered:

e Briefly about application execution
o Symmetric multicore debugging
o Asymmetric multicore debugging

o Requirements and restrictions for multicore debugging

BRIEFLY ABOUT MULTICORE DEBUGGING

Multicore debugging means that you can debug targets with multiple cores. The C-SPY
debugger supports multicore debugging in two ways:

o Symmetric multicore debugging (SMP), which means debugging two or more
identical cores. This is handled using a single instance of the IAR Embedded
Workbench IDE.

o Asymmetric multicore debugging (AMP), which means debugging two or more
cores based on different architectures. It could be two different Arm-cores, for
example a Cortex—A9 and a Cortex—MO. This is handled using two cooperating
instances of the IAR Embedded Workbench IDE.

SYMMETRIC MULTICORE DEBUGGING

Symmetric multicore debugging means that the target has two or more identical cores
on the board (usually on the same chip) that typically can be accessed through a single
debug probe.

In the debugger, at any given time the windows show the state of only one of the cores—
the one in focus.

This is an overview of special support for symmetric multicore debugging:

e You can control whether to automatically start and stop the whole application or to
run the cores independently of each other.
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® You can also control which core you want the debugger to focus on. This affects
editor windows and the Disassembly, Registers, Watch, Locals, Call Stack
window, etc.

o The Cores window shows a list of all available cores, and gives some information
about each core, such as its execution state. The Cores toolbar is a complement to
the Cores window,

o The Stack window can show the stack for each core by means of dedicated stack
sections.

o RTOS support is available in separate multicore-aware plugins, Typically, they work
like their single-core plugin counterparts, but handle multiple active tasks on
separate cores. The plugins might also provide the information required by the
Stack window to display the stack for any selected task.

ASYMMETRIC MULTICORE DEBUGGING

Asymmetric multicore means that the target has two or more cores based on different
architectures. To debug the target, two IDE instances will be used, where each instance
is connected to one or more identical cores. The two IDE instances synchronize so that
debugging sessions can be started and stopped and the cores can be controlled from
either instance. Except for shared memory, each debugging session can only show
information (variables, call stack, etc) about its own cores.

You start one IDE instance manually and that instance is referred to as the master. When
you start an asymmetric multicore debugging session, the master will initiate a second
instance—the s/ave. The slave instance will be reused if it is already running.

The master and slave each require their own project. You have to set up each project with
the correct processor variant, linker, and debugger options. The master project must also
be configured to act as multicore master or have multicore master mode enabled.

One possible strategy for download is to combine the images for the cores into one and
let the master project download the combined image. In this scenario, the slave must be
configured to attach to a running target, and/or to suppress any downloading.

Another strategy is to download the master and slave as separate binary images, in which
case you must make sure to avoid any unintentional overlaps in memory.

This is an overview of special support for asymmetric multicore debugging:

® You can control whether to automatically start and stop the whole application or to
run the cores independently of each other.

e Each instance of the IDE displays debug information for the cores that it is
connected to.
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o The Cores window shows a list of all available cores, and gives some information
about each core, such as its execution state. The Cores toolbar is a complement to
the Cores window,

e When you set a breakpoint it is connected to one core only and when the breakpoint
is triggered, that core is stopped.

REQUIREMENTS AND RESTRICTIONS FOR MULTICORE
DEBUGGING

The C-SPY simulator supports multicore debugging and there are no specific
requirements or restrictions.

To use multicore debugging in your hardware debugger system, you need a specific
combination of C-SPY driver and debug probe:

o The IAR C-SPY I-jet/JTAGjet driver
o An I-jet, I-jet Trace, JTAGjet, or JTAGjet-Trace debug probe

Note: There might be restrictions in trace support due to limitations in the hardware you
are using.

Debugging multiple cores

These tasks are covered:

e Setting up for symmetric multicore debugging
e Setting up for asymmetric multicore debugging

e Starting and stopping a multicore debug session

SETTING UP FOR SYMMETRIC MULTICORE DEBUGGING

I Choose Project>Options>Debugger>Multicore and specify the number of cores you
have.

2 You can now start your debug session.

SETTING UP FOR ASYMMETRIC MULTICORE DEBUGGING

There are a number of ways that you can set up for multicore debugging, but this strategy
is recommended:

I Create a workspace with two projects, one for each core or set of cores.

2 In the intended master project, choose Project>Options>Debugger>Multicore to
open the Multicore options page.
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3 Select Enable multicore master mode. Specify the options Slave workspace (path),

Slave project (project name), and Slave configuration (build configuration). These
settings are used when the slave session starts.

Mutticore

Symmetric multicore

Number of cores: 1

Asymmetric multicore

Enable multicore master mode
Port: 53461
Slave workspace: SWS_DIRS\dual_core.eww E]
Slave project: Slave

Slave configuration: Debug

[ Attach slave to running target Slave cores: 1

4 Select the option Attach slave to running target. Use the Slave cores option to
specify the number of cores in the slave project.

5 Select appropriate reset strategies for both projects:

o In the master project, choose Project>Options>C-SPY driver>Setup>Reset and
select a reset strategy, typically Hardware

o In the Workspace window, switch to the slave project. Then choose
Project>Options>C-SPY driver>Setup>Reset and select a reset strategy for the
slave session that does not affect the master session, typically Software.

Make sure to use compatible settings for the debug probe for both projects.

The master and slave instances are indicated in the main IDE window title bar.

& dual_cor@ﬂ Embedded Workbench IDE
File Edit View Project I[-jet/JTAGjet Tools Window Help

s=R=N=1=] | |

Workspace g~ —
3 dual_cof@ - Slave - IR Embedded Workbench IDE
[ dual_core_to

File Edit View Project

- Tools
Files

B Fauad[ D == ==y

& dud Workspace
I—EJ  du [slave_m4_proxy - SRAM

I DE Files
|
|

b= B @l dual_care
14 () dual_care_m4_tower - SRk

C-SPY® Debugging Guide
382 for Arm



Multicore debugging ___4

STARTING AND STOPPING A MULTICORE DEBUG SESSION

I To start a multicore debug session, for example use the standard Download and
Debug command, either in the master or slave session.

2 To stop a multicore debug session, for example use the standard Stop Debugging
command, which will stop both debugging sessions.

Reference information on multicore debugging

Reference information about:
o Cores window, page 383
o Cores toolbar, page 386
See also:

o  getSelectedCore, page 442
o _ selectCore, page 465

Cores window

The Cores window is available from the View menu.

s 22020202020 =)

Core Status PC Cycles
= 0:mcu Stopped 0x0000612C 0
8 1:mcu Stopped 0x0000612C 0

This window shows a list of all available cores, and gives some information about each
core, such as its execution state. The line highlighted in bold is the core currently in
focus, which means that any window showing information that is specific to a core will
be updated to reflect the state of the core in focus. This includes highlights in editor
windows and the Disassembly, Registers, Watch, Locals, Call Stack window, etc.
Double-click a line to focus on that core.

Note: For asymmetric multicore debugging, only the local core can be in focus.

If both cores are executing, and either one of them hits a breakpoint (or some other
condition which causes the program execution to stop), then the debugger attempts to
focus on that core automatically.

See also Debugging multiple cores, page 381.
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One of these alternatives:

o The C-SPY simulator
o An I-jet, I-jet Trace, JTAGjet, or JTAGjet-Trace debug probe.

A row in this area shows information about a core, in these columns:
Execution state
Displays one of these icons to indicate the execution state of the core.
in focus, not executing
not in focus, not executing
in focus, executing
not in focus, executing
in focus, in sleep mode
not in focus, in sleep mode

in focus, unknown status

Ho#oEMol

not in focus, unknown status

Core
The name of the core.

Status
The status of the execution, which can be one of Stopped, Running, Sleeping,
or Unknown.

PC

The value of the program counter.

Cycles | Time
The value of the cycle counter or the execution time since the start of the
execution, depending on the debugger driver you are using.
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Context menu

For symmetric multicore debugging, this context menu is available:
Start Core
Stop Core

Focus on Core (also double-click)

v | Run/Step/Stop affect all cores

Run/Step/Stop affect current core only
These commands are available:

Start Core

Starts the selected core.

Stop Core
Stops the selected core.

Focus on Core (also double-click)
Focuses on the selected core.

Run/Step/Stop affect all cores
The Run, Step, Stop commands affect all cores.

Run/Step/Stop affect current core only

The Run/Step/Stop commands affect only the current core. This menu
command is only supported if your device supports it.

Note: These commands are not supported by all target hardware.
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The Cores toolbar is available from the View menu if you have enabled multicore
debugging, see Setting up for symmetric multicore debugging, page 381 or Setting up
for asymmetric multicore debugging, page 381, respectively.

Execution state

Run/Step/Stop
for core 0

affect all cores

Start all cores

U:EY 1:¢>'I.-... W [::]

Commands for
starting/stopping
core 0

Stop all cores

This toolbar is a complement to and shows the same state as the Cores window. Each
core has a button with an adjacent drop-down menu. Click a button to make C-SPY
focus on that core.

Note: For asymmetric multicore debugging, you can use the toolbar commands to start
and stop cores in the associated debugging session.
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e Introduction to interrupts
e Using the interrupt system

e Reference information on interrupts

Introduction to interrupts

These topics are covered:

Briefly about the interrupt simulation system
Interrupt characteristics

Interrupt simulation states

C-SPY system macros for interrupt simulation

Target-adapting the interrupt simulation system

Briefly about interrupt logging
See also:
® Reference information on C-SPY system macros, page 430

® Breakpoints, page 119
o The IAR C/C++ Development Guide for Arm

BRIEFLY ABOUT THE INTERRUPT SIMULATION SYSTEM

By simulating interrupts, you can test the logic of your interrupt service routines and

debug the interrupt handling in the target system long before any hardware is available.
If you use simulated interrupts in conjunction with C-SPY macros and breakpoints, you
can compose a complex simulation of, for instance, interrupt-driven peripheral devices.

The C-SPY Simulator includes an interrupt simulation system where you can simulate
the execution of interrupts during debugging. You can configure the interrupt simulation
system so that it resembles your hardware interrupt system.

The interrupt system has the following features:

e Simulated interrupt support for the Arm core
e Single-occasion or periodical interrupts based on the cycle counter

e Predefined interrupts for various devices
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o Configuration of hold time, probability, and timing variation
State information for locating timing problems

Configuration of interrupts using a dialog box or a C-SPY system macro—that is,
one interactive and one automating interface. In addition, you can instantly force an
interrupt.

o A log window that continuously displays events for each defined interrupt.
o A status window that shows the current interrupt activities.
All interrupts you define using the Interrupt Configuration window are preserved

between debug sessions, unless you remove them. A forced interrupt, on the other hand,
exists only until it has been serviced and is not preserved between sessions.

The interrupt simulation system is activated by default, but if not required, you can turn
off the interrupt simulation system to speed up the simulation. To turn it off, use either
the Interrupt Configuration window or a system macro.

INTERRUPT CHARACTERISTICS

The simulated interrupts consist of a set of characteristics which lets you fine-tune each
interrupt to make it resemble the real interrupt on your target hardware. You can specify
a first activation time, a repeat interval, a hold time, a variance, and a probability.

H H H
Activation | |_‘ |_|—| | | |
signal } I | I I
F‘meI ] | | | l |
cycles
B Ton ot wt it
A A+R A+2R A+3R

*If probability is less than 100%, some interrupts may be omitted.

A = Activation time
R = Repeat interval
H =Hold time

Y =Variance

The interrupt simulation system uses the cycle counter as a clock to determine when an
interrupt should be raised in the simulator. You specify the first activation time, which
is based on the cycle counter. C-SPY will generate an interrupt when the cycle counter
has passed the specified activation time. However, interrupts can only be raised between
instructions, which means that a full assembler instruction must have been executed
before the interrupt is generated, regardless of how many cycles an instruction takes.

To define the periodicity of the interrupt generation you can specify the repeat interval
which defines the amount of cycles after which a new interrupt should be generated. In
addition to the repeat interval, the periodicity depends on the two options probability—
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the probability, in percent, that the interrupt will actually appear in a period—and
variance—a time variation range as a percentage of the repeat interval. These options
make it possible to randomize the interrupt simulation. You can also specify a hold time
which describes how long the interrupt remains pending until removed if it has not been
processed. If the hold time is set to infinite, the corresponding pending bit will be set
until the interrupt is acknowledged or removed.

INTERRUPT SIMULATION STATES

The interrupt simulation system contains status information that you can use for locating
timing problems in your application. The Interrupt Status window displays the
available status information. For an interrupt, these states can be displayed: /dle,
Pending, Executing, or Suspended.

Normally, a repeatable interrupt has a specified repeat interval that is longer than the
execution time. In this case, the status information at different times looks like this:

Hold time
- >
| T
interrupe. A | B : C D: E F : G| H
activation | I \ R
signal | I |
I*—lvl Iq
Execution time for
interrupt handler Time Status
A Idle
B Pending
D Executing
E Idle
F Pending
G, H Executing

Note: The interrupt activation signal—also known as the pending bit—is automatically
deactivated the moment the interrupt is acknowledged by the interrupt handler.
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However, if the interrupt repeat interval is shorter than the execution time, and the
interrupt is reentrant (or non-maskable), the status information at different times looks
like this:

Hold time
-
T

I |
Interrupt AlBy C b Ey F G
activation : ! L
signal i !

i

Execution time for

interrupt invocation (1) Execution time for

interrupt invocation (2)

Time Status
A Idle
B Pending

CDE Executing
FG 1st interrupt: Suspended
2nd interrupt: Executing

An execution time that is longer than the repeat interval might indicate that you should
rewrite your interrupt handler and make it faster, or that you should specify a longer
repeat interval for the interrupt simulation system.

C-SPY SYSTEM MACROS FOR INTERRUPT SIMULATION

Macros are useful when you already have sorted out the details of the simulated interrupt
so that it fully meets your requirements. If you write a macro function containing
definitions for the simulated interrupts, you can execute the functions automatically
when C-SPY starts. Another advantage is that your simulated interrupt definitions will
be documented if you use macro files, and if you are several engineers involved in the
development project you can share the macro files within the group.

The C-SPY Simulator provides these predefined system macros related to interrupts:
__enableInterrupts

__disableInterrupts

__orderInterrupt

__cancelInterrupt

__cancelAllInterrupts

__popSimulatorInterruptExecutingStack

The parameters of the first five macros correspond to the equivalent entries of the
Interrupt Configuration window.
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For more information about each macro, see Reference information on C-SPY system
macros, page 430.

TARGET-ADAPTING THE INTERRUPT SIMULATION SYSTEM

The interrupt simulation system is easy to use. However, to take full advantage of the
interrupt simulation system you should be familiar with how to adapt it for the processor
you are using.

The interrupt simulation has the same behavior as the hardware. This means that the
execution of an interrupt is dependent on the status of the global interrupt enable bit. The
execution of maskable interrupts is also dependent on the status of the individual
interrupt enable bits.

To simulate device-specific interrupts, the interrupt system must have detailed
information about each available interrupt. This information is provided in the device
description files.

For information about device description files, see Selecting a device description file,
page 53.

BRIEFLY ABOUT INTERRUPT LOGGING

Interrupt logging provides you with comprehensive information about the interrupt
events. This might be useful for example, to help you locate which interrupts you can
fine-tune to become faster. You can log entrances and exits to and from interrupts. If you
are using the C-SPY simulator, you can also log internal interrupt status information,
such as triggered, expired, etc. In the IDE:

e The logs are displayed in the Interrupt Log window

e A summary is available in the Interrupt Log Summary window

o The Interrupt graph in the Timeline window provides a graphical view of the
interrupt events during the execution of your application.

Requirements for interrupt logging

Interrupt logging is supported by the C-SPY simulator.

To use interrupt logging you need a Cortex-M device. You also need one of these
alternatives:

o An I-jet or I-jet Trace in-circuit debugging probe or a JTAGjet debug probe, and an
SWD interface between the debug probe and the target system

o A J-Link or J-Trace debug probe and an SWD interface between the debug probe
and the target system
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o An ST-LINK debug probe and an SWD interface between the debug probe and the
target system

o A TI XDS debug probe and an SWD interface between the debug probe and the
target system

See also Getting started using interrupt logging, page 395.

Using the interrupt system

C-SPY® Debugging Guide
for Arm

These tasks are covered:

o Simulating a simple interrupt
o Simulating an interrupt in a multi-task system
o Getting started using interrupt logging.

See also:

o Using C-SPY macros, page 415 for details about how to use a setup file to define
simulated interrupts at C-SPY startup

e The tutorial Simulating an interrupt in the Information Center.

SIMULATING A SIMPLE INTERRUPT

This example demonstrates the method for simulating a timer interrupt. However, the
procedure can also be used for other types of interrupts.
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To simulate and debug an interrupt:

I Assume this simple application which contains an IRQ handler routine that handles
system timer interrupts. It increments a tick variable. The main function sets the
necessary status registers. The application exits when 100 interrupts have been
generated.

/* Enables use of extended keywords */
#pragma language=extended

#include <intrinsics.h>
#include <stdio.h>

unsigned int ticks = 0;

/* IRQ handler */
#if __ARM_PROFILE_M _
/* Defines an interrupt handler for the Cortex-M UART interrupt.
*/
void UART_Handler ()
#else
/* Defines an interrupt handler for other cores. */
__irg __arm void IRQ_Handler (void)
#endif
{
/* We use only system timer interrupts, so we do not need
to check the interrupt source. */
ticks += 1;
TMOVFR_bit.OVF = 1; /* Clear system timer overflow flag */

int main( void )

{
__enable_interrupt();
/* Timer setup code */

ILCO_bit.ILRO = 4; /* System timer interrupt priority */
TMRLR_bit.TMRLR = 1E5; /* System timer reload value */
TMEN_bit.TCEN = 1; /* Enable system timer */

while (ticks < 100);
printf ("Done\n") ;

}

2 Add your interrupt service routine to your application source code and add the file to
your project.

3 Build your project and start the simulator.
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Choose Simulator>Interrupt Configuration to open the Interrupt Configuration
window. Right-click in the window and select Enable Interrupt Simulation on the
context menu. For the timer example, verify these settings:

Option Settings
Interrupt IRQ
First activation 4000
Repeat interval 2000
Hold time 10
Probability (%) 100
Variance (%) 0

Table 15: Timer interrupt settings
Click OK.

Execute your application. If you have enabled the interrupt properly in your application
source code, C-SPY will:

o Generate an interrupt when the cycle counter has passed 4000

o Continuously repeat the interrupt after approximately 2000 cycles.

To watch the interrupt in action, choose Simulator>Interrupt Log to open the
Interrupt Log window.

From the context menu, available in the Interrupt Log window, choose Enable to
enable the logging. If you restart program execution, status information about
entrances and exits to and from interrupts will now appear in the Interrupt Log
window.

For information about how to get a graphical representation of the interrupts correlated
with a time axis, see Timeline window—Interrupt Log graph, page 408.

SIMULATING AN INTERRUPT IN A MULTI-TASK SYSTEM

If you are using interrupts in such a way that the normal instruction used for returning
from an interrupt handler is not used, for example in an operating system with
task-switching, the simulator cannot automatically detect that the interrupt has finished
executing. The interrupt simulation system will work correctly, but the status
information in the Interrupt Configuration window might not look as you expect. If
too many interrupts are executing simultaneously, a warning might be issued.

To simulate a normal interrupt exit:

Set a code breakpoint on the instruction that returns from the interrupt function.
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2 Specify the __popSimulatorInterruptExecutingStack macro as a condition to
the breakpoint.

When the breakpoint is triggered, the macro is executed and then the application
continues to execute automatically.

GETTING STARTED USING INTERRUPT LOGGING

I To set up for interrupt logging, choose C-SPY driver>SWO Configuration. In the
dialog box, set up the serial-wire output communication channel for trace data. Note
specifically the CPU clock option. The CPU clock can also be set up on the
Project>Options>ST-LINK>Communication page and the
Project>Options>TI XDS>Communication page, respectively.

For the C-SPY simulator, no specific settings are required.

2 Choose C-SPY driver>Interrupt Log to open the Interrupt Log window. Optionally,
you can also choose:

o C-SPY driver>Interrupt Log Summary to open the Interrupt Log Summary
window

o C-SPY driver>Timeline to open the Timeline window and view the Interrupt
graph.

3 From the context menu in the Interrupt Log window, choose Enable to enable the

logging.

In the SWO Configuration dialog box, you can see in the Interrupt Log Events area

that interrupt logs are enabled.

4 Start executing your application program to collect the log information.

To view the interrupt log information, look in the Interrupt Log or Interrupt Log
Summary window, or at the Interrupt graph in the Timeline window.

6 1If you want to save the log or summary to a file, choose Save to log file from the
context menu in the window in question.

7 To disable interrupt logging, from the context menu in the Interrupt Log window,
toggle Enable off.

Reference information on interrupts
Reference information about:

o Interrupt Configuration window, page 396
® Available Interrupts window, page 399
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Interrupt Status window, page 400
Interrupt Log window, page 402
Interrupt Log Summary window, page 406.

Timeline window—Interrupt Log graph, page 408.

Interrupt Configuration window
The Interrupt Configuration window is available by choosing Simulator>Interrupt

Configuration.
Interrupt Configuration x
Interrupt Id Type Description First Activation  RepeatInterval  Hold Time Yariance (%) Probability (%)
7] NI 0 Single -2 0x08 0 0 inf 0 100
V| IELO 1 Single 1 0x40 0 0 inf 0 100
V| HardFault 2 Single -1 0x0C PRIL.. 0 0 inf 0 100

| Build | Debug Log | Interrupt Configuration |

This window lists all installed interrupts. Use this window to enable or disable
individual interrupts or the interrupt simulation system, and to edit the properties of
installed interrupts.

See also Using the interrupt system, page 392.

Requirements
The C-SPY simulator.

Display area
This area contains these columns:

Interrupt
Lists all installed interrupts. Use the checkbox to enable or disable the interrupt.

ID
A unique interrupt identifier.

C-SPY® Debugging Guide
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Type
Shows the type of the interrupt. The type can be one of:

Forced, a single-occasion interrupt defined in the Available Interrupts
window.

Single, a single-occasion interrupt.
Repeat, a periodically occurring interrupt.

If the interrupt has been set from a C-SPY macro, the additional part (macro) is
added, for example: Repeat(macro).

Description

A description of the selected interrupt, if available. The description is retrieved
from the selected device description file and consists of a string describing the
priority, vector offset, enable bit, and pending bit, separated by space characters.
The enable bit and pending bit are optional. It is possible to have none, only the
enable bit, or both. For interrupts specified using the system macro
__orderInterrupt, the Description box is empty.

For Cortex-M devices, the description is retrieved from the selected device
description file and is editable. Enable bit and pending bit are not available from
the ddf file; they must be manually edited if wanted. The priority is as in the
hardware: the lower the number, the higher the priority. NMI and HardFault are
special, and their descriptions should not be edited. Cortex-M interrupts are also
affected by the PRIMASK, FAULTMASK, and BASEPRI registers, as described in
the Arm documentation.

For other devices, the description strings for IRQ and FIQ are hardcoded and
cannot be edited. In those descriptions, a higher priority number means a higher
priority.

First activation
The value of the cycle counter after which the specified interrupt will be
generated. Click to edit.

Repeat interval
The periodicity of the interrupt in cycles. Click to edit.

Hold time

How long, in cycles, the interrupt remains pending until removed if it has not
been processed. Click to edit. If you specify inf, the corresponding pending bit
will be set until the interrupt is acknowledged or removed.
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Variance %
A timing variation range, as a percentage of the repeat interval, in which the
interrupt might occur for a period. For example, if the repeat interval is 100 and
the variance 5%, the interrupt might occur anywhere between T=95 and T=105,
to simulate a variation in the timing. Click to edit.

Probability %

The probability, in percent, that the interrupt will actually occur within the
specified period. Click to edit.

Context menu
This context menu is available:
v | Enable Interrupt Simulation
IELO:
v Enable

Rermove

Add Interrupt 3

Rermove All

Open Available Interrupts Window

These commands are available:

Enable Interrupt Simulation
Enables or disables the entire interrupt simulation system. If the interrupt
simulation is disabled, the definitions remain but no interrupts are generated.
Note that you can also enable and disable installed interrupts individually by
using the check box to the left of the interrupt name in the list of installed
interrupts.

Enable
Enables or disables the individual interrupt you clicked on.

Remove
Removes the individual interrupt you clicked on.

Add Interrupt
Selects an interrupt to install. The drop-down list contains all available
interrupts. Your selection will automatically update the Description box. The
list is, for Cortex-M devices, populated with entries from the device description
file that you have selected. For other devices, only two interrupts are available:
IRQ and FIQ.

Remove All

Removes all installed interrupts in the window.

C-SPY® Debugging Guide
398 for Arm



Interrupts °

Open Available Interrupts Window

Opens the Available Interrupts window, see Available Interrupts window, page
399.

Available Interrupts window
The Available Interrupts window is available from the C-SPY driver menu.

Available Interrupts x
Interrupt Description i
IELSZ 10x1B0
IELS3 10x1B4
IEL34 10x1B8
IELS5 10<1BC
Memianage 10x10
Tl -2 0=08
PendSy 1038
SWC 10x2C
SysTick 10x3C
UsageFault 10x18 i

Use this window for an overview of all available interrupts for your project. You can also
use it for forcing an interrupt instantly. This is useful when you want to check your
interrupt logic and interrupt routines. Just start typing an interrupt name and focus shifts
to the first line found with that name.

The hold time for a forced interrupt is infinite, and the interrupt exists until it has been
serviced or until a reset of the debug session.

To sort the window contents, click on either the Interrupt or the Description column
header. A second click on the same column header reverses the sort order.

To force an interrupt:
I Enable the interrupt simulation system, see Interrupt Configuration window, page 396.
2 Activate the interrupt by using the Force Interrupt command available on the context

menu.

Requirements
The C-SPY simulator.

Display area

This area lists all available interrupts and their definitions. This information is retrieved
from the selected device description file. See this file for a detailed description.
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Context menu

This context menu is available:
Add to Configuration

Force Interrupt

Open Configuration Window

These commands are available:

Add to Configuration

Installs the selected interrupt and adds it to the Interrupt Configuration
window.

Force Interrupt

Triggers the selected interrupt.

Open Configuration Window

Opens the Interrupt Configuration window, see Interrupt Configuration
window, page 396.

Interrupt Status window

The Interrupt Status window is available from the C-SPY driver menu.

Interrupt Status * O X
Interrupt D Type Status Mext Time Timing [eycles]
TIM_INT 1 Single Idle o 0
MNRAI 0 Single Idle 0 0
SClo_lo 2 Repeat{macra) Idle 4000 4000 + n*2000

This window shows the status of all the currently active interrupts, in other words
interrupts that are either executing or waiting to be executed.
Requirements

The C-SPY simulator.

Display area
This area contains these columns:

Interrupt
Lists all interrupts.

C-SPY® Debugging Guide
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ID
A unique interrupt identifier.
Type
The type of the interrupt. The type can be one of:
Forced, a single-occasion interrupt defined in the Available Interrupts
window.
Single, a single-occasion interrupt.
Repeat, a periodically occurring interrupt.
If the interrupt has been set from a C-SPY macro, the additional part (macro) is
added, for example: Repeat(macro).
Status
The state of the interrupt:
Idle, the interrupt activation signal is low (deactivated).
Pending, the interrupt activation signal is active, but the interrupt has not been
yet acknowledged by the interrupt handler.
Executing, the interrupt is currently being serviced, that is the interrupt handler
function is executing.
Suspended, the interrupt is currently suspended due to execution of an interrupt
with a higher priority.
(deleted) is added to Executing and Suspended if you have deleted a currently
active interrupt. (deleted) is removed when the interrupt has finished executing.
Next Time
The next time an idle interrupt is triggered. Once a repeatable interrupt stats
executing, a copy of the interrupt will appear with the state Idle and the next time
set. For interrupts that do not have a next time—that is pending, executing, or
suspended—the column will show --.
Timing

The timing of the interrupt. For a Single and Forced interrupt, the activation
time is displayed. For a Repeat interrupt, the information has the form:
Activation Time + n*Repeat Time. For example, 2000 + n*2345. This
means that the first time this interrupt is triggered, is at 2000 cycles and after that
with an interval of 2345 cycles.
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Interrupt Log window

Requirements
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The Interrupt Log window is available from the C-SPY driver menu.

Interrupt Log *®
Time  Interrupt Status Frogram Counter Execution Time i
189.32 us IRQTO Triggered Bx13E8
111.26 us IRQTO Enter Bx13F@
135.78 us IRQT1 Enter Bx1126
148.72 us IRQT1 Leave Bx1378 12.94 us
189.34 us Overflow
29?:’-_39 us  IRQTO Leave Bx1126 96.84 us
230.00 us IRQTO Triggered 9x1118
231.34 us IRQTO Enter 0x1126
248.26\us IRQTO Leave Bx1122 . 8.92 us
300.00 s IRQTL Enter . ---
371.12 L,Ii"& IRQT1 Leave N, Bx1128 \71.12 us
431.3@ ud_ IROTI Enter - -
\ -
Red indicates overflows Light-celored rows !:)Larker =
and italic indicates indicate entrances indicate exits
approximate values to interrupts from interrupts J

This window logs entrances to and exits from interrupts. The C-SPY simulator also logs
internal state changes.

The information is useful for debugging the interrupt handling in the target system.
When the Interrupt Log window is open, it is updated continuously at runtime.

Note: There is a limit on the number of saved logs. When this limit is exceeded, the
oldest entries in the buffer are erased.

For more information, see Getting started using interrupt logging, page 395.

For information about how to get a graphical view of the interrupt events during the
execution of your application, see Timeline window—Interrupt Log graph, page 408.

One of these alternatives:

The C-SPY simulator

An I-jet or I-jet Trace in-circuit debugging probe or a JTAGjet debug probe, and an
SWD interface between the debug probe and the target system

o A J-Link or J-Trace debug probe with an SWD interface between the debug probe
and the target system

o An ST-LINK debug probe with an SWD interface between the debug probe and the
target system
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o A TI XDS debug probe and an SWD interface between the debug probe and the
target system.

Display area for the C-SPY hardware debugger drivers
This area contains these columns:
Time
The time for the interrupt entrance, based on the CPU clock frequency specified

in the SWO Configuration dialog box.

If a time is displayed in italics, the target system has not been able to collect a
correct time, but instead had to approximate it.

This column is available when you have selected Show Time from the context
menu. If the Show Time command is not available, the Time column is
displayed by default.

Cycles
The number of cycles from the start of the execution until the event.
A cycle count displayed in italics indicates an approximative value. Italics is

used when the target system has not been able to collect a correct value, but
instead had to approximate it.

This column is available when you have selected Show Cycles from the context
menu provided that the C-SPY driver you are using supports it.
Interrupt

The name of the interrupt source where the interrupt occurred. If the column
displays Overflow in red, the communication channel failed to transmit all
interrupt logs from the target system.

Status
The event status of the interrupt:

Enter, the interrupt is currently executing.
Leave, the interrupt has finished executing.

Program Counter*
The address of the interrupt handler.

Execution Time/Cycles

The time spent in the interrupt, calculated using the Enter and Leave
timestamps. This includes time spent in any subroutines or other interrupts that
occurred in the specific interrupt.
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*You can double-click an address. If it is available in the source code, the editor window
displays the corresponding source code, for example for the interrupt handler (this does
not include library source code).

Display area for the C-SPY simulator
This area contains these columns:
Time

The time for the interrupt entrance, based on an internally specified clock
frequency.

This column is available when you have selected Show Time from the context
menu.

Cycles
The number of cycles from the start of the execution until the event.

This column is available when you have selected Show Cycles from the context
menu.

Interrupt
The interrupt as defined in the device description file.

Status
Shows the event status of the interrupt:

Triggered, the interrupt has passed its activation time.

Forced, the same as Triggered, but the interrupt was forced from the Available
Interrupts window.

Enter, the interrupt is currently executing.
Leave, the interrupt has been executed.

Expired, the interrupt hold time has expired without the interrupt being
executed.

Rejected, the interrupt has been rejected because the necessary interrupt
registers were not set up to accept the interrupt.

Program Counter
The value of the program counter when the event occurred.

Execution Time/Cycles
The time spent in the interrupt, calculated using the Enter and Leave
timestamps. This includes time spent in any subroutines or other interrupts that
occurred in the specific interrupt.

C-SPY® Debugging Guide
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Context menu

This context menu is available:
v Enable

Clear

Save to File...

v | Show Time
Show Cycles

These commands are available:

Enable
Enables the logging system. The system will log information also when the
window is closed.

Clear
Deletes the log information. Note that this will happen also when you reset the
debugger.

Save to File
Displays a standard file selection dialog box where you can select the
destination file for the log information. The entries in the log file are separated
by TaB and LF characters. An X in the Approx column indicates that the
timestamp is an approximation.

Show Time
Displays the Time column.
If the Time column is displayed by default in the C-SPY driver you are using,
this menu command is not available.

Show Cycles
Displays the Cycles column.

If the Cyecles column is not supported in the C-SPY driver you are using, this
menu command is not available.
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Interrupt Log Summary window

Interrupt Log Summary

The Interrupt Log Summary window is available from the C-SPY driver menu.

Approximative time count. 1
Cwerflow count. 1
Currenttime:  3350.080us us

*®
Interrupt Count First Time  Total (Time)  Total (>4) Fastest Slowest in Intersal Max Interval
ADC 5 25 . 560us 95 . 400us 17 .61 16.320us 30.120us 192 640us 1284 . 100us
RTC 4 41 . 700us 55.200us 22 BB 13.800us 13.800us 27 .060us 2687 . 420us

Requirements

This window displays a summary of logs of entrances to and exits from interrupts.
For more information, see Getting started using interrupt logging, page 395.

For information about how to get a graphical view of the interrupt events during the
execution of your application, see Timeline window—Interrupt Log graph, page 408.

One of these alternatives:

o The C-SPY simulator

® An I-jet or I-jet Trace in-circuit debugging probe or a JTAGjet debug probe, and an
SWD interface between the debug probe and the target system

o A J-Link or J-Trace debug probe with an SWD interface between the debug probe
and the target system

o An ST-LINK debug probe with an SWD interface between the debug probe and the
target system

o A TI XDS debug probe and an SWD interface between the debug probe and the
target system.

Display area for the C-SPY simulator

C-SPY® Debugging Guide
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Each row in this area displays statistics about the specific interrupt based on the log
information in these columns:
Interrupt

The type of interrupt that occurred.

At the bottom of the column, the current time or cycles is displayed—the

number of cycles or the execution time since the start of execution. Overflow
count and approximative time count is always zero.
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Count

The number of times the interrupt occurred.

First time
The first time the interrupt was executed.

Total (Time)**
The accumulated time spent in the interrupt.

Total (%)
The time in percent of the current time.

Fastest**

The fastest execution of a single interrupt of this type.

Slowest**
The slowest execution of a single interrupt of this type.
Min interval
The shortest time between two interrupts of this type.
The interval is specified as the time interval between the entry time for two
consecutive interrupts.
Max interval
The longest time between two interrupts of this type.

The interval is specified as the time interval between the entry time for two
consecutive interrupts.

** Calculated in the same way as for the Execution time/cycles in the Interrupt Log
window.

Context menu

This context menu is available:
v Enable

Clear

Save to File...
v Show Time
Show Cycles

These commands are available:

Enable

Enables the logging system. The system will log information also when the
window is closed.
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Clear
Deletes the log information. Note that this will happen also when you reset the
debugger.

Save to File
Displays a standard file selection dialog box where you can select the
destination file for the log information. The entries in the log file are separated
by TaB and LF characters. An X in the Approx column indicates that the
timestamp is an approximation.

Show Time
Displays the Time column.
If the Time column is displayed by default in the C-SPY driver you are using,
this menu command is not available.
Show Cycles
Displays the Cycles column.

If the Cyeles column is not supported in the C-SPY driver you are using, this
menu command is not available.

Timeline window—Interrupt Log graph

The Interrupt Log graph displays interrupts collected by the trace system. In other
words, the graph provides a graphical view of the interrupt events during the execution
of your application.

Active interrupt l |Overf|ow |
Timeline ...\_ V4 X
— — O
= ' T
L T

2.00815s 8.000208s 8.00025s 8.000308s 8.90835s

Commaon time axis

Note: There is a limit on the number of saved logs. When this limit is exceeded, the
oldest entries in the buffer are erased.

Display area
o The label area at the left end of the graph displays the names of the interrupts.

C-SPY® Debugging Guide
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The graph itself shows active interrupts as a thick green horizontal bar where the
white figure indicates the time spent in the interrupt. This graph is a graphical
representation of the information in the Interrupt Log window, see Interrupt Log
window, page 402.

If the bar is displayed without horizontal borders, there are two possible causes:

o The interrupt is reentrant and has interrupted itself. Only the innermost interrupt
will have borders.

o There are irregularities in the interrupt enter-leave sequence, probably due to
missing logs.

If the bar is displayed without a vertical border, the missing border indicates an

approximate time for the log.

A red vertical line indicates overflow, which means that the communication channel

failed to transmit all interrupt logs from the target system.

At the bottom of the window, there is a common time axis that uses seconds as the time
unit.

This context menu is available:

MNavigate 3
Auto Scroll

Zoom 3
Interrupts

Enable

Clear

Go to Source

Sort by 3
IRQTO: 2
Select Graphs 3
Tirme Axis Unit 3

Note: The exact contents of the context menu you see on the screen depends on which
features that your combination of software and hardware supports. However, the list of
menu commands below is complete and covers all possible commands.

These commands are available:

Navigate

Commands for navigating the graph(s). Choose between:

Next moves the selection to the next relevant point in the graph. Shortcut key:
right arrow.
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Previous moves the selection backward to the previous relevant point in the
graph. Shortcut key: left arrow.

First moves the selection to the first data entry in the graph. Shortcut key:
Home.

Last moves the selection to the last data entry in the graph. Shortcut key: End.

End moves the selection to the last data in any displayed graph, in other words
the end of the time axis. Shortcut key: Ctrl+End.

Auto Scroll
Toggles automatic scrolling on or off. When on, the most recently collected data
is automatically displayed when you choose Navigate>End.

Zoom
Commands for zooming the window, in other words, changing the time scale.

Choose between:

Zoom to Selection makes the current selection fit the window. Shortcut key:
Return.

Zoom In zooms in on the time scale. Shortcut key: +
Zoom Out zooms out on the time scale. Shortcut key: —

10ns, 100ns, 1us, etc makes an interval of 10 nanoseconds, 100 nanoseconds, 1
microsecond, respectively, fit the window.

1ms, 10ms, etc makes an interval of 1 millisecond or 10 milliseconds,
respectively, fit the window.

10m, 1h, etc makes an interval of 10 minutes or 1 hour, respectively, fit the
window.

Interrupt

A heading that shows that the Interrupt Log-specific commands below are
available.

Enable

Toggles the display of the graph on or off. If you disable a graph, that graph will
be indicated as OFF in the window. If no data has been collected for a graph, no
data will appear instead of the graph.

Clear

Deletes the log information. Note that this will happen also when you reset the
debugger.

C-SPY® Debugging Guide
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Go To Source
Displays the corresponding source code in an editor window, if applicable.

Sort by
Sorts the entries according to their ID or name. The selected order is used in the
graph when new interrupts appear.

source

Goes to the previous/next log for the selected source.

Select Graphs
Selects which graphs to be displayed in the Timeline window.

Time Axis Unit
Selects the unit used in the time axis; choose between Seconds and Cycles.

If Cycles is not available, the graphs are based on different clock sources. In that
case you can view cycle values as tooltip information by pointing at the graph
with your mouse pointer.
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C-SPY macros

e Introduction to C-SPY macros

e Using C-SPY macros

e Reference information on the macro language

e Reference information on reserved setup macro function names
e Reference information on C-SPY system macros

e Graphical environment for macros

Introduction to C-SPY macros

These topics are covered:

o Reasons for using C-SPY macros
e Briefly about using C-SPY macros
e Briefly about setup macro functions and files

e Briefly about the macro language

REASONS FOR USING C-SPY MACROS

You can use C-SPY macros either by themselves or in conjunction with complex
breakpoints and interrupt simulation to perform a wide variety of tasks. Some examples
where macros can be useful:

o Automating the debug session, for instance with trace printouts, printing values of
variables, and setting breakpoints.

e Hardware configuring, such as initializing hardware registers.

e Feeding your application with simulated data during runtime.

o Simulating peripheral devices, see the chapter /nterrupts. This only applies if you
are using the simulator driver.

o Developing small debug utility functions, for instance calculating the stack depth,
see the provided example stack.mac located in the directory \arm\src\.
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BRIEFLY ABOUT USING C-SPY MACROS
To use C-SPY macros, you should:

o Write your macro variables and functions and collect them in one or several macro
files

e Register your macros

e Execute your macros.

For registering and executing macros, there are several methods to choose between.
Which method you choose depends on which level of interaction or automation you
want, and depending on at which stage you want to register or execute your macro.

BRIEFLY ABOUT SETUP MACRO FUNCTIONS AND FILES

There are some reserved setup macro function names that you can use for defining
macro functions which will be called at specific times, such as:

o Once after communication with the target system has been established but before
downloading the application software

o Once after your application software has been downloaded
o FEach time the reset command is issued

o Once when the debug session ends.

To define a macro function to be called at a specific stage, you should define and register
a macro function with one of the reserved names. For instance, if you want to clear a
specific memory area before you load your application software, the macro setup
function execUserPreload should be used. This function is also suitable if you want
to initialize some CPU registers or memory-mapped peripheral units before you load
your application software.

You should define these functions in a setup macro file, which you can load before
C-SPY starts. Your macro functions will then be automatically registered each time you
start C-SPY. This is convenient if you want to automate the initialization of C-SPY, or
if you want to register multiple setup macros.

For more information about each setup macro function, see Reference information on
reserved setup macro function names, page 425.

Remapping memory

A common feature of many Arm-based processors is the ability to remap memory. After
areset, the memory controller typically maps address zero to non-volatile memory, such
as flash. By configuring the memory controller, the system memory can be remapped to
place RAM at zero and non-volatile memory higher up in the address map. By doing
this, the exception table will reside in RAM and can be easily modified when you
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download code to the target hardware. To handle this in C-SPY, the setup macro function
execUserPreload () is suitable. For an example, see Remapping memory, page 58.

BRIEFLY ABOUT THE MACRO LANGUAGE
The syntax of the macro language is very similar to the C language. There are:

® Macro statements, which are similar to C statements.

® Macro functions, which you can define with or without parameters and return
values.

e Predefined built-in system macros, similar to C library functions, which perform
useful tasks such as opening and closing files, setting breakpoints, and defining
simulated interrupts.

® Macro variables, which can be global or local, and can be used in C-SPY
expressions.

® Macro strings, which you can manipulate using predefined system macros.

For more information about the macro language components, see Reference information
on the macro language, page 420.

Example

Consider this example of a macro function which illustrates the various components of
the macro language:

__var oldval;
CheckLatest (val)
{
if (oldval != val)
{
__message "Message: Changed from ", oldval, " to ", val, "\n";
oldval = val;
}
}

Note: Reserved macro words begin with double underscores to prevent name conflicts.

Using C-SPY macros

These tasks are covered:

o Registering C-SPY macros—an overview
o Executing C-SPY macros—an overview

o Registering and executing using setup macros and setup files
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o Executing macros using Quick Watch
e Executing a macro by connecting it to a breakpoint
o Aborting a C-SPY macro

For more examples using C-SPY macros, see:

o The tutorial about simulating an interrupt, which you can find in the Information
Center

e I[nitializing target hardware before C-SPY starts, page 58.

REGISTERING C-SPY MACROS—AN OVERVIEW

C-SPY must know that you intend to use your defined macro functions, and thus you
must register your macros. There are various ways to register macro functions:

® You can register macro functions during the C-SPY startup sequence, see
Registering and executing using setup macros and setup files, page 417.

® You can register macros interactively in the Macro Registration window, see
Macro Registration window, page 484. Registered macros appear in the Debugger
Macros window, see Debugger Macros window, page 486.

® You can register a file containing macro function definitions, using the system
macro __registerMacroFile. This means that you can dynamically select which
macro files to register, depending on the runtime conditions. Using the system
macro also lets you register multiple files at the same moment. For information
about the system macro, see __registerMacroFile, page 464.

Which method you choose depends on which level of interaction or automation you
want, and depending on at which stage you want to register your macro.

EXECUTING C-SPY MACROS—AN OVERVIEW
There are various ways to execute macro functions:

® You can execute macro functions during the C-SPY startup sequence and at other
predefined stages during the debug session by defining setup macro functions in a
setup macro file, see Registering and executing using setup macros and setup files,
page 417.

o The Quick Watch window lets you evaluate expressions, and can thus be used for
executing macro functions. For an example, see Executing macros using Quick
Watch, page 418.

o The Macro Quicklaunch window is similar to the Quick Watch window, but is
more specified on designed for C-SPY macros. See Macro Quicklaunch window,
page 488.
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o A macro can be connected to a breakpoint; when the breakpoint is triggered the
macro is executed. For an example, see Executing a macro by connecting it to a
breakpoint, page 418.

Which method you choose depends on which level of interaction or automation you
want, and depending on at which stage you want to execute your macro.
REGISTERING AND EXECUTING USING SETUP MACROS AND
SETUP FILES

It can be convenient to register a macro file during the C-SPY startup sequence. To do
this, specify a macro file which you load before starting the debug session. Your macro
functions will be automatically registered each time you start the debugger.

If you use the reserved setup macro function names to define the macro functions, you
can define exactly at which stage you want the macro function to be executed.

To define a setup macro function and load it during C-SPY startup:
Create a new text file where you can define your macro function.
For example:

execUserSetup ()

{

_ _registerMacroFile("MyMacroUtils.mac") ;
_ _registerMacroFile("MyDeviceSimulation.mac") ;

}

This macro function registers the additional macro files MyMacroUtils.mac and
MyDeviceSimulation.mac. Because the macro function is defined with the function
name execUserSetup, it will be executed directly after your application has been
downloaded.

Save the file using the filename extension mac.

Before you start C-SPY, choose Project>Options>Debugger>Setup. Select Use
Setup file and choose the macro file you just created.

The macros will now be registered during the C-SPY startup sequence.
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EXECUTING MACROS USING QUICK WATCH

The Quick Watch window lets you dynamically choose when to execute a macro
function.

Consider this simple macro function that checks the status of a timer enable bit:

TimerStatus ()
{
if ((TimerStatreg & 0x01) != 0)/* Checks the status of reg */
return "Timer enabled"; /* C-SPY macro string used */
else
return "Timer disabled"; /* C-SPY macro string used */

}
Save the macro function using the filename extension mac.

To load the macro file, choose View>Macros>Macro Registration. The Macro
Registration window is displayed. Click Add and locate the file using the file browser.
The macro file appears in the list of macros in the Macro Registration window.

Select the macro you want to register and your macro will appear in the Debugger
Macros window.

Choose View>Quick Watch to open the Quick Watch window, type the macro call
TimerStatus () in the text field and press Return,

Alternatively, in the macro file editor window, select the macro function name
TimerStatus (). Right-click, and choose Quick Watch from the context menu that

appears.
Quick Watch * O X
@ TimerStatus]] -
Expression Yalue Location  Type
TimerStatus() 'Timer disabled® macro string

The macro will automatically be displayed in the Quick Watch window.

For more information, see Quick Watch window, page 112.

EXECUTING A MACRO BY CONNECTINGITTO A
BREAKPOINT

You can connect a macro to a breakpoint. The macro will then be executed when the
breakpoint is triggered. The advantage is that you can stop the execution at locations of
particular interest and perform specific actions there.
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For instance, you can easily produce log reports containing information such as how the
values of variables, symbols, or registers change. To do this you might set a breakpoint
on a suspicious location and connect a log macro to the breakpoint. After the execution
you can study how the values of the registers have changed.

To create a log macro and connect it to a breakpoint:
Assume this skeleton of a C function in your application source code:

int fact(int x)
{

}
Create a simple log macro function like this example:

logfact ()
{
__message "fact(" ,x, ")";

}
The __message statement will log messages to the Debug Log window.
Save the macro function in a macro file, with the filename extension mac.

To register the macro, choose View>Macros>Macro Registration to open the Macro
Registration window and add your macro file to the list. Select the file to register it.
Your macro function will appear in the Debugger Macros window.

To set a code breakpoint, click the Toggle Breakpoint button on the first statement
within the function fact in your application source code. Choose View>Breakpoints
to open the Breakpoints window. Select your breakpoint in the list of breakpoints and
choose the Edit command from the context menu.

To connect the log macro function to the breakpoint, type the name of the macro
function, logfact (), in the Action field and click OK to close the dialog box.

Execute your application source code. When the breakpoint is triggered, the macro
function will be executed. You can see the result in the Debug Log window.

e Note that the expression in the Action field is evaluated only when the breakpoint
causes the execution to really stop. If you want to log a value and then automatically
continue execution, you can either:

Use a Log breakpoint, see Log breakpoints dialog box, page 140

o Use the Condition field instead of the Action field. For an example, see Performing

a task and continuing execution, page 131.

You can easily enhance the log macro function by, for instance, using the __ fmessage
statement instead, which will print the log information to a file. For information about
the __ fmessage statement, see Formatted output, page 423.
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For an example where a serial port input buffer is simulated using the method of
connecting a macro to a breakpoint, see the tutorial Simulating an interrupt in the
Information Center.
ABORTING A C-SPY MACRO
To abort a C-SPY macro:

I Press Ctrl+Shift+. (period) for a short while.

2 A message that says that the macro has terminated is displayed in the Debug Log
window.

This method can be used if you suspect that something is wrong with the execution, for
example because it seems not to terminate in a reasonable time.

Reference information on the macro language
Reference information about:

Macro functions, page 420
Macro variables, page 421
Macro parameters, page 421
Macro strings, page 422

Macro statements, page 422

Formatted output, page 423.

MACRO FUNCTIONS

C-SPY macro functions consist of C-SPY variable definitions and macro statements
which are executed when the macro is called. An unlimited number of parameters can
be passed to a macro function, and macro functions can return a value on exit.

A C-SPY macro has this form:

macroName (parameterList)
{
macroBody

}

where parameterList is a list of macro parameters separated by commas, and
macroBody is any series of C-SPY variable definitions and C-SPY statements.

Type checking is neither performed on the values passed to the macro functions nor on
the return value.

C-SPY® Debugging Guide
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MACRO VARIABLES

A macro variable is a variable defined and allocated outside your application. It can then
be used in a C-SPY expression, or you can assign application data—values of the
variables in your application—to it. For more information about C-SPY expressions, see
C-SPY expressions, page 94.

The syntax for defining one or more macro variables is:
__var nameList;
where nameList is a list of C-SPY variable names separated by commas.

A macro variable defined outside a macro body has global scope, and it exists
throughout the whole debugging session. A macro variable defined within a macro body
is created when its definition is executed and destroyed on return from the macro.

By default, macro variables are treated as signed integers and initialized to 0. When a
C-SPY variable is assigned a value in an expression, it also acquires the type of that
expression. For example:

Expression What it means
myvar = 3.5; myvar is now type double, value 3. 5.
myvar = (int*)i; myvar is now type pointer to int, and the value is the same as i.

Table 16: Examples of C-SPY macro variables

In case of a name conflict between a C symbol and a C-SPY macro variable, C-SPY
macro variables have a higher precedence than C variables. Note that macro variables
are allocated on the debugger host and do not affect your application.

MACRO PARAMETERS

A macro parameter is intended for parameterization of device support. The named
parameter will behave as a normal C-SPY macro variable with these differences:

o The parameter definition can have an initializer

e Values of a parameters can be set through options (either in the IDE or in cspybat).
o A value set from an option will take precedence over a value set by an initializer
.

A parameter must have an initializer, be set through an option, or both. Otherwise, it
has an undefined value, and accessing it will cause a runtime error.

The syntax for defining one or more macro parameters is:
__param param|[ = value, ...;]

Use the command line option --macro_param to specify a value to a parameter, see
--macro_param, page 529.
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MACRO STRINGS

In addition to C types, macro variables can hold values of macro strings. Note that
macro strings differ from C language strings.

When you write a string literal, such as "Hello! ", in a C-SPY expression, the value is
amacro string. It is not a C-style character pointer char*, because char* must point to
a sequence of characters in target memory and C-SPY cannot expect any string literal to
actually exist in target memory.

You can manipulate a macro string using a few built-in macro functions, for example
__strFind or __subString. The result can be a new macro string. You can
concatenate macro strings using the + operator, for example str + "tail". You can
also access individual characters using subscription, for example sz [3]. You can get the
length of a string using sizeof (str). Note that a macro string is not
NULL-terminated.

The macro function __toString is used for converting from a NULL-terminated C
string in your application (char* or char []) to a macro string. For example, assume
this definition of a C string in your application:

char const *cstr = "Hello";

Then examine these macro examples:

__var str; /* A macro variable */

str = cstr /* str is now just a pointer to char */

sizeof str /* same as sizeof (char*), typically 2 or 4 */
str = __toString(cstr,512) /* str is now a macro string */
sizeof str /* 5, the length of the string */

str[l] /* 101, the ASCII code for 'e' */

str += " World!" /* str is now "Hello World!" */

See also Formatted output, page 423.

MACRO STATEMENTS

Statements are expected to behave in the same way as the corresponding C statements
would do. The following C-SPY macro statements are accepted:

Expressions

expression;

For more information about C-SPY expressions, see C-SPY expressions, page 94.

Conditional statements

if (expression)
statement

C-SPY® Debugging Guide
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if (expression)
statement
else
statement

Loop statements

for (init_expression; cond_expression; update_expression)
statement

while (expression)
statement

do
statement
while (expression);

Return statements
return;
return expression;

If the return value is not explicitly set, signed int 0 is returned by default.

Blocks
Statements can be grouped in blocks.

{
statementl
statement2

statementN

FORMATTED OUTPUT

C-SPY provides various methods for producing formatted output:

__message argList; Prints the output to the Debug Log window.
__fmessage file, argList; Prints the output to the designated file.

__smessage argList; Returns a string containing the formatted output.
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where argList is acomma-separated list of C-SPY expressions or strings, and fileis
the result of the __openFile system macro, see __openkFile, page 457.

To produce messages in the Debug Log window:

varl = 42;
var2 = 37;
__message "This line prints the values ", varl, " and ", var2,

" in the Debug Log window.";

This produces this message in the Debug Log window:

This line prints the values 42 and 37 in the Debug Log window.
To write the output to a designated file:

__fmessage myfile, "Result is ", res, "!\n";

To produce strings:

myMacroVar = __smessage 42, " is the answer.";

myMacroVar now contains the string "42 is the answer.".

Specifying display format of arguments

To override the default display format of a scalar argument (number or pointer) in
argList, suffix it with a : followed by a format specifier. Available specifiers are:

b for binary scalar arguments

%0 for octal scalar arguments

%d for decimal scalar arguments

$x for hexadecimal scalar arguments
%c for character scalar arguments

These match the formats available in the Watch and Locals windows, but number
prefixes and quotes around strings and characters are not printed. Another example:

__message "The character '", cvar:%c, "' has the decimal value
", cvar;

Depending on the value of the variables, this produces this message:
The character 'A' has the decimal value 65

Note: A character enclosed in single quotes (a character literal) is an integer constant
and is not automatically formatted as a character. For example:

__message 'A', " is the numeric value of the character ",
"A':%C
1 %C;

C-SPY® Debugging Guide
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would produce:
65 is the numeric value of the character A

Note: The default format for certain types is primarily designed to be useful in the
Watch window and other related windows. For example, a value of type char is
formatted as 'A' (0x41), while a pointer to a character (potentially a C string) is
formatted as 0x8102 "Hello", where the string part shows the beginning of the string
(currently up to 60 characters).

When printing a value of type char*, use the $x format specifier to print just the pointer
value in hexadecimal notation, or use the system macro __toString to get the full
string value.

Reference information on reserved setup macro function names

There are reserved setup macro function names that you can use for defining your setup
macro functions. By using these reserved names, your function will be executed at
defined stages during execution. For more information, see Briefly about setup macro
functions and files, page 414.

Reference information about:

execConfigureTraceETM
execConfigureTraceSWO
execUserPreload
execUserExecutionStarted
execUserExecutionStopped

execUserFlashInit

[ ]

[ ]

[ ]

[ ]

[ ]

[ ]

® execUserSetup
® execUserFlashReset
® execUserPreReset

® execUserReset

® execUserExit

® execUserFlashExit
[ ]

execUserCoreConnect
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execConfigureTraceETM

Syntax
For use with

Description

execConfigureTraceETM
All C-SPY hardware drivers where full instruction trace is supported and enabled.

This macro is executed just before execution begins, and should be used for setting up
device-specific registers that might be required to get full instruction trace (ETM/PTM)
out to a physical pin, or to configure device-specific parts of an on-chip trace unit
(ETB/MTB/PTB).

execConfigureTraceSWO

Syntax
For use with

Description

execUserPreload

Syntax
For use with

Description

C-SPY® Debugging Guide
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execConfigureTraceSWO
All C-SPY hardware drivers where SWO trace is supported and enabled.
This macro is executed just before execution begins, and should be used for setting up

device-specific registers that might be required to get SWO trace out to a physical pin.

Configuring SWO/ITM or TPIU should generally not be required here, because this is
handled by the probe driver.

execUserPreload
All C-SPY drivers.
Called after communication with the target system is established but before

downloading the target application

Implement this macro to initialize memory locations and/or registers which are vital for
loading data properly.

Note: Do not use this macro if you are using a flash loader. Use the macro
execUserFlashInit instead to perform early initializations required by the flash
loader; see execUserFlashlinit, page 427.
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execUserExecutionStarted

Syntax
For use with

Description

execUserExecutionStarted

All C-SPY drivers.

Called when the debugger is about to start or resume execution. The macro is not called
when performing a one-instruction assembler step, in other words, Step or Step Into in
the Disassembly window.

execUserExecutionStopped

Syntax
For use with

Description

execUserFlashlnit

Syntax
For use with

Description

execUserSetup

Syntax
For use with

Description

execUs erExecutionStopped
All C-SPY drivers.

Called when the debugger has stopped execution. The macro is not called when
performing a one-instruction assembler step, in other words, Step or Step Into in the
Disassembly window.

execUserFlashInit
The C-SPY hardware debugger drivers.

Called once before the flash loader is downloaded to RAM. Implement this macro
typically for setting up the memory map required by the flash loader. This macro is only
called when you are programming flash, and it should only be used for flash loader
functionality.

execUserSetup
All C-SPY drivers.

Called once after the target application is downloaded.

Implement this macro to set up the memory map, breakpoints, interrupts, register macro
files, etc.
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execUserFlashReset

Syntax
For use with

Description

execUserPreReset

Syntax
For use with

Description

execUserReset

Syntax
For use with

Description

C-SPY® Debugging Guide
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If you define interrupts or breakpoints in a macro file that is executed at system start
(using execUserSetup) we strongly recommend that you also make sure that they are
removed at system shutdown (using execUserExit). An example is available in
SetupSimple.mac, see the tutorials in the Information Center.

The reason for this is that the simulator saves interrupt settings between sessions and if
they are not removed they will get duplicated every time execUserSetup is executed
again. This seriously affects the execution speed.

execUserFlashReset
The C-SPY hardware debugger drivers.
Called once after the flash loader is downloaded to RAM, but before execution of the

flash loader. This macro is only called when you are programming flash, and it should
only be used for flash loader functionality.

execUserPreReset
All C-SPY drivers.

Called each time just before the reset command is issued.

Implement this macro to set up any required device state.

execUserReset

All C-SPY drivers.

Called each time just after the reset command is issued.

Implement this macro to set up and restore data.
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execUserExit
Syntax execUserExit
For use with All C-SPY drivers.
Description Called once when the debug session ends.

Implement this macro to save status data etc.

execUserFlashExit

Syntax execUserFlashExit
For use with The C-SPY hardware debugger drivers.
Description Called once when the flash programming ends.

Implement this macro to save status data etc. This macro is useful for flash loader

functionality.
execUserCoreConnect
Syntax execUserCoreConnect
For use with The C-SPY CMSIS-DAP driver

The C-SPY I-jet/JTAGjet driver
The C-SPY TI MSP-FET driver
The C-SPY TI Stellaris driver
The C-SPY TI XDS driver

Description Called immediately when connection with the probe is established.

Implement this macro to perform actions before connecting the CPU. This macro is
useful for unlocking/erasing a secured device.
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Reference information on C-SPY system macros

This section gives reference information about each of the C-SPY system macros.

This table summarizes the pre-defined system macros:

Macro

Description

_ _abortLaunch
__cancelAllInterrupts
__cancelInterrupt
__clearBreak
__closeFile

__delay
__disableInterrupts
__driverType

__emulatorSpeed

__emulatorStatusCheckOnRead

__enableInterrupts

__evaluate

__fillMemory8
__fillMemorylé6
__fillMemory32
__gdbserver_exec_command
__getSelectedCore
__getTracePortSize

__hasDAPRegs

__hwJetResetWithStrategy

__hwReset

_hwResetRunToBp

Aborts the launch of the debugger

Cancels all ordered interrupts

Cancels an interrupt

Clears a breakpoint

Closes a file that was opened by __openFile
Delays execution

Disables generation of interrupts

Verifies the driver type

Sets the emulator clock frequency

Enables or disables the verification of the CPSR
register after each read operation

Enables generation of interrupts

Interprets the input string as an expression and
evaluates it.

Fills a specified memory area with a byte value.
Fills a specified memory area with a 2-byte value.
Fills a specified memory area with a 4-byte value.
Send strings or commands to the GDB Server
Gets the number of the current core.

Returns the width of the trace port

Returns true if the C-SPY driver supports the macros
__readAPReg,
__writeAPReg, and __writeDPReg.

readDPReg, and

Performs a hardware reset and a halt of the target
CPU

Performs a hardware reset and a halt of the target
CPU

Performs a hardware reset and then executes to the
specified address

Table 17: Summary of system macros
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Description

__hwResetWithStrategy

_ _hwRunToBreakpoint

__isBatchMode

__JjlinkExecCommand

__JjtagCommand

__JjtagCPl5IsPresent
__JjtagCPl5ReadReg
__JjtagCPl5WriteReg
__Jjtagbata
__JjtagRawRead
__jtagRawSync
__JjtagRawWrite

__JjtagResetTRST

__loadImage

__memoryRestore

__memorySave

__messageBoxYesCancel
__messageBoxYesNo
__openFile
__orderInterrupt

__popSimulatorInterruptExec
utingStack

__probeType
__readAPReg
__readDPReg
__readFile

__readFileByte

Performs a hardware reset and halt with delay of the
target CPU

Sets a temporary breakpoint and starts the
execution.

Checks if C-SPY is running in batch mode or not.

Sends a low-level command to the J-Link/)-Trace
driver

Sends a low-level command to the JTAG instruction
register

Checks if coprocessor CP15 is available

Returns the coprocessor CPI5 register value

Writes to the coprocessor CPI5 register

Sends a low-level data value to the JTAG data register
Returns the read data from the JTAG interface
Writes accumulated data to the JTAG interface
Accumulates data to be transferred to the JTAG

Resets the ARM TAP controller via the TRST JTAG
signal

Loads an image.

Restores the contents of a file to a specified memory
zone

Saves the contents of a specified memory area to a
file

Displays a Yes/Cancel dialog box for user interaction
Displays a Yes/No dialog box for user interaction
Opens a file for /O operations

Generates an interrupt

Informs the interrupt simulation system that an
interrupt handler has finished executing

Verifies the probe type
Reads from an AP register
Reads from a DP register
Reads from the specified file

Reads one byte from the specified file

Table 17: Summary of system macros
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Macro

Description

__readMemoryS8,

__readMemoryByte
__readMemoryl6
__readMemory32
__registerMacroFile
__resetFile

__restoreSoftwareBreakpoint
s

__selectCore

__setCodeBreak
__setDhataBreak
__setDhataLogBreak
__setLogBreak
__setSimBreak
__setTraceStartBreak
__setTraceStopBreak

__sourcePosition

__strFind

__subString
__targetDebuggerVersion

__toLower

__toString

__toUpper

__unloadImage
__writeAPReg
_ _writeDPReg
__writeFile

__writeFileByte

Reads one byte from the specified memory location

Reads two bytes from the specified memory location
Reads four bytes from the specified memory location
Registers macros from the specified file

Rewinds a file opened by __openFile

Restores any breakpoints that were destroyed during
system startup.

Switches focus from the current core to the specified
core.

Sets a code breakpoint

Sets a data breakpoint

Sets a data log breakpoint
Sets a log breakpoint

Sets a simulation breakpoint
Sets a trace start breakpoint
Sets a trace stop breakpoint

Returns the file name and source location if the
current execution location corresponds to a source
location

Searches a given string for the occurrence of another
string

Extracts a substring from another string
Returns the version of the target debugger

Returns a copy of the parameter string where all the
characters have been converted to lower case

Prints strings

Returns a copy of the parameter string where all the
characters have been converted to upper case

Unloads a debug image
Writes to an AP register
Writes to a DP register
Writes to the specified file

Werites one byte to the specified file

Table 17: Summary of system macros
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Macro Description

__writeMemorys8, Werites one byte to the specified memory location

__writeMemoryByte

__writeMemoryl6 Writes a two-byte word to the specified memory
location

__writeMemory32 Writes a four-byte word to the specified memory
location

Table 17: Summary of system macros

__abortLaunch
Syntax __abortLaunch (message)
Parameters message
A string that is printed as an error message when the macro executes.
Return value None.
For use with All C-SPY drivers.
Description This macro can be used for aborting a debugger launch, for example if another macro
sees that something goes wrong during initialization and cannot perform a proper setup.
This is an emergency stop when launching, not a way to end an ongoing debug session
like the C library function abort ().
Example if (!__messageBoxYesCancel ("Do you want to mass erase to unlock
the device?", "Unlocking device"))
{ __abortLaunch("Unlock canceled. Debug session cannot
continue."); }
__cancelAllinterrupts
Syntax __cancelAllInterrupts ()
Return value int 0
For use with The C-SPY Simulator.
Description Cancels all ordered interrupts.
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__cancellnterrupt
Syntax __cancelInterrupt (interrupt_id)
Parameters interrupt_id

The value returned by the corresponding __orderInterrupt macro call
(unsigned long).

Return value

Result Value
Successful int 0
Unsuccessful Non-zero error number

Table 18: __cancellnterrupt return values

For use with The C-SPY Simulator.

Description Cancels the specified interrupt.
__clearBreak

Syntax __clearBreak (break_id)

Parameters break_id

The value returned by any of the set breakpoint macros.

Return value int 0
For use with All C-SPY drivers.
Description Clears a user-defined breakpoint.
See also Breakpoints, page 119.
__closeFile
Syntax __closeFile(fileHandle)
Parameters fileHandle
A macro variable used as filehandle by the __openFile macro.
Return value int 0
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For use with

Description

__delay

Syntax

Parameters

Return value
For use with

Description

__disablelnterrupts

Syntax

Return value

For use with

Description

__driverType

Syntax

Parameters

C-SPY macros __4

All C-SPY drivers.

Closes a file previously opened by __openFile.

__delay(value)

value

The number of milliseconds to delay execution.
int 0
All C-SPY drivers.

Delays execution the specified number of milliseconds.

__disablelInterrupts()

Result Value
Successful int 0
Unsuccessful Non-zero error number

Table 19: __disableInterrupts return values
The C-SPY Simulator.

Disables the generation of interrupts.

__driverType(driver_id)

driver_id
A string corresponding to the driver you want to check for. Choose one of these:

"sim" corresponds to the simulator driver.

"cadi" corresponds to the C-SPY CADI driver
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Return value

For use with

Description

Example

__emulatorSpeed

Syntax

Parameters

C-SPY® Debugging Guide
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"cmsisdap" corresponds to the C-SPY CMSIS-DAP driver
"gdbserv" corresponds to the C-SPY GDB Server driver
"generic" corresponds to third-party drivers

"ijet" corresponds to the C-SPY I-jet/JTAGjet driver
"jlink" corresponds to the C-SPY J-Link/J-Trace driver
"lmiftdi" corresponds to the C-SPY TI Stellaris driver
"mspfet" corresponds to the C-SPY MSP-FET driver
"nulink" corresponds to the C-SPY Nu-Link driver

"xds" corresponds to the C-SPY TI XDS driver

"stlink" corresponds to the C-SPY ST-LINK driver.

Result Value
Successful 1
Unsuccessful 0

Table 20: __driverType return values
All C-SPY drivers

Checks to see if the current C-SPY driver is identical to the driver type of the
driver_1id parameter.

__driverType("sim")

If the simulator is the current driver, the value 1 is returned. Otherwise 0 is returned.

__emulatorSpeed (speed)

speed The emulator speed in Hz. Use 0 (zero) to make the speed
automatically detected. Use -1 for adaptive speed (only for
emulators supporting adaptive speed).



Return value

For use with

Description

Example

C-SPY macros __4

Result Value
Successful The previous speed, or 0 (zero) if unknown
Unsuccessful; the speed is not supported -1

by the emulator

Table 21: __emulatorSpeed return values
The C-SPY hardware drivers

Sets the emulator clock frequency. For JTAG interfaces, this is the JTAG clock
frequency as seen on the TCK signal.

__emulatorSpeed(0)

Sets the emulator speed to be automatically detected.

__emulatorStatusCheckOnRead

Syntax

Parameters

Return value

For use with

Description

Example

__emulatorStatusCheckOnRead (status)

status Use 0 to enable checks (default). Use 1 to disable checks.

int 0

The C-SPY J-Link/J-Trace driver
For the C-SPY I-jet/JTTAG-jet driver, this macro is recognized, but has no effect.
Enables or disables the driver verification of CPSR (current processor status register)

after each read operation. Typically, this macro can be used for initiating JTAG
connections on some CPUs, like Texas Instruments’ TMS470R1B1M.

Note: Enabling this verification can cause problems with some CPUs, for example if
invalid CPSR values are returned. However, if this verification is disabled
(SetCheckModeafterRead = 0), the success of read operations cannot be verified
and possible data aborts are not detected.

__emulatorStatusCheckOnRead (1)

Disables the checks for data aborts on memory reads.
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__enablelnterrupts

Syntax

Return value

For use with

Description

__evaluate

Syntax

Parameters

Return value

For use with

Description

Example
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__enableInterrupts()

Result Value
Successful int 0
Unsuccessful Non-zero error number

Table 22: __enablelnterrupts return values
The C-SPY Simulator.

Enables the generation of interrupts.

__evaluate(string, valuePtr)
string
Expression string.

valuePtr

Pointer to a macro variable storing the result.

Result Value
Successful int 0
Unsuccessful int 1

Table 23: __evaluate return values
All C-SPY drivers.

This macro interprets the input string as an expression and evaluates it. The result is
stored in a variable pointed to by valueptr.

This example assumes that the variable i is defined and has the value 5:
__evaluate("i + 3", &myVar)

The macro variable myvar is assigned the value 8.



__fillMemory8

Syntax

Parameters

Return value
For use with
Description

Example

__fillMemoryl 6

Syntax

Parameters
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__fillMemory8 (value, address, zone, length, format)

value
An integer that specifies the value.
address
An integer that specifies the memory start address.
zone
A string that specifies the memory zone, see C-SPY memory zones, page 159.
length
An integer that specifies how many bytes are affected.
format
A string that specifies the exact fill operation to perform. Choose between:
Copy value will be copied to the specified memory area.
AND An AND operation will be performed between value and the
existing contents of memory before writing the result to memory.
OR An OR operation will be performed between value and the
existing contents of memory before writing the result to memory.
XOR An XOR operation will be performed between value and the
existing contents of memory before writing the result to memory.
int 0

All C-SPY drivers.
Fills a specified memory area with a byte value.

__fillMemory8(0x80, 0x700, "Memory", 0x10, "OR");

__fillMemorylé6 (value, address, zone, length, format)

value

An integer that specifies the value.
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Return value
For use with
Description

Example

__fillMemory32

Syntax

Parameters
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address

An integer that specifies the memory start address.

zone
A string that specifies the memory zone, see C-SPY memory zones, page 159.
length
An integer that defines how many 2-byte entities to be affected.
format
A string that specifies the exact fill operation to perform. Choose between:
Copy value will be copied to the specified memory area.
AND An AND operation will be performed between value and the
existing contents of memory before writing the result to memory.
OR An OR operation will be performed between value and the
existing contents of memory before writing the result to memory.
XOR An XOR operation will be performed between value and the
existing contents of memory before writing the result to memory.
int 0

All C-SPY drivers.
Fills a specified memory area with a 2-byte value.

_fillMemoryl6 (0xCDCD, 0x7000, "Memory", 0x200, "Copy"):;

__fillMemory32 (value, address, zone, length, format)

value

An integer that specifies the value.

address

An integer that specifies the memory start address.

zone

A string that specifies the memory zone, see C-SPY memory zones, page 159.
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length
An integer that defines how many 4-byte entities to be affected.

format

A string that specifies the exact fill operation to perform. Choose between:

Copy value will be copied to the specified memory area.

AND An AND operation will be performed between value
and the existing contents of memory before writing
the result to memory.

OR An OR operation will be performed between value
and the existing contents of memory before writing
the result to memory.

XOR An XOR operation will be performed between value
and the existing contents of memory before writing
the result to memory.

Return value int 0

For use with All C-SPY drivers.

Description Fills a specified memory area with a 4-byte value.

Example __fillMemory32 (0x0000FFFF, 0x4000, "Memory", 0x1000, "XOR");

__gdbserver_exec_command

Syntax __gdbserver_exec_command ("string")

Parameters
"string" String or command sent to the GDB Server; see its
documentation for more information.

For use with The C-SPY C-SPY GDB Server driver

Description Use this option to send strings or commands to the GDB Server.
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__getSelectedCore
Syntax __getSelectedCore ()
Return value The current core. The cores are numbered from 0 and upwards.
For use with The C-SPY simulator.
The C-SPY I-jet/JTAGjet driver.
Description Gets the number of the current core.
Example test ()
{
__message "Core: ", __getSelectedCore(), " pc = ", #PC:%x,
w \n " ;
_ _selectCore(0);
__message "Core: ", __getSelectedCore(), " pc = ", #PC:%x,
A\ \n " ;
__selectCore(l);
__message "Core: ", __getSelectedCore(), " pc = ", #PC:%x,
A\ \nll ;
A typical result of the above macro would be (assuming that the original core was
number 1):
Core: 1 pc = 0000213C
Core: 0 pc = 00000494
Core: 1 pc = 0000213C
See also __selectCore, page 465.
__getTracePortSize
Syntax __getTracePortSize

Return value
Result Value

The width of the trace port in bits. 1,2,4,8,0r1l6.

Table 24: __getTracePortSize return values

For use with The C-SPY I-jet/JTAGjet driver
The C-SPY J-Link/J-Trace driver
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Description

See also

__hasDAPRegs

Syntax

Return value

For use with

Description

C-SPY macros __4

Returns the width of the trace port.

ETM Trace Settings dialog box, page 212 and ETM Trace Settings dialog box
(J-Link/J-Trace), page 214, respectively.

__hasDAPRegs ()
Result Value
The C-SPY driver supports the macros __readAPReg, true

__readDPReg, __writeAPRegq, and __ writeDPReg for the

current CPU core.

The C-SPY driver does not support the macros __readAPReg, false
__readDPReg, __writeAPReg, and __ writeDPReg for the

current CPU core.

Table 25: __hasDAPRegs return values

The C-SPY hardware drivers

This macro returns true if the C-SPY driver supports the macros __readAPReg,
__readDPReg, __writeAPReg, and __writeDPReg for the current CPU core,

otherwise it returns false.

__hwJetResetWithStrategy

Syntax

Parameters

Return value

__hwJetResetWithStrategy (halt_delay, strategy)

halt_delay The delay, in milliseconds, between the end of the reset pulse
and the halt of the CPU. Use 0 (zero) to make the CPU halt
immediately after reset; only when strategy is set to 0.

strategy The reset strategy number. For information about supported
reset strategies, see --jet_standard_reset, page 521.

Result Value

Successful. The delay feature is not supported by the debugging probe -1

Table 26: __hwJetResetWithStrategy return values
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For use with
Description

Example

__hwReset

Syntax

Parameters

Return value

For use with
Description

Example
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Result Value
Unsuccessful. The reset strategy is not supported by the debugging -3
probe

Unsuccessful. Other -4
Table 26: __hwJetResetWithStrategy return values (Continued)

The C-SPY I-jet/JTAGjet driver

Specifies the reset strategy to perform.
__hwJetResetWithStrategy (0, 2)

Performs a hardware reset.

__hwReset (halt_delay)

halt_delay The delay, in milliseconds, between the end of the reset pulse

and the halt of the CPU. Use 0 (zero) to make the CPU halt

immediately after reset

Result

Value

Successful. The actual delay value implemented by the emulator
Successful. The delay feature is not supported by the emulator

Unsuccessful. Hardware reset is not supported by the emulator

>=0
-1

Table 27: __hwReset return values
This system macro is available for all JTAG interfaces.
Performs a hardware reset and halt of the target CPU.

_ _hwReset (0)

Resets the CPU and immediately halts it.
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__hwResetRunToBp

Syntax __hwResetRunToBp (strategy, breakpoint_address, timeout)

Parameters
strategy For information about supported reset strategies in the
C-SPY I-jet/JTAG-jet driver, see --jet_standard_reset, page
521. For information about supported reset strategies in the
C-SPY J-Link driver, see the [4AR J-Link and IAR J-Trace
User Guide for JTAG Emulators for ARM Cores.

breakpoint_address The address of the breakpoint to execute to, specified as an
integer value (symbols cannot be used).

timeout A time out for the breakpoint, specified in milliseconds. If
the breakpoint is not reached within the specified time, the
core will be halted.

Return value

Value Result

>=0 Successful. The approximate execution time in ms until the breakpoint
is hit.

-2 Unsuccessful. Hardware reset is not supported by the emulator.

-3 Unsuccessful. The reset strategy is not supported by the emulator.

Table 28: __hwResetRunToBp return values

For use with The C-SPY CMSIS-DAP driver
The C-SPY I-jet/JTAGjet driver
The C-SPY J-Link/J-Trace driver
Description Performs a hardware reset, sets a breakpoint at the specified address, executes to the

breakpoint, and then removes it. The breakpoint address should be the start address of
the downloaded image after it has been copied to RAM.

This macro is intended for running a boot loader that copies the application image from
flash to RAM. The macro should be executed after the image has been downloaded to
flash, but before the image is verified. The macro can be run in execUserFlashExit
or execUserPreload.

Example _ _hwResetRunToBp (0, 0x400000,10000)
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Resets the CPU with the reset strategy 0 and executes to the address 0x400000. If the
breakpoint is not reached within 10 seconds, execution stops in accordance with the
specified time out.

__hwResetWithStrategy
Syntax __hwResetWithStrategy (halt_delay, strategy)
Parameters
halt_delay The delay, in milliseconds, between the end of the reset pulse
and the halt of the CPU. Use 0 (zero) to make the CPU halt
immediately after reset; only when strategy is set to 0.
strategy The C-SPY I-jet/ITAGjet driver only supports strategy 2

(hardware reset). For information about supported reset
strategies in the C-SPY J-Link driver, see the J-Link/J-Trace

User Guide.

Return value
Result Value
Successful. The actual delay in milliseconds, as implemented by the >=0
emulator
Successful. The delay feature is not supported by the emulator -1
Unsuccessful. Hardware reset is not supported by the emulator -2
Unsuccessful. The reset strategy is not supported by the emulator -3

Table 29: __hwResetWithStrategy return values

For use with The C-SPY I-jet/JTAGjet driver
The C-SPY J-Link/J-Trace driver

This macro exists also in the other C-SPY hardware drivers, but there it has no effect.
Description Performs a hardware reset and a halt with delay of the target CPU.

Example __hwResetWithStrategy (0,1)

Resets the CPU and halts it using a breakpoint at memory address zero.
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__hwRunToBreakpoint

Syntax

Parameters

Return value

For use with

Description

Example
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__hwRunToBreakpoint (breakpoint_address, timeout)

breakpoint_address The address of the breakpoint to execute to, specified as an
integer value (symbols cannot be used).

timeout A time out for the breakpoint, specified in milliseconds. If
the breakpoint is not reached within the specified time, the
core will be halted.

Value Result

>=0 Successful. The approximate execution time in ms until the breakpoint
is hit.

-1 Failed to set the breakpoint.

-2 Failed to stop at the breakpoint before timeout.

Table 30: __hwRunToBreakpoint return values

The C-SPY CMSIS-DAP driver

The C-SPY I-jet/JTAGjet driver

The C-SPY J-Link/J-Trace driver

The C-SPY PE micro driver

The C-SPY ST-LINK driver

The C-SPY TI XDS driver.

Use this macro to set a temporary breakpoint and then start the execution. When the
breakpoint is triggered, the execution stops. This macro can be used for running
initialization code on the target system.

_ _hwRunToBreakpoint (0x20000048,1000)

Sets a temporary breakpoint at the address 0x20000048, starts executing, and executes
until the breakpoint is triggered or until 1000 ms have passed.
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__isBatchMode

Syntax __isBatchMode ()

Return value

Result Value
True int 1
False int 0

Table 31: __isBatchMode return values

For use with All C-SPY drivers.

Description This macro returns True if the debugger is running in batch mode, otherwise it returns
False.

__jlinkExecCommand

Syntax __jlinkExecCommand (cmdstr)

Parameters
cmdstr J-Link/J-Trace command string

Return value int 0

For use with The C-SPY J-Link/J-Trace driver

Description Sends a low-level command to the J-Link/J-Trace driver. For a list of possible

commands, see the J-Link/J-Trace User Guide.

Example See the J-Link/J-Trace User Guide.
See also --jlink_exec_command, page 525
__jtagCommand
Syntax __jtagCommand (ir)
Parameters ir can be one of:
2 SCAN_N
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4 RESTART
12 INTEST
14 IDCODE
15 BYPASS
Return value int 0
For use with The C-SPY J-Link/J-Trace driver
Description Sends a low-level command to the JTAG instruction register IR.
Example __jtagCommand (14) ;
Id = __jtagbhata(0,32);

Returns the JTAG ID of the Arm target device.

__jtagCPI5IsPresent
Syntax __jtagCPl5IsPresent ()
Return value 1 if CP15 is available, otherwise 0.
For use with The C-SPY I-jet/JTAGjet driver
The C-SPY J-Link/J-Trace driver
Description Checks if the coprocessor CP15 is available.
__jtagCPI5ReadReg
Syntax __jtagCPl5ReadReg (CRn, CRm, opl, op2)
ParametersParameter The parameters—registers and operands—of the MRC instruction. For details, see the
ARM Architecture Reference Manual. Note that op1 should always be 0.
Return value The register value.
For use with The C-SPY I-jet/JTAGjet driver

The C-SPY J-Link/J-Trace driver
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Description

__jtagCPI5WriteReg

Syntax

Parameters

Applicability

Description

__jtagData

Syntax

Parameters

Return value

For use with

Description

Example
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Reads the value of the CP15 register and returns its value.

__JjtagCPl5WriteReg (CRn, CRm, opl, op2, value)
The parameters—registers and operands—of the MCR instruction. For details, see the
ARM Architecture Reference Manual. Note that op1 should always be 0. value is the

value to be written.

The C-SPY I-jet/JTAGjet driver
The C-SPY J-Link/J-Trace driver

Writes a value to the CP15 register.

__Jjtagbata(dr, bits)

dr 32-bit data register value

bits Number of valid bits in dr, both for the macro parameter and
the return value; starting with the least significant bit
(1...32)

Returns the result of the operation; the number of bits in the result is given by the bits
parameter.

The C-SPY J-Link/J-Trace driver

Sends a low-level data value to the JTAG data register DR. The bit shifted out of DR is
returned.

__JjtagCommand (14) ;
Id = __jtagbata(0,32);

Returns the JTAG ID of the Arm target device.



C-SPY macros __4

__jtagRawRead

Syntax __jtagRawRead (bitpos, numbits)

Parameters
bitpos The start bit position in the returned JTAG bits to return data

from

numbits The number of bits to read. The maximum value is 32.

For use with The C-SPY J-Link/J-Trace driver

Description Returns the data read from the JTAG TDO. Only the least significant bits contain data;
the last bit read is from the least significant bit. This function can be called an arbitrary
number of times to get all bits returned by an operation. This function also makes an
implicit synchronization of any accumulated write bits.

Example The following piece of pseudocode illustrates how the data is written to the JTAG (on
the TS and TDI pins) and read (from TDO):
__var Id;
__var BitPos;
/****************************************************************
*
* ReadId()
*/
ReadId() {
__message "Reading JTAG Id\n";
__jtagRawWrite (0, Ox1f, 6); /* Goto IDLE via RESET state */
__JjtagRawWrite (0, 0x1, 3); /* Enter DR scan chain */
BitPos = __jtagRawWrite (0, 0x80000000, 32); /* Shift 32 bits

into DR. Remember BitPos for Read operation */
__JjtagRawWrite (0, 0x1, 2); /* Goto IDLE */
Id = __jtagRawRead(BitPos, 32); /* Read the Id */
__message "JTAG Id: ", Id:%$x, "\n";
}
__jtagRawSync

Syntax __JjtagRawSync ()

Return value int 0

For use with The C-SPY J-Link/J-Trace driver
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Description Sends arbitrary data to the JTAG interface. All accumulated bits using
__jtagRawWrite will be written to the JTAG scan chain. The data is sent
synchronously with TCK and typically sampled by the device on rising edge of TCK.

Example The following piece of pseudocode illustrates how the data is written to the JTAG (on
the TMS and TDI pins) and read (from TDO):
int 1i;

U32 tdo;
for (1 = 0; 1 < numBits; i++) {
TDI = tdi & 1; /* Set TDI pin */
™S = tms & 1; /* Set TMS pin */
TCK = 0;
TCK = 1;
tdo <<= 1;
if (TDO) {
tdo | =1;
}
tdi >>= 1;
tms >>= 1;

__jtagRawWrite
Syntax __jtagRawWrite(tdi, tms, numbits)
Parameters
tdi The data output to the TDI pin. This data is sent with the least
significant bit first.
tms The data output to the T™S pin. This data is sent with the least
significant bit first.
numbits The number of bits to transfer. Every bit results in a falling
and rising edge of the JTAG TCK line. The maximum value is
64.
Return value Returns the bit position of the data in the accumulated packet. Typically, this value is
used when reading data from the JTAG.
For use with The C-SPY J-Link/J-Trace driver
Description Accumulates bits to be transferred to the JTAG. If 32 bits are not enough, this function
can be called multiple times. Both data output lines (TMS and TDI) can be controlled
separately.
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Example

__jtagResetTRST

Syntax

Return value

For use with

Description

__loadlmage

Syntax

Parameters

C-SPY macros __4

/* Send five 1 bits on TMS to go to TAP-RESET state */

__JjtagRawWrite (0x1F, 0, 5); /* Store bits in buffer */

__JjtagRawSync(); /* Transfer buffer, writing tms, tdi,
reading tdo */

Returns the JTAG ID of the Arm target device.

__JjtagResetTRST()

Result Value

Successful int 0

Unsuccessful Non-zero error number

Table 32: __jtagResetTRST return values

The C-SPY J-Link/J-Trace driver

Resets the Arm TAP controller via the TRST JTAG signal.

__loadImage (path, offset, debugInfoOnly)

path
A string that identifies the path to the image to download. The path must either
be absolute or use argument variables. For information about argument
variables, see the IDE Project Management and Building Guide for Arm.
offset
An integer that identifies the offset to the destination address for the downloaded
image.
debugInfoOnly

A non-zero integer value if no code or data should be downloaded to the target
system, which means that C-SPY will only read the debug information from the
debug file. Or, 0 (zero) for download.
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Return value

For use with

Description

Example |

Example 2

See also

__memoryRestore

Syntax

Parameters

C-SPY® Debugging Guide
454  for Arm

Value Result

Non-zero integer number A unique module identification.

int 0 Loading failed.

Table 33: __loadlmage return values
All C-SPY drivers.

Loads an image (debug file).

Note: Images are only downloaded to RAM and no flash loading will be performed,
unless you are using J-Link or TI MSP-FET.

Your system consists of a ROM library and an application. The application is your active
project, but you have a debug file corresponding to the library. In this case you can add
this macro call in the execUserSetup macro in a C-SPY macro file, which you
associate with your project:

__loadImage("ROMfile", 0x8000, 1);

This macro call loads the debug information for the ROM library rRoMfi1e without
downloading its contents (because it is presumably already in ROM). Then you can
debug your application together with the library.

Your system consists of a ROM library and an application, but your main concern is the
library. The library needs to be programmed into flash memory before a debug session.
While you are developing the library, the library project must be the active project in the
IDE. In this case you can add this macro call in the execUserSetup macro in a C-SPY
macro file, which you associate with your project:

__loadImage("ApplicationFile", 0x8000, 0);

The macro call loads the debug information for the application and downloads its
contents (presumably into RAM). Then you can debug your library together with the
application.

Images, page 551 and Loading multiple images, page 55.

_ _memoryRestore (zone, filename)

zone

A string that specifies the memory zone, see C-SPY memory zones, page 159.
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filename
A string that specifies the file to be read. The filename must include a path,
which must either be absolute or use argument variables. For information about
argument variables, see the /DE Project Management and Building Guide for

Arm.
Return value int 0
For use with All C-SPY drivers.
Description Reads the contents of a file and saves it to the specified memory zone.
Exmnpk __memoryRestore ("Memory", "c:\\temp\\saved_memory.hex") ;
See also Memory Restore dialog box, page 171.
__memorySave
Swwax __memorySave (start, stop, format, filename)
Parameters start

A string that specifies the first location of the memory area to be saved.

stop

A string that specifies the last location of the memory area to be saved.

format

A string that specifies the format to be used for the saved memory. Choose
between:

intel-extended
motorola
motorola-sl9
motorola-s28
motorola-s37.

filename
A string that specifies the file to write to. The filename must include a path,
which must either be absolute or use argument variables. For information about
argument variables, see the IDE Project Management and Building Guide for
Arm.
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Return value int 0

For use with All C-SPY drivers.

Description Saves the contents of a specified memory area to a file.

Example _ _memorySave ("Memory:0x00", "Memory:0xFF", "intel-extended",

"c:\\temp\\saved_memory.hex") ;

See also Memory Save dialog box, page 170.

__messageBoxYesCancel

Syntax __messageBoxYesCancel (message, caption)

Parameters message

A message that will appear in the message box.

caption

The title that will appear in the message box.

Return value

Result Value
Yes 1
No 0

Table 34: __messageBoxYesCancel return values
For use with All C-SPY drivers.

Description Displays a Yes/Cancel dialog box when called and returns the user input. Typically, this
is useful for creating macros that require user interaction.

__messageBoxYesNo
Syntax __messageBoxYesNo (message, caption)
Parameters message

A message that will appear in the message box.

caption

The title that will appear in the message box.
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Return value

Result Value
Yes 1
No 0

Table 35: __messageBoxYesNo return values
For use with All C-SPY drivers.

Description Displays a Yes/No dialog box when called and returns the user input. Typically, this is
useful for creating macros that require user interaction.

__openFile
Syntax __openFile(filename, access)
Parameters filename

The file to be opened. The filename must include a path, which must either be
absolute or use argument variables. For information about argument variables,
see the IDE Project Management and Building Guide for Arm.

access

The access type (string).

These are mandatory but mutually exclusive:

"a" append, new data will be appended at the end of the open file

"r" read (by default in text mode; combine with b for binary mode: rb)

"w" write (by default in text mode; combine with b for binary mode: wb)
These are optional and mutually exclusive:

"b" binary, opens the file in binary mode

"t ASCII text, opens the file in text mode

This access type is optional:

"+" together with r, w, or a; r+ or w+ is read and write, while a+ is read and

append

Return value
Result Value

Successful The file handle

Table 36: __openFile return values
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Result Value

Unsuccessful An invalid file handle, which tests as False

Table 36: __openFile return values
For use with All C-SPY drivers.

Description Opens a file for I/O operations. The default base directory of this macro is where the
currently open project file (* . ewp) is located. The argument to __openFile can
specify a location relative to this directory. In addition, you can use argument variables
such as $PROJ_DIRS and $TOOLKIT_DIRS in the path argument.

Example __var myFileHandle; /* The macro variable to contain */
/* the file handle */
myFileHandle = __openFile("$SPROJ_DIRS\\Debug\\Exe\\test.tst",
npny

if (myFileHandle)
{
/* successful opening */

See also For information about argument variables, see the IDE Project Management and
Building Guide for Arm.
__orderinterrupt
Syntax __orderInterrupt (specification, first_activation,

repeat_interval, variance, infinite_hold time,
hold time, probability)

Parameters specification

The interrupt (string). The specification can either be the full specification used
in the device description file (dd£) or only the name. In the latter case the
interrupt system will automatically get the description from the device
description file.

first_activation

The first activation time in cycles (integer)

repeat_interval

The periodicity in cycles (integer)

variance

The timing variation range in percent (integer between 0 and 100)
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Return value

For use with
Description

Example
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infinite_hold_time

1 if infinite, otherwise 0.

hold_time
The hold time (integer)

probability
The probability in percent (integer between 0 and 100)

The macro returns an interrupt identifier (unsigned long).

If the syntax of specification isincorrect, it returns -1.
The C-SPY Simulator.
Generates an interrupt.

This example generates a repeating interrupt using an infinite hold time first activated
after 4000 cycles:

__orderInterrupt( "IRQ", 4000, 2000, O, 1, 0, 100 );

__popSimulatorinterruptExecutingStack

Syntax
Return value
For use with

Description

See also

__popSimulatorInterruptExecutingStack (void)
int 0
The C-SPY Simulator.

Informs the interrupt simulation system that an interrupt handler has finished executing,
as if the normal instruction used for returning from an interrupt handler was executed.

This is useful if you are using interrupts in such a way that the normal instruction for
returning from an interrupt handler is not used, for example in an operating system with
task-switching. In this case, the interrupt simulation system cannot automatically detect
that the interrupt has finished executing.

Simulating an interrupt in a multi-task system, page 394.
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__probeType

__readAPReg

C-SPY® Debugging Guide

for Arm

Syntax

Parameters

Return value

For use with

Description

Example

Syntax

Parameters

Return value

For use with

__driverType (probe_id)

probe_id
A string corresponding to the probe you want to check for. Choose one of these:

"I-jet" corresponds to the I-jet probe
"JTAGjet" corresponds to the JTAGjet probe
"I-jet-Trace" corresponds to the I-jet Trace probe.

The strings are case-insensitive.

Result Value
Successful 1
Unsuccessful 0

Table 37: __probeType return values
The C-SPY I-jet/JTAGjet driver

Checks to see if the current connected probe is identical to the probe type of the
probe_id parameter.

_ _probeType("I-jet")

If I-jet is the current connected probe, the value 1 is returned. Otherwise 0 is returned.

__readAPReg (register)

register An 8-bit AP register offset.
Result Value

Successful true

Unsuccessful false

Table 38: __readAPReg return values

The C-SPY I-jet/JTAGjet driver



Description

__readDPReg

Syntax

Parameters

Return value

For use with

Description

__readFile
Syntax

Parameters

Return value

The C-SPY J-Link/J-Trace driver
The C-SPY TI Stellaris driver
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Performs a read operation from an AP register of the currently selected access port.

__readDPReg (register)

register An 8-bit DP register offset.
Result Value

Successful true

Unsuccessful false

Table 39: __readDPReg return values

The C-SPY I-jet/JTAGjet driver
The C-SPY J-Link/J-Trace driver
The C-SPY TI Stellaris driver

Performs a read operation from a DP register.

__readFile(fileHandle, valuePtr)

fileHandle

A macro variable used as filehandle by the __openFile macro.

valuePtr

A pointer to a variable.

Result Value
Successful 0
Unsuccessful Non-zero error number

Table 40: __readFile return values
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For use with

Description

Example

__readFileByte

Syntax

Parameters

Return value
For use with
Description

Example

C-SPY® Debugging Guide

for Arm

All C-SPY drivers.

Reads a sequence of hexadecimal digits from the given file and converts them to an
unsigned long which is assigned to the value parameter, which should be a pointer
to a macro variable.

Only printable characters representing hexadecimal digits and white-space characters
are accepted, no other characters are allowed.

__var number;
if (__readFile(myFileHandle, &number) == 0)
{

// Do something with number

}

In this example, if the file pointed to by myFileHandle contains the ASCII characters
1234 abcd 90ef, consecutive reads will assign the values 0x1234 Oxabcd 0x90ef
to the variable number.

__readFileByte(fileHandle)

fileHandle
A macro variable used as filehandle by the __openFile macro.

-1 upon error or end-of-file, otherwise a value between 0 and 255.
All C-SPY drivers.
Reads one byte from a file.

__var byte;
while ( (byte = __readFileByte(myFileHandle)) != -1 )
{

/* Do something with byte */
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__readMemory8, __readMemoryByte

Syntax

Parameters

Return value
For use with
Description

Example

__readMemoryl 6

Syntax

Parameters

Return value
For use with
Description

Example

__readMemory8 (address, zone)
__readMemoryByte (address, zone)

address

The memory address (integer).

zone

A string that specifies the memory zone, see C-SPY memory zones, page 159.
The macro returns the value from memory.
All C-SPY drivers.
Reads one byte from a given memory location.

__readMemory8 (0x0108, "Memory") ;

__readMemoryl6 (address, zone)

address

The memory address (integer).

zone

A string that specifies the memory zone, see C-SPY memory zones, page 159.
The macro returns the value from memory.
All C-SPY drivers.
Reads a two-byte word from a given memory location.

__readMemoryl6 (0x0108, "Memory") ;
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__readMemory32

__registerMacrofFile

C-SPY® Debugging Guide

for Arm

Syntax

Parameters

Return value
For use with
Description

Example

Syntax

Parameters

Return value
For use with

Description

Example

See also

__readMemory32 (address, zone)

address

The memory address (integer).

zone

A string that specifies the memory zone, see C-SPY memory zones, page 159.
The macro returns the value from memory.
All C-SPY drivers.
Reads a four-byte word from a given memory location.

__readMemory32 (0x0108, "Memory") ;

__registerMacroFile(filename)

filename

A file containing the macros to be registered (string). The filename must include
a path, which must either be absolute or use argument variables. For information
about argument variables, see the IDE Project Management and Building Guide
for Arm.

int 0

All C-SPY drivers.

Registers macros from a setup macro file. With this function you can register multiple
macro files during C-SPY startup.

__registerMacroFile("c:\\testdir\\macro.mac") ;

Using C-SPY macros, page 415.



__resetFile

Syntax

Parameters

Return value
For use with

Description

C-SPY macros __4

__resetFile(fileHandle)

fileHandle
A macro variable used as filehandle by the __openFile macro.

int 0
All C-SPY drivers.

Rewinds a file previously opened by __openFile.

__restoreSoftwareBreakpoints

Syntax
Return value
For use with

Description

__selectCore

Syntax

Parameters

Return value

For use with

__restoreSoftwareBreakpoints ()
int 0
All C-SPY hardware drivers.

Restores automatically any breakpoints that were destroyed during system startup.

This can be useful if you have an application that is copied to RAM during startup and
is then executing in RAM. This can, for example, be the caseif youuse the initialize
by copy directive for code in the linker configuration file or if you have any
__ramfunc declared functions in your application. In this case, any breakpoints will be
overwritten during the RAM copying when the application execution starts.

By using the this macro, C-SPY will restore the destroyed breakpoints.

__selectCore(int core)

core

The core to switch to. The cores are numbered from 0 and upwards.
int 0

The C-SPY simulator.
The C-SPY I-jet/JTAGjet driver.
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Description Switches focus from the current core to the specified core for the duration of the macro
invocation or until any next invocation of __selectCore.

Example test ()

{

__message "Core: ", __getSelectedCore(), " pc = ", #PC:%x,
“\n”;

_ _selectCore(0);

__message "Core: ", __getSelectedCore(), " pc = ", #PC:%x,
“\n”;

_ _selectCore(l);

__message "Core: ", __getSelectedCore(), " pc = ", #PC:%x,
“\n”;

A typical result of the above macro would be (assuming that the original core was
number 1):

Core: 1 pc = 0000213C
Core: 0 pc = 00000494
Core: 1 pc = 0000213C

See also __getSelectedCore, page 442.

__setCodeBreak
Swwax __setCodeBreak (location, count, condition, cond_type, action)
Parameters location

A string that defines the code location of the breakpoint, either a valid C-SPY
expression whose value evaluates to a valid address, an absolute location, or a
source location. For more information about the location types, see Enter
Location dialog box, page 25.

count
The number of times that a breakpoint condition must be fulfilled before a break
occurs (integer).

condition
The breakpoint condition. This must be a valid C-SPY expression, for instance
a C-SPY macro function.

cond_type
The condition type; either "CHANGED" or "TRUE" (string).

C-SPY® Debugging Guide
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action

An expression, typically a call to a macro, which is evaluated when the
breakpoint is detected.

Return value
Result Value

Successful An unsigned integer uniquely identifying the breakpoint. This value
must be used to clear the breakpoint.

Unsuccessful 0

Table 41: __setCodeBreak return values
For use with The C-SPY hardware debugger drivers.

Description Sets a code breakpoint, that is, a breakpoint which is triggered just before the processor
fetches an instruction at the specified location.

Examples __setCodeBreak ("{D:\\src\\prog.c}.12.9", 3, "d>16", "TRUE",
"ActionCode()");

This example sets a code breakpoint on the label main in your source:

__setCodeBreak("main", 0, "1", "TRUE", "");
See also Breakpoints, page 119.
__setDataBreak
Syntax In the simulator:
__setDataBreak(location, count, condition, cond_type, access,
action)
In the C-SPY I-jet/JTAGjet driver and in the C-SPY CMSIS-DAP driver:
__setDhataBreak (location, access, extend, match, data, mask)
Parameters location

A string that defines the data location of the breakpoint, either a valid C-SPY
expression whose value evaluates to a valid address or an absolute location. For
more information about the location types, see Enter Location dialog box, page
153.

count

The number of times that a breakpoint condition must be fulfilled before a break
occurs (integer).
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This parameter applies to the simulator only.

condition

The breakpoint condition (string).
This parameter applies to the simulator only.

cond_type
The condition type; either "CHANGED" or "TRUE" (string).

This parameter applies to the simulator only.

access

The memory access type: "R", for read, "w" for write, or "Rw" for read/write.

action

An expression, typically a call to a macro, which is evaluated when the
breakpoint is detected.

This parameter applies to the simulator only.

extend

Extends the breakpoint so that a whole data structure is covered. For data
structures that do not fit the size of the possible breakpoint ranges supplied by
the hardware breakpoint unit, for example three bytes, the breakpoint range will
not cover the whole data structure. Note that the breakpoint range will be
extended beyond the size of the data structure, which might cause false triggers
at adjacent data. Choose between "TRUE"Or "FALSE".

This parameter applies to the C-SPY I-jet/JTAGjet driver and the C-SPY
CMSIS-DAP driver only.

match
Enables matching of the accessed data. Choose between "TRUE"or "FALSE".
This parameter applies to the C-SPY I-jet/JTAGjet driver and the C-SPY
CMSIS-DAP driver only.

data
A data value to match, in unsigned 32-bit format.
This parameter applies to the C-SPY I-jet/JTAGjet driver and the C-SPY
CMSIS-DAP driver only.

mask

Specifies which part of the data value to match (word, halfword, or byte), in
unsigned 32-bit format.

C-SPY® Debugging Guide
468 for Arm



C-SPY macros __4

This parameter applies to the C-SPY I-jet/JTAGjet driver and the C-SPY
CMSIS-DAP driver only.

Return value
Result Value

Successful An unsigned integer uniquely identifying the breakpoint. This value
must be used to clear the breakpoint.

Unsuccessful 0

Table 42: __setDataBreak return values

For use with The C-SPY Simulator.
The C-SPY I-jet/JTAGjet driver
The C-SPY CMSIS-DAP driver

Description Sets a data breakpoint, that is, a breakpoint which is triggered directly after the processor
has read or written data at the specified location.

Example For the C-SPY simulator:

__var brk;
brk = __setDataBreak("Memory:0x4710", 3, "d>6", "TRUE",
"W", "ActionDatal()");

__clearBreak (brk) ;

For I-jet:
__var brk;
brk = __ setDataBreak("myVar", "W", "FALSE", "TRUE",

0xABCD, OxFFFF) ;

__clearBreak (brk) ;

See also Breakpoints, page 119.
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__setDatalLogBreak
Syntax __setDataLogBreak (variable, access)
Parameters variable

A string that defines the variable the breakpoint is set on, a variable of integer
type with static storage duration. The microcontroller must also be able to
access the variable with a single-instruction memory access, which means that
you can only set data log breakpoints on 8-, 16-, and 32-bit variables.

access

The memory access type: "R", for read, "w" for write, or "Rw" for read/write.

extend

Use extended range: "TRUE" or "FALSE".

This parameter is only available for the C-SPY I-jet/JTAGjet driver.

Return value
Result Value

Successful An unsigned integer uniquely identifying the breakpoint. This value
must be used to clear the breakpoint.

Unsuccessful 0

Table 43: __setDatalLogBreak return values

For use with The C-SPY Simulator.

The C-SPY I-jet/JTAGjet driver.

Description Sets a data log breakpoint, that is, a breakpoint which is triggered when a specified
variable is accessed. Note that a data log breakpoint does not stop the execution, it just
generates a data log.

Example For the simulator:

__var brk;
brk = __setDataLogBreak ("MyVar", "R");

__clearBreak (brk) ;
For the C-SPY I-jet/JTAGjet driver:

__var brk;
brk = _ seDatalLogBreak ("myVar", "RW", "FALSE");

__clearBreak (brk) ;
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See also Breakpoints, page 119 and Getting started using data logging, page 258.
__setLogBreak
Syntax __setLogBreak(location, message, msg_type, condition,
cond_type)
Parameters location

A string that defines the code location of the breakpoint, either a valid C-SPY
expression whose value evaluates to a valid address, an absolute location, or a
source location. For more information about the location types, see Enter
Location dialog box, page 153.

message

The message text.

msg_type
The message type; choose between:

TEXT, the message is written word for word.

ARGS, the message is interpreted as a comma-separated list of C-SPY
expressions or strings.

condition

The breakpoint condition (string).

cond_type
The condition type; either "CHANGED" or "TRUE" (string).

Return value
Result Value

Successful An unsigned integer uniquely identifying the breakpoint. The same
value must be used when you want to clear the breakpoint.

Unsuccessful 0

Table 44: __setLogBreak return values
For use with All C-SPY drivers.

Description Sets a log breakpoint, that is, a breakpoint which is triggered when an instruction is
fetched from the specified location. If you have set the breakpoint on a specific machine
instruction, the breakpoint will be triggered and the execution will temporarily halt and
print the specified message in the C-SPY Debug Log window.
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Example __var logBpl;
__var logBp2;
logOn ()
{
logBpl = __setLogBreak ("{C:\\temp\\Utilities.c}.23.1",
"\"Entering trace zone at :\", #PC:%X", "ARGS", "1", "TRUE");
logBp2 = __setLogBreak ("{C:\\temp\\Utilities.c}.30.1",
"Leaving trace zone...", "TEXT", "1", "TRUE");
}
logOff ()
{

__clearBreak(logBpl) ;
__clearBreak (logBp2) ;

See also Formatted output, page 423 and Breakpoints, page 119.
__setSimBreak

Syntax __setSimBreak(location, access, action)

Parameters location

A string that defines the data location of the breakpoint, either a valid C-SPY
expression whose value evaluates to a valid address or an absolute location. For
more information about the location types, see Enter Location dialog box, page
153.

access

The memory access type: "R" for read or "w" for write.

action

An expression, typically a call to a macro, which is evaluated when the
breakpoint is detected.

Return value
Result Value

Successful An unsigned integer uniquely identifying the breakpoint. This value
must be used to clear the breakpoint.

Unsuccessful 0

Table 45: __setSimBreak return values

For use with The C-SPY Simulator.
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Description Use this system macro to set immediate breakpoints, which will halt instruction
execution only temporarily. This allows a C-SPY macro function to be called when the
processor is about to read data from a location or immediately after it has written data.
Instruction execution will resume after the action.

This type of breakpoint is useful for simulating memory-mapped devices of various
kinds (for instance serial ports and timers). When the processor reads at a
memory-mapped location, a C-SPY macro function can intervene and supply the
appropriate data. Conversely, when the processor writes to a memory-mapped location,
a C-SPY macro function can act on the value that was written.

__setTraceStartBreak

Syntax In the simulator:
__setTraceStartBreak (location)
In the I-jet/JTAGjet driver:

__setTraceStartBreak (location, access, extend, match, data,
mask)

Parameters location

A string that defines the code location of the breakpoint, either a valid C-SPY
expression whose value evaluates to a valid address, an absolute location, or a
source location. For more information about the location types, see Enter
Location dialog box, page 153.

access
The memory access type: "F" for fetch, "R" for read, "w" for write, or "Rw" for
read/write.

This parameter applies to I-jet/JTTAGjet only.

extend

Extends the breakpoint so that a whole data structure is covered. For data
structures that do not fit the size of the possible breakpoint ranges supplied by
the hardware breakpoint unit, for example three bytes, the breakpoint range will
not cover the whole data structure. Note that the breakpoint range will be
extended beyond the size of the data structure, which might cause false triggers
at adjacent data. Choose between "TRUE"Or "FALSE".

This parameter applies to I-jet/JTAGjet only.

match

Enables matching of the accessed data. Choose between "TRUE"or "FALSE".
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This parameter applies to I-jet/JTTAGjet only.

data
A data value to match, in unsigned 32-bit format.
This parameter applies to I-jet/JTAGjet only.
mask
Specifies which part of the data value to match (word, halfword, or byte), in
unsigned 32-bit format.
This parameter applies to I-jet/JTTAGjet only.
Return value
Result Value
Successful An unsigned integer uniquely identifying the breakpoint. The same
value must be used when you want to clear the breakpoint.
Unsuccessful 0

Table 46: __setTraceStartBreak return values
For use with The C-SPY Simulator.

The C-SPY I-jet/JTAGjet driver.

Description Sets a breakpoint at the specified location. When that breakpoint is triggered, the trace
system is started.

Example __var startTraceBp;
__var stopTraceBp;

traceOn ()
{
startTraceBp = __setTraceStartBreak
("{C:\\TEMP\\Utilities.c}.23.1");
stopTraceBp = __setTraceStopBreak

("{C:\\temp\\Utilities.c}.30.1");

traceOff ()
{

__clearBreak(startTraceBp) ;
__clearBreak (stopTraceBp) ;

See also Breakpoints, page 119.
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__setTraceStopBreak
Syntax In the simulator:

__setTraceStopBreak (location)

In the I-jet/JTAGjet driver:

__setTraceStopBreak (location, access, extend, match, data, mask)

Parameters location

A string that defines the code location of the breakpoint, either a valid C-SPY
expression whose value evaluates to a valid address, an absolute location, or a
source location. For more information about the location types, see Enter
Location dialog box, page 153.

access
The memory access type: "F" for fetch, "R" forread, "w" for write, or "Rw" for
read/write.
This parameter applies to I-jet/JTTAGjet only.

extend
Extends the breakpoint so that a whole data structure is covered. For data
structures that do not fit the size of the possible breakpoint ranges supplied by
the hardware breakpoint unit, for example three bytes, the breakpoint range will
not cover the whole data structure. Note that the breakpoint range will be
extended beyond the size of the data structure, which might cause false triggers
at adjacent data. Choose between "TRUE"Or "FALSE".
This parameter applies to I-jet/JTAGjet only.

match
Enables matching of the accessed data. Choose between "TRUE"or "FALSE".
This parameter applies to I-jet/JTAGjet only.

data
A data value to match, in unsigned 32-bit format.
This parameter applies to I-jet/JTAGjet only.

mask

Specifies which part of the data value to match (word, halfword, or byte), in
unsigned 32-bit format.

This parameter applies to I-jet/JTAGjet only.
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__sourcePosition
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Return value

For use with

Description

Example

See also

Syntax

Parameters

Return value

For use with

Description

Result Value

Successful An unsigned integer uniquely identifying the breakpoint. The same
value must be used when you want to clear the breakpoint.

Unsuccessful int 0

Table 47: __setTraceStopBreak return values

The C-SPY Simulator.
The C-SPY I-jet/JTAGjet driver.

Sets a breakpoint at the specified location. When that breakpoint is triggered, the trace
system is stopped.

See __setTraceStartBreak, page 473.

Breakpoints, page 119.

__sourcePosition(linePtr, colPtr)

linePtr

Pointer to the variable storing the line number

colPtr
Pointer to the variable storing the column number

Result Value
Successful Filename string
Unsuccessful Empty (" ") string

Table 48: __sourcePosition return values
All C-SPY drivers.

If the current execution location corresponds to a source location, this macro returns the
filename as a string. It also sets the value of the variables, pointed to by the parameters,
to the line and column numbers of the source location.



__strFind

Syntax

Parameters

Return value
For use with

Description

Example

See also

__subString

Syntax

Parameters

Return value
For use with

Description

C-SPY macros __4

__strFind(macroString, pattern, position)
macroString
A macro string.

pattern

The string pattern to search for

position

The position where to start the search. The first position is 0
The position where the pattern was found or -1 if the string is not found.
All C-SPY drivers.

This macro searches a given string (macroString) for the occurrence of another string
(pattern).

__strFind("Compiler", "pile", 0) = 3
_strFind("Compiler", "foo", 0) = -1

Macro strings, page 422.

__subString (macroString, position, length)

macroString

A macro string.

position

The start position of the substring. The first position is 0.

length
The length of the substring

A substring extracted from the given macro string.
All C-SPY drivers.

This macro extracts a substring from another string (macroString).
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Example __subString("Compiler", 0, 2)
The resulting macro string contains Co.
__subString("Compiler", 3, 4)

The resulting macro string contains pile.

See also Macro strings, page 422.

__targetDebuggerVersion

Syntax __targetDebuggerVersion ()
Return value A string that represents the version number of the C-SPY debugger processor module.
For use with All C-SPY drivers.
Description This macro returns the version number of the C-SPY debugger processor module.
Example __var toolVer;
toolVer = __targetDebuggerVersion() ;
__message "The target debugger version is, ", toolVer;
__toLower
Syntax __toLower (macroString)
Parameters macroString

A macro string.

Return value The converted macro string.
For use with All C-SPY drivers.
Description This macro returns a copy of the parameter macroString where all the characters have

been converted to lower case.

Example __toLower ("IAR")
The resulting macro string contains iar.
__toLower ("Mix42")

The resulting macro string contains mix42.
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__toString

Syntax

Parameters

Return value
For use with
Description

Example

See also

__toUpper

Syntax

Parameters

Return value
For use with

Description

Macro strings, page 422.

__toString(C_string, maxlength)

C_string

Any null-terminated C string.

maxlength

The maximum length of the returned macro string.
Macro string.

All C-SPY drivers.

C-SPY macros __4

This macro is used for converting C strings (char* or char [ ]) into macro strings.

Assuming your application contains this definition:
char const * hptr = "Hello World!";

this macro call:

__toString (hptr, 5)

would return the macro string containing Hello.

Macro strings, page 422.

__toUpper (macroString)

macroString

A macro string.
The converted string.

All C-SPY drivers.

This macro returns a copy of the parameter macroString where all the characters have

been converted to upper case.
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Example

See also

__unloadimage

Syntax

Parameters

Return value

For use with
Description

See also

__writeAPReg

Syntax

Parameters

Return value
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__toUpper ("string")

The resulting macro string contains STRING.

Macro strings, page 422.

__unloadImage (module_id)

module_id
An integer which represents a unique module identification, which is retrieved
as a return value from the corresponding __loadImage C-SPY macro.

Value Result

module_id A unique module identification (the same as the input
parameter).

int 0 The unloading failed.

Table 49: __unloadlmage return values
All C-SPY drivers.
Unloads debug information from an already downloaded image.

Loading multiple images, page 55 and Images, page 551.

__writeAPReg(data, register)

data A 32-bit value.

register An 8-bit AP register offset.
Result Value

Successful true

Unsuccessful false

Table 50: __writeAPReg return values
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For use with The C-SPY I-Jet/JTAGjet driver
The C-SPY J-Link/J-Trace driver
The C-SPY TI Stellaris driver

Description Performs a write operation to an AP register of the currently selected access port.
__writeDPReg
Syntax __writeDPReg(data, register)
Parameters
data A 32-bit value.
register An 8-bit DP register offset.

Return value

Result Value
Successful true
Unsuccessful false

Table 51: __writeDPReg return values

For use with The C-SPY I-Jet/JTAG;jet driver
The C-SPY J-Link/J-Trace driver
The C-SPY TI Stellaris driver

Description Performs a write operation to a DP register.

Example __writeDPReg (0x010000F0, 0x8)
/* Selects access port 1 and bank 15 */

__writeFile
Syntax __writeFile(fileHandle, value)
Parameters fileHandle

A macro variable used as filehandle by the __openFile macro.

value

An integer.
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Return value int 0
For use with All C-SPY drivers.
Description Prints the integer value in hexadecimal format (with a trailing space) to the file file.

Note: The __fmessage statement can do the same thing. The __writeFile macro is
provided for symmetry with __readFile.

__writeFileByte
Syntax __writeFileByte (fileHandle, value)
Parameters fileHandle
A macro variable used as filehandle by the __openFile macro.
value
An integer.
Return value int 0
For use with All C-SPY drivers.
Description Writes one byte to the file fileHandle.

__writeMemory8, __writeMemoryByte

Syntax __writeMemory8 (value, address, zone)
__writeMemoryByte(value, address, zone)

Parameters value
An integer.

address

The memory address (integer).

zone
A string that specifies the memory zone, see C-SPY memory zones, page 159.
Return value int 0
For use with All C-SPY drivers.
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Description Writes one byte to a given memory location.
Example __writeMemory8 (0x2F, 0x8020, "Memory");
__writeMemoryl 6
Syntax __writeMemoryl6 (value, address, zomne)
Parameters value
An integer.
address

The memory address (integer).

zone
A string that specifies the memory zone, see C-SPY memory zones, page 159.
Return value int 0
For use with All C-SPY drivers.
Description Writes two bytes to a given memory location.
Example __writeMemoryl6 (0x2FFF, 0x8020, "Memory");
__writeMemory32
Syntax __writeMemory32 (value, address, zone)
Parameters value
An integer.
address
The memory address (integer).
zone
A string that specifies the memory zone, see C-SPY memory zones, page 159.
Return value int 0
For use with All C-SPY drivers.
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Description Writes four bytes to a given memory location.

Example __writeMemory32 (0x5555FFFF, 0x8020, "Memory");

Graphical environment for macros

Reference information about:

® Macro Registration window, page 484
® Debugger Macros window, page 486
® Macro Quicklaunch window, page 488

Macro Registration window

The Macro Registration window is available from the View>Macros submenu during
a debug session.

Macro Registration x
Add Remove Remove Al Reload
File Full Path i
SetupSimple.mac ChtutonSetupSimple.mac

7] SetupAdvanced.mac ChtutonSetupAdvanced.mac

Use this window to list, register, and edit your debugger macro files.
Double-click a macro file to open it in the editor window and edit it.

See also Registering C-SPY macros—an overview, page 416.

Requirements

None; this window is always available.

Display area
This area contains these columns:
File
The name of an available macro file. To register the macro file, select the check

box to the left of the filename. The name of a registered macro file appears in
bold style.
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Full path
The path to the location of the added macro file.

Context menu

This context menu is available:
Add...

Remove
Rermove All

Reload
Open File

Open Debugger Macros Window

These commands are available:

Add
Opens a file browser where you can locate the macro file that you want to add
to the list. This menu command is also available as a function button at the top
of the window.

Remove

Removes the selected debugger macro file from the list. This menu command is
also available as a function button at the top of the window.

Remove All

Removes all macro files from the list. This menu command is also available as
a function button at the top of the window.

Reload

Registers the selected macro file. Typically, this is useful when you have edited
a macro file. This menu command is also available as a function button at the
top of the window.

Open File

Opens the selected macro file in the editor window.

Open Debugger Macros Window
Opens the Debugger Macros window.
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Debugger Macros window
The Debugger Macros window is available from the View>Macros submenu during a
debug session.
Click the Name header or the File

header to sort alphabetically on
either function name or filename.

Debugger Macros x
MName Parameters File it
Access i} SetupSimulation.mac 3
__abortlaunch (string)

__cancelAllinterrupts 0

__cancellnterrupt {inf)

__clearBreak {id)

__closeFile (file) :

_ delay fvalug) Sglect amacroand '

_ disablelnterrupts i ick Fl for reference ©

__driverType {string)  information £ -

Use this window to list all registered debugger macro functions, either predefined

system macros or your own. This window is useful when you edit your own macro

functions and want an overview of all available macros that you can use.

o Click the column headers Name or File to sort alphabetically on either function
name or filename.

o Double-clicking a macro defined in a file opens that file in the editor window.

o To open a macro in the Macro Quicklaunch window, drag it from the Debugger
Macros window and drop it in the Macro Quicklaunch window.

o Select a macro and press F1 to get online help information for that macro.

Requirements
None; this window is always available.

Display area
This area contains these columns:

Name
The name of the debugger macro.

Parameters
The parameters of the debugger macro.

File
For macros defined in a file, the name of the file is displayed. For predefined
system macros, -System Macro- is displayed.

C-SPY® Debugging Guide
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Context menu

This context menu is available:

Open File

Add to Quicklaunch Window

User Macros
System Macros

v All Macros

Open Macro Registration Window

These commands are available:
Open File
Opens the selected debugger macro file in the editor window.

Add to Quicklaunch Window
Adds the selected macro to the Macro Quicklaunch window.

User Macros

Lists only the debugger macros that you have defined yourself.

System Macros
Lists only the predefined system macros.

All Macros

Lists all debugger macros, both predefined system macros and your own.

Open Macro Registration Window
Opens the Macro Registration window.
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Macro Quicklaunch window

al

Requirements
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The Macro Quicklaunch window is available from the View menu.

= Expression Result
G testEval()
G nval Error (col 1): Unknown or ambiguous symbol. nval
G testEval2() 0
Q s2-37
G incval() 3
=
2
B
=
5
&
2
= Macro Quicklaunch B

Use this window to evaluate expressions, typically C-SPY macros.

For some devices, there are predefined C-SPY macros available with device support,
typically provided by the chip manufacturer. These macros are useful for performing
certain device-specific tasks. The macros are available in the Macro Quicklaunch
window and are easily identified by their green icon,

The Macro Quicklaunch window is similar to the Quick Watch window, but is
primarily designed for evaluating C-SPY macros. The window gives you precise control
over when to evaluate an expression.

See also Executing C-SPY macros—an overview, page 416.
To add an expression:
Choose one of these alternatives:

o Drag the expression to the window

e In the Expression column, type the expression you want to examine.

If the expression you add and want to evaluate is a C-SPY macro, the macro must first
be registered, see Registering C-SPY macros—an overview, page 416.

To evaluate an expression:

Double-click the Recalculate icon to calculate the value of that expression.

None; this window is always available.
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Display area
This area contains these columns:

g Recalculate icon

To evaluate the expression, double-click the icon. The latest evaluated
expression appears in bold style.

Expression

One or several expressions that you want to evaluate. Click <click to add>
to add an expression. If the return value has changed since last time, the value
will be displayed in red.

Result
Shows the return value from the expression evaluation.

Context menu

This context menu is available:

Evaluate Now
Rermove
Rermove All

These commands are available:

Evaluate Now

Evaluates the selected expression.

Remove
Removes the selected expression.

Remove All
Removes all selected expressions.
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The C-SPY command line
utility—cspybat

e Summary of C-SPY command line options

e Reference information on C-SPY command line options.

Using C-SPY in batch mode

You can execute C-SPY in batch mode if you use the command line utility cspybat,
installed in the directory common\bin.

These topics are covered:

e Starting cspybat
e Output

e Invocation syntax

STARTING CSPYBAT

I To start cspybat you must first create a batch file. An easy way to do that is to use one
of the batch files that C-SPY automatically generates when you start C-SPY in the
IDE.

C-SPY generates a batch file projectname. buildconfiguration.cspy.bat every
time C-SPY is initialized. In addition, two more files are generated:

® project.buildconfiguration.general.xcl, which contains options specific
to cspybat.

® project.buildconfiguration.driver.xcl, which contains options specific to
the C-SPY driver you are using.

You can find the files in the directory $PROJ_DIR$\settings. The files contain the
same settings as the IDE, and provide hints about additional options that you can use.

2 To start cspybat, you can use this command line:

project.cspybat.bat [debugfile]
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Note that debug£ileis optional. You can specify it if you want to use a different debug
file than the one that is used in the project.buildconfiguration.general .xcl
file.

OUTPUT

When you run cspybat, these types of output can be produced:

Terminal output from cspybat itself

All such terminal output is directed to stderr. Note that if you run cspybat from
the command line without any arguments, the cspybat version number and all
available options including brief descriptions are directed to stdout and displayed
on your screen.

Terminal output from the application you are debugging

All such terminal output is directed to stdout, provided that you have used the
--plugin option. See --plugin, page 532.

Error return codes

cspybat returns status information to the host operating system that can be tested in

abatch file. For successful, the value int 0 is returned, and for unsuccessful the value
int 1 is returned.

INVOCATION SYNTAX

The invocation syntax for cspybat is:

cspybat processor DLL driver DLL debug_file

[cspybat_options] --backend driver_ options

Note: In those cases where a filename is required—including the DLL files—you are
recommended to give a full path to the filename.

Parameters

The parameters are:

Parameter Description

processor_DLL The processor-specific DLL file; available in arm\bin.

driver DLL The C-SPY driver DLL file; available in arm\bin.

debug_file The object file that you want to debug (filename extension out). See

also —debugfile, page 502.

cspybat_options The command line options that you want to pass to cspybat. Note

that these options are optional. For information about each option,
see Reference information on C-SPY command line options, page 500.

Table 52: cspybat parameters
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Parameter Description

--backend Marks the beginning of the parameters to the C-SPY driver; all

options that follow will be sent to the driver. Note that this option is
mandatory.

driver_options The command line options that you want to pass to the C-SPY driver.

Note that some of these options are mandatory and some are
optional. For information about each option, see Reference information
on C-SPY command line options, page 500.

Table 52: cspybat parameters (Continued)

Summary of C-SPY command line options

Reference information about:

General cspybat options

Options available for all C-SPY drivers

Options available for the simulator driver

Options available for the C-SPY GDB Server driver
Options available for the C-SPY I-jet/JTAGjet driver
Options available for the C-SPY CMSIS-DAP driver
Options available for the C-SPY J-Link/J-Trace driver
Options available for the C-SPY TI MSP-FET driver
Options available for the C-SPY TI Stellaris driver
Options available for the C-SPY TI XDS driver
Options available for the C-SPY ST-LINK driver
Options available for the C-SPY third-party drivers

GENERAL CSPYBAT OPTIONS

--application_args Passes command line arguments to the debugged

application.

--attach_to_running ta Makes the debugger attach to a running application at
rget its current location, without resetting the target system.

--backend Marks the beginning of the parameters to be sent to the

C-SPY driver (mandatory).

--code_coverage_file Enables the generation of code coverage information

and places it in a specified file.
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--cycles Specifies the maximum number of cycles to run.
--debugfile Specifies an alternative debug file.
--device_macro Specifies a C-SPY device macro file.
--download_only Downloads a code image without starting a debug

session afterwards.

-f Extends the command line.

--flash_loader Specifies a flash loader specification XML file.

--macro Specifies a macro file to be used.

--macro_param Assigns a value to a C-SPY macro parameter.

--plugin Specifies a plugin file to be used.

--rtc_enable Enables C-RUN runtime error checking in cspybat.

--rtc_output Specifies to cspybat a file for the C-RUN message
output.

--rtc_raw_to_txt Makes cspybat act as a runtime checking message

filter by reading a file as input.

--rtc_rules Specifies a file for the C-RUN rules to cspybat.
--silent Onmits the sign-on message.
--timeout Limits the maximum allowed execution time.

OPTIONS AVAILABLE FOR ALL C-SPY DRIVERS

--BES8 Uses the big-endian format BES. For reference
information, see the /AR C/C++ Development Guide for
Arm.

--BE32 Uses the big-endian format BE32. For reference
information, see the /AR C/C++ Development Guide for
Arm.

--cpu Specifies a processor variant. For reference information,
see the JAR C/C++ Development Guide for Arm.

--device Specifies the name of the device.

--drv_communication  Specifies the communication link to be used.

C-SPY® Debugging Guide
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--drv_communication_1

og

--drv_reset_to_cpu_st
art

--drv_restore_breakpo
ints

--drv_suppress_downlo
ad
--drv_vector_table_ba

se

--drv_verify download

--endian

--fpu

--leave_target_runnin
g

-
--proc_stack_stack

--semihosting
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Creates a log file.

Onmits setting the PC when resetting the application.

Restores automatically any breakpoints that were
destroyed during system startup.

Suppresses download of the executable image. For
reference information, see Download, page 550,
specifically the option Suppress download.

Specifies the location of the Cortex-M reset vector and
the initial stack pointer value.

Verifies the target program. For reference information,
see Download, page 550, specifically the option Verify
download.

Available for all hardware drivers.

Specifies the byte order of the generated code and data.
For reference information, see the /AR C/C++
Development Guide for Arm.

Selects the type of floating-point unit. For reference
information, see the /AR C/C++ Development Guide for
Arm.

Starts the execution on the target and then exits but leaves
the target running.

Specifies the device description file to be used.
Provides C-SPY with information about reserved stacks.

Enables semihosted 1/0.

OPTIONS AVAILABLE FOR THE SIMULATOR DRIVER

--disable_interrupts

--function_profiling

--mapu

Disables the interrupt simulation.

Analyzes your source code to find where the most time is
spent during execution.

Activates memory access checking.
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OPTIONS AVAILABLE FOR THE C-SPY GDB SERVER DRIVER

--drv_default_breakpoint Sets the type of breakpoint resource to be used
when setting breakpoints.

--gdbserv_exec_command Sends a command string to the GDB Server.

OPTIONS AVAILABLE FOR THE C-SPY I-JET/JTAGJET DRIVER

--drv_catch_exceptions Makes the application stop for certain
exceptions.
--drv_default_breakpoint Sets the type of breakpoint resource to be used

when setting breakpoints.

--drv_interface Selects the communication interface.

--drv_interface_speed Specifies the JTAG and SWD speed.

--jet_board_cfg Specifies a probe configuration file.

--jet_board_did Selects which CPU to debug on a multi-core
system.

--jet_cpu_clock Specifies the frequency of the internal

processor clock.

--jet_ir_length Specifies the number of IR bits preceding the
Arm core to connect to.

--jet_power_from_probe Specifies the power supply from the I-jet or
I-jet Trace probe.

--jet_probe Specifies which debug system the C-SPY
I-jet/JTAGjet driver is an interface to.
--jet_script_file Specifies the reset script file.
--jet_standard_reset Selects the reset strategy to be used when
C-SPY starts.
--jet_startup_connection_tim Prolongs the time that the C-SPY driver tries to
eout connect to the target board.
--jet_swo_on_do Specifies that SWO trace data is output on the

trace data pin DO

C-SPY® Debugging Guide
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--jet_swo_prescaler Specifies the SWO prescaler for the CPU clock
frequency.

--jet_swo_protocol Selects the SWO communication protocol.

--jet_tap_position Selects a specific device in the JTAG scan
chain.

--reset_style Specifies the reset strategies that will be

available when debugging.

OPTIONS AVAILABLE FOR THE C-SPY CMSIS-DAP DRIVER

--drv_catch_exceptions Makes the application stop for certain
exceptions.
--drv_default_breakpoint Sets the type of breakpoint resource to be used

when setting breakpoints.

--drv_interface Selects the communication interface.
--drv_interface_speed Specifies the JTAG and SWD speed.
--jet_board_cfg Specifies a probe configuration file.
--jet_board_did Selects which CPU to debug on a multi-core
system.
--jet_probe Specifies which debug system the C-SPY
driver is an interface to.
--jet_script_file Specifies the reset script file.
--jet_standard_reset Selects the reset strategy to be used when
C-SPY starts.
--jet_startup_connection_tim Prolongs the time that the C-SPY driver tries to
eout connect to the target board.
--jet_tap_position Selects a specific device in the JTAG scan
chain.
--reset_style Specifies the reset strategies that will be

available when debugging.
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OPTIONS AVAILABLE FOR THE C-SPY J-LINK/J-TRACE DRIVER

--drv_catch_exceptions Makes the application stop for certain
exceptions.
--drv_default_breakpoint Sets the type of breakpoint resource to be used

when setting breakpoints.

--drv_interface Selects the communication interface.

--drv_interface_speed Specifies the JTAG and SWD speed.

--drv_swo_clock_setup Specifies the CPU clock and the wanted SWO
speed.

--jlink_dcc_timeout Specifies the timeout for a pending request

from C-SPY to the DCC agent on target.

--jlink_device_select Selects a specific device in the JTAG scan
chain.
--jlink_exec_command Calls the __j1inkExecCommand macro after

target connection has been established.

--jlink_initial_speed Sets the initial JTAG communication speed in
kHz.

--jlink_ir_length Sets the number of IR bits preceding the Arm
core to connect to.

--jlink_reset_strategy Selects the reset strategy to use at debugger
startup.

--jlink_script_file Specifies the script file for setting up hardware.

--jlink_trace_source Selects either ETB or ETM as the trace source.

OPTIONS AVAILABLE FOR THE C-SPY TI MSP-FET DRIVER

--mspfet_erase_flash .Specifies which flash memory to erase before
download.

--mspfet_interface_speed Specifies the interface communication speed.

--mspfet_reset_strategy Selects the reset strategy to use at debugger
startup.

C-SPY® Debugging Guide
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--mspfet_vccvoltage
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Specifies a delay that will be used between
switching on the target VCC and starting the
identification of the Arm device.

Specifies the target VCC voltage.

OPTIONS AVAILABLE FOR THE C-SPY TI STELLARIS DRIVER

--drv_interface

--drv_interface_speed

Selects the communication interface.

Specifies the JTAG and SWD speed.

OPTIONS AVAILABLE FOR THE C-SPY TI XDS DRIVER

--drv_catch_exceptions

--drv_default_breakpoint

--drv_interface
--drv_interface_speed

--drv_swo_clock_setup

--xds_board_file
--xds_reset_strategy

--xds_rootdir

Makes the application stop for certain
exceptions.

Sets the type of breakpoint resource to be used
when setting breakpoints.

Selects the communication interface.
Specifies the JTAG and SWD speed.

Specifies the CPU clock and the wanted SWO
speed.

Overrides the default board file.
Specifies the reset strategy to use.

Specifies the installation directory of the TI
XDS driver package.

OPTIONS AVAILABLE FOR THE C-SPY ST-LINK DRIVER

--drv_catch_exceptions

--drv_interface
--drv_interface_speed

--drv_swo_clock_setup

Makes the application stop for certain
exceptions.

Selects the communication interface.
Specifies the JTAG and SWD interface speed.

Specifies the CPU clock and the wanted SWO
speed.
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--stlink_reset_strategy Specifies the reset strategy to use.

OPTIONS AVAILABLE FOR THE C-SPY THIRD-PARTY DRIVERS

For information about any options specific to the third-party driver you are using, see its
documentation.

Reference information on C-SPY command line options

--application_args

Syntax
Parameters
For use with

Description

Example

[1H

This section gives detailed reference information about each cspybat option and each
option available to the C-SPY drivers.

--application_args="arg0 argl ..."

arg

/* __argc, the number of arguments in __argv. */
__no_init int __argc;

/* __argv, an array of pointers to strings that holds the

arguments; must be large enough to fit the number of
parameters.*/
__no_init const char * __argv[MAX_ ARGS];

/* __argvbuf, a storage area for __argv; must be large enough to

hold all command line parameters. */
__no_init __root char __argvbuf [MAX_ARG_SIZE];

--application_args="--logfile log.txt --verbose"

To set related options, use Project>Options>Debugger>Extra Options.

--attach_to_running_target

Syntax

For use with

C-SPY® Debugging Guide
for Arm

--attach_to_running_target

cspybat.



Description

--backend

Syntax

Parameters

For use with

Description

--code_coverage_file

Syntax

Parameters

For use with

Description

The C-SPY command line utility—cspybat ___o

Note: This option might not be supported by the combination of C-SPY driver and
device that you are using. If you are using this option with an unsupported combination,
C-SPY produces a message.

Use this option to make the debugger attach to a running application at its current
location, without resetting the target system.

If you have defined any breakpoints in your project, the C-SPY driver will set them
during attachment. If the C-SPY driver cannot set them without stopping the target
system, the breakpoints will be disabled. The option also suppresses download and the
Run to option.

Project>Attach to Running Target

--backend {driver options}

driver options

Any option available to the C-SPY driver you are using.
cspybat (mandatory).

Use this option to send options to the C-SPY driver. All options that follow --backend
will be passed to the C-SPY driver, and will not be processed by cspybat itself.

This option is not available in the IDE.

--code_coverage_file file

Note that this option must be placed before the --backend option on the command line.

file
The name of the destination file for the code coverage information.

cspybat

Use this option to enable the generation of a text-based report file for code coverage
information. The code coverage information will be generated after the execution has
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--cycles

Syntax

Parameters

For use with

Description

--debugfile

Syntax

Parameters

For use with
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completed and you can find it in the specified file. Because most embedded applications
do not terminate, you might have to use this option in combination with --timeout or
--cycles.

Note that this option requires that the C-SPY driver you are using supports code
coverage. If you try to use this option with a C-SPY driver that does not support code
coverage, an error message will be directed to stderr.

Code coverage, page 305, --cycles, page 502, --timeout, page 536.

To set this option, choose View>Code Coverage, right-click and choose Save As when
the C-SPY debugger is running.

--cycles cycles

Note that this option must be placed before the - -backend option on the command line.

cycles

The number of cycles to run.
cspybat

Use this option to specify the maximum number of cycles to run. If the target program
executes longer than the number of cycles specified, the target program will be aborted.
Using this option requires that the C-SPY driver you are using supports a cycle counter,
and that it can be sampled while executing.

This option is not available in the IDE.

--debugfile filename

filename

The name of the debug file to use.

cspybat

This option can be placed both before and after the --backend option on the command
line.
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Description Use this option to make cspybat use the specified debug file instead of the one used in
the generated cpsybat .bat file.

This option is not available in the IDE.

--device
Syntax --device=device_name
Parameters
device_name The name of the device, for example, ADuC7030,
AT91SAM7S256, LPC2378, STRO912FM44, or TMS470R1B1M.
For use with All C-SPY drivers.
Description Use this option to specify the name of the device.

To set related option, choose:

Project>Options>General Options>Target>Device

--device_macro
Syntax --device_macro filename
Note that this option must be placed before the - -backend option on the command line.

Parameters filename
The C-SPY device macro file to be used (filename extension dmac).

For use with cspybat

Description Use this option to specify a C-SPY device macro file to be loaded before you execute
the target application. A device macro is also loaded when you run a flash loader.

A device macro can include scripted reset styles that can be used by the debugger.

This option can be used more than once on the command line.

See also Briefly about using C-SPY macros, page 414.

mm  This option is not available in the IDE.

[1H
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--disable_interrupts

Syntax
For use with

Description

--download_only

Syntax

For use with

Description

C-SPY® Debugging Guide
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--disable_interrupts
The C-SPY Simulator driver.

Use this option to disable the interrupt simulation.

To set this option, choose Simulator>Interrupt Setup and deselect the Enable
interrupt simulation option.

--download_only

Note that this option must be placed before the - -backend option on the command line.
cspybat

Use this option to download the code image without starting a debug session afterwards.
Project>Download>Download active application
Alternatively, to set a related option, choose:

Project>Options>Debugger>Setup and deselect Run to.
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--drv_catch_exceptions

Syntax --drv_catch_exceptions=value

Parameters
value A value in the range of 0-0x1FF. Each bit specifies
which exception to catch:

(for Arm9, Cortex-R4, Arm11,
and Cortex-A) Bit 0 = Reset

Bit 1 = Undefined instruction

Bit 2 = SWI

Bit 3 = Prefetch abort

Bit 4 = Data abort

Bit 5 = Not used

Bit 6 =IRQ

Bit 7 = FIQ

Bit 8 = Other errors
value A value in the range of 0-0x7FF. Each bit specifies
(for Cortex-M) which exception to catch:

Bit 0 = CORERESET - Reset Vector

Bit 4 = MMERR - Memory Management Fault

Bit 5 = NOCPERR - Coprocessor Access Error

Bit 6 = CHKERR - Checking Error

Bit 7= STATERR - State Error

Bit 8 = BUSERR - Bus Error

Bit 9 = INTERR - Interrupt Service Errors

Bit 10 = HARDERR - Hard Fault

For use with The C-SPY I-jet/JTAGjet driver
The C-SPY J-Link/J-Trace driver
The C-SPY CMSIS-DAP driver
The C-SPY ST-LINK driver
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See also

--drv_communication

Syntax

Parameters
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The C-SPY TI XDS driver.

Use this option to make the application stop when a certain exception occurs.

Setting a breakpoint on an exception vector, page 129.

Project>Options>Debugger>Driver>Breakpoints>Catch exceptions

--drv_communication=connection

Where connection is one of these for the C-SPY GDB Server driver:

Via Ethernet

TCPIP: ip_address
TCPIP:ip_address, port
TCPIP: hostname
TCPIP:hostname, port

Note that if no port is specified, port 3333 is used by default.

Where connection is one of these for the C-SPY J-Link/J-Trace driver:

Via USB port

Via USB directly to the
debug probe

USB: #serial where serial is a string of digits and letters
that identifies which probe you want to connect to. The serial
number can be found either printed on the probe or obtained
by connecting only one probe and then starting the debug
session. The serial number is then displayed in the Debug
Log window. The serial number is also displayed in the
Debug Probe Selection dialog box.

USB: #select forces the Debug Probe Selection dialog box
to be displayed each time you start a debug session.

USBO-USB3

When using USBO and if there are more than one debug
probes on the USB connection, a dialog box is displayed
when the debug session starts. Use the dialog box to choose
which debug probe to connect to.
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Via J-Link on LAN TCPIP:

When the colon sign is not followed by any address, host
name, or serial number, the J-Link driver searches for all
J-Link debug probes on the local network and displays them
in a dialog box where you can choose which one to connect
to (Auto detect).

TCPIP:ip_address
TCPIP:ip_address, port
TCPIP: hostname
TCPIP:hostname, port

TCPIP:#serial, connects to the J-Link with the serial
number number on the local network

Note that if no port is specified, port 19020 is used by default.
Where connection is one of these for the C-SPY I-jet/JTTAGjet driver:

Via USB port USB: #serial where serial is a string of digits and letters
that identifies which probe you want to connect to. The serial
number can be found either printed on the probe or obtained
by connecting only one probe and then starting the debug
session. The serial number is then displayed in the Debug
Log window. The serial number is also displayed in the
Debug Probe Selection dialog box.

USB: #select forces the Debug Probe Selection dialog box
to be displayed each time you start a debug session.
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Where connection is one of these for the C-SPY ST-LINK driver, the C-SPY TI
Stellaris driver, and the C-SPY TI XDS driver:

Via USB port

USB: #serial where serial is a string of digits and letters
that identifies which probe you want to connect to. The serial
number can be found either printed on the probe or obtained
by connecting only one probe and then starting the debug
session. The serial number is then displayed in the Debug
Log window. The serial number is also displayed in the
Debug Probe Selection dialog box.

USB: #select forces the Debug Probe Selection dialog box
to be displayed each time you start a debug session.

USBx where x is the enumeration order (0-256) of the probe
when plugged in. This is an alternative notation for when the
serial number cannot be used—a solution for older probes.
However, this is an uncertain method, because the order can
change the next time that you plug in the probes, or when you
reboot your computer. The USB port can be obtained by
plugging in all probes to be used. Then use
--drv_communication=USB: #select to display all
connected probes in the Debug Probe Selection dialog box.

Where connection is one of these for the C-SPY TI MSP-FET driver:

Via COM port

coMx where x is the enumeration order (0-256) of the probe
when plugged in. This is an uncertain method, because the
order can change the next time that you plug in the probes, or
when you reboot your computer.

If you do not specity the option --drv_communication, the
debug probe is automatically selected.

The C-SPY GDB Server driver

The C-SPY J-Link/J-Trace driver

The C-SPY ST-LINK driver
The C-SPY TI MSP-FET driver
The C-SPY TI Stellaris driver

The C-SPY TI XDS driver.

Use this option to choose communication link.
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Project>Options>Debugger>GDB Server>TCP/IP address or hostname [,port]
Project>Options>Debugger>J-Link/J-Trace>Connection>Communication
Project>Options>Debugger>ST-LINK>Setup

Project>Options>Debugger>TI MSP-FET>Setup
Project>Options>Debugger>TI XDS>Setup

To set this option for the C-SPY TI Stellaris driver, use
Project>Options>Debugger>Extra Options.

--drv_communication_log

Syntax

Parameters

For use with

Description

--drv_communication_log=filename

filename The name of the log file.

All C-SPY hardware drivers.

Use this option to log the communication between C-SPY and the target system to a file.

To interpret the result, detailed knowledge of the communication protocol is required.

Project>Options>Debugger>Driver>Log communication

--drv_default_breakpoint

Syntax

Parameters

For use with

--drv_default_breakpoint={0|1]|2}

0 Auto (default)
1 Hardware
2 Software

The C-SPY GDB Server driver
The C-SPY I-jet/JTAGjet driver
The C-SPY J-Link/J-Trace driver
The C-SPY CMSIS-DAP driver

509



Reference information on C-SPY command line options

510

Description

See also

--drv_interface

Syntax

Parameters

For use with

Description

C-SPY® Debugging Guide
for Arm

The C-SPY TI XDS driver.

Use this option to select the type of breakpoint resource to be used when setting a
breakpoint.

Breakpoints options dialog box, page 148.
Project>Options>Debugger>Driver>Breakpoints>Default breakpoint type

--drv_interface={SWD|JTAG|cJTAG|auto}

SWD Specifies the SWD interface
JTAG (default) Specifies the JTAG interface
CJTAG Specifies the cJTAG interface.

This parameter is only available for the C-SPY
I-jet/JTAGjet driver and the C-SPY TI XDS driver.

auto Automatically selects the debug interface. This parameter is
only available for the C-SPY TI MSP-FET driver.

The C-SPY CMSIS-DAP driver

The C-SPY I-jet/JTAGjet driver

The C-SPY J-Link/J-Trace driver

The C-SPY ST-LINK driver.

The C-SPY TI MSP-FET driver.

The C-SPY TI Stellaris driver

The C-SPY TI XDS driver.

Use this option to specify the communication interface between the debug probe and the
target system.

The SWD interface uses fewer pins than JTAG. Specify --drv_interface=swDif you
want to use the serial-wire output (SWO) communication channel. Alternatively, you
can set this option to JTAG and also specify the --jet_swo_on_do0 option. SWO output
on Trace_DO is only supported by the C-SPY I-Jet/I-jet Trace driver.



See also

--drv_interface_speed

Syntax

Parameters

For use with

Description

See also

The C-SPY command line utility—cspybat ___o

Note that if you select stdout/stderr via SWO on the General Options>Library
Configuration page, SWD is selected automatically, unless the device supports output
of SWO on Trace_DO.

o SWO Trace Window Settings dialog box, page 216
o J-Link/J-Trace - Connection, page 576
o ST-LINK - Setup, page 580

Project>Options>Debugger>CMSIS-DAP>Interface/Interface
Project>Options>Debugger>I-jet/JTAGjet>Interface>Interface
Project>Options>Debugger>J-Link/J-Trace>Connection>Interface
Project>Options>Debugger>ST-LINK>Setup>Interface
Project>Options>Debugger>TI MSP-FET>Setup>Interface
Project>Options>Debugger>TI Stellaris>Interface

Project>Options>Debugger>TI XDS>Setup>Interface

--drv_interface_speed=Hz

Hz The frequency in Hz

The C-SPY CMSIS-DAP driver
The C-SPY I-jet/JTAGjet driver
The C-SPY J-Link/J-Trace driver
The C-SPY ST-LINK driver

The C-SPY TI Stellaris driver
The C-SPY TI XDS driver.

Use this option to set the JTAG and SWD communication speed in Hz.

J-Link/J-Trace - Setup, page 572.
Project>Options>Debugger>CMSIS-DAP>Interface>Interface speed
Project>Options>Debugger>I-jet/JTAGjet>Interface>Interface speed
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Project>Options>Debugger>J-Link/J-Trace>Setup>JTAG/SWD speed
Project>Options>Debugger>ST-LINK>Setup>JTAG/SWD speed
Project>Options>Debugger>TI Stellaris>Setup>JTAG/SWD speed
Project>Options>Debugger>TI XDS>Setup>JTAG/SWD speed

--drv_reset_to_cpu_start

Syntax

For use with

Description

--drv_reset_to_cpu_start

The C-SPY GDB Server driver
The C-SPY J-Link/J-Trace driver
The C-SPY TI Stellaris driver
The C-SPY TI XDS driver

The C-SPY ST-LINK driver

The C-SPY TI Stellaris driver
The C-SPY TI XDS driver.

Normally, at reset, the debugger sets PC to the entry point of the application.

This option omits setting the PC each time that the application is reset. This can be useful
when you want to keep the reset value that the CPU sets at reset, for example to start
executing from the very first instruction pointed out by the vector table, or to run a
bootloader or OS startup code before entering the start address of the application.

This option also keeps the value of the sp (for Cortex-M) or CPSR register (for other

devices) set by the CPU.

To set this option, use Project>Options>Debugger>Extra Options.

--drv_restore_breakpoints

Syntax

ParametersParameters

For use with

C-SPY® Debugging Guide
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--drv_restore_breakpoints=location

location Address or function name label

The C-SPY CMSIS-DAP driver



Description

See alsoSee also

--drv_swo_clock_setup

Syntax

Parameters

For use with

Description

The C-SPY command line utility—cspybat ___o

The C-SPY GDB Server driver

The C-SPY I-jet/JTAGjet driver

The C-SPY J-Link/J-Trace driver

The C-SPY CMSIS-DAP driver

The C-SPY ST-LINK driver

The C-SPY TI XDS driver.

Use this option to restore automatically any software breakpoints that were overwritten
during system startup.

Breakpoints options dialog box, page 148.

Project>Options>Debugger>Driver>Breakpoints>Restore software breakpoints
at

--drv_swo_clock_setup=frequency, autodetect, wanted

frequency The exact clock frequency used by the internal processor
clock, HCLK, in Hz. This value is used for configuring the
SWO communication speed and for calculating timestamps.

autodetect 0, Specify the wanted frequency using the parameter
wanted.

1, Automatically uses the highest possible frequency that the
J-Link debug probe can handle.

wanted The frequency to be used, if autodetect is 0, in Hz. Use
wanted if data packets are lost during transmission.

The C-SPY J-Link/J-Trace driver
The C-SPY ST-LINK driver
The C-SPY TI XDS driver.

Use this option to set up the CPU clock. If this option is not used, the CPU clock
frequency is by default set to 72 MHz.
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Project>Options>Debugger>J-Link/J-Trace>Setup>Clock setup
Project>Options>Debugger>ST-LINK>Communication>Clock setup

Project>Options>Debugger>TI XDS>Communication>Clock setup

--drv_vector_table_ base

Syntax --drv_vector_table_base=expression
Parameters

expression A label or an address
For use with The C-SPY GDB Server driver

The C-SPY I-jet/JTAGjet driver
The C-SPY J-Link/J-Trace driver
The C-SPY CMSIS-DAP driver
The C-SPY TI Stellaris driver
The C-SPY TI XDS driver
The C-SPY ST-LINK driver
The C-SPY Simulator driver.
Description Use this option to specify the location of the reset vector (this also determines the
placement of the initial stack pointer value for Cortex-M). This is useful if you want to
override the default __vector_table label—defined in the system startup code—in

the application or if the application lacks this label, which can be the case if you debug
code that is built by tools from another vendor.

To set this option, use Project>Options>Debugger>Extra Options.

Syntax -f filename

Parameters filename

A text file that contains the command line options (default filename extension
xcl).

C-SPY® Debugging Guide
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For use with

Description

--flash_loader

Syntax

Parameters

For use with

Description

See also

--function_profiling

Syntax

Parameters

The C-SPY command line utility—cspybat ___o

cspybat

This option can be placed either before or after the --backend option on the command
line.

Use this option to make cspybat read command line options from the specified file.

In the command file, you format the items exactly as if they were on the command line
itself, except that you may use multiple lines, because the newline character is treated
like a space or tab character.

Both C/C++ style comments are allowed in the file. Double quotes behave in the same
way as in the Microsoft Windows command line environment.

To set this option, use Project>Options>Debugger>Extra Options.

--flash_loader filename

Note that this option must be placed before the --backend option on the command line.

filename

The flash loader specification XML file, with the filename extension board.
cspybat

Use this option to specify a flash loader specification xml file which contains all relevant
information about the flash loading. There can be more than one such argument, in
which case each argument will be processed in the specified order, resulting in several
flash programming passes.

The IAR Embedded Workbench flash loader User Guide.
To set related options, choose:

Project>Options>Debugger>Use flash loader(s)

--function_profiling filename

filename

The name of the log file where the profiling data is saved.
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For use with

Description

The C-SPY simulator driver.

Use this option to find the functions in your source code where the most time is spent
during execution. The profiling information is saved to the specified file. For more
information about function profiling, see Profiling, page 291.

C-SPY driver>Function Profiling

--gdbserv_exec_command

Syntax

Parameters

For use with

Description

--jet_board_cfg

Syntax

Parameters

For use with

Description

C-SPY® Debugging Guide
for Arm

--gdbserv_exec_command="string"

"string" String or command sent to the GDB Server; see its
documentation for more information.

The C-SPY GDB Server driver.

Use this option to send strings or commands to the GDB Server.

Project>Options>Debugger>Extra Options

--jet_board_cfg=probe_configuration_ file

probe_configuration _file  The full path to a probe configuration file.

The C-SPY I-jet/JTAGjet driver

The C-SPY CMSIS-DAP driver

Use this option to specify a probe configuration file that defines the debug system on the
board.

Project>Options>Debugger>CMSIS DAP>Interface>Probe configuration file

Project>Options>Debugger>I-jet/JTAGjet>Interface>Probe configuration file



--jet_board_did

Syntax

Parameters

For use with

Description

Example

The C-SPY command line utility—cspybat ___o

--jet_board_did={cpu | #cpu_number}

cpu If a board configuration file is specified (using
--jet_board_cfg) and the defined debug system
contains more than one CPU, use this parameter to select a
CPU. The value of cpu is a text string. The range of valid
values can be found in the probe configuration file.

#cpu_number If the debug system is a multi-core SWD system, specify the
CPU number on the DAP.

If the debug system is a JTAG scan chain, and there are
several CPUs at the specified TAP position, then specify the
CPU number on target.

Note that # cou_number has no effect if a board
configuration file is specified using --jet_board_cfg.

The C-SPY CMSIS-DAP driver
The C-SPY I-jet/JTAGjet driver

Use this option to specify which CPU to debug on a multi-core system.
--jet_board_did=#cpu_number is applicable also when --jet_probe=cmsisdap
is specified.

Selecting the CPU on a multi-core device with a probe configuration file:
--jet-board-cfg=device.ProbeConfig --jet_board_did=A9_1

Selecting the CPU on a multi-core device with a JTAG scan chain, where several CPUs
are found at the specified TAP position:

--jet_tap_position=1 --jet_ir_length=5 --jet_board_did=#2

Project>Options>Debugger>CMSIS DAP>Interface>Probe configuration
file>CPU

Project>Options>Debugger>CMSIS DAP>Interface>Probe config>Explicit>CPU
number on target

Project>Options>Debugger>I-jet/JTAGjet>Interface>Probe configuration
file>CPU
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--jet_cpu_clock

Syntax

Parameters

For use with

Description

--jet_ir_length
Syntax

Parameters

For use with
Description

See also

C-SPY® Debugging Guide
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Project>Options>Debugger>I-jet/JTAGjet>Interface>Explicit probe
configuration>CPU number on target

--jet_cpu_clock=frequency

frequency The clock frequency in Hz

The C-SPY I-jet/JTAGjet driver.

Use this option to specify the exact clock frequency used by the internal processor clock,
HCLK. This value is used for configuring the SWO communication speed and for
calculating timestamps.

Note: This option is relevant only when the option --jet_swo_protocol is set to
UART.

Project>Options>Debugger>I-jet/JTAGjet>Trace>SWO clock setup>CPU clock

--jet_ir_length=Iength

length The number of IR bits preceding the Arm core to connect to,
for JTAG scan chains that mix Arm devices with other
devices.

The C-SPY I-jet/JTAGjet driver.
Use this option to set the number of IR bits preceding the Arm core to connect to.

I-jet/JTAGjet - Interface, page 566

Project>Options>Debugger>I-jet/JTAGjet>Interface>Explicit probe
configuration>Preceding bits
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--jet_power_from_probe

Syntax

Parameters

For use with

Description

--jet_probe

Syntax

Parameters

For use with

Description

--jet_power_from_probe=[leave_on | switch_off]

leave_on Continues to supply power to the target even after the debug
session has been stopped.

switch_off Turns off the power to the target when the debug session
stops.

The C-SPY I-jet/JTAGjet driver.

Use this option to specify the status of the probe power supply after debugging.
If this option is not specified, the probe will not supply power to the board.

Project>Options>Debugger>I-jet/JTAGjet>Setup>Target power

--jet_probe=[ijet|cmsisdap]

ijet Specifies the C-SPY I-jet/JITAGjet driver as the interface to
an I-jet, I-jet Trace, or JTAGjet probe.

cmsisdap Specifies the C-SPY I-jet/JTAGjet driver as the interface to a
CMSIS-DAP system.

The C-SPY I-jet/JTAGjet driver
The C-SPY CMSIS-DAP driver

Use this option to specify the C-SPY I-jet/JTAGjet driver as the interface to a debug
system.

Project>Options>Debugger>Driver
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--jet_script_file

Syntax --jet_script_file=path
Parameters
path The path to the file where the scripted reset strategies are
described.
For use with The C-SPY I-jet/JTAGjet driver

The C-SPY CMSIS-DAP driver

Description Use this option to specify the file that describes the available scripted reset strategies, if
any.
See also --reset_style, page 533 and --jet_standard_reset, page 521.

To set this option, use Project>Options>Debugger>Extra Options.

C-SPY® Debugging Guide
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--jet_standard_reset

Syntax

Parameters

The C-SPY command line utility—cspybat ___o

--jet_standard_reset=strategy, duration, delay

strategy

duration

delay

The reset strategy. Choose between:
0, reset disabled

1, software reset

2, hardware reset

3, core reset

4, system reset.

The following reset strategies are available, if present in the
file specified by --jet_script_file and defined by
corresponding instances of --reset_style:

5, custom reset

6, reset by watchdog or reset register
7, reset and halt after bootloader

8, reset and halt before bootloader

9, connect during reset

The time in milliseconds that the hardware reset asserts the
reset signal (line nSRST/nRESET) low to reset the device.

Some devices might require a longer reset signal than the
default 200 ms.

This parameter applies to the hardware reset, and to those
custom reset strategies that use the hardware reset.

The delay time, in milliseconds, after the reset signal has
been de-asserted, before the debugger attempts to control the
processor.

The processor might be kept internally in reset for some time
after the external reset signal has been de-asserted, thus
inaccessible for the debugger.

This parameter applies to the Hardware reset, and to those
custom reset strategies that use the Hardware reset.
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For use with

Description

See also

The C-SPY CMSIS-DAP driver

The C-SPY I-jet/JTAGjet driver

Use this option to select the reset strategy to be used when the debugger starts. Note that
Cortex-M uses a different set of strategies than other devices.

--reset_style, page 533 and --jet_script_file, page 520.
Project>Options>Debugger>CMSIS DAP>Setup>Reset
Project>Options>Debugger>I-jet/JTAGjet>Setup>Reset

--jet_startup_connection_timeout

Syntax

Parameters

For use with

Description

--jet_swo_on_d0

Syntax
For use with

Description

C-SPY® Debugging Guide
522 for Arm

--jet_startup_connection_timeout=milliseconds

milliseconds The time in milliseconds.
The C-SPY CMSIS-DAP driver
The C-SPY I-jet/JTAGjet driver

Use this option to prolong the time that the C-SPY driver tries to connect to the target
board.

To set this option, use Project>Options>Debugger>Extra Options.

--jet_swo_on_do0
The C-SPY I-jet/JTAGjet driver.

Use this option to specify that SWO trace data is output on the trace data pin D0. When
using this option, both the SWD and the JTAG interface can handle SWO trace data.

Project>Options>Debugger>I-jet/JTAGjet>Trace>SWO on the TraceD0 pin



--jet_swo_prescaler

Syntax

Parameters

For use with

Description

--jet_swo_protocol

Syntax

Parameters

For use with

Description

The C-SPY command line utility—cspybat ___o

--jet_swo_prescaler=number

number The prescaler value, 1-100, which in turn determines the
CPU clock frequency.

The C-SPY I-jet/JTAGjet driver.

Use this option to specify the prescaler for the SWO clock. The CPU clock frequency is
divided by the number specified as the prescaler. If data packets are lost during
transmission, try using a higher prescaler value.

If this option is not specified, a prescaler value is set automatically. This automatically
set value is the highest possible frequency that the debug probe can handle.

Project>Options>Debugger>I-jet/JTAGjet>Trace>SWO clock setup>SWO
prescaler

--jet_swo_protocol={auto|Manchester |UART}

auto Automatically selects the communication protocol.
Manchester Specifies the Manchester protocol.
UART Specifies the UART protocol.

The C-SPY I-jet/JTAGjet driver.

Use this option to specify the communication protocol for the SWO channel. If this
option is not specified, auto is automatically used.

Project>Options>Debugger>I-jet/JTAGjet>Trace>SWO protocol
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--jet_tap_position

Syntax

Parameters

For use with

Description

See also

--jlink_dcc_timeout

Syntax

Parameters

For use with

Description

C-SPY® Debugging Guide
for Arm

--jet_tap_position=tap number | multidrop_id

tap_number The TAP position of the device you want to connect to.

multidrop_id The target ID in a multi-drop system.

The C-SPY I-jet/JTAGjet driver

The C-SPY CMSIS-DAP driver

If you are using the JTAG interface, and there is more than one device on the JTAG scan
chain, use this option to select a specific device. If you are using the SWD interface, and
there is a multi-drop SWD system on the board, use this option to select a target ID.
I-jet/JTAGjet - Interface, page 566.

Project>Options>Debugger>I-jet/JTAGjet>Interface>Explicit probe
configuration>Target number (TAP or Multidrop ID)

--jlink_dcc_timeout=milliseconds

milliseconds The timeout in milliseconds. The valid range is 5-5000. The
default value is 100 milliseconds.

The C-SPY J-Link/J-Trace driver.

Use this option to specify a timeout for a pending request from C-SPY to the DCC agent
on target.

To set this option, use Project>Options>Debugger>Extra Options.



--jlink_device_select

Syntax

Parameters

For use with

Description

See also

--jlink_exec_command

Syntax

Parameters

For use with

Description

See also

--jlink_initial_speed
Syntax

Parameters

The C-SPY command line utility—cspybat ___o

--jlink_device_select=tap_number

tap_number The TAP position of the device you want to connect to.

The C-SPY J-Link/J-Trace driver.

If there is more than one device on the JTAG scan chain, use this option to select a
specific device.

I-jet/JTAGjet - Interface, page 566.

Project>Options>Debugger>J-Link/J-Trace>Connection>JTAG scan chain>TAP
number

--jlink_exec_commmand=cmdstrl; cmdstr2; cmdstr3 ...

cmdstrn J-Link/J-Trace command string.

The C-SPY J-Link/J-Trace driver.

Use this option to make the debugger call the __j1inkExecCommand macro with one
or several command strings, after target connection has been established.

__jlinkExecCommand, page 448.

To set this option, use Project>Options>Debugger>Extra Options.

--jlink_initial_speed=speed

speed The initial communication speed in kHz. If no speed is
specified, 32 kHz will be used as the initial speed.
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For use with
Description

See also

--jlink_ir_length

Syntax

Parameters

For use with
Description

See also

--jlink_reset_strategy

Syntax

Parameters

For use with

C-SPY® Debugging Guide
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The C-SPY J-Link/J-Trace driver.
Use this option to set the initial JTAG communication speed in kHz.

J-Link/J-Trace - Setup, page 572.
Project>Options>Debugger>J-Link/J-Trace>Setup>JTAG speed>Fixed

--jlink_ir_ length=Iength

length The number of IR bits preceding the Arm core to connect to,
for JTAG scan chains that mix Arm devices with other
devices.

The C-SPY J-Link/J-Trace driver.
Use this option to set the number of IR bits preceding the Arm core to connect to.

J-Link/J-Trace - Connection, page 576.

Project>Options>Debugger>J-Link/J-Trace>Connection>JTAG scan
chain>Preceding bits

--jlink_reset_strategy=delay, strategy

delay For Cortex-M and Arm 7/9/11 with strategies 1-9, delay
should be 0 (ignored). For Arm 7/9/11 with strategy 0, the
delay should be one of 0-10000.

strategy For information about supported reset strategies, see the
J-Link/J-Trace User Guide.

The C-SPY J-Link/J-Trace driver.



Description

See also

--jlink_script_file

Syntax

Parameters

For use with

Description

See also

--jlink_trace_source

Syntax

Parameters

For use with

Description

The C-SPY command line utility—cspybat ___o

Use this option to select the reset strategy to be used at debugger startup.

J-Link/J-Trace - Setup, page 572.
Project>Options>Debugger>J-Link/J-Trace>Setup>Reset

--jlink_script_file=filename

filename The name of the J-Link script file.

The C-SPY J-Link/J-Trace driver.

Use this option to specify the J-Link script file to be used.

J-Link has a script language that can be used for setting up hardware. For certain targets,
ready-made script files are automatically pointed out by IAR Embedded Workbench. In
command line mode, the script file needs to be manually specified by using this option.

The J-Link/J-Trace User Guide (JLinkARM. pdf, document number UMO08001), for a
detailed description of the script language.

To set this option using a non-predefined script file, use
Project>Options>Debugger>Extra Options.

--jlink_trace_source={ETB|ETM}
ETB Selects ETB trace.

ETM Selects ETM trace.

The C-SPY J-Link/J-Trace driver.

Use this option to select either ETB or ETM as the trace source.

Note: This option applies only to J-Trace.
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See also J-Link/J-Trace - Setup, page 572.
Project>Options>Debugger>J-Link/J-Trace>Setup>ETM/ETB

--leave_target_running

Syntax --leave_target_running

For use with cspybat.
Any C-SPY hardware debugger driver.
Note: Even if this option is supported by the C-SPY driver you are using, there might
be device-specific limitations.

Description Use this option to make the debugger leave the application running on the target

hardware after the debug session is closed.

Any existing breakpoints will not be automatically removed. You might want to
consider disabling all breakpoints before using this option.

C-SPY driver>Leave Target Running

=-==MmMacro
Syntax --macro filename
Note that this option must be placed before the - -backend option on the command line.
Parameters filename
The C-SPY macro file to be used (filename extension mac).
For use with cspybat
Description Use this option to specify a C-SPY macro file to be loaded before executing the target
application. This option can be used more than once on the command line.
See also Briefly about using C-SPY macros, page 414.

Project>Options>Debugger>Setup>Setup macros>Use macro file

C-SPY® Debugging Guide
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=--Macro_param

Syntax

Parameters

For use with

Description

See also

--mapu
Syntax

For use with

Description

See also

--mspfet_erase_flash

Syntax

Parameters

The C-SPY command line utility—cspybat ___o

--macro_param [param=value]

Note that this option must be placed before the - -backend option on the command line.

param = value
paramis a parameter defined using the __param C-SPY macro construction.
value is a value.

cspybat

Use this option to assign av value to a C-SPY macro parameter.This option can be used
more than once on the command line.

Macro parameters, page 421.

Project>Options>Debugger>Extra Options

--mapu

The C-SPY simulator driver.

Specify this option to use the section information in the debug file for memory access
checking. During the execution, the simulator will then check for accesses to
unspecified memory ranges. If any such access is found, the C function call stack and a

message will be printed on stderr and the execution will stop.

Monitoring memory and registers, page 161.
To set related options, choose:

Simulator>Memory Access Setup

--mspfet_erase_flash=main|main_info|main_info_ip

main Erases the main flash memory
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main_info Erases both flash memories—main and Information
memory.
main_info_ip Erases the main and Information flash memories,

including the IP protected area.

For use with The C-SPY TI MSP-FET driver.

Description Use this option to specify which flash memories to erase before download.

Project>Options>Debugger>TI MSP-FET>Download>Flash erase

--mspfet_interface_speed

Syntax --mspfet_interface_speed=fast|medium|slow
Parameters
fast The fast interface speed.
medium The medium interface speed.
slow The slow interface speed.
For use with The C-SPY TI MSP-FET driver.
Description Use this option to set the interface communication speed.

Project>Options>Debugger>TI MSP-FET>Setup>Interface speed

--mspfet_reset_strategy

Syntax --mspfet_reset_strategy=delay, strategy
Parameters
delay The delay time in milliseconds.
strategy The reset strategy, where 0 is Normal.
For use with The C-SPY TI MSP-FET driver.
Description Use this option to select the reset strategy to use at debugger startup.

C-SPY® Debugging Guide
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--mspfet_settlingtime

Syntax

Parameters

For use with

Description

--mspfet_vccvoltage

Syntax

Parameters

For use with

Description

Syntax

Parameters

For use with

The C-SPY command line utility—cspybat ___o

Project>Options>Debugger>TI MSP-FET>Setup>Reset

--mspfet_settlingtime=delay

delay The delay in milliseconds.

The C-SPY TI MSP-FET driver.

Use this option to specify a delay that will be used between switching on the target VCC
and starting the identification of the Arm device.

Project>Options>Debugger>TI MSP-FET>Setup>Target VCC>Settling time

-mspfet_vccvoltage=voltage

voltage The target VCC voltage in mV.

The C-SPY TI MSP-FET driver.

Use this option to specify the target VCC voltage.
Project>Options>Debugger>TI MSP-FET>Setup>Target VCC>Target VCC

-p filename

filename

The device description file to be used.

All C-SPY drivers.
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Description

See also

--plugin

Syntax

Parameters

For use with

Description

--proc_stack_stack

Syntax

Parameters
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Use this option to specify the device description file to be used.

Selecting a device description file, page 53.

Project>Options>Debugger>Setup>Device description file

--plugin filename

Note that this option must be placed before the - -backend option on the command line.

filename

The plugin file to be used (filename extension d11).
cspybat

Certain C/C++ standard library functions, for example print£, can be supported by
C-SPY—for example, the C-SPY Terminal I/O window—instead of by real hardware
devices. To enable such support in cspybat, a dedicated plugin module called
armbat.dll located in the arm\bin directory must be used.

Use this option to include this plugin during the debug session. This option can be used
more than once on the command line.

Note: You can use this option to include also other plugin modules, but in that case the
module must be able to work with cspybat specifically. This means that the C-SPY
plugin modules located in the common\plugin directory cannot normally be used with
cspybat.

Project>Options>Debugger>Plugins

--proc_stack_stack=startaddress, endaddress
where stack is one of main or proc for Cortex-M and

where stackis one of usr, svc, irqg, fig, und, or abt for other Arm cores

startaddress The start address of the stack, specified either as a value or
as an expression.
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endaddress The end address of the stack, specified either as a value or as
an expression.

For use with All C-SPY drivers. Note that this command line option is only available when using
C-SPY from the IDE; not in batch mode using cspybat.

Description Use this option to provide C-SPY with information about reserved stacks. By default,
C-SPY receives this information from the system startup code, but if you for some
reason want to override the default values, this option can be useful.

Example --proc_stack_irg=0x8000, 0x80FF

m  To set this option, use Project>Options>Debugger>Extra Options.

--reset_style

Syntax --reset_style="reset_1id, reset_name, selected, menu_command"

Parameters
reset_id The number of the reset strategy, 0-9, as described for
--jet_standard_reset

reset_name The name of the reset strategy, according to the file specified by
--jet_script_file.

For the built-in reset strategies, this parameter is -. To override
a built-in reset strategy, enter the label or function name in your
reset script file.

selected 0 or 1, where 1 sets the default reset strategy for the Reset
drop-down button

menu_command The name of the reset strategy as it will be displayed on the
Reset drop-down menu.

For use with The C-SPY CMSIS-DAP driver
The C-SPY I-jet/JTAGjet driver

Description Use this option to specify the reset strategies that will be available when debugging,
once for each reset strategy.
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Example This example specifies a script file, sets the standard reset strategy, and specifies the
reset strategies that will be available when debugging:

--jet_script_file=myDir\myProbeScriptFile
--jet_standard_reset=9,0,0

--reset_style="0,-,0,Disabled (no reset)"
--reset_style="1,-,0,Software"
--reset_style="2,-,0,Hardware"

--reset_style="3,-,0,Core"

--reset_style="4,-,0,System"
--reset_style="5,Custom, 0,Custom reset"
--reset_style="9,ConnectUnderReset, 1,Connect during reset"

See also --jet_script_file, page 520 and --jet standard reset, page 521
To set this option, use Project>Options>Debugger>Extra Options.

--semihosting

Syntax --semihosting={none|iar_breakpoint}

Parameters
No parameter Use standard semihosting.
none Does not use semihosted I/0.
iar_breakpoint Uses the IAR proprietary semihosting variant.

For use with All C-SPY drivers.

Description Use this option to enable semihosted I/O and to choose the kind of semihosting interface
to use. Note that if this option is not used, semihosting will by default be enabled and
C-SPY will try to choose the correct semihosting mode automatically. This means that
normally you do not have to use this option if your application is linked with
semihosting.
To make semihosting work, your application must be linked with a semihosting library.

See also The IAR C/C++ Development Guide for Arm for more information about linking with

semihosting.

m  Project>Options>General Options>Library Configuration
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--silent
Syntax --silent
Note that this option must be placed before the - -backend option on the command line.
For use with cspybat
Description Use this option to omit the sign-on message.

This option is not available in the IDE.

--stlink_reset_strategy

Syntax --stlink_reset_strategy=delay, strategy

Parameters
delay The delay time measured in milliseconds. delay is ignored
and should be 0.

strategy The reset strategy.
0, (Normal) performs the standard reset procedure.

1, (Reset Pin) uses the reset pin to perform a hardware reset.
Only available for ST-LINK version 2.

2, (Connect during reset) ST-LINK connects to the target
while keeping Reset active (Reset is pulled low and remains
low while connecting to the target). Only available for
ST-LINK version 2.

For use with The C-SPY ST-LINK driver.
Description Use this option to select the reset strategy to be used at debugger startup.
See also ST-LINK - Setup, page 580

Project>Options>Debugger>ST-LINK>Setup>Reset
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--timeout

Syntax

Parameters

For use with

Description

--xds_board_ file

Syntax

Parameters

For use with

Description

--xds_reset_strategy

Syntax

Parameters
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--timeout milliseconds

Note that this option must be placed before the - -backend option on the command line.

milliseconds

The number of milliseconds before the execution stops.
cspybat

Use this option to limit the maximum allowed execution time.

This option is not available in the IDE.

--xds_board_file=dat_file

dat_file The (path and) filename of the board file.

The C-SPY TI XDS driver.

Use this option to override the default board file by specifying a custom board file.
Project>Options>Debugger>TI XDS>Setup>Emulator>Specify custom board file
Project>Options>Debugger>TI XDS>Setup>Emulator>Board file

--stlink_reset_strategy=delay, strategy

delay The delay time measured in milliseconds.
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strategy The reset strategy.
For Cortex-M devices:
0, CPU reset
1, System Reset

2, Board reset. Only available for CC26xx and CC13xx
devices.

3, Board reset, run and halt with delay. Available for all other
Cortex-M devices.

For other devices (not Cortex-M):
0, Software reset

1, Hardware reset

For use with The C-SPY TI XDS driver.
Description Use this option to select the reset strategy to be used at debugger startup.
See also TI XDS - Setup, page 586

Project>Options>Debugger>TI XDS>Setup>Reset

--xds_rootdir

Syntax --xds_rootdir=path
For use with The C-SPY TI XDS driver
Description Use this option to specify the path to the directory where the TI XDS driver package is

installed. If you installed the package in an alternative location, you can use the global
argument variable XDS_EMUPACK_DIR to set a new default value.

m  To set this option, use Project>Options>Debugger>TI XDS>Setup>TI emulation
package installation path.
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Flash loaders

e Introduction to the flash loader
e Using flash loaders

e Reference information on the flash loader

Introduction to the flash loader

A flash loader is an agent that is downloaded to the target. It fetches your application
from the debugger and programs it into flash memory. The flash loader uses the file I/O
mechanism to read the application program from the host. You can select one or several
flash loaders, where each flash loader loads a selected part of your application. This
means that you can use different flash loaders for loading different parts of your
application.

Flash loaders for various microcontrollers is provided with IAR Embedded Workbench
for Arm. In addition to these, more flash loaders are provided by chip manufacturers and
third-party vendors. The flash loader API, documentation, and several implementation

examples are available to make it possible for you to implement your own flash loader.

Using flash loaders

These tasks are covered:

o Setting up the flash loader(s)
o The flash loading mechanism
o Aborting a flash loader.

SETTING UP THE FLASH LOADER(S)

To use a flash loader for downloading your application:
Choose Project>Options.

Choose the Debugger category and click the Download tab.

Select the Use Flash loader(s) option. A default flash loader configured for the device
you have specified will be used. The configuration is specified in a preconfigured
board file.
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To override the default flash loader or to modify the behavior of the default flash loader
to suit your board, select the Override default. board file option, and Edit to open the
Flash Loader Configuration dialog box. A copy of the *.board file will be created

in your project directory and the path to the * . board file will be updated accordingly.

The Flash Loader Overview dialog box lists all currently configured flash loaders, see
Flash Loader Overview dialog box, page 541. You can either select a flash loader or
open the Flash Loader Configuration dialog box.

In the Flash Loader Configuration dialog box, you can configure the download. For
more information about the various flash loader options, see Flash Loader
Configuration dialog box, page 543.

THE FLASH LOADING MECHANISM

When the Use flash loader(s) option is selected and one or several flash loaders have
been configured, these steps are performed when the debug session starts.

Steps 1 to 4 are performed for each flash loader in the flash loader configuration.
C-SPY downloads the flash loader into target RAM.

Steps 2 to 4 are performed one or more times depending on the size of the RAM and the
size of the application image.

C-SPY writes code/data from the application image into target RAM (RAM buffer).
C-SPY starts execution of the flash loader.
The flash loader reads data from the RAM buffer and programs the flash memory.

The application image now resides in flash memory and can be started. The flash
loader and the RAM buffer are no longer needed, so RAM is fully available to the
application in the flash memory.

ABORTING A FLASH LOADER

To abort a flash loader:

Press Ctrl+Shift- (minus) for a short while.

A message that says that the flash loader has aborted is displayed in the Debug Log
window.

This method can be used if you suspect that something is wrong with the execution, for
example because it seems not to terminate in a reasonable time.
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Reference information on the flash loader

Reference information about:

o Flash Loader Overview dialog box, page 541
e Flash Loader Configuration dialog box, page 543.

Flash Loader Overview dialog box

The Flash Loader Overview dialog box is available from the
Project>Options>Debugger>Download page.

Flash Loader Overview

CODE : 0x8000000 - 0x80 1ffff - STOOLKIT_DIR S\configiflashloader?, ..

Range Offset/Address  Loader Path Extra Parameters 0K

The display area

This dialog box lists all defined flash loaders. If you have selected a device on the
Project>Options>General Options>Target page for which there is a flash loader, this
flash loader is by default listed in the Flash Loader Overview dialog box.

Each row in the display area shows how you have set up one flash loader for flashing a
specific part of memory:
Range

The part of your application to be programmed by the selected flash loader.

Offset/Address
The start of the memory where your application will be flashed. If the address
is preceded with a, the address is absolute. Otherwise, it is a relative offset to the
start of the memory.

Loader Path
The path to the flash loader * . f1ash file to be used (* . out for old-style flash
loaders).

Extra Parameters

List of extra parameters that will be passed to the flash loader.

541



Reference information on the flash loader

Click on the column headers to sort the list by range, offset/address, etc.

Function buttons

These function buttons are available:

OK
The selected flash loader(s) will be used for downloading your application to
memory.

Cancel
Standard cancel.

New
Displays a dialog box where you can specify what flash loader to use, see Flash
Loader Configuration dialog box, page 543.

Edit
Displays a dialog box where you can modify the settings for the selected flash
loader, see Flash Loader Configuration dialog box, page 543.

Delete

Deletes the selected flash loader configuration.
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Flash Loader Configuration dialog box

Memory range

Relocate

The Flash Loader Configuration dialog box is available from the Flash Loader
Overview dialog box.

Flash Loader Configuration

Memory range

l

@ Start:  OxD End: 0x0 Cancel
Relocate
Offset: Ox0

Absolute adress:

Flash loader path:

Extra parameters:

Parameter descriptions:

Use the Flash Loader Configuration dialog box to configure the download to suit your
board. A copy of the default board file will be created in your project directory.

Specify the part of your application to be downloaded to flash memory. Choose
between:

All
The whole application is downloaded using this flash loader.

Start/End

Specity the start and the end of the memory area for which part of the
application will be downloaded.

Overrides the default flash base address, in other words, relocates the location of the
application in memory. This means that you can flash your application to a different
location from where it was linked. Choose between:

Offset

A numeric value for a relative offset. This offset will be added to the addresses
in the application file.
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Absolute address

A numeric value for an absolute base address where the application will be
flashed. The lowest address in the application will be placed on this address.
Note that you can only use one flash loader for your application when you
specify an absolute address.

You can use these numeric formats:

® 123456, decimal numbers

® 0x123456, hexadecimal numbers

® 0123456, octal numbers

The default base address used for writing the first byte—the lowest address—to flash is
specified in the linker configuration file used for your application. However, it can
sometimes be necessary to override the flash base address and start at a different location

in the address space. This can, for example, be necessary for devices that remap the
location of the flash memory.

Flash loader path

Use the text box to specify the path to the flash loader file (* . £1ash) to be used by your
board configuration.

Extra parameters

Some flash loaders define their own set of specific options. Use this text box to specify
options to control the flash loader. For information about available flash loader options,
see the Parameter descriptions field.

Parameter descriptions

Displays a description of the extra parameters specified in the Extra parameters text
box.
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Part 4. Additional
reference information

This part of the C-SPY® Debugging Guide for Arm includes these chapters:
e Debugger options

o Additional information on C-SPY drivers
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Debugger options

e Setting debugger options

e Reference information on general debugger options

e Reference information on C-SPY hardware debugger driver options

Setting debugger options

Before you start the C-SPY debugger you might need to set some options—both C-SPY
generic options and options required for the target system (C-SPY driver-specific

options).

To set debugger options in the IDE:

I Choose Project>Options to display the Options dialog box.

2 Select Debugger in the Category list.

For more information about the generic options, see Reference information on general

debugger options, page 548.

3 On the Setup page, make sure to select the appropriate C-SPY driver from the Driver

drop-down list.

4 To set the driver-specific options, select the appropriate driver from the Category list.
Depending on which C-SPY driver you are using, different options are available.

C-SPY driver

Available options pages

C-SPY CADI driver
C-SPY CMSIS-DAP driver

C-SPY GDB Server driver

C-SPY I-jet/JTAGjet driver

CADI - Setup, page 556

CMSIS-DAP - Setup, page 557
CMSIS-DAP - Interface, page 560
Breakpoints options dialog box, page 148
GDB Server, page 562

Breakpoints options dialog box, page 148
l-jet/[TAGjet - Setup, page 563
I-jet/|TAGjet - Interface, page 566
l-jet/|TAGjet - Trace, page 568
Breakpoints options dialog box, page 148

Table 53: Options specific to the C-SPY drivers you are using
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C-SPY driver Available options pages

C-SPY J-Link/J-Trace driver J-Link/|-Trace - Setup, page 572
J-Link{J-Trace - Connection, page 576

Breakpoints options dialog box, page 148

C-SPY Nu-Link driver Nu-Link - Setup, page 578
C-SPY PE micro driver PE micro - Setup, page 579
C-SPY ST-LINK driver ST-LINK - Setup, page 580

ST-LINK - Communication, page 582
C-SPY Tl MSP-FET driver TI MSP-FET - Setup, page 583

TI MSP-FET - Download, page 584
C-SPY TI Stellaris driver Ti Stellaris - Setup, page 585
C-SPY TI XDS driver TI XDS - Setup, page 586

TI XDS - Communication, page 587
Third-party driver Third-Party Driver options, page 589.

Table 53: Options specific to the C-SPY drivers you are using (Continued)
5 To restore all settings to the default factory settings, click the Factory Settings button.

6 When you have set all the required options, click OK in the Options dialog box.

Reference information on general debugger options

Reference information about:

Setup
Download
Images

Extra Options

Multicore

Plugins
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Setup

Driver

Run to

Setup macros
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The general Setup options select the C-SPY driver, the setup macro file, and device
description file to use, and specify which default source code location to run to.

Setup

Driver Fun to
main
Setup macros

[ Use macro file(s)

Device description file
[F] Overide defautt

Selects the C-SPY driver for the target system you have.

Specifies the location C-SPY runs to when the debugger starts after a reset. By default,
C-SPY runs to the main function.

To override the default location, specify the name of a different location you want
C-SPY torun to. You can specify assembler labels or whatever can be evaluated as such,
for example function names.

If the option is deselected, the program counter will contain the regular hardware reset
address at each reset.

See also Executing from reset, page 52.

Registers the contents of a setup macro file in the C-SPY startup sequence. Select Use
macro file and specify the path and name of the setup file, for example
SetupSimple.mac. If no extension is specified, the extension mac is assumed. A
browse button is available for your convenience.

It is possible to specify up to two different macro files.

Device description file

A default device description file—either an IAR-specific ddf file or a CMSIS System
View Description file—is selected automatically based on your project settings. To
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override the default file, select Override default and specify an alternative file. A
browse button is available for your convenience.

For information about the device description file, see Modifying a device description
file, page 57.

IAR-specific device description files for each arm device are provided in the directory
arm\config and have the filename extension daf.

Download
By default, C-SPY downloads the application to RAM or flash when a debug session
starts. The Download options let you modify the behavior of the download.

Download |

[V Verify download
™ Suppress download
[V Use flash loaderis)
[~ Ovenide default board file

IE-TC'C'_-‘Q T_DIRs"corfig‘flashloader\ TexasInstrumen _l
Edlit... |

[~ Perform mass erase before flashing

Verify download

Verifies that the downloaded code image can be read back from target memory with the
correct contents.

Suppress download

Disables the downloading of code, while preserving the present content of the flash.
This command is useful if you want to debug an application that already resides in target
memory.

If this option is combined with the Verify download option, the debugger will read back
the code image from non-volatile memory and verify that it is identical to the debugged
application.

Use flash loader(s)

Use this option to use one or several flash loaders for downloading your application to
flash memory. If a flash loader is available for the selected chip, it is used by default.
Press the Edit button to display the Flash Loader Overview dialog box.

C-SPY® Debugging Guide
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For more information about flash loaders, see Flash loaders, page 539.

Override default .board file

A default flash loader is selected based on your choice of device on the General
Optios>Target page. To override the default flash loader, select Override default
.board file and specify the path to the flash loader you want to use. A browse button is
available for your convenience. Click Edit to display the Flash Loader Overview
dialog box. For more information, see Flash Loader Overview dialog box, page 541.

Perform mass erase before flashing
Use this option to perform a mass erase on your device. Mass erase uses an on-chip
algorithm that is more efficient than erasing using the flash loader.

Note: This option is only available if your flash loader supports mass erase.

The Images options control the use of additional debug files to be downloaded.

Images

Download extra image
Path: E]

Offzet: [ Debug infa onty

[ Download extra image

Debug info only

[ Download extra image

Debug info only

Download extra Images
Controls the use of additional debug files to be downloaded:

Path
Specity the debug file to be downloaded. A browse button is available for your
convenience.

Offset
Specify an integer that determines the destination address for the downloaded
debug file.
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Extra Options

Debug info only

Makes the debugger download only debug information, and not the complete
debug file.

If you want to download more than three images, use the related C-SPY macro, see
__loadlmage, page 453.

For more information, see Loading multiple images, page 55.

The Extra Options page provides you with a command line interface to C-SPY.
Extra Options

[ Use command line options

Use command line options

C-SPY® Debugging Guide
for Arm

Specify command line arguments that are not supported by the IDE to be passed to
C-SPY.

Note that it is possible to use the /args option to pass command line arguments to the
debugged application.

Syntax: /args arg0 argl ...
Multiple lines with /args are allowed, for example:
/args --logfile log.txt

/args --verbose



Multicore

Number of cores

Debugger options °

If you use /args, these variables must be defined in your application:

/* __argc, the number of arguments in __argv. */
__no_init int __argc;
/* __argv, an array of pointers to strings that holds the

arguments; must be large enough to fit the number of
parameters.*/
__no_init const char * __argv[MAX_ ARGS];

/* __argvbuf, a storage area for __argv; must be large enough to
hold all command line parameters. */
__no_init __root char __argvbuf [MAX_ARG_SIZE];

The Multicore options configure multicore debugging.

Mutticore

Symmetric multicore

Number of cores: 1

Asymmetric multicore

Enable multicore master mode
Port: 53461
Slave workspace: SWS_DIRS\dual_core.eww E]
Slave project: Slave

Slave configuration: Debug

[ Attach slave to running target Slave cores: 1

For symmetric multicore debugging, specify the number of cores on your device. For
asymmetric multicore debugging, specify the number of cores in the master project.
(Normally, this will be 1.)

Enable multicore master mode

Makes the debug session an asymmetric multicore debugger master. When you start a
debug session, a new instance of the IAR Embedded Workbench IDE will be started,
using the following options:

Port
Specity the TCP port (typically, larger than 1023) used for communication
between the IDE instances.
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Slave workspace
Specity the workspace to be opened in the slave instance.

Slave project
Specity the name of the project in the workspace to be opened in the slave
instance. For example, if the project filename is MySlaveProj . ewp, specify
MySlaveProj.

Slave configuration
Specity the build configuration to be used when debugging the slave. For
example, Debug or Release.

Attach slave to running target

If you have selected the command Attach to Running Target from the Project
menu, which affects the master. You might want to select also Attach slave to
running target to make the debugger attach also the slave to the running
application at its current location, without resetting the target system.

For information about Attach to Running Target, see the /DE Project
Management and Building Guide for Arm.

Slave cores
Specity the number of cores in the slave project.

Plugins
The Plugins options select the C-SPY plugin modules to be loaded and made available
during debug sessions.

Plugins
Select plugins to load:

Description: Enables code coverage in the debugger.

Location: n 8.0_2common'pluginsCodeCoverage \CodeCoverage dll
Criginator: IAR Systems

Version: 8.05.4818

Select plugins to load

Selects the plugin modules to be loaded and made available during debug sessions. The
list contains the plugin modules delivered with the product installation.
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Description

Describes the plugin module.

Location
Informs about the location of the plugin module.
Generic plugin modules are stored in the common\plugins directory. Target-specific
plugin modules are stored in the arm\plugins directory.

Originator
Informs about the originator of the plugin module, which can be modules provided by
IAR Systems or by third-party vendors.

Version

Informs about the version number.

Reference information on C-SPY hardware debugger driver options

Reference information about:

CADI - Setup, page 556
CMSIS-DAP - Setup, page 557
CMSIS-DAP - Interface, page 560
GDB Server, page 562

I-jet/JTAGjet - Setup, page 563
I-jet/JTAGjet - Interface, page 566
I-jet/JTAGjet - Trace, page 568
J-Link/J-Trace - Setup, page 572
J-Link/J-Trace - Connection, page 576
PE micro - Setup, page 579

ST-LINK - Setup, page 580

ST-LINK - Communication, page 582
TI MSP-FET - Setup, page 583

TI MSP-FET - Download, page 584
T1I Stellaris - Setup, page 585

TI XDS - Setup, page 586

TI XDS - Communication, page 587
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o Third-Party Driver options, page 589

CADI - Setup
The Setup options control the C-SPY CADI driver:

Setup

Name or PID of server to connect to

Memory
@ Physical
) Mirtual

[ Log communication
$PROJ_DIRS\cspycomm Jog

Name or PID of server to connect to

To use the C-SPY CADI driver, you must start an Arm Fast model virtual platform with
a CADI server running (using the -s command when starting the Fast model). If
multiple Fast model platforms are running, use this option to specify the name or the
Process ID of the Fast model server to connect to.

Memory
The memory type of the Fast model platform. Choose between Physical and Virtual.

Log communication

Logs the communication between C-SPY and the target system to a file. To interpret the
result, detailed knowledge of the interface is required.
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Reset
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The Setup options control the C-SPY CMSIS-DAP driver.
Setup |

Reset
IConned during reset (default) j

Duration:l 300 s [relay after: I 200 ms

™ Log communication
I’:PF!C'J_DIF!’: \cspycomm Jog J

Selects the reset strategy to be used when the debugger starts. Note that the Reset option
is applicable only for Cortex-M devices. Based on your hardware, one of the strategies
is the default. Choose between:

Disabled (no reset)

No reset is performed.

Software
Sets PC to the program entry address.

This is a software reset.

Hardware

The probe toggles the nSRST/nRESET line on the JTAG connector to reset the
device. This reset usually also resets the peripheral units. The reset pulse timing
is controlled by the Duration and Delay after options.

The processor should stop at the reset handler before executing any instruction.
Some processors might not stop at the reset vector, but will be halted soon after,
executing some instructions.

Core
Resets the core via the VECTRESET bit; the peripheral units are not affected.

System
Resets the core and peripherals.
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Connect during reset
CMSIS-DAP connects to the target while keeping Reset active. Reset is pulled
low and remains low while connecting to the target.

Custom
Device-specific hardware reset. Some devices might require a special reset
procedure or timing to enable debugging, or to bring the processor to a halt
before it has executed any instruction.

A watchdog timer might be disabled.

Special debug modes, such as debugging in power-saving modes, might be
turned on.

This option is only available for some devices.

Reset by watchdog or reset register
Resets the processor using a software reset register or a watchdog reset.
Peripheral units might not be reset.

This reset strategy is recommended when the processor cannot be stopped at the
reset vector using the hardware reset.

Device-specific software reset. This option is only available for some devices.

Reset and halt after bootloader

Some devices have a ROM bootloader that executes before the processor jumps
to your application code. Use this reset strategy to let the bootloader code
execute and to halt the processor at the entry of the application code.

Depending on the device, this reset strategy is implemented using the hardware,
core, or system reset.

This option is only available for some devices.

Reset and halt before bootloader

This reset strategy is complementary to the Reset and halt after bootloader
strategy. Depending on the device, it is implemented using the hardware, core,
or system reset.

This option is only available for some devices.

All of these strategies are available for both the JTAG and the SWD interface, and all
strategies halt the CPU after the reset.

A software reset of the target does not change the settings of the target system; it only
resets the program counter.
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Normally, a C-SPY reset is a software reset only. If you use the Hardware option,
C-SPY will generate an initial hardware reset when the debugger is started. This is
performed once before download, and if the option Use flash loader(s) is selected, also
once after flash download, see Debugging code in flash, page 60, and Debugging code
in RAM, page 61.

Hardware resets can be a problem if the low-level setup of your application is not

g  complete. If the low-level setup does not set up memory configuration and clocks, the
application will not work after a hardware reset. To handle this in C-SPY, the setup
macro function execUserReset () is suitable. For a similar example where
execUserPreload () is used, see Remapping memory, page 58.

Duration
The time in milliseconds that the hardware reset asserts the reset signal (line
nSRST/nRESET) low to reset the device.
Some devices might require a longer reset signal than the default 200 ms.
This option applies to the hardware reset, and to those custom reset strategies that use
the hardware reset.

Delay after

The delay time, in milliseconds, after the reset signal has been de-asserted, before the
debugger attempts to control the processor.

The processor might be kept internally in reset for some time after the external reset
signal has been de-asserted, thus inaccessible for the debugger.

This option applies to the hardware reset, and to those custom reset styles that use the

hardware reset.

Log communication

Logs the communication between C-SPY and the target system to a file. To interpret the
result, detailed knowledge of the interface is required.
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CMSIS-DAP - Interface

The Interface options specify the interface between CMSIS-DAP and the target system.

Interface

Probe config Praobe configuration file
@ Auto Dverride default
_ From file
) Explicit Select
Interface Explicit probe configuration
ITAG Multi-target debug spstem
@ SWD 1]

Target with multiple CPU =

Interface speed

Auto detect =

Probe config
Auto
The CMSIS-DAP driver automatically identifies the target CPU. It uses the
default probe configuration file, if there is one.

This works best if there is only one CPU present.

From file
Specifies that the probe configuration file needs to be overridden, or that there
are several target CPUs.

Explicit
Specify how to find the target CPU.

Interface

Selects the communication interface between the debug probe and the target system.
Choose between:

JTAG
Uses the JTAG interface.

SWD
Uses the SWD interface.
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JTAG/SWD speed
Specify the JTAG and SWD communication speed. Choose between:
Auto detect
Automatically uses the highest possible frequency for reliable operation.

Adaptive
Synchronizes the clock to the processor clock outside the core. Works only with
Arm devices that have the RTCK JTAG signal available.
n MHz
Sets the JTAG and SWD communication speed to the selected frequency.
If there are JTAG communication problems or problems in writing to target

memory (for example during program download), these problems might be
resolved if the speed is set to a lower frequency.

Probe configuration file
Override default
Specity a probe configuration file to be used instead of the default probe
configuration file that comes with the product package.
Select
Specify how to find the target CPU.

Explicit probe configuration

Multi-target debug system
Specifies that the debug system consists of more than one CPU.

Target number (TAP or Multidrop ID)
If the debug system is a multi-drop SWD, specify the Multidrop ID (in
hexadecimal notation) of the DAP where your CPU is located.

If the debug system is a JTAG scan chain, specify the Target number TAP (Test
Access Port) position of the device you want to connect to. The TAP numbers
start from zero. If there are several CPUs at the TAP position, you also need to
specify the CPU number on target.

CPU number on target
If the debug system is a multi-core SWD, specify the CPU number on the DAP.
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GDB Server

The GDB Server options control the C-SPY GDB Server for the STR9-comStick
evaluation board.
GDB Server

TCPAP address or hostname [port]
a3a.bbb.coe.ddd

™ Log communication

| o

TCPI/IP address or hosthame

Specify the IP address and port number of a GDB server; by default the port number
3333 is used. The TCP/IP connection is used for connecting to a J-Link server running
on a remote computer.

Log communication

Logs the communication between C-SPY and the target system to a file. To interpret the
result, detailed knowledge of the interface is required.
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The Setup options control the I-jet and I-jet Trace in-circuit debugging probes and the

JTAGjet debug probe.

Setup

Reset
Disabled {no reset)

Target power
From the probe
Leave on after debugging
(@ Switch off after debugging

Log communication

SPROJ_DIRS \cspycomm log

Selects the reset strategy to be used when the debugger starts. Note that Cortex-M uses
a different set of strategies than other devices. Based on your hardware, one of the

strategies is the default. Choose between:

Disabled (no reset)

No reset is performed.

Software

Sets PC to the program entry address and SP to the initial stack pointer value.

This is a software reset.

Hardware

The probe toggles the nSRST/nRESET line on the JTAG connector to reset the
device. This reset usually also resets the peripheral units. The reset pulse timing

is controlled by the Duration and Delay after options.

The processor should stop at the reset handler before executing any instruction.
Some processors might not stop at the reset vector, but will be halted soon after,

executing some instructions.

Core

Resets the core via the VECTRESET bit; the peripheral units are not affected. For

Cortex-M devices only.
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System

Resets the core and peripheral units by setting the SYSRESETREQ bit in the
ATIRCR register. Reset vector catch is used for stopping the CPU at the reset
vector before the first instruction is executed. For Cortex-M devices only.

Connect during reset

I-jet/JTAGjet connects to the target while keeping Reset active. Reset is pulled
low and remains low while connecting to the target. This is the recommended
reset strategy for STM32 devices.

Custom

Device-specific hardware reset. Some devices might require a special reset
procedure or timing to enable debugging, or to bring the processor to a halt
before it has executed any instruction.

A watchdog timer might be disabled.

Special debug modes, such as debugging in power-saving modes, might be
turned on.

This option is only available for some devices.

Reset by watchdog or reset register
Resets the processor using a software reset register or a watchdog reset.
Peripheral units might not be reset.

This reset strategy is recommended when the processor cannot be stopped at the
reset vector using the hardware reset.

Device-specific software reset. This option is only available for some devices.

Reset and halt after bootloader
Some devices have a ROM bootloader that executes before the processor jumps
to your application code. Use this reset strategy to let the bootloader code
execute and to halt the processor at the entry of the application code.

Depending on the device, this reset strategy is implemented using the hardware,
core, or system reset.

This option is only available for some devices.

All of these strategies are available for both the JTAG and the SWD interface, and all
strategies halt the CPU after the reset.

A software reset of the target does not change the settings of the target system; it only
resets the program counter and the mode register CPSR to its reset state. For some
Arm9, Arm11, and Cortex-A devices, it also resets the CP15 system control
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coprocessor, effectively disabling the virtual memory (MMU), caches and memory
protection.

Normally, a C-SPY reset is a software reset only. If you use the Hardware option,
C-SPY will generate an initial hardware reset when the debugger is started. This is
performed once before download, and if the option Use flash loader(s) is selected, also
once after flash download, see Debugging code in flash, page 60, and Debugging code
in RAM, page 61.

Hardware resets can be a problem if the low-level setup of your application is not

g  complete. If the low-level setup does not set up memory configuration and clocks, the
application will not work after a hardware reset. To handle this in C-SPY, the setup
macro function execUserReset () is suitable. For a similar example where
execUserPreload () is used, see Remapping memory, page 58.

Duration
The time in milliseconds that the hardware reset asserts the reset signal (line
nSRST/nRESET) low to reset the device.
Some devices might require a longer reset signal than the default 200 ms.
This option applies to the hardware reset, and to those custom reset strategies that use
the hardware reset.

Delay after

The delay time, in milliseconds, after the reset signal has been de-asserted, before the
debugger attempts to control the processor.

The processor might be kept internally in reset for some time after the external reset
signal has been de-asserted, thus inaccessible for the debugger.

This option applies to the hardware reset, and to those custom reset styles that use the
hardware reset.
Target power

If power for the target system is supplied from the probe, this option specifies the status
of the power supply after debugging. Choose between:

Leave on after debugging

Continues to supply power to the target even after the debug session has been
stopped.

Switch off after debugging
Turns off the power to the target when the debug session stops.
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Log communication

Logs the communication between C-SPY and the target system to a file. To interpret the
result, detailed knowledge of the interface is required.

I-jet/JTAGjet - Interface

The Interface options specify the interface between I-jet, I-jet Trace, or JTAGjet and the
target system.

Interface |
i~ Probe config —| [ Frabe configuration file
* Ao I~ Overide default

" From file I J
 Explicit EIF'U:I Select |

r~Interface - Explicit probe configuration
O JTAG I | Multitaraet debug spstem
* SWD Taraet number [TAR o kultidrop [D]; l:—
C cITAG ™| Tiarget with multiple CRLs
LR number on target: IC
Interface speed

| TG szan chait cantaits nonsEt deviees

IMD detect jv Freceding bits: IC

Probe config
Auto
The I-jet/JTAGjet driver automatically identifies the target CPU. It uses the
default probe configuration file, if there is one.

This works best if there is only one CPU present.

From file
Specifies that the probe configuration file needs to be overridden, or that there
are several target CPUs.

Explicit
Specify how to find the target CPU.

Interface

Selects the communication interface between the debug probe and the target system.
Choose between:

JTAG
Uses the JTAG interface.
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SWD

Uses the SWO interface, which uses fewer pins than JTAG. Select SWD if you
want to use the serial-wire output (SWO) communication channel. Note that if
you select stdout/stderr via SWO on the General Options>Library
Configuration page, SWD is selected automatically. For more information
about SWO settings, see SWO Trace Window Settings dialog box, page 216.

cJTAG
Uses the cJTAG interface.

JTAG/SWD speed
Specify the JTAG and SWD communication speed. Choose between:
Auto detect
Automatically uses the highest possible frequency for reliable operation.
Adaptive

Synchronizes the clock to the processor clock outside the core. Works only with
Arm devices that have the RTCK JTAG signal available.

n MHz

If there are JTAG communication problems or problems in writing to target
memory (for example during program download), these problems might be
resolved if the speed is set to a lower frequency.

Probe configuration file
Override default

Specify a probe configuration file to be used instead of the default probe
configuration file that comes with the product package.

Select
Specify how to find the target CPU.

Explicit probe configuration
Multi-target debug system

Specifies that the debug system consists of more than one CPU.

Target number (TAP or Multidrop ID)

If the debug system is a multi-drop SWD, specify the Multidrop ID (in
hexadecimal notation) of the DAP where your CPU is located.
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I-jet/JTAGjet - Trace

Mode
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If the debug system is a JTAG scan chain, specify the Target number TAP (Test
Access Port) position of the device you want to connect to. The TAP numbers
start from zero and are counted from the TDO end (TAP number 0 is the one
connected to the TDO line). If there are several CPUs at the TAP position, you
also need to specify the CPU number on target.

CPU number on target
If the debug system is a multi-core SWD, specify the CPU number on the DAP.

JTAG scan chain contains non-Arm devices
Enables JTAG scan chains that mix Arm devices with other devices like, for

example, FPGA.
Preceding bits

Specity the TAP (Test Access Port) position of the device you want to connect
to. The TAP numbers start from zero.

The Trace options specify the trace behavior for I-jet/JTAGjet.

Trace

Trace data collection
Auto Allow ETE
8 Msamples
SWO protocol SWO clock setup
@ Auto
Manchester o
UART
SWO on the TraceD0 pin

Power measurement (either TrgPwr as provided by the probe or via I-scope) does not
depend on a particular trace mode and is always possible (if the probe supports it).

The Debug Log window will include messages about the currently used trace mode. If
a particular mode cannot be used, either due to probe or board/device limitations, trace
will be disabled and a warning message will be displayed in the Debug Log window.
This is how the support of a particular trace mode is checked:

o The probe must support the particular mode.



Debugger options °

o The probe must support the particular mode on a specific core. For example, ETM
on Arm?9 is not supported by the I-jet Trace probe.

e The specific core must support the particular mode. For example, Cortex-MO does
not support SWO/ETM/ETB at all and Arm9 does not support SWO.

o The used adapter must support the specified mode. For example, ETM trace is not
possible when the Arm20 adapter is used with I-jet Trace.

o The specific device must support the particular mode. For example, ETM trace is
not possible on a Cortex-M3 without ETM, which cannot be detected until reading
the on-chip TPIU configuration register.

The Mode option specifies the mechanism and interface for trace data collection.
Choose between:
Auto
Automatically selects the best possible mechanism and interface, depending on
probe and board/device capabilities.

The basic modes are tried in probe-dependent order:

I-jet: First SWO, then ETB (ETM is not supported).

I-jet Trace: First ETM, then SWO, then ETB.

JTAG;jet-Trace: First ETM, then ETB (SWO is not supported).
JTAGjet: Only ETB (SWO and ETM are not supported).

If none of these modes are available, trace will be disabled (as when None is
selected). In Auto mode, more initial accesses to trace-related on-chip resources
might be made. So, if you are using a specific probe and a specific mode, you
might want to set the mode explicitly which will make C-SPY
initialize/configure trace resources more efficiently.

None

Disables trace. In this mode, C-SPY will not access any trace-related on-chip
resources. You can use this mode when:

® You are experiencing connectivity problems. It might be easier to diagnose
the reason for connectivity problems without the interference from
initialization of trace resources.

o Trace might change some internal clocking and/or GPIO mux settings and
as a result some applications might not work well with a specific trace
mode.

o You want to exercise low-power modes. Internal on-chip trace logic and
toggling trace pins will require some additional current and it might
interfere with low-power measurements. In extreme cases, enabling clocks

569



Reference information on C-SPY hardware debugger driver options

570

Allow ETB

Buffer limit
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for trace/GPIO might prevent the CPU from actually entering low-power
modes, because some clocks inside the CPU must be kept active.

Serial (SWO)
Collects trace data through the serial (SWO) interface.

Parallel (ETM)
Collects trace data through the parallel (ETM) interface.

On-chip (ETB/MTB)
Collects trace data through the on-chip (ETB/MTB) interface.

Allows simultaneous on-chip (ETB) trace. This option is only available when Mode is
Serial (SWO).

Limits probe memory use. This option is only available if parallel (ETM) mode is used,
either explicitly through Parallel (ETM) or implicitly through Auto.

Collected trace data is stored in probe memory.

Because reading and decoding large amounts of trace data takes time, it is possible to
limit what portion of ETM memory will actually be read by C-SPY once trace data
collection is stopped (either because the CPU stopped or because the buffer got full).
Using the Buffer limit option limits the buffer use to a percentage of the total memory
size. Using more probe memory yields more trace data, but will take longer to see results
and use up more host memory. C-SPY will retrieve the most recent samples from the
trace probe, and the rest of the collected trace data will be discarded.

There is no simple correlation between the number of raw ETM samples and the number
of PC samples visible in the ETM Trace window. The ETM protocol itself is highly
compressed, and the probe provides additional compression of ETM idle cycles, so it is
not possible to guess how many instructions can be decoded from a certain number of
raw ETM samples collected by the trace probe. If your application changes PC a lot,
ETM will need to use more samples to send more PC bits and as such, trace data will
not compress well. For a particular application profile, this number is usually constant
(between 0.5 and 2 instructions for a 4-bit sample), so you must use your own judgment
to see what buffer limit that provides a good balance between the size of decoded data
and C-SPY performance.

Note: For the JTAGjet-Trace probe, this option is not available. The buffer limit for
JTAGjet-Trace is fixed to 1M/2M/4M samples, depending on hardware limitations.
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SWO protocol
Specifies the communication protocol for the SWO channel. Choose between:

Auto

Automatically selects the best possible protocol and speed, depending on the
device you are using.

Manchester

Specifies the Manchester protocol.

UART
Specifies the UART protocol.

CPU clock

Specifies the exact clock frequency used by the internal processor clock, HCLK, in MHz.
The value can have decimals. This value is used for configuring the SWO
communication speed.

SWO prescaler

Specifies the clock prescaler of the SWO communication channel in KHz. The
prescaler, in turn, determines the SWO clock frequency.

Auto automatically uses the highest possible frequency that the I-jet or I-jet Trace debug
probe can handle. Use this setting if data packets are lost during transmission.

To override the SWO clock setup options, use the Override project default option in

the SWO Configuration dialog box, see Override project default, page 220.

SWO on the TraceDO pin

Specifies that SWO trace data is output on the trace data DO pin. When using this option,
both the SWD and the JTAG interface can handle SWO trace data.

Note that both the device and the board you are using must support this pin.
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J-Link/}-Trace - Setup

Reset
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The Setup options specify the J-Link/J-Trace probe.

Setup |
~ Resat
INorrnaI j IE:
rJTAG/SWD speed—— | [ Clock setup
 Auto

Iitial |?2 kHz CPU clock: |?2-D MHz

 Ficed |?z kHz SWO clock: [~ Auto
' Adaptive IZDDD kHz

~ETM/ETB
[~ Prefer ETB

Selects the reset strategy to be used when the debugger starts. Note that Cortex-M uses
a different set of strategies than other devices. The actual reset strategy type number is
specified for each available choice. Choose between:
Normal (0, default)
This is the default strategy. It does whatever is the best way to reset the target
device, which for most devices is the same as the reset strategy Core and
peripherals (8). Some special handling might be needed for certain devices, for
example devices which have a ROM bootloader that needs to run after reset and
before your application is started.
Core (1)
Resets the core via the VECTRESET bit; the peripheral units are not affected.

Core and peripherals (8)
Resets the core and the peripherals.

Reset Pin (2)
J-Link pulls its RESET pin low to reset the core and the peripheral units.
Normally, this causes the CPU RESET pin of the target device to go low as well,
which results in a reset of both the CPU and the peripheral units.

Connect during reset (3)

J-Link connects to the target while keeping Reset active (reset is pulled low and
remains low while connecting to the target). This is the recommended reset
strategy for STM32 devices. This strategy is available for STM32 devices only.
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Halt after bootloader (4 or 7)
NXP Cortex-MO devices. This is the same strategy as the Normal strategy, but
the target is halted when the bootloader has finished executing. This is the
recommended reset strategy for LPC11xx and LPC13xx devices.

Analog Devices Cortex-M3 devices (7), Resets the core and peripheral units by
setting the SYSRESETREQ bit in the AIRCR. The core is allowed to perform the
ADI kernel (which enables the debug interface), but the core is halted before the
first instruction after the kernel is executed to guarantee that no user application
code is performed after reset.

Halt before bootloader (5)
This is the same strategy as the Normal strategy, but the target is halted before
the bootloader has started executing. This strategy is normally not used, except
in situations where the bootloader needs to be debugged. This strategy is
available for LPC11xx and LPC13xx devices only.

Normal, disable watchdog (6, 9, or 10)

First performs a Normal reset, to reset the core and peripheral units and halt the
CPU immediately after reset. After the CPU is halted, the watchdog is disabled,
because the watchdog is by default running after reset. If the target application
does not feed the watchdog, J-Link loses connection to the device because it is
permanently reset. This strategy is available for Freescale Kinetis devices (6),
for NXP LPC 1200 devices (9), and for Samsung S3FN60D devices (10).

All of these strategies are available for both the JTAG and the SWD interface, and all
strategies halt the CPU after the reset.

For other cores, choose between these strategies:

Hardware, halt after delay (ms) (0)

Specity the delay between the hardware reset and the halt of the processor. This
is used for making sure that the chip is in a fully operational state when C-SPY
starts to access it. By default, the delay is set to zero to halt the processor as
quickly as possible.

This is a hardware reset.

Hardware, halt using Breakpoint (1)

After reset, J-Link continuously tries to halt the CPU using a breakpoint.
Typically, this halts the CPU shortly after reset; the CPU can in most systems
execute some instructions before it is halted.

This is a hardware reset.
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Hardware, halt at 0 (4)
Halts the processor by placing a breakpoint at the address zero. Note that this is
not supported by all Arm microcontrollers.

This is a hardware reset.

Hardware, halt using DBGRQ (5)

After reset, J-Link continuously tries to halt the CPU using DBGRQ. Typically,
this halts the CPU shortly after reset; the CPU can in most systems execute some
instructions before it is halted.

This is a hardware reset.

Software (-)
Sets PC to the program entry address.

This is a software reset.

Software, Analog devices (2)

Uses a reset sequence specific for the Analog Devices ADuC7xxx family. This
strategy is only available if you have selected such a device from the Device
drop-down list on the General Options>Target page.

This is a software reset.

Hardware, NXP LPC (9)

This strategy is only available if you have selected such a device from the
Device drop-down list on the General Options>Target page.

This is a hardware reset specific to NXP LPC devices.

Hardware, Atmel AT91SAM7 (8)

This strategy is only available if you have selected such a device from the
Device drop-down list on the General Options>Target page.

This is a hardware reset specific for the Atmel AT91SAM?7 family.

For more details about the different reset strategies, see the /AR J-Link and IAR J-Trace
User Guide for JTAG Emulators for ARM Cores available in the arm\doc directory.

A software reset of the target does not change the settings of the target system; it only
resets the program counter and the mode register CPSR to its reset state. Normally, a
C-SPY reset is a software reset only. If you use the Hardware reset option, C-SPY will
generate an initial hardware reset when the debugger is started. This is performed once
before download, and if the option Use flash loader(s) is selected, also once after flash
download, see Debugging code in flash, page 60, and Debugging code in RAM, page 61.

Hardware resets can be a problem if the low-level setup of your application is not
complete. If the low-level setup does not set up memory configuration and clocks, the
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application will not work after a hardware reset. To handle this in C-SPY, the setup
macro function execUserReset () is suitable. For a similar example where
execUserPreload () is used, see Remapping memory, page 58.

JTAG/SWD speed
Specify the JTAG communication speed in kHz. Choose between:

Auto

Automatically uses the highest possible frequency for reliable operation. The

initial speed is the fixed frequency used until the highest possible frequency is
found. The default initial frequency—1000 kHz—can normally be used, but in
cases where it is necessary to halt the CPU after the initial reset, in as short time
as possible, the initial frequency should be increased. If the CPU starts at a very
low clock speed, you might need to set a lower initial value, for example 32 kHz.

A high initial speed is necessary, for example, when the CPU starts to execute
unwanted instructions—for example power down instructions—from flash or
RAM after a reset. A high initial speed would in such cases ensure that the
debugger can quickly halt the CPU after the reset.

The initial value must be in the range 1-50000 kHz.

Fixed
Sets the JTAG communication speed in kHz. The value must be in the range 1—
50000 kHz.

If there are JTAG communication problems or problems in writing to target
memory (for example during program download), these problems might be
resolved if the speed is set to a lower frequency.

Adaptive

Synchronizes the clock to the processor clock outside the core. Works only with
Arm devices that have the RTCK JTAG signal available. For more information
about adaptive speed, see the J-Link/J-Trace User Guide available in the
arm\doc directory.

Clock setup
Specifies the CPU clock. Choose between:
CPU clock

Specifies the exact clock frequency used by the internal processor clock, HCLK,
in MHz. The value can have decimals. This value is used for configuring the
SWO communication speed and for calculating timestamps.
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SWO clock

Specifies the clock frequency of the SWO communication channel in KHz.

Auto

Automatically uses the highest possible frequency that the debug probe can
handle. If Auto is not selected, the wanted SWO clock value can be input in the
text box. The value can have decimals. Use this option if data packets are lost
during transmission.

To override the Clock setup options, use the Override project default option in the
SWO Configuration dialog box, see SWO Configuration dialog box, page 218.

ETM/ETB
The Prefer ETB option selects ETB trace instead of ETM trace, which is the default.

Note: This option applies only to J-Trace.

J-Link/})-Trace - Connection

The Connection options specify the connection with the J-Link/J-Trace probe.
Connection

Communication

O UsE:
& ICPAP: Serial number w
Serial no:

Interface JTAG scan chain
[CJUTAG scan chain with multiple targets

[ Log communication

Communication

Selects the communication channel between C-SPY and the J-Link debug probe.
Choose between:

USB

Selects the USB connection. If Serial number is selected in the drop-down list,
the J-Link debug probe with the specified serial number is chosen.
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TCP/IP
Specify the IP address of a J-Link server. The TCP/IP connection is used for
connecting to a J-Link server running on a remote computer.

IP address, specify the IP address of a J-Link probe connected to LAN.

Auto detect, automatically scans the network for J-Link probes. Use the dialog
box to choose among the detected J-Link probes.

Serial number, connects to the J-Link probe on the network with the serial
number that you specify.

Selects the communication interface between the J-Link debug probe and the target
system. Choose between:
JTAG (default)

Uses the JTAG interface.

SWD

Uses fewer pins than JTAG. Select SWD if you want to use the serial-wire
output (SWO) communication channel. Note that if you select stdout/stderr via
SWO on the General Options>Library Configuration page, SWD is selected
automatically. For more information about SWO settings, see SWO Trace
Window Settings dialog box, page 216.

Specifies the JTAG scan chain. Choose between:

JTAG scan chain with multiple targets
Specifies that there is more than one device on the JTAG scan chain.

TAP number
Specify the TAP (Test Access Port) position of the device you want to connect
to. The TAP numbers start from zero.

Scan chain contains non-ARM devices
Enables JTAG scan chains that mix Arm devices with other devices like, for
example, FPGA.

Preceeding bits
Specity the number of IR bits before the Arm device to be debugged.
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Log communication

Logs the communication between C-SPY and the target system to a file. To interpret the
result, detailed knowledge of the interface is required.

Nu-Link - Setup
The Setup options specify the Nu-Link interface.

Setup

[ Log communication

SPROJ_DIRS \cspycomm log

For information about this driver, see the file NuMicro Cortex-M IAR ICE driver
user manual.pdf available in the arm\bin\Nu-Link directory.

Log communication

Logs the communication between C-SPY and the target system to a file. To interpret the
result, detailed knowledge of the interface is required.
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PE micro - Setup

The Setup options specify the PE micro interface.

Setup

[ Show settings dialog

[ Log communication

$PROJ_DIRS\cspycomm Jog

Show settings dialog

Displays the P&E Connection Manager dialog box. For more information, see the file
PEMicroSettings.pdf, available in the arm\doc directory.

Log communication

Logs the communication between C-SPY and the target system to a file. To interpret the
result, detailed knowledge of the interface is required.
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ST-LINK - Setup

Emulator

Reset

C-SPY® Debugging Guide
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The Setup options specify the ST-LINK interface.
Setup |
r~ Emulator

ST-LINK v2 Serial I [™ Shared mode

[~ Always prompt for probe selection

~ Resat
| System (defauit) |
rInterface Access Port
& ITAG Interface speed & Auto
rswp | [peut 1| speci |

Specify the emulator you are using. If more than one debug probe is connected to the
host computer, use the Serial option to select the correct one.

Shared mode debugging lets two or more instances of IAR Embedded Workbench share
the same debug probe. Each instance then accesses one core on the target device. To
enable shared mode debugging, use the option Shared mode. This requires that you
have installed the ST-LINK server. To install the server, run
arm\drivers\ST-Link\st-stlink-server.1.0.6-1.msi. See also the option
Access Port.

To force the Debug Probe Selection dialog box to be displayed each time you start a
debug session, use the option Always prompt for probe selection.

Selects the reset strategy to be used when the debugger starts. The actual reset strategy
type number is specified for each available choice. Choose between:
System (default) (0)

Resets the core and peripheral units by setting the SYSRESETREQ bit in the
AIRCR register. Reset vector catch is used for stopping the CPU at the reset
vector before the first instruction is executed. For Cortex-M devices only.

Core (1)

Resets the core via the VECTRESET bit; the peripheral units are not affected. For
Cortex-M devices only.
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Software (4)
Sets the pC to program entry address and SP to the initial stack pointer value.

Hardware (1)

The probe toggles the nSRST/nRESET line on the JTAG connector to reset the
device. This reset usually also resets the peripheral units. Only available for
ST-LINK version 2.

Connect during reset (2)

ST-LINK connects to the target while keeping the reset pin active (the reset pin
is pulled low and remains low while connecting to the target). Only available for
ST-LINK version 2.

Interface

Selects the communication interface between the ST-LINK debug probe and the target
system. Choose between:

JTAG (default)
Uses the JTAG interface.

SWD
Uses fewer pins than JTAG.

JTAG/SWD speed
Specify the JTAG and SWD communication speed. Choose between:

Auto detect
Automatically uses the highest possible frequency for reliable operation.

Adaptive
Synchronizes the clock to the processor clock outside the core. Works only with
Arm devices that have the RTCK JTAG signal available.

n MHz
Sets the JTAG and SWD communication speed to the selected frequency.

If there are JTAG communication problems or problems in writing to target
memory (for example during program download), these problems might be
resolved if the speed is set to a lower frequency.

Access port

The number of the access port on the device you want to connect to, 0-3. Use this option
for shared mode debugging.

This option is only applicable for devices with more than one core.
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ST-LINK - Communication

Clock setup

The Communication options specify the ST-LINK interface.

Communication

Clock setup

Auto

Specifies the CPU clock. Choose between:

CPU clock

Specifies the exact clock frequency used by the internal processor clock, HCLK,
in MHz. The value can have decimals. This value is used for configuring the
SWO communication speed and for calculating timestamps.

SWO clock
Specifies the clock frequency of the SWO communication channel in KHz.

Auto
Automatically uses the highest possible frequency that the debug probe can
handle. If Auto is not selected, the wanted SWO clock value can be input in the
text box. The value can have decimals. Use this option if data packets are lost
during transmission.

To override the Clock setup options, use the Override project default option in the
SWO Configuration dialog box, see Override project default, page 220.

Log communication
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Logs the communication between C-SPY and the target system to a file. To interpret the
result, detailed knowledge of the interface is required.
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T1 MSP-FET - Setup
The Setup options specify the TI MSP-FET interface.

Setup |
rConnection ——————— Tamet VCC —————————
[Texas Instrument USB4F | Overide defautt [~
Target WEC [in ol (2.0
Settling time (in ms): ID
~ Resat
INorrnaI j
r~Interface Interface speed ——
 Auto  Fast
& ITAG & Medium
& SWD £ Slow

Connection

Controls the communication between C-SPY and the target device.

The C-SPY TI MSP-FET debugger can communicate with the target device via a
number of different debug probes. Select the probe you are using. If you select
Automatic, the debugger will automatically connect to the correct port.

Some emulator drivers support multiple emulators connected to the same host computer.
Each emulator requires its own instance of IAR Embedded Workbench and each
instance must identify its emulator. To identify an emulator, click the browse button to
display a list of all detected emulators. To identify a connection, click the port in the list
and the Mode LED on the attached emulator will light up.

Target VCC
Specify the voltage provided by the USB interface:

Override default

Overrides the default voltage. The default voltage is displayed in the Target
VCC text box, when you deselect the Override default option.

Target VCC

Specify the voltage with one decimal’s precision in the range 1.0-4.0 V. This
option can only be used when your target device is powered by the debug probe.

Settling time

Specify a delay that will be used between switching on the target VCC and
starting the identification of the Arm device.
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Reset
Selects the reset strategy to be used when the debugger starts.
Normal
This is the default strategy. It does whatever is the best way to reset the target
device.
Interface

Determines the debug interface to use:

Auto
Selects the debug interface automatically.

JTAG
Selects the JTAG interface.

SWD
Selects the SWD interface. SWD uses fewer pins than JTAG.

Interface speed

Sets the JTAG communication speed. Choose between Fast, Medium, and Slow.

T1 MSP-FET - Download
The Download options specify the TI MSP-FET interface.

Download |

Flash erase
" Erase main memory

" Erase main and Information memory

' Frase main and Inf ion memory incl. P PROTECTED area;

™ Log communication

Erase main memory

Erases only the main flash memory before download. The Information memory is not
erased.
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Erase main and Information memory

Erases both flash memories—main and Information memory—before download.

Erase main and Information memory inc. IP PROTECTED area
Erases the main and Information flash memories, including the IP protected area before
download.

Log communication

Logs the communication between C-SPY and the target system to a file. To interpret the
result, detailed knowledge of the interface is required.

TI Stellaris - Setup

The Setup options specify the TI Stellaris interface.
Setup

~ Interface
o ITAG
& 5wD

—JTAG/SWD speed

500 kHz

" Log communication

[(TO0LRIT_DIRS espycomm.iog J

Interface

Selects the communication interface between the TI Stellaris debug probe and the target
system. Choose between:
JTAG (default)

Uses the JTAG interface.

SWD

Uses fewer pins than JTAG. Select SWD if you want to use the serial-wire
output (SWO) communication channel. Note that if you select stdout/stderr via
SWO on the General Options>Library Configuration page, SWD is selected
automatically. For more information about SWO settings, see SWO Trace
Window Settings dialog box, page 216.
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JTAG/SWD speed
Specifty the JTAG communication speed in kHz.

Log communication

Logs the communication between C-SPY and the target system to a file. To interpret the
result, detailed knowledge of the interface is required.

TI1 XDS - Setup

The Setup options control the TI XDS interface.

Setup |
r~ Emulator
| TI XDS 110 Emulator | serialno: |
Board|file I™ Aways prompt for probe selection

IE TOOLKIT_DIRS'configdebugger Texasinstruments xds \ LINKNOWN J

~ Reset Interface Target power
IDefauIt <] || & ITAG (4pin) ™ From the probe
& SWD Targetviee [33 vl

Delay after: IC L1} © cITAG (2pin)

JTAG/SWD speed

I Default = l

Tl emulation pach installation path
[~ Ovenide defautt

I-C:"-ti"-ccs_base J

Emulator
Specify the emulator you are using. If more than one debug probe is connected to the
host computer, use the Serial no option to select the correct one.

To force the Debug Probe Selection dialog box to be displayed each time you start a
debug session, use the option Always prompt for probe selection.

To override the default board file, first select the menu command Specify custom board
file in the Emulator drop-down menu and then specify a board file using the Board file
option.

Reset
Select the reset strategy to be used when C-SPY starts.
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Select the communication interface between the XDS debug probe and the target

system.

Target power

Select From the probe to specify that the supply voltage to your target device will be
supplied by the probe. Use Target Vee to specify the voltage.

This option is only available for the stand-alone TI XDS110 debug probe.

JTAG/SWD speed

Specify the JTAG communication speed.

Tl emulation package installation path

Select Override default to override the default installation path of the Texas
Instruments emulation package.

TI1 XDS - Communication

The Communication options control the TI XDS interface.

Communication |

Clock setup

CPU clock: |?2 MHz

SWO clock: [~ Auto

I‘IDDD kHz

COM port for SWO
* Auto

" Specify |‘

" None

™ Log communication

Clock setup

Specifies the CPU clock. Choose between:

CPU clock

Specifies the exact clock frequency used by the internal processor clock, HCLK,
in MHz. The value can have decimals. This value is used for configuring the
SWO communication speed and for calculating timestamps.
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SWO clock

Specifies the clock frequency of the SWO communication channel in KHz.

Auto

Automatically uses the highest possible frequency that the debug probe can
handle. If Auto is not selected, the wanted SWO clock value can be input in the
text box. The value can have decimals. Use this option if data packets are lost
during transmission.

To override the Clock setup options, use the Override project default option in the
SWO Configuration dialog box, see SWO Configuration dialog box, page 218.

COM port for SWO
Specifies the COM port to use for the SWO communication. Choose between:

Auto

The debugger automatically identifies the COM port that is associated with the
debug probe.

Specify
Specify the number of the COM port, 1-256.

None
The debugger leaves the COM port unused and SWO trace is disabled.

Log communication

Logs the communication between C-SPY and the target system to a file. To interpret the
result, detailed knowledge of the interface is required.
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Third-Party Driver options

The Third-Party Driver options are used for loading any driver plugin provided by a
third-party vendor. These drivers must be compatible with the C-SPY debugger driver
specification.

Third-Party Driver

|AR debugger driver plugin
Browse to your third-party driver U

[ Log communication
$PROJ_DIRS\cspycomm Jog

In addition to the options you can set here, you can set options for the third-party driver
using the Project>Options>Debugger>Extra Options page.

IAR debugger driver plugin
Specify the file path to the third-party driver plugin DLL file. A browse button is
available for your convenience.

Log communication

Logs the communication between C-SPY and the target system to a file. To interpret the
result, detailed knowledge of the interface is required.
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Additional information on
C-SPY drivers

This chapter describes the additional menus and features provided by the

C-SPY® drivers. You will also find some useful hints about resolving problems.

Reference information on C-SPY driver menus

C-SPY driver

This section gives reference information on the menus specific to the C-SPY drivers.
More specifically, this means:
C-SPY driver, page 591
Simulator menu, page 592
CADI menu, page 595
CMSIS-DAP menu, page 596
GDB Server menu, page 598
I-jet/JTAGjet menu, page 599
J-Link menu, page 603
Nu-Link menu, page 606
ST-LINK menu, page 607

TI MSP-FET menu, page 609
T1 Stellaris menu, page 610
TI XDS menu, page 611

Before you start the C-SPY debugger, you must first specify a C-SPY driver in the
Options dialog box, using the option Debugger>Setup>Driver.

When you start a debug session, a menu specific to that C-SPY driver will appear on the
menu bar, with commands specific to the driver.

When we in this guide write “choose C-SPY driver>" followed by a menu command,
C-SPY driver refers to the menu. If the feature is supported by the driver, the command
will be on the menu.
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Simulator menu

When you use the simulator driver, the Simulator menu is added to the menu bar.
&, Memory Configuration...
L Simulated Frequengy...

A Trace

+|= Function Trace

Trace Expressions
Function Profiler

Data Log

Data Log Summary
Interrupt Log
Interrupt Log Summary

Timeline

B KR

Interrupt Configuration
Available Interrupts

Interrupt Status

==, Breakpoint Usage

Menu commands

These commands are available on the menu:

(=] Memory Configuration
]

Displays a dialog box where you configure C-SPY to match the memory of your
device, see Memory Configuration dialog box, for the C-SPY simulator, page
190.

4 Trace

Opens a window which displays the collected trace data, see Trace window,
page 222.
#* Function Trace
F Opens a window which displays the trace data for function calls and function
returns, see Function Trace window, page 231.

Trace Expressions
Opens a window where you can specify specific variables and expressions for
which you want to collect trace data, see Trace Expressions window, page 248.
Function Profiler

Opens a window which shows timing information for the functions, see
Function Profiler window, page 299.
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Data Log
Opens a window which logs accesses to up to four different memory locations
or areas, see Data Log window, page 271.

Data Log Summary
Opens a window which displays a summary of data accesses to specific memory
location or areas, see Data Log Summary window, page 274.

Interrupt Log
Opens a window which displays the status of all defined interrupts, see Interrupt
Log window, page 402.

Interrupt Log Summary
Opens a window which displays a summary of the status of all defined
interrupts, see Interrupt Log Summary window, page 406.

Timeline
Opens a window which gives a graphical view of various kinds of information
on a timeline, see The application timeline, page 253.

Simulated Frequency
Opens the Simulated Frequency dialog box where you can specify the
simulator frequency used when the simulator displays time information, for
example in the log windows. Note that this does not affect the speed of the
simulator. For more information, see Simulated Frequency dialog box.

Interrupt Configuration
Opens a window where you can configure C-SPY interrupt simulation, see
Interrupt Configuration window, page 396.

Available Interrupts
Opens a window with an overview of all available interrupts. You can also force
an interrupt instantly from this window, see Available Interrupts window, page
399.

Interrupt Status
Opens a window from where you can instantly trigger an interrupt, see Interrupt
Status window, page 400.

Breakpoint Usage

Displays a window which lists all active breakpoints, see Breakpoint Usage
window, page 134.
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Reference information on the C-SPY simulator

This section gives additional reference information the C-SPY simulator, reference
information not provided elsewhere in this documentation.

Reference information about:

o Simulated Frequency dialog box, page 594

Simulated Frequency dialog box
The Simulated Frequency dialog box is available from the C-SPY driver menu.
f Simulated Frequency [ér

Frequency [Hz]:
1000000
1 MHz Cancel

Uszed only for converting cycles to time.

L

Use this dialog box to specify the simulator frequency used when the simulator displays
time information.

Requirements
The C-SPY simulator.

Frequency

Specify the frequency in Hz.

Reference information on the C-SPY hardware debugger drivers

This section gives additional reference information on the C-SPY hardware debugger
drivers, reference information not provided elsewhere in this documentation.

Reference information about:
CADI menu, page 595
CMSIS-DAP menu, page 596
GDB Server menu, page 598
I-jet/JTAGjet menu, page 599
J-Link menu, page 603

Nu-Link menu, page 606
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ST-LINK menu, page 607

TI MSP-FET menu, page 609
TI Stellaris menu, page 610
TI XDS menu, page 611

CADI menu
When you are using the C-SPY CADI driver, the CADI menu is added to the menu bar:

&, Memory Configuration...

Disable Debugger Cache

Breakpoint Usage

Menu commands

These commands are available on the menu:

Memory Configuration
Displays a dialog box; see Memory Configuration dialog box, in C-SPY
hardware debugger drivers, page 194.

Disable Debugger Cache
Disables memory caching and memory range checking in C-SPY.
Normally, C-SPY uses the memory range information in the Memory
Configuration dialog box both to restrict access to certain parts of target
memory and to cache target memory contents for improved C-SPY
performance. Under certain rare circumstances, this is not appropriate, and you
can choose Disable Debugger Cache to turn off the caching and memory range

checking completely. All accesses from C-SPY will then result in corresponding
accesses to the target system. Some of those circumstances are:

o When memory is remapped at runtime and cannot be specified as a fixed set
of ranges.

o When the memory range setup is incorrect or incomplete.

Breakpoint Usage

Opens a window which lists all active breakpoints; see Breakpoint Usage
window, page 134.
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CMSIS-DAP menu

When you are using the C-SPY CMSIS-DAP driver, the CMSIS-DAP menu is added
to the menu bar.

&, Memory Configuration...
Disable Debugger Cache
Disable Interrupts When Stepping

Leave Target Running

ETM Trace Settings...
ETM Trace Save...
ETM Trace

¢ | Function Trace
Vector Catch...
Timeline

Function Profiler

Session Ov

Breakpoint Usage

Menu commands

These commands are available on the menu:

Memory Configuration

Displays a dialog box; see Memory Configuration dialog box, in C-SPY
hardware debugger drivers, page 194.

Disable Debugger Cache
Disables memory caching and memory range checking in C-SPY.

Normally, C-SPY uses the memory range information in the Memory
Configuration dialog box both to restrict access to certain parts of target
memory and to cache target memory contents for improved C-SPY
performance. Under certain rare circumstances, this is not appropriate, and you
can choose Disable Debugger Cache to turn off the caching and memory range
checking completely. All accesses from C-SPY will then result in corresponding
accesses to the target system. Some of those circumstances are:

o When memory is remapped at runtime and cannot be specified as a fixed set
of ranges.

o When the memory range setup is incorrect or incomplete.
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Disable Interrupts When Stepping

Ensures that only the stepped statements will be executed. Interrupts will not be
executed. This command can be used when not running at full speed and some
interrupts interfere with the debugging process.

Leave Target Running

Leaves the application running on the target hardware after the debug session is
closed.

Note that any existing breakpoints will not be automatically removed. You
might want to consider disabling all breakpoints before using this menu
command.

ETM Trace Settings
Displays a dialog box; see ETM Trace Settings dialog box, page 212.

ETM Trace Save
Displays a dialog box; see Trace Save dialog box, page 252.

ETM Trace
Opens the ETM Trace window; see Trace window, page 222.

Function Trace
Opens a window; see Function Trace window, page 231.

Vector Catch
Displays a dialog box for setting a breakpoint directly on a vector in the interrupt
vector table, see Vector Catch dialog box, page 151. Note that this command is
not available for all Arm cores.

Timeline

Opens a window; see Reference information on application timeline, page 261.
This menu command is only available when the SWD/SWO interface is used.

Function Profiler

Opens a window which shows timing information for the functions; see
Function Profiler window, page 299.

Session Overview

Displays a window that lists information about the debug session, such as details
about project settings, session settings, and the session state. To save the
contents of the window to a file, choose Save As from the context menu.

Breakpoint Usage

Opens a window which lists all active breakpoints; see Breakpoint Usage
window, page 134.
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GDB Server menu

When you are using the C-SPY GDB Server driver, the GDB Server menu is added to
the menu bar.

Breakpoint Usage...

Leave Target Running

Menu commands

These commands are available on the menu:

Breakpoint Usage
Opens a window which lists all active breakpoints; see Breakpoint Usage
window, page 134.

Leave Target Running
Leaves the application running on the target hardware after the debug session is
closed.

Note that any existing breakpoints will not be automatically removed. You
might want to consider disabling all breakpoints before using this menu
command.
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When you are using the C-SPY I-jet/JTAGjet driver, the I-jet/JTAGjet menu is added
to the menu bar.

#ﬂ

s

L [

Memory Configuration...
Disable Debugger Cache
Leave Target Running

Disable Interrupts When Stepping

ETM Trace Settings...
ETM Trace Save...
ETM Trace

Function Trace

SWO Configuration..,

SWO Trace Window Settings...
SWO Trace

Interrupt Log

Interrupt Log Summary

Data Log

Data Log Summary

Event Log

Event Log Summary

Power Log Setup

Power Log
Vector Catch...
Timeline
Function Profiler

Session Overview

Breakpoint Usage

EmuDiag

These commands are available on the menu:

Memory Configuration

Displays a dialog box; see Memory Configuration dialog box, in C-SPY
hardware debugger drivers, page 194.

Disable Debugger Cache

Disables memory caching and memory range checking in C-SPY.
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Normally, C-SPY uses the memory range information in the Memory
Configuration dialog box both to restrict access to certain parts of target
memory and to cache target memory contents for improved C-SPY
performance. Under certain rare circumstances, this is not appropriate, and you
can choose Disable Debugger Cache to turn off the caching and memory range
checking completely. All accesses from C-SPY will then result in corresponding
accesses to the target system. Some of those circumstances are:

e When memory is remapped at runtime and cannot be specified as a fixed set
of ranges.

o When the memory range setup is incorrect or incomplete.

Leave Target Running

Leaves the application running on the target hardware after the debug session is
closed.

Note that any existing breakpoints will not be automatically removed. You
might want to consider disabling all breakpoints before using this menu
command.

Disable Interrupts When Stepping

Ensures that only the stepped statements will be executed. Interrupts will not be
executed. This command can be used when not running at full speed and some
interrupts interfere with the debugging process.

ETM Trace Settings
Displays a dialog box; see ETM Trace Settings dialog box, page 212.
ETM Trace Save
Displays a dialog box; see Trace Save dialog box, page 252.
ETM Trace
Opens the ETM Trace window; see Trace window, page 222.
Function Trace
Opens a window; see Function Trace window, page 231.
SWO Configuration
Displays a dialog box; see SWO Configuration dialog box, page 218.
This menu command is only available when the SWD/SWO interface is used.

SWO Trace Window Settings
Displays a dialog box; see SWO Trace Window Settings dialog box, page 216.
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SWO Trace

Opens the SWO Trace window to display the collected trace data; see Trace
window, page 222.

This menu command is only available when the SWD/SWO interface is used.

Interrupt Log
Opens a window; see Interrupt Log window, page 402.

This menu command is only available when the SWD/SWO interface is used.

Interrupt Log Summary

Opens a window; see Interrupt Log Summary window, page 406.
This menu command is only available when the SWD/SWO interface is used.

Data Log
Opens a window; see Data Log window, page 271.

This menu command is only available when the SWD/SWO interface is used.

Data Log Summary
Opens a window; see Data Log Summary window, page 274.

This menu command is only available when the SWD/SWO interface is used.

Event Log
Opens a window; see Event Log window, page 282.

Event Log Summary

Opens a window; see Event Log Summary window, page 284.

Power Log Setup
Opens a window; see Power Log Setup window, page 321.

Power Log
Opens a window; see Power Log window, page 323.

Vector Catch

Displays a dialog box for setting a breakpoint directly on a vector in the interrupt
vector table, see Vector Catch dialog box, page 151. Note that this command is
not available for all Arm cores.

Timeline

Opens a window; see Reference information on application timeline, page 261.

This menu command is only available when the SWD/SWO interface is used.
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Function Profiler
Opens a window which shows timing information for the functions; see
Function Profiler window, page 299.

Session Overview
Displays a window that lists information about the debug session, such as details
about project settings, session settings, and the session state. To save the
contents of the window to a file, choose Save As from the context menu.

Breakpoint Usage
Opens a window which lists all active breakpoints; see Breakpoint Usage
window, page 134.

EmuDiag

Starts the EmuDiag application where you can diagnose the connection
between the host computer, the probe, and the board.
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Menu commands
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When you are using the C-SPY J-Link driver, the J-Link menu is added to the menu bar.

s

L [

Watchpoints..,

Vector Catch...

Disable Interrupts When Stepping

Leave Target Running

ETM Trace Settings...
ETM Trace Save...
ETM Trace

Function Trace

SWO Configuration..,

SWO Trace Window Settings...

SWO Trace Save...
SWO Trace

Interrupt Log

Interrupt Log Summary
Data Log

Data Log Summary
Event Log

Event Summary

Power Log Setup

Power Log
Timeline
Function Profiler

Breakpoint Usage

These commands are available on the menu:

Watchpoints

Displays a dialog box for setting watchpoints, see Code breakpoints dialog box,

page 135.

Vector Catch

Displays a dialog box for setting a breakpoint directly on a vector in the interrupt
vector table, see Vector Catch dialog box, page 151. Note that this command is

Disable Interrupts When Stepping

not available for all Arm cores.

Ensures that only the stepped statements will be executed. Interrupts will not be
executed. This command can be used when not running at full speed and some
interrupts interfere with the debugging process.
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Leave Target Running

Leaves the application running on the target hardware after the debug session is
closed.

Note that any existing breakpoints will not be automatically removed. You
might want to consider disabling all breakpoints before using this menu
command.

ETM Trace Settings

Displays a dialog box to configure ETM trace data generation and collection;
see ETM Trace Settings dialog box (J-Link/J-Trace), page 214.

This menu command is only available when using either ETM or J-Link with
ETB.

ETM Trace Save

Displays a dialog box to save the collected trace data to a file; see Trace Save
dialog box, page 252.

This menu command is only available when using either ETM or J-Link with
ETB.

ETM Trace

Opens the ETM Trace window to display the collected trace data; see Trace
window, page 222.

This menu command is only available when using either ETM or J-Link with
ETB.

Function Trace

Opens a window which displays the trace data for function calls and function
returns; see Function Trace window, page 231.

This menu command is only available when using either ETM or J-Link with
ETB.

SWO Configuration
Displays a dialog box; see SWO Configuration dialog box, page 218.

This menu command is only available when the SWD/SWO interface is used.

SWO Trace Window Settings
Displays a dialog box; see SWO Trace Window Settings dialog box, page 216.

This menu command is only available when the SWD/SWO interface is used.
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SWO Trace Save

Displays a dialog box to save the collected trace data to a file; see Trace Save
dialog box, page 252.

This menu command is only available when the SWD/SWO interface is used.

SWO Trace

Opens the SWO Trace window to display the collected trace data; see Trace
window, page 222.

This menu command is only available when the SWD/SWO interface is used.

Interrupt Log
Opens a window; see Interrupt Log window, page 402.

This menu command is only available when the SWD/SWO interface is used.

Interrupt Log Summary

Opens a window; see Interrupt Log Summary window, page 406.
This menu command is only available when the SWD/SWO interface is used.

Data Log

Opens a window; see Data Log window, page 271.
This menu command is only available when the SWD/SWO interface is used.

Data Log Summary
Opens a window; see Data Log Summary window, page 274.

This menu command is only available when the SWD/SWO interface is used.

Event Log
Opens a window; see Event Log window, page 282.

Event Log Summary
Opens a window; see Event Log Summary window, page 284.

Power Log Setup
Opens a window; see Power Log Setup window, page 321.

Power Log

Opens a window; see Power Log window, page 323.

Timeline

Opens a window; see Reference information on application timeline, page 261.

This menu command is available when using ETM or SWD/SWO.
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Function Profiler
Opens a window which shows timing information for the functions; see
Function Profiler window, page 299.

Breakpoint Usage

Opens a window which lists all active breakpoints; see Breakpoint Usage
window, page 134.

When you are using the C-SPY Nu-Link driver, the Nu-Link menu is added to the menu
bar:

MuTool - FinView
MuConsale

Mu-Link Monitor

ICP Programming Tool

For information about Nu-Link, see the file NuMicro Cortex-M IAR ICE driver
user manual.pdf, available in the arm\bin\Nu-Link directory.
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ST-LINK menu

When you are using the C-SPY ST-LINK driver, the ST-LINK menu is added to the
menu bar.

Vector Catch...
Disable Interrupts When Stepping

Leave Target Running

SWO Configuration..,
SWO Trace Window Settings...
SWO Trace Save...

SWO Trace

Interrupt Log

L [

Interrupt Log Summary
Data Log

Data Log Summary
Event Log

Event Summary
Timeline

Function Profiler

Breakpoint Usage

Menu commands

These commands are available on the menu:

Vector Catch
Opens a dialog box for setting a breakpoint directly on a vector in the interrupt
vector table, see Vector Catch dialog box, page 151. Note that this command is
not available for all Arm cores.

Disable Interrupts When Stepping
Ensures that only the stepped statements will be executed. Interrupts will not be
executed. This command can be used when not running at full speed and some
interrupts interfere with the debugging process.

Leave Target Running
Leaves the application running on the target hardware after the debug session is
closed.

Note that any existing breakpoints will not be automatically removed. You
might want to consider disabling all breakpoints before using this menu
command.

SWO Configuration'
Displays a dialog box; see SWO Configuration dialog box, page 218.
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SWO Trace Window Settings1
Displays a dialog box; see SWO Trace Window Settings dialog box, page 216.

SWO Trace Save!

Displays a dialog box to save the collected trace data to a file; see Trace Save
dialog box, page 252.

SWO Trace!

Opens the SWO Trace window to display the collected trace data; see Trace
window, page 222.

Interrupt Log1
Opens a window; see Interrupt Log window, page 402.

Interrupt Log Summary1
Opens a window; see Interrupt Log Summary window, page 406.

Data Log1
Opens a window; see Data Log window, page 271.

Data Log Summary1
Opens a window; see Data Log Summary window, page 274.
Event Log
Opens a window; see Event Log window, page 282.
Event Log Summary
Opens a window; see Event Log Summary window, page 284.
Timeline?
Opens a window; see Reference information on application timeline, page 261.
Function Profiler
Opens a window which shows timing information for the functions; see
Function Profiler window, page 299.
Breakpoint Usage
Opens a window which lists all active breakpoints; see Breakpoint Usage
window, page 134.
1 Only available when the SWD/SWO interface is used.

2 Available when using either ETM or SWD/SWO.
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TI MSP-FET menu

When you are using the C-SPY TI MSP-FET driver, the TI MSP-FET menu is added
to the menu bar.

Leave Target Running
Release JTAG on Go

Secure Device

Power Log Setup

Power Log

State Log

State Log Summary
Timeline

Breakpoint Usage

Menu commands

These commands are available on the menu:

Leave Target Running
Leaves the application running on the target hardware after the debug session is

closed.
Release JTAG on Go
+++| Sets the JTAG drivers in tri-state so that the device is released from JTAG
= control when the Go button is activated.

Secure Device

Activates the flash memory protection lock. After this command has been
executed, you must terminate the debug session and then reconnect the power to
make it take effect.

Power Log Setup

Opens a window; see Power Log Setup window, page 321.

Power Log
Opens a window; see Power Log window, page 323.

State Log
Opens a window; see State Log window, page 328.

State Log Summary
Opens a window; see State Log Summary window, page 330.

Timeline

Opens a window; see Reference information on application timeline, page 261.
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Breakpoint Usage

Opens a window which lists all active breakpoints; see Breakpoint Usage
window, page 134.

TI Stellaris menu

When you are using the C-SPY TI Stellaris driver, the TI Stellaris menu is added to the
menu bar.

Breakpoint Usage...

Reset will do system reset

Leave Target Running

Menu commands

These commands are available on the menu:

Breakpoint Usage
Opens a window which lists all active breakpoints; see Breakpoint Usage
window, page 134.

Reset will do system reset
Sets the reset strategy for the Reset button in the C-SPY Debugger main
window.

Leave Target Running
Leaves the application running on the target hardware after the debug session is
closed.

Note that any existing breakpoints will not be automatically removed. You
might want to consider disabling all breakpoints before using this menu
command.
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TI XDS menu

When you are using the C-SPY TI XDS driver, the TI XDS menu is added to the menu
bar.

Vector Catch...
Disable Interrupts When Stepping

Leave Target Running

SWO Configuration..,

SWO Trace Window Settings...
SWO Trace Save...

SWO Trace

Interrupt Log

L [

Interrupt Log Summary
Data Log

Data Log Summary
Event Log

Event Summary

Power Log Setup
Power Log

State Log

State Log Summary
Timeline

Function Profiler

Breakpoint Usage

Menu commands

These commands are available on the menu:

Vector Catch
Opens a dialog box for setting a breakpoint directly on a vector in the interrupt
vector table, see Vector Catch dialog box, page 151. Note that this command is
not available for all Arm cores.

Disable Interrupts When Stepping
Ensures that only the stepped statements will be executed. Interrupts will not be
executed. This command can be used when not running at full speed and some
interrupts interfere with the debugging process.

Leave Target Running

Leaves the application running on the target hardware after the debug session is
closed.
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Note that any existing breakpoints will not be automatically removed. You
might want to consider disabling all breakpoints before using this menu
command.

SWO Configuration
Displays a dialog box; see SWO Configuration dialog box, page 218.
SWO Trace Window Settings
Displays a dialog box; see SWO Trace Window Settings dialog box, page 216.

SWO Trace Save
Displays a dialog box to save the collected trace data to a file; see Trace Save
dialog box, page 252.

SWO Trace
Opens the SWO Trace window to display the collected trace data; see Trace
window, page 222.

Interrupt Log
Opens a window; see Interrupt Log window, page 402.

Interrupt Log Summary

Opens a window; see Interrupt Log Summary window, page 406.
Data Log

Opens a window; see Data Log window, page 271.
Data Log Summary

Opens a window; see Data Log Summary window, page 274.
Event Log

Opens a window; see Event Log window, page 282.
Event Log Summary

Opens a window; see Event Log Summary window, page 284.

Power Log Setup

Opens a window; see Power Log Setup window, page 321.

Power Log
Opens a window; see Power Log window, page 323.

State Log
Opens a window; see State Log window, page 328.

State Log Summary

Opens a window; see State Log Summary window, page 330.
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Timeline

Opens a window; see Reference information on application timeline, page 261.

Function Profiler
Opens a window which shows timing information for the functions; see
Function Profiler window, page 299.

Breakpoint Usage

Opens a window which lists all active breakpoints; see Breakpoint Usage
window, page 134.

Resolving problems

These topics are covered:
o No contact with the target hardware

Debugging using the C-SPY hardware debugger systems requires interaction between
many systems, independent from each other. For this reason, setting up this debug
system can be a complex task. If something goes wrong, it might be difficult to locate
the cause of the problem.

For information about the current debug session, choose Session Overview from the
driver menu. Note that this window might not be supported by the C-SPY driver you are
using.

This section includes suggestions for resolving the most common problems that can
occur when debugging with the C-SPY hardware debugger systems.

For problems concerning the operation of the evaluation board, refer to the
documentation supplied with it, or contact your hardware distributor.
NO CONTACT WITH THE TARGET HARDWARE

There are several possible reasons for C-SPY to fail to establish contact with the target
hardware. Do this:

Check the communication devices on your host computer

Verify that the cable is properly plugged in and not damaged or of the wrong type

Make sure that the evaluation board is supplied with sufficient power

Check that the correct options for communication have been specified in the IAR
Embedded Workbench IDE.

o Check that the correct reset strategy is used.
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Examine the linker configuration file to make sure that the application has not been
linked to the wrong address.
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