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Preface

e Who should read this guide

e How to use this guide

What this guide contains
e Other documentation

e Document conventions

Who should read this guide

Read this guide if you plan to develop an application using IAR Embedded Workbench
and want to get the most out of the features and tools available in the IDE.

REQUIRED KNOWLEDGE

To use the tools in IAR Embedded Workbench, you should have working knowledge of:

o The architecture and instruction set of the MSP430 microcontroller (refer to the
chip manufacturer's documentation)

o The C or C++ programming language
o Application development for embedded systems
o The operating system of your host computer.

For more information about the other development tools incorporated in the IDE, refer
to their respective documentation, see Other documentation, page 17.

How to use this guide

Each chapter in this guide covers a specific fopic area. In many chapters, information is
typically divided in different sections based on information types:

o Concepts, which describes the topic and gives overviews of features related to the
topic area. Any requirements or restrictions are also listed. Read this section to learn
about the topic area.

o Tasks, which lists useful tasks related to the topic area. For many of the tasks, you

can also find step-by-step descriptions. Read this section for information about
required tasks as well as for information about how to perform certain tasks.



What this guide contains

® Reference information, which gives reference information related to the topic area.
Read this section for information about certain GUI components. You can easily
access this type of information for a certain component in the IDE by pressing F1.

If you are new to using IAR Embedded Workbench, we suggest that you first read the
guide Getting Started with IAR Embedded Workbench® for an overview of the tools and
the features that the IDE offers. The tutorials, which you can find in the IAR Information
Center, will help you get started using IAR Embedded Workbench.

Finally, we recommend the Glossary if you should encounter any unfamiliar terms in
the IAR Systems user documentation.

What this guide contains

This is a brief outline and summary of the chapters in this guide.

PART |. PROJECT MANAGEMENT AND BUILDING
This section describes the process of editing and building your application:

o The development environment introduces you to the IAR Embedded Workbench
development environment. The chapter also demonstrates the facilities available for
customizing the environment to meet your requirements.

® Project management describes how you can create workspaces with multiple
projects, build configurations, groups, source files, and options that help you handle
different versions of your applications.

® Building projects discusses the process of building your application.

e [Editing contains detailed descriptions of the IAR Embedded Workbench editor, how
to use it, and the facilities related to its usage. The final section also contains
information about how to integrate an external editor of your choice.

PART 2. REFERENCE INFORMATION

® Product files describes the directory structure and the types of files it contains.

® Menu reference contains detailed reference information about menus and menu
commands.

o General options specifies the target, output, library, and MISRA C options.

o Compiler options specifies compiler options for language, optimizations, code,
output, list file, preprocessor, diagnostics, and MISRA C.

o Assembler options describes the assembler options for language, output, list,
preprocessor, and diagnostics.

o Custom build options describes the options available for custom tool configuration.

IDE Project Management and Building Guide
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Build actions options describes the options available for pre-build and post-build
actions.

e Linker options describes the options for setting up for linking.

o TI ULP Advisor™ Software options describes the options for configuring the TI

ULP Advisor static code analyzer from Texas Instruments.

Library builder options describes the options for building a library.

Other documentation

User documentation is available as hypertext PDFs and as a context-sensitive online
help system in HTML format. You can access the documentation from the Information
Center or from the Help menu in the IAR Embedded Workbench IDE. The online help
system is also available via the F1 key.

USER AND REFERENCE GUIDES

The complete set of IAR Systems development tools is described in a series of guides.
Information about:

System requirements and information about how to install and register the IAR
Systems products, is available in the booklet Quick Reference (available in the
product box) and the Installation and Licensing Guide.

Getting started using IAR Embedded Workbench and the tools it provides, is
available in the guide Getting Started with [AR Embedded Workbench®.

Using the IDE for project management and building, is available in the IDE Project
Management and Building Guide.

Using the IAR C-SPY® Debugger, is available in the C-SPY® Debugging Guide

for MSP430.

Programming for the IAR C/C++ Compiler for MSP430, is available in the /AR
C/C++ Compiler Reference Guide for MSP430.

Using the IAR XLINK Linker, the IAR XAR Library Builder, and the AR XLIB
Librarian, is available in the /AR Linker and Library Tools Reference Guide.

Programming for the IAR Assembler for MSP430, is available in the /AR Assembler
Reference Guide for MSP430.

Performing a static analysis using C-STAT and the required checks, is available in
the C-STAT® Static Analysis Guide.

Developing safety-critical applications using the MISRA C guidelines, is available
in the /AR Embedded Workbench® MISRA C:2004 Reference Guide or the IAR
Embedded Workbench® MISRA C:1998 Reference Guide.



Other documentation

e Porting application code and projects created with a previous version of the IAR
Embedded Workbench for MSP430, is available in the JAR Embedded Workbench®
Migration Guide.

Note: Additional documentation might be available depending on your product
installation.

THE ONLINE HELP SYSTEM
The context-sensitive online help contains information about:

IDE project management and building
Debugging using the IAR C-SPY® Debugger
The IAR C/C++ Compiler

The IAR Assembler

Keyword reference information for the DLIB library functions. To obtain reference
information for a function, select the function name in the editor window and press
F1. Note that if you select a function name in the editor window and press F1 while
using the CLIB C standard library, you will get reference information for the DLIB
C standard library.

e C-STAT
e MISRA C

WEB SITES

Recommended web sites:

® The Texas Instruments web site, www.ti.com, that contains information and news
about the MSP430 microcontrollers.

o The IAR Systems web site, www.iar.com, that holds application notes and other
product information.

o The web site of the C standardization working group,
www.open-std.org/jtcl/sc22/wgl4.

o The web site of the C++ Standards Committee, www.open-std.org/jtc1/sc22/wg21.
o The C++ programming language web site, isocpp.org.
This web site also has a list of recommended books about C++ programming.

o The C and C++ reference web site, en.cppreference.com.

IDE Project Management and Building Guide
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Document conventions

When, in the IAR Systems documentation, we refer to the programming language C, the
text also applies to C++, unless otherwise stated.

When referring to a directory in your product installation, for example 430\ doc, the full
path to the location is assumed, for example c: \Program Files\IAR
Systems\Embedded Workbench N.n\430\doc, where the initial digit of the version
number reflects the initial digit of the version number of the IAR Embedded Workbench
shared components.

TYPOGRAPHIC CONVENTIONS
The IAR Systems documentation set uses the following typographic conventions:

Style Used for

computer * Source code examples and file paths.
* Text on the command line.
* Binary, hexadecimal, and octal numbers.

parameter A placeholder for an actual value used as a parameter, for example
filename.h where filename represents the name of the file.

[option] An optional part of a directive, where [ and ] are not part of the actual
directive, but any [, ], {, or } are part of the directive syntax.

{option} A mandatory part of a directive, where { and } are not part of the
actual directive, butany [, 1, {, or } are part of the directive syntax.

[option] An optional part of a command.

[a]b|c] An optional part of a command with alternatives.

{a|b|c} A mandatory part of a command with alternatives.

bold Names of menus, menu commands, buttons, and dialog boxes that

appear on the screen.

italic * A cross-reference within this guide or to another guide.
* Emphasis.

An ellipsis indicates that the previous item can be repeated an arbitrary
number of times.

Identifies instructions specific to the IAR Embedded Workbench® IDE
interface.
Identifies instructions specific to the command line interface.

Identifies helpful tips and programming hints.
F
Table 1: Typographic conventions used in this guide




Document conventions

Style Used for

Identifies warnings.

Table 1: Typographic conventions used in this guide (Continued)

NAMING CONVENTIONS

The following naming conventions are used for the products and tools from IAR
Systems®, when referred to in the documentation:

Brand name Generic term

IAR Embedded Workbench® for MSP430 IAR Embedded Workbench®
IAR Embedded Workbench® IDE for MSP430 the IDE

IAR C-SPY® Debugger for MSP430 C-SPY, the debugger

IAR C-SPY® Simulator the simulator

IAR C/C++ Compiler™ for MSP430 the compiler

IAR Assembler™ for MSP430 the assembler

IAR XLINK Linker™ XLINK, the linker

IAR XAR Library Builder™ the library builder

IAR XLIB Librarian™ the librarian

IAR DLIB Runtime Environment™ the DLIB runtime environment
IAR CLIB Runtime Environment™ the CLIB runtime environment

Table 2: Naming conventions used in this guide

IDE Project Management and Building Guide
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Part |. Project
management and building

This part contains these chapters:
e The development environment
e Project management

o Building projects

o Editing.
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The development
environment

e Introduction to the IAR Embedded Workbench IDE
e Using and customizing the IDE

e Reference information on the IDE.

Introduction to the IAR Embedded Workbench IDE

These topics are covered:

e Briefly about the IDE and the build toolchain
e Tools for analyzing and checking your application
® An extensible and modular environment.

o Organizing windows on the screen.

BRIEFLY ABOUT THE IDE AND THE BUILD TOOLCHAIN

The IDE is the environment where all tools needed to build your application—the build
toolchain—are integrated: a C/C++ compiler, C/C++ libraries, an assembler, a linker,
library tools, an editor, a project manager with Make utility, and the IAR C-SPY®
Debugger. The tools used specifically for building your source code are referred to as
the build tools.

The toolchain that comes with your product package supports a specific microcontroller.
However, the IDE can simultaneously contain multiple toolchains for various
microcontrollers. This means that if you have IAR Embedded Workbench installed for
several microcontrollers, you can choose which microcontroller to develop for.

Note: The compiler, assembler, and linker and library tools can also be run from a
command line environment, if you want to use them as external tools in an already
established project environment.

23



Introduction to the IAR Embedded Workbench IDE

TOOLS FOR ANALYZING AND CHECKING YOUR
APPLICATION

IAR Embedded Workbench comes with various types of support for analyzing and
finding errors in your application, such as:

e Compiler and linker errors, warnings, and remarks

All diagnostic messages are issued as complete, self-explanatory messages. Errors
reveal syntax or semantic errors, warnings indicate potential problems, and remarks
(default off) indicate deviations from the standard. Double-click a message and the
corresponding source code construction is highlighted in the editor window. For
more information, see the JAR C/C++ Compiler Reference Guide for MSP430.

e Stack usage analysis during linking
Under the right circumstances, the linker can accurately calculate the maximum
stack usage for each call tree, such as cstartup, interrupt functions, RTOS tasks,
etc. For more information, see the /AR C/C++ Compiler Reference Guide for
MSP430.

o C-STAT for static analysis

C-STAT is a static analysis tool that tries to find deviations from specific sets of rules,
where each rule specifies an unsafe source construct. The rules come from various

institutes, like MISRA (MISRA C:2004, MISRA C++:2008, and MISRA C:2012),
CWE, and CERT. For information about how to use C-STAT and the rules, see the
C-STAT® Static Analysis Guide.

e MISRA C:1998 and 2004

In addition to the MISRA checks in C-STAT, the IDE provides compiler checks for
MISRA C:1998 and 2004. For more information, see the /AR Embedded
Workbench® MISRA C:2004 Reference Guide or the IAR Embedded Workbench®
MISRA C:1998 Reference Guide.

e TIULP Advisor™
TI ULP Advisor is a static code analyzer from Texas Instruments that flags source
code and helps you improve the power consumption properties of your application.
For more information, see 7/ ULP Advisor, page 252.

o C-SPY debugging features such as, Profiling, Code Coverage, Trace, and Power
debugging
For more information, see the C-SPY® Debugging Guide for MSP430.

IDE Project Management and Building Guide
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AN EXTENSIBLE AND MODULAR ENVIRONMENT

Although the IDE provides all the features required for your project, you can also
integrate other tools. For example, you can:

o Use the Custom Build mechanism to add other tools to the toolchain, see Extending
the toolchain, page 107.

o Add IAR visualSTATE to the toolchain, which means that you can add state
machine diagrams directly to your project in the IDE.

o Use the Subversion version control system to keep track of different versions of
your source code. The IDE can attach to files in a Subversion working copy.

o Add an external analyzer, for example a lint tool, of your choice to be used on whole
projects, groups of files, or an individual file of your project. Typically, you might
want to perform a static code analysis on your source code, using the same settings
and set of source code files as when you compile. See Getting started using external
analyzers, page 32.

o Add external tools to the Tools menu, for convenient access from within the IDE.
For this reason, the menu might look different depending on which tools you have
preconfigured to appear as menu commands.

o Configure custom argument variables, which typically can be useful if you install a
third-party product and want to specify its include directory. Custom argument
variables can also be used for simplifying references to files that you want to be part
of your project.

THE LAYOUT OF THE WINDOWS ON THE SCREEN

In the IDE, each window that you open has a default location, which depends on other
currently open windows. You can position the windows and arrange a layout according
to your preferences. Each window can be either docked or floating.

You can dock each window at specific places, and organize them in tab groups. If you
rearrange the size of one docked window, the sizes of any other docked windows are
adjusted accordingly. You can also make a window floating, which means it is always
on top of other windows. The location and size of a floating window does not affect
other currently open windows. You can move a floating window to any place on your
screen, also outside of the IAR Embedded Workbench IDE main window.

Each time you open a previously saved workspace, the same windows are open, and they
have the same sizes and positions.

For every project that is executed in the C-SPY environment, a separate layout is saved.
In addition to the information saved for the workspace, information about all open
debugger-specific windows is also saved.
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Note: The editor window is always docked. When you open the editor window, its
placement is decided automatically depending on other currently open windows. For
more information about how to work with the editor window, see Introduction to the AR
Embedded Workbench editor, page 123.

Using and customizing the IDE

These tasks are covered:

Running the IDE

Running an example project

Organizing windows on the screen
Specifying tool options

Adding a button to a toolbar

Removing a button from a toolbar
Showing/hiding toolbar buttons
Recognizing filename extensions

Getting started using external analyzers
Invoking external tools from the Tools menu

Adding command line commands to the Tools menu

Using an external editor.

See also Extending the toolchain, page 107.

For more information about customizations related to C-SPY, see the C-SPY®
Debugging Guide for MSP430.

RUNNING THE IDE

Click the Start button on the Windows taskbar and choose All Programs>IAR
Systems>IAR Embedded Workbench for MSP430>IAR Embedded Workbench.

The file TarIdePm. exe is located in the common\bin directory under your IAR
Systems installation, in case you want to start the program from the command line or
from within Windows Explorer.

Double-clicking the workspace filename

The workspace file has the filename extension eww. If you double-click a workspace
filename, the IDE starts.

IDE Project Management and Building Guide
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If you have several versions of IAR Embedded Workbench installed, the workspace file
is opened by the most recently used version of your IAR Embedded Workbench that
uses that file type, regardless of which version the project file was created in.

RUNNING AN EXAMPLE PROJECT

Example applications are provided with IAR Embedded Workbench. You can use these
examples to get started using the development tools from IAR Systems. You can also
use the examples as a starting point for your application project.

You can find the examples in the msp43 0\examples directory. The examples are ready
to be used as is. They are supplied with ready-made workspace files, together with
source code files and all other related files.

To run an example project:
Choose Help>Information Center and click Example projects.

Browse to the example that matches the specific evaluation board or starter kit you are
using.

IAR Information

EXAMPLE PROJECTS

IAR Information Center for MSP430 | Example projects | ... |

EXAMPLE PROJECTS

Example applications that demonstrates hardware peripherals
for specific devices and evaluation boards.

MSP430 Driver Library (MSP430F5xx 6xx Family)

MSP430 Driver Library (MSP430FR2xx 4xx Family)

MSP430 Driver Library (MSP430FR57xx Family)

Click the Open Project button.
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In the dialog box that appears, choose a destination folder for your project.

4 The available example projects are displayed in the workspace window. Select one of
the projects, and if it is not the active project (highlighted in bold), right-click it and
choose Set As Active from the context menu.

5 To view the project settings, select the project and choose Options from the context
menu. Verify the settings for General Options>Target> and
Debugger>Setup>Driver. As for other settings, the project is set up to suit the target
system you selected.

For more information about the C-SPY options and how to configure C-SPY to interact
with the target board, see the C-SPY® Debugging Guide for MSP430.

Click OK to close the project Options dialog box.
6 To compile and link the application, choose Project>Make or click the Make button.
7 To start C-SPY, choose Project>Debug or click the Download and Debug button.
8 Choose Debug>Go or click the Go button to start the application.

Click the Stop button to stop execution.

ORGANIZING WINDOWS ON THE SCREEN

Use these methods to organize the windows on your screen:

o To disconnect a tabbed window from a tab group and place it as a separate window,
drag it next to another open window.

o To place a window in the same tab group as another open window, drag the window
you want to locate and drop it in the middle of the other window.

o To make a window or tab group floating, double-click on the window’s title bar.

® When dragging a window to move it, press Shift to flip its orientation, and press Ctrl
to prevent it from docking.

Click and hold in a window’s title bar to get help on how to arrange windows. The help
is displayed on the status bar, located at the bottom of the IAR Embedded Workbench
IDE main window.

See also Organizing windows on the screen, page 28.

SPECIFYING TOOL OPTIONS

You can find commands for customizing the IDE on the Tools menu.

IDE Project Management and Building Guide
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To display the IDE Options dialog box, choose Tools>Options to get access to a wide
variety of options:

- Common Fonts
- Key Bindings Tab size:
- Language
- Editor Indent size
Extemal. Editor Tab Key
Setup Files 5
@ Inse
Colors and Fonts -
- Messages @ inde
[=I- Project i
; Show r
i External Analyzers = .
- Source Code Control - R
- Debugger ® Col.
- Stack File Enc
Defa

Select a category to the left in the dialog box and you have access to the options to the
right.

For more information about the various options for customizing the IDE, see Tools
menu, page 189.

ADDING ABUTTON TO A TOOLBAR

The buttons on the IDE toolbars provide shortcuts for commands on the IDE menus.

I To add a new button to a toolbar in the main IDE window, click the Toolbar Options
button and choose Add or Remove Buttons>Customize.

ce.

2 The Customize dialog box opens on the Commands page.
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In the Categories list, select the menu on which the command you want to add to the
toolbar is located.

Customize @
Commands | Options | Toolbars
Categories: Commands:
| New File -
View Tj Mew Workspace
Project =
Simulator [ Open File...
Tocls ] Open Workspace... m
Window
Help [ Open Header/Source File
New Menu
All Commands a s
BN Save Workspace
G Save Workspace fs. .. 2
Description:

3 Drag a command from the Commands list to one of the toolbars where you want to
insert the command as a button.

You can rearrange the existing buttons by dragging them to new positions.

Note: If you instead of adding a button want to show a button that has been hidden
temporarily, see Showing/hiding toolbar buttons, page 31.

REMOVING A BUTTON FROM A TOOLBAR

I To remove a button from any of the toolbars in the main window of the IDE, click the
Toolbar Options button and choose Add or Remove Buttons>Customize. Ignore the
Customize dialog box that is opened.

[E=N ECH =

ce.
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2 Right-click on the toolbar button that you want to remove and choose Delete from the
context menu.

Note: If you instead of removing a button want to hide it temporarily, see
Showing/hiding toolbar buttons, page 31.

SHOWING/HIDING TOOLBAR BUTTONS

As an alternative to removing a button from an IDE toolbar, you can toggle its visibility
on/off.

I To hide a button temporarily from any of the toolbars in the main window of the IDE,
click the Toolbar Options button and choose Add or Remove Buttons>foolbar.

460 R@-=0 "+ .

Add or Remove Buttons  » Main » T MewFile

Customize... [ openFile...
B save
B save Al
= Frint...

Cut

[v] %
F oV SV S S S &
ThBrekﬂt \ \'

° Download and Debug

¥ Debug without Downloading

Reset Toolbar

2 Select or deselect the command button you want to show/hide.
Note: If you want to delete a button entirely from the toolbar, see Removing a button
from a toolbar, page 30.
RECOGNIZING FILENAME EXTENSIONS

In the IDE, you can increase the number of recognized filename extensions. By default,
each tool in the build toolchain accepts a set of standard filename extensions. Also, if
you have source files with a different filename extension, you can modify the set of
accepted filename extensions.

To get access to the necessary commands, choose Tools>Filename Extensions.
See Filename Extensions dialog box, page 79.

To override the default filename extension from the command line, include an explicit
extension when you specify a filename.
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GETTING STARTED USING EXTERNAL ANALYZERS

I To add an external analyzer to the Project menu, choose Tools>Options to open the
IDE Options dialog box and select the Project>External Analyzers page.

2 To configure the invocation, click Add to open the External Analyzer dialog box.

Marme: Analyzer 1

Fath: C>Program Files [x86]\MypdnalyzerT oolhbnalyzer C]

Arguments:  -nc $FILE_PATH$ $COMPILER_ARGS$

Output matching patterns
Location:  $FILE_NAME$:$LINE_MUMBER$
‘Warning: [ ¥ijwarningl?-i):

Error: (¥ilerrar ?-i):

[ (] 3 ][ Cancel ]

Specify the details required for the analyzer you want to be able to invoke.

Use Output matching patterns to specify (or choose from a list) three regular
expressions for identifying warning and error messages and to find references to source
file locations.

Click OK when you have finished.
For more information about this dialog box, see External Analyzer dialog box, page 66.

3 In the IDE Options dialog box, click OK.
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Choose Project>Analyze Project and select the analyzer that you want to run,
alternatively choose Analyze File(s) to run the analyzer on individual files.

1 Workbench 1D

or [Ploject Tools Window Help

Add Files...

Add Group...

Import File List...

Add Project Connection...

3 Edit Configurations...

bBatch build... F&

Analyze Project
Analyze File(s)

Q.
]

e Stop Build CTRL+BREAK
I Download and Debug CTRL+D
Debug without Downloading
Make & Restart Debugger CTRL+R
Restart Debugger CTRL+SKIFT+R
Download
SFR Setup

Open Device File

EXErY-

Tutor.c | Utilities. ¢ | Utlities.h

'
N

ives you all the

hardy
Analyzer1 1
Analyzer 2
Analyzer 3

Each of the regular expressions that you specified will be applied on each line of output
from the external analyzer. Output from the analyzer is listed in the Build Log window.
You can double-click any line that matches the Location regular expression you

specified in the External Analyzer dialog box to jump to the corresponding location in

the editor window.

Note: If you want to stop the analysis before it is finished, click the Stop Build button.
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INVOKING EXTERNAL TOOLS FROM THE TOOLS MENU

I To add an external tool to the menu, for example Notepad, choose Tools>Configure
Tools to open the Configure Tools dialog box.

Configure Tools

Menu Content:
(]
Cancel
Mew
Delete
Menu Text:
|&N otepad
Command:
|E:\W’INDDWS\n0tepad.exe Browse... |
Argument:

Initial Directary:

™ Redirect to Dutput Window

I~ Prompt for Command Line

Tool Available:

|Always j

2 Fill in the text fields according to the screenshot.
For more information about this dialog box, see Configure Tools dialog box, page 75.

3 After you have entered the appropriate information and clicked OK, the menu
command you have specified is displayed on the Tools menu.

ﬁt Options...

Filename Extensions...
Configure Viewers..,

Configure Custom Argument Variables..,

ar

Configure Toaols...
Motepad
Note: You cannot use the Configure Tools dialog box to extend the toolchain in the

IDE. If you intend to add an external tool to the standard build toolchain, see Extending
the toolchain, page 107.
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ADDING COMMAND LINE COMMANDS TO THE TOOLS MENU

Command line commands and calls to batch files must be run from a command shell.
You can add command line commands to the Tools menu and execute them from there.

To add a command, for example Backup, to the Tools menu to make a copy of the entire
project directory to a network drive:

Choose Tools>Configure Tools to open the Configure Tools dialog box.
Type or browse to the cmd.exe command shell in the Command text box.

Type the command line command or batch file name in the Argument text box, for
example:

/C copy c:\project\*.* F:

Alternatively, use an argument variable to allow relocatable paths:

/C copy $PROJ_DIRS\*.* F:

The argument text should be specified as:

/C name

where name is the name of the command or batch file you want to run.

The /c option terminates the shell after execution, to allow the IDE to detect when the
tool has finished.

USING AN EXTERNAL EDITOR

The External Editor options—available by choosing Tools>Options>Editor—Ilet you
specify an external editor of your choice.

Note: While you are debugging using C-SPY, C-SPY will not use the external editor for
displaying the current debug state. Instead, the built-in editor will be used.

To specify an external editor of your choice:
Select the option Use External Editor.
An external editor can be called in one of two ways, using the Type drop-down menu:

e Command Line calls the external editor by passing command line parameters.

o DDE calls the external editor by using DDE (Windows Dynamic Data Exchange).

If you use the command line, specify the command to pass to the editor, that is, the
name of the editor and its path, for instance:

C:\Windows\NOTEPAD.EXE
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To send an argument to the external editor, type the argument in the Arguments field.
For example, type SFILE_PATHS to start the editor with the active file (in editor, project,
or messages windows).

IDE Options =23l

- Common Fonts

[] Use Extemal Editor
Command Line

--Key Bindings
--Language
=- Editor

.. External Editor

- Setup Files

L. Colors and Fonts
- Messages
-Project
- Source Code Control
-~ Debugger
- Stack
- Terminal /0

Note: Options for Terminal I/O are only available when the C-SPY debugger is running.

4 If you use DDE, specify the editor’s DDE service name in the Service field. In the
Command field, specify a sequence of command strings to send to the editor.

The service name and command strings depend on the external editor that you are using.
Refer to the user documentation of your external editor to find the appropriate settings.

The command strings should be entered as:

DDE-Topic CommandStringl
DDE-Topic CommandString2

IDE Project Management and Building Guide
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as in this example, which applies to Codewright®:

Use Extemnal Editor

Type: [DDE -
Editor: CACW32'ow32 exe E]
Service: Codewright

Command: System BufEditFile SFILE_PATHS

SFILE_PATHS MovToline SCUR_LINES

The command strings used in this example will open the external editor with a dedicated
file activated. The cursor will be located on the current line as defined in the context
from where the file is open, for instance when searching for a string in a file, or when
double-clicking an error message in the Message window.

5 Click OK.

When you double-click a filename in the Workspace window, the file is opened by the
external editor.

Variables can be used in the arguments. For more information about the argument
variables that are available, see Argument variables, page 82.

Reference information on the IDE

Reference information about:

1AR Embedded Workbench IDE window, page 39
Customize dialog box, page 44

Button Appearance dialog box, page 47

Tool Output window, page 48

Common Fonts options, page 49

Key Bindings options, page 50

Language options, page 52

Editor options, page 53
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Configure Auto Indent dialog box, page 56
External Editor options, page 57

Editor Setup Files options, page 59

Editor Colors and Fonts options, page 60
Messages options, page 61

Project options, page 62

External Analyzers options, page 64

External Analyzer dialog box, page 66

Source Code Control options (deprecated), page 68
Debugger options, page 69

Stack options, page 71

Terminal 1/0 options, page 73

Configure Tools dialog box, page 75

Configure Viewers dialog box, page 77

Edit Viewer Extensions dialog box, page 78
Filename Extensions dialog box, page 79
Filename Extension Overrides dialog box, page 80
Edit Filename Extensions dialog box, page 81
Product Info dialog box, page 81

Argument variables, page 82

Configure Custom Argument Variables dialog box, page 83
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IAR Embedded Workbench IDE window
The main window of the IDE is displayed when you launch the IDE.

— € tutorials - AR Embedded Workbench IDE - MSP430 6.60.0 =N ECR =<
I Menu bar I —— File Edit View Project Simulastor Tools Window Help
[Toolbar DR = XEG DcC 4 Q>8+=< 0> BO=0 > .
S— Workspace > & X [Tutorc x -
pioject2 - Debug +| mainl iy
AL &= : Tutor.c ]
B Chutarials "
:prDJEEﬂ -Debug ¥ + C tutorial. Prints the Fibonacci seguence.
project2 - Debug v =
1 il [ATutore * §Revision: £910 §
Workspace | c] Utilities.c =
window | L@ i Output
@ oject-Debug . v #include "Tutor.h”
@projectd-Debug v
[ ] rojectd - Debug v int callCount; 3
.tutmjibrarnyeh v -
/* Increase the 'callCount' variable by one. */
void NextCounter [void)
R {
‘ Editor ‘ T callCount += 1;
B e — P
/* Increase th
T + Get and prin
<
void DoForegroundProcess (void)
Overview_moject! | proect2 | pre o [ ] || « [ i Dl <
Build v 31X
Messages
I Building confiquration: project2 - Debug
Message Updating build tree
windows
— Configuration is up-to-date
‘ i v
—— Build | Debug Log
I Status bar 1 - Ready Errars 0, Warnings 0 Ln 53, Col3 Sye
The figure shows the window and its default layout.
Menu bar
The menu bar contains:
File
Commands for opening source and project files, saving and printing, and exiting
from the IDE.
Edit
Commands for editing and searching in editor windows and for enabling and
disabling breakpoints in C-SPY.
View

Commands for opening windows and controlling which toolbars to display.
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Toolbar

Project
Commands for adding files to a project, creating groups, and running the IAR
Systems tools on the current project.

Simulator
Commands specific for the C-SPY simulator. This menu is only available when
you have selected the simulator driver in the Options dialog box.

C-SPY hardware driver
Commands specific for the C-SPY hardware debugger driver you are using, in
other words, the C-SPY driver that you have selected in the Options dialog box.
For some IAR Embedded Workbench products, the name of the menu reflects
the name of the C-SPY driver you are using and for others, the name of the menu
is Emulator.

Tools
User-configurable menu to which you can add tools for use with the IDE.

Window
Commands for manipulating the IDE windows and changing their arrangement

on the screen.

Help
Commands that provide help about the IDE.

For more information about each menu, see Menus, page 175.

The buttons on the IDE toolbar provide shortcuts for the most useful commands on the
IDE menus, and a text box for typing a string to do a quick search. For information about
how to add and remove buttons on the toolbars, see Using and customizing the IDE, page
26.

For a description of any button, point to it with the mouse pointer. When a command is
not available, the corresponding toolbar button is dimmed, and you will not be able to
click it.

The toolbars are dockable; drag and drop to rearrange them.

IDE Project Management and Building Guide
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This figure shows the menu commands corresponding to each of the toolbar buttons:

Toggle

I T I |F’rint ||CODY | [Ouick Search text box ] I Navigate Forwarld_.rBackward ‘ Toedle —Toolbar
i : : reakpaint
|_Save | |Undo | [Find N ext | lTogg1e Bookmark } |Make | —-p— | Options ‘
D@ = x®8p OC Q25200 RO= 0 o
|5av;A|| | |ch | |Re::|o | |Fm:1 | |£| [m| 'D.e.b“g
v —— 1 |Find —/ Previous/Next Download without
‘OPE‘“ ‘ |Paste | | Previous [Replace ‘ ‘ Bookmark and Debug .Downloading |

Note: When you start C-SPY, the Download and Debug button will change to a Make
and Restart Debugger button @ and the Debug without Downloading will change
to a Restart Debugger button C .

Toolbar Options
Click the Toolbars Options button to open the Toolbars Options menu.

-

Context menu
This context menu is available by right-clicking a toolbar button when the Customize
dialog box is open. For information about how to open this dialog box, see Customize
dialog box, page 44.

Reset to Default

Copy Button Image
Delete

Button Appearance...
v | Image

Text

Image and Text

Start Group

These commands are available:

Reset to Default
Hides the button icon and displays the name of the button instead.

Copy Button Image
Copies the button icon and stores the image on the clipboard.

Delete
Removes the button from the toolbar.
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Button Appearance
Displays the Button Appearance dialog box, see Button Appearance dialog
box, page 47.
Image
Displays the button only as an icon.
Text
Displays the button only as text.

Image and Text
Displays the button both as an icon and as text.

Start Group
Inserts a delimiter to the left of the button.

Toolbars Options menu

This menu and its submenus are available by clicking the Toolbars Options button on
the far right end of a toolbar:

4 B@-=0 - .

Add or Remove Buttons  « Main 3

!Tj New File
Customize.., [ openFile...
BE save
B save Al
= Frint...

Cut

(/] %
F ol 2 S S 8 4
i—hmekﬁ\\

° Download and Debug

¥ Debug without Downloading

Reset Toolbar

These commands are available:

Add or Remove Buttons
Opens a submenu.

toolbar

Opens a submenu that lists all command buttons on the toolbar. Select or
deselect a checkbox to show/hide the button on the toolbar. Choose Reset
Toolbar to restore the toolbar to its default appearance.
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Customize
Displays the Customize dialog box, see Customize dialog box, page 44.

Status bar

The status bar at the bottom of the window can be enabled from the View menu.

x

— [Errors 0, Warnings 0 [tn 124, Col 19 [System  [CaP [nUmM [ove [BEES

The status bar displays:

Source browser progress information
o The number of errors and warnings generated during a build

o The position of the insertion point in the editor window. When you edit, the status
bar shows the current line and column number containing the insertion point.

o The character encoding
o The state of the modifier keys Caps Lock, Num Lock, and Overwrite.

e If your product package is available in more languages than English, a flag in the
corner shows the language version you are using. Click the flag to change the
language. The change will take force the next time you launch the IDE.
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Customize dialog box

The Customize dialog box is available by clicking the Toolbars Options button on the
far right end of the a toolbar in the main IDE window and choosing Add or Remove

Buttons>Customize.
Customize @
Commands | Options | Toolbars
Categories: Commands:
| New File -
View Tj Mew Workspace
Project =
Simulator [ Open File...
Tocls ] Open Workspace...
Window
Help [ Open Header/Source File
New Menu
All Commands a s
BN Save Workspace
G Save Workspace fs. .. 2
Description:

These are the options on the Commands page of the Customize dialog box:

Categories
Lists the menus in the IDE. Select a menu name to make the commands on that menu
available for adding as buttons to a toolbar. Select New Menu to make it possible to add
a custom dropdown menu to a toolbar.

Commands

Lists menu commands that can be dragged to one of the toolbars and inserted as buttons.
If New Menu is the selected Category, the command New Menu can be dragged to a
toolbar to add a custom dropdown menu to the toolbar. Commands from the Commands
list can then be dragged to populate the custom menu.

IDE Project Management and Building Guide
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Options

Toolbar
Show Screen Tips on toolbars
Show shortcut keys in ScreenTips
[ Large lcons

These are the options on the Options page of the Customize dialog box:

Show Screen Tips on toolbars

Enables tooltips for the buttons on the toolbars. The tooltips contain the display names
of the buttons.

Show shortcut keys in Screen Tips
Includes the keyboard shortcut in the tooltip text for the buttons on the toolbar.

Large icons

Increases the size of the buttons on the toolbars.
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Toolbars
Toolbars:

Eain ] Reset
Menu Bar

Reset All

[ Show text labels

These are the options on the Toolbars page of the Customize dialog box:

Toolbars
Select/deselect a toolbar to show/hide it in the main IDE window. The menu bar cannot
be hidden.

Reset
Restores the selected toolbar to its default appearance.

Reset All

This button is disabled.

Show text labels

Displays the names of the buttons on the selected toolbar.

IDE Project Management and Building Guide
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Button Appearance dialog box

The Button Appearance dialog box is available by right-clicking a toolbar button when
the Customize dialog box is open and choosing Button Appearance from the context

menu.
Button Appearance @
Image onty Use Default Image:
@ Text only Select User-defined Image:
Image and text ™
Description: Ed

Button text: Stop Debugaing [ oK ]| Cancel |

Use this dialog box to change the display name of a toolbar button.

Image only

This option has no effect.

Text only
Enables the text box Button text.

Image and text

Enables the text box Button text.

Use default image

This option is disabled.

Select User-defined image

This option is disabled.

New
This button is disabled.

Edit
This button is disabled.
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Button text
The display name of the toolbar button. Edit the text to change the name.

Tool Output window

The Tool Output window is available by choosing View>Messages>Tool Output.

=

Output |

Tool Output

This window displays any messages output by user-defined tools in the Tools menu,
provided that you have selected the option Redirect to Output Window in the
Configure Tools dialog box; see Configure Tools dialog box, page 75. When opened,
this window is, by default, grouped together with the other message windows.

Context menu

This context menu is available:

Copy
Select Al

Clear Al

These commands are available:

Copy
Copies the contents of the window.

Select All
Selects the contents of the window.

Clear All
Deletes the contents of the window.

IDE Project Management and Building Guide
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Common Fonts options

The Common Fonts options are available by choosing Tools>Options.
IDE Options =
Fixed Width Fort

- Key Bindings

Fort... Courier, size = 10
- Language

ditor

- Messages
roject Fortt... MS Sans Serf, size = 10

Proportional Width Font

- Source Code Control
- Debugger

[ ok ][ canca |

Use this page to configure the fonts used for all project windows except the editor
windows.

For information about how to change the font in the editor windows, see Editor Colors
and Fonts options, page 60.

Fixed Width Font
Selects which font to use in the Disassembly, Register, and Memory windows.

Proportional Width Font

Selects which font to use in all windows except the Disassembly, Register, Memory,
and editor windows.
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Key Bindings options

The Key Bindings options are available by choosing Tools>Options.

IDE Options

- Common Fonts
-Language

- Editor

- Messages

: - Project

.. Source Code Control

-Debugger

Menu: File:

-

Command

New Document
Mew workspace
Open

Open Workspace
COpen file

Close

Primary Hlias
Cir+N

Cir=0

Cirl+5Shift+H

m

Press shortcut key:

Primary

Set

Use this page to customize the shortcut keys used for the IDE menu commands.

Menu

Selects the menu to be edited. Any currently defined shortcut keys for the selected menu

are listed below the Menu drop-down list.

List of commands

Selects the menu command you want to configure your own shortcut keys for, from this

list of all commands available on the selected menu.

Press shortcut key

Type the key combination you want to use as shortcut key for the selected command.

You cannot set or add a shortcut if it is already used by another command.

Primary

Choose to:

Set

Saves the key combination in the Press shortcut key field as a shortcut for the
selected command in the list.

IDE Project Management and Building Guide
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Clear

Removes the listed primary key combination as a shortcut for the selected
command in the list.

The new shortcut will be displayed next to the command on the menu.

Alias

Choose to:

Add

Saves the key combination in the Press shortcut key field as an alias—a hidden
shortcut—for the selected command in the list.

Clear

Removes the listed alias key combination as a shortcut for the selected
command in the list.

The new shortcut will be not displayed next to the command on the menu.

Reset All

Reverts the shortcuts for all commands to the factory settings.
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Language options

Language

The Language options are available by choosing Tools>Options.

IDE Options

¥

Comrmon Fonts

Key Bindings
Language

Editar

Messages

Project

Source Code Contral
Debugger

Stack.

X

Language

After changing to a different language,
you must restart the application.

=]

Cancel | | Help |

Use this page to specify the language to be used in windows, menus, dialog boxes, etc.

Selects the language to be used. The available languages depend on your product
package, English (United States) and Japanese.

Note: If you have installed IAR Embedded Workbench for several different toolchains
in the same directory, the IDE might be in mixed languages if the toolchains are
available in different languages.

IDE Project Management and Building Guide
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The Editor options are available by choosing Tools>Options.

IDE Options

-Commeon Fonts
-Key Bindings
-Language

- Editor

-Messages

- Project

-Source Code Control
-Debugger

-Stack

Tab size: 8

Indent size: 2
Tab Key Function:
() Insert tab

@ Indent with spaces

Show right margin
() Printing edge
@ Columns: 80

File Encoding

Default character encoding:

[System

Auto-detect character encoding

EOL characters: | PC

Syntax highlighting

Auto indent

Show line numbers

Scan for changed files

Show bookmarks

Show fold margin

[ Enable virtual space

[7] Remove trailing blanks

Auto code completion and parameter hints
Show source browser tooltips
[ Show line break characters

Use this page to configure the editor.

For more information about the editor, see Editing, page 123.

Tab size

Specify the width of a tab character, in terms of character spaces.

Indent size

Specify the number of spaces to be used when tabulating with an indentation.

Tab Key Function

Controls what happens when you press the Tab key. Choose between:

Insert tab

Inserts a tab character when the Tab key is pressed.

Indent with spaces

Inserts an indentation (space characters) when the Tab key is pressed.
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Show right margin

Displays the area of the editor window outside the right margin as a light gray field. If
this option is selected, you can set the width of the text area between the left margin and
the right margin. Choose to set the width based on:

Printing edge

Bases the width on the printable area, which is taken from the general printer
settings.

Columns

File Encoding

Bases the width on the number of columns.

Controls file encoding. Choose between:

Default character encoding

IDE Project Management and Building Guide
for MSP430

Selects the character encoding to be used by default for new files. Choose
between:

System (uses the Windows settings)
Western European

UTF-8

Japanese (Shift-JIS)

Chinese Simplified (GB2312)
Korean (Unified Hangul Code)
Arabic

Baltic

Central European

Greek

Hebrew

Russian

Thai

Vietnamese

Note that if you have specified a character encoding from the editor window
context menu, that encoding will override this setting for the specific document.
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Auto-detect character encoding

Detects automatically which character encoding that should be used when you
open an existing document.

EOL characters

Selects which line break character to use when editor documents are saved.
Choose between:

PC (default), Windows and DOS end of line characters.
Unix, UNIX end of line characters.

Preserve, the same end of line character as the file had when it was opened,
either PC or UNIX. If both types or neither type are present in the opened file,
PC end of line characters are used.

Syntax highlighting
Makes the editor display the syntax of C or C++ applications in different text styles.

For more information about syntax highlighting, see Editor Colors and Fonts options,
page 60 and Syntax coloring, page 129.

Auto indent

Makes the editor indent the new line automatically when you press Return. For C/C++
source files, click the Configure button to configure the automatic indentation; see
Configure Auto Indent dialog box, page 56. For all other text files, the new line will have
the same indentation as the previous line.

Show line numbers

Makes the editor display line numbers in the editor window.

Scan for changed files

Makes the editor reload files that have been modified by another tool.

If afile is open in the IDE, and the same file has concurrently been modified by another
tool, the file will be automatically reloaded in the IDE. However, if you already started
to edit the file, you will be prompted before the file is reloaded.

Show bookmarks

Makes the editor display a column on the left side in the editor window, with icons for
compiler errors and warnings, Find in Files results, user bookmarks, and breakpoints.
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Show fold margin
Makes the editor display the fold margin in the left side of the editor window. For more
information, see Code folding, page 126.

Enable virtual space

Allows the insertion point to move outside the text area.

Remove trailing blanks
Removes trailing blanks from files when they are saved to disk. Trailing blanks are blank
spaces between the last non-blank character and the end of line character.

Auto code completion and parameter hints
Enables code completion and parameter hints. For more information, see Editing a file,
page 124.

Show source browser tooltips
Toggles the display of detailed information about the identifier that the cursor currently
hovers over.

Show line break characters

Toggles the display of carriage return and line feed characters in the editor window.

Configure Auto Indent dialog box
The Configure Auto Indent dialog box is available from the IDE Options dialog box.

Configure Auto Indent @
Sample code
Opening Brace (&) int f£({int x)
0 ¢
b awitch (x)
Body (b) a | |
2 c case 0:
b return 1;
Label {c) c default:
0 b return x;
}
}
[ oK ] | Cancel |

Use this dialog box to configure the editor’s automatic indentation of C/C++ source
code.

IDE Project Management and Building Guide
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For more information about indentation, see /ndenting text automatically, page 125.

Opening Brace (a)

Specify the number of spaces used for indenting an opening brace.

Body (b)

Specify the number of additional spaces used for indenting code after an opening brace,
or a statement that continues onto a second line.

Label (c)

Specify the number of additional spaces used for indenting a label, including case labels.

Sample code

This area reflects the settings made in the text boxes for indentation. All indentations are
relative to the preceding line, statement, or other syntactic structures.

External Editor options

The External Editor options are available by choosing Tools>Options.

IDE Options =

- Common Fonts

Use Extemnal Editor

- Key Bindings
- Language Type: DDE v]
&=- Editor Editor: C:\Program Files (x86)\CVW32\cw32.exe E]
‘.. External Editor
Setup Files Service: Codewright
- Colors and Fonts Command: System BufEditFils SFILE_PATHS
- Messages SFILE_PATHS MovToline SCUR_LINES
[#- Project
- Source Code Control
- Debugger
- Stack
[ ok ][ Ccancel

Use this page to specify an external editor of your choice.
Note: The contents of this dialog box depends on the setting of the Type option.

See also Using an external editor, page 35.

Use External Editor

Enables the use of an external editor.
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Type

Editor

Arguments

Service

Command

Selects the type of interface. Choose between:

e Command Line

o DDE (Windows Dynamic Data Exchange).

Specify the filename and path of your external editor. A browse button is available for
your convenience.

Specify any arguments to be passed to the editor. This is only applicable if you have
selected Command Line as the interface type.

Specify the DDE service name used by the editor. This is only applicable if you have
selected DDE as the interface type.

The service name depends on the external editor that you are using. Refer to the user
documentation of your external editor to find the appropriate settings.

Specify a sequence of command strings to be passed to the editor. The command strings
should be typed as:

DDE-Topic CommandStringl
DDE-Topic CommandString2

This is only applicable if you have selected DDE as the interface type.

The command strings depend on the external editor that you are using. Refer to the user
documentation of your external editor to find the appropriate settings.

Note: You can use variables in arguments, see Argument variables, page 82.

IDE Project Management and Building Guide
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Editor Setup Files options
The Editor Setup Files options are available by choosing Tools>Options.

IDE Options =
- Common Fonts
.. Key Bindings [T Use Custom Keyword File:
- Language

= Editor
: /| Use Code Templates:
i External Editor se ~ode Jempiates

Setup Files C\Users\johana'AppData“Roaming AR Embedded Workbench'Code Templates. ENL b C]

Colors and Fonts
- Messages

el
[

- Project

- Source Code Control
- Debugger

- Stack

oK | [ Cancel

Use this page to specify setup files for the editor.

Use Custom Keyword File

Specify a text file containing keywords that you want the editor to highlight. For
information about syntax coloring, see Syntax coloring, page 129.

Use Code Templates

Specify a text file with code templates that you can use for inserting frequently used
code in your source file. For information about using code templates, see Using and
adding code templates, page 128.
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Editor Colors and Fonts options

The Editor Colors and Fonts options are available by choosing Tools>Options.

IDE Options @
- Common Fonts Editor Fort
- Key Bindings Font... Courier New, size = 9
- Language
[=I- Editor
‘... External Editor Syntax Coloring
- Setup Files Default = Color

----- Chamor
- Messages CST}:I:rgs | Type Style:
- Project Preprocessor r
- Source Code Control Number

C++ comment Sample

- Debugger Comment
.. Stack User keyword - ’—

Background Color

[ ok ][ cancel || pply Help

Editor Font

Use this page to specity the colors and fonts used for text in the editor windows. The
keywords controlling syntax highlighting for assembler and C or C++ source code are
specified in the files syntax_icc.cfgand syntax_asm.cfg, respectively. These files
are located in the msp430\config directory.

Click the Font button to open the standard Font dialog box where you can choose the
font and its size to be used in editor windows.

Syntax Coloring

Selects a syntax element in the list and sets the color and style for it:

Color

Lists colors to choose from. Choose Custom from the list to define your own
color.

Type Style
Select Normal, Bold, or Italic style for the selected element.

IDE Project Management and Building Guide
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Sample
Displays the current appearance of the selected element.

Background Color
Click to set the background color of the editor window.

Note: The User keyword syntax element refers to the keywords that you have listed in
the custom keyword file; see Editor Setup Files options, page 59.

Messages options
The Messages options are available by choosing Tools>Options.

IDE Options =

= Some dialog boxes can be suppressed
Enable Al Dialogs ] by selecting a "Don't show again”

check box. Click "Enable Al Dialogs"

to enable all suppressed dialog boxes again.

oK | [ Cancel

Use this page to re-enable suppressed dialog boxes.

Enable All Dialogs

Enables all dialog boxes you have suppressed by selecting a Don’t show again check
box, for example:

TarldePm =

l._\ This will terminate the debug session.

[ OK ] [ Cancel

[7] Don't show again
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Project options
The Project options are available by choosing Tools>Options.

IDE Options

Common Fonts

Key Bindi
o Stop build operation on:
Language
Editor Save editor windows before building:
Messages
Proi Save workspace and projects before
[l building:
Source Code Control kS bk e
Debugger
""" tack [] Reload last workspacs at startup

Play a sound after build operations

(Generate browse information

[ No source browser and build status updates when the IDE is not the foreground process
Enable project connections

[ Enable paraliel build Processes: |2

oKk | [ Cancel |

Use this page to set options for the Make and Build commands.

Stop build operation on
Selects when the build operation should stop. Choose between:
Never
Never stops.
Warnings
Stops on warnings and errors.

Errors
Stops on errors.

Save editor windows before building

Selects when the editor windows should be saved before a build operation. Choose
between:

Never
Never saves.

IDE Project Management and Building Guide
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Ask
Prompts before saving.

Always
Always saves before Make or Build.

Save workspace and projects before building
Selects when a workspace and included projects should be saved before a build
operation. Choose between:

Never
Never saves.

Ask
Prompts before saving.

Always
Always saves before Make or Build.

Make before debugging
Selects when a Make operation should be performed as you start a debug session.
Choose between:

Never
Never performs a Make operation before a debug session.

Ask
Prompts before performing a Make operation.

Always

Always performs a Make operation before a debug session.

Reload last workspace at startup

Loads the last active workspace automatically the next time you start the IAR Embedded
Workbench IDE.

Play a sound after build operations

Plays a sound when the build operations are finished.

Generate browse information

Enables the use of the Source Browser window, see Source Browser window, page 154.
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No source browser and build status updates when the IDE is not the foreground process
Halts the source browser when the IDE is not the foreground process. This also means
that the build status is no longer updated in the Workspace window. This option is
useful for example, if you are using a laptop and want to reduce power consumption.

Enable project connections
Enables the support for setting up live project connections, see Add Project Connection
dialog box, page 104.

Enable parallel build

Enables the support for parallel build. The compiler runs in several parallel processes to
better use the available cores in the CPU. In the Processes text box, specify the number
of processes you want to use. Using all available cores might result in a less responsive
IDE.

External Analyzers options

The External Analyzers options are available by choosing Tools>Options.

- Common Fonts
- Key Bindings Analyzers:
.. Language Analyzer 1 Move Up

. Analyzer 2
[+ Editor Analyzer 3

- Messages Move Down

[=I- Project

- Source Code Control
- Debugger
- Stack

Use this page to add an external analyzer to the standard build toolchain.

For more information, see Getting started using external analyzers, page 32.

IDE Project Management and Building Guide
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Analyzers

Lists the external analyzers that you have added to the standard build toolchain.

Move Up

Moves the analyzer you have selected in the list one step up. This order is reflected on
the Project menu.

Move Down

Moves the analyzer you have selected in the list one step down. This order is reflected
on the Project menu.

Add
Displays the External Analyzer dialog box where you can add a new analyzer to the
toolchain and configure the invocation of the analyzer.

Delete
Deletes the selected analyzer from the list of analyzers.

Edit

Displays the External Analyzer dialog box where you can edit the invocation details of
the selected analyzer.
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External Analyzer dialog box

The External Analyzer dialog box is available by choosing
Tools>Options>Project>External Analyzers.

Marme: Analyzer 1

Fath: C>Program Files [x86]\MypdnalyzerT oolhbnalyzer C]

Arguments:  -nc $FILE_PATH$ $COMPILER_ARGS$

Output matching patterns
Location:  $FILE_NAME$:$LINE_MUMBER$
‘Warning: [ ¥ijwarningl?-i):

Errar: [Fi)erran] -]:

[ (] 3 J[ Cancel ]

Use this dialog box to configure the invocation of the external analyzer that you want to
add to the standard build toolchain.

For more information, see Getting started using external analyzers, page 32.

Name

Specify the name of the external analyzer. Note that the name must be unique.

IDE Project Management and Building Guide
66 for MSP430



The development environment ___4

Path

Specify the path to the analyzer’s executable file. A browse button is available for your
convenience.

Arguments

Specify the arguments that you want to pass to the analyzer. Note that you can use
argument variables for specifying the arguments, see Argument variables, page 82.

Location

Specify a regular expression used for finding source file locations. The regular
expression is applied to each output line which will appear as text in the Build Log
window. You can double-click a line that matches the regular expression you specify.

You can use the argument variables $FILE_NAMES$, $LINE_NUMBERS, and
$COLUMN_NUMBERS to identify a filename, line number, and column number,
respectively. Choose one of the predefined expressions:

\"?$FILE_NAMES$\"?:$LINE_NUMBERS$
Will, for example, match a location of the form file.c:17.

\"?$FILE_NAMES$\"? +SLINE_NUMBERS$
Will, for example, match a location of the form file.c17.

\"?$FILE_NAMES$\"?

Will, for example, match a location of the form file.c.

Alternatively, you can specify your own expression. For example, the regular expression
Msg: SFILE_NAMES$ @ SLINE_NUMBERS, when applied to the output string
Msg:MySourceFile.c @ 32, will identify the file as MySourceFile.c, and the line
number as 32.

Warning
Any output line that matches this expression is tagged with the warning symbol.
For example, the expression (?i)warning (?-i): will identify any line that contains

the string warning: (regardless of case) as a warning.

Error

Any output line that matches this expression is tagged with the error symbol. Errors have
precedence over warnings.
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For example, the expression (?i)error (?-i) : will identify any line that contains the
string error: (regardless of case) as an error.

Source Code Control options (deprecated)
The Source Code Control options are available by choosing Tools>Options.

IDE Options =

- Common Fonts

- Key Bindings SCC Options
.. Language [] Keep items checked out when checking in
(=) Editor Save editor windows before performing
External Editor source code control commands:

Setup Files
i Colors and Fonts

- Messages

[#- Project

= Source Code Control
- Debugger

- Stack

[ ok ][ canca |

Use this page to configure the interaction between an IAR Embedded Workbench
project and an SCC project.

Note: This is a deprecated feature which is not supported for new projects.

Keep items checked out when checking in

Determines the default setting for the option Keep Checked Out in the Check In Files
dialog box.

Save editor windows before performing source code control commands

Determines whether editor windows should be saved before you perform any source

code control commands. Choose between:

Never
Never saves editor windows before performing any source code control
commands.

Ask
Prompts before performing any source code control commands.

Always

Always saves editor windows before performing any source code control
commands.

IDE Project Management and Building Guide
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Debugger options

The Debugger options are available by choosing Tools>Options.

IDE Options (=23

When source resolves to multiple function instances

[ Automatically choose all instances

Source code color in disassembly window

o

Step into functions STL container expansion

@ All functions

Depth: 10
() Functions with source only

Update intervals {miliseconds) Default integer format
Memory window: 1000

Window classification by background color

[ OK ] [ Cancel Apply Help

Use this page to configure the debugger environment.

When source resolves to multiple function instances
Some source code corresponds to multiple code instances, for example template code.
When specifying a source location in such code, for example when setting a source
breakpoint, you can make C-SPY act on all instances or a subset of instances. Use the
Automatically choose all instances option to let C-SPY act on all instances without
asking first.

Source code color in disassembly window
Click the Color button to select the color for source code in the Disassembly window.
To define your own color, choose Custom from the list.

Step into functions
Controls the behavior of the Step Into command. Choose between:
All functions

Makes the debugger step into all functions.
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Functions with source only

Makes the debugger step only into functions for which the source code is
known. This helps you avoid stepping into library functions or entering
disassembly mode debugging.

STL container expansion

Specify how many elements that are shown initially when a container value is expanded
in, for example, the Watch window.

Update intervals

Specify how often the contents of the Live Watch window and the Memory window
are updated.

These text boxes are only available if the C-SPY driver you are using has access to the
target system memory while executing your application.

Default integer format

Selects the default integer format in the Watch, Locals, and related windows.

Window classification by background color

Toggles background colors in some C-SPY windows on or off. Colors are used for
differentiating types of windows; for example, all interrupt-related windows have one
background color, and all watch-related windows have another color, etc.

IDE Project Management and Building Guide
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Stack options

The Stack options are available by choosing Tools>Options or from the context menu
in the Memory window.

IDE Options =
- Common Fonts
. Key Bindings Enable graphical stack display and stack usage tracking
- Language 50 % stack usage threshold
= E::Iitor Wam when exceeding stack threshold
i External Editor

Setup Files Wam when stack pointer is out of bounds

Colors and Fonts Stack pointer{s) not valid urtil program reaches:

- Messages -
+- Project main
.. Source Code Control Wamings
- Debugger @ Log
- Stack *) Log and alert
[T] Limit stack: display to 50 bytes

[ ok ][ cance |

Use this page to set options specific to the Stack window.

Enable graphical stack display and stack usage tracking

Enables the graphical stack bar available at the top of the Stack window. It also enables
detection of stack overflows. For more information about the stack bar and the
information it provides, see the C-SPY® Debugging Guide for MSP430.

% stack usage threshold

Specify the percentage of stack usage above which C-SPY should issue a warning for
stack overflow.

Woarn when exceeding stack threshold

Makes C-SPY issue a warning when the stack usage exceeds the threshold specified in
the % stack usage threshold option.

Warn when stack pointer is out of bounds

Makes C-SPY issue a warning when the stack pointer is outside the stack memory range.
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Stack pointer(s) not valid until program reaches

Warnings

Specity a location in your application code from where you want the stack display and
verification to occur. The Stack window will not display any information about stack
usage until execution has reached this location.

By default, C-SPY will not track the stack usage before the main function. If your
application does not have a main function, for example, if it is an assembler-only
project, you should specify your own start label. If this option is selected, after each reset
C-SPY keeps a breakpoint on the given location until it is reached.

Typically, the stack pointer is set up in the system initialization code cstartup, but not
necessarily from the very first instruction. Select this option to avoid incorrect warnings
or misleading stack display for this part of the application.

Selects where warnings should be issued. Choose between:
Log
Warnings are issued in the Debug Log window.

Log and alert
Warnings are issued in the Debug Log window and as alert dialog boxes.

Limit stack display to

Limits the amount of memory displayed in the Stack window by specifying a number
of bytes, counting from the stack pointer. This can be useful if you have a big stack or
if you are only interested in the topmost part of the stack. Using this option can improve
the Stack window performance, especially if reading memory from the target system is
slow. By default, the Stack window shows the whole stack, or in other words, from the
stack pointer to the bottom of the stack. If the debugger cannot determine the memory
range for the stack, the byte limit is used even if the option is not selected.

Note: The Stack window does not affect the execution performance of your application,
but it might read a large amount of data to update the displayed information when the
execution stops.
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Terminal I/O options

Input mode

The Terminal I/O options are available by choosing Tools>Options when C-SPY is

The development environment ___4

running.
IDE Options =

EomBrjnor? Fonts Input mode

- Key Bindings © Keyboard

- Language _

. (@ Buffered

[+ Editor .

.. Messages © Direct

[#- Project “) File

- Source Code Control @ Text

- Debugger Binary

- Stack $PROJ_DIRS\TemOlnput b2

® Terminal /O
Input echoing
Log file
[ Teminal 1/0 window
Encoding
@) System
O UTF-8

[ Show target reset in Terminal /0 window
[ ok [ cancel |

Use this page to configure the C-SPY terminal I/O functionality.

Controls how the terminal I/O input is read.

Keyboard = Makes the input characters be read from the keyboard. Choose between:
Buffered: Buffers input characters.
Direct: Does not buffer input characters.

File Makes the input characters be read from a file. Choose between:

Text: Reads input characters from a text file.

Binary: Reads input characters from a binary file.

A browse button is available for locating the input file.
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Input echoing

Encoding

Determines whether to echo the input characters and where to echo them. Choose
between:

Log file

Echoes the input characters in the Terminal I/O log file. Requires that you have
enabled the option Debug>Logging>Enable log file.

Terminal I/0 window

Echoes the input characters in the Terminal I/O window.

Determines the encoding used for terminal input and output. Choose between:

System

Uses the Windows settings.
UTF-8

Uses the UTF-8 encoding.

Show target reset in Terminal /O window

Displays a message in the C-SPY Terminal I/O window when the target resets.
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Configure Tools dialog box
The Configure Tools dialog box is available from the Tools menu.

Configure Tools

Menu Content:

—

Cancel

2w

Initial Directary:

I~ Prompt for Command Line

Tool Available:

™ Redirect to Dutput Window

|Always

[~ |

[ bk

Delete
Menu Text:
|&N otepad
Command:
|E:\W’INDDWS\n0tepad.exe Browse...
Argument:

The development environment ___4

Use this dialog box to specity a tool of your choice to add to the Tools menu, for

example Notepad:

Options...

Filename Extensions...

Configure Viewers...

Configure Tools...

Configure Custom Argument Variables...

Note: If you intend to add an external tool to the standard build toolchain, see Extending

the toolchain, page 107.

You can use variables in the arguments, which allows you to set up useful tools such as
interfacing to a command line revision control system, or running an external tool on the

selected file.

Adding a command line command or batch file to the Tools menu:

Type or browse to the cmd . exe command shell in the Command text box.

75



Reference information on the IDE

76

New

Delete

Menu Content

Menu Text

Command

Argument

Initial Directory

Type the command line command or batch file name in the Argument text box as:
/C name
where name is the name of the command or batch file you want to run.

The /c option terminates the shell after execution, to allow the IDE to detect when the
tool has finished.

For an example, see Adding command line commands to the Tools menu, page 35.

Creates a stub for a new menu command for you to configure using this dialog box.

Removes the command selected in the Menu Content list.

Lists all menu commands that you have defined.

Specify the name of the menu command. If you add the & sign anywhere in the name,
the following letter, N in this example, will appear as the mnemonic key for this
command. The text you specify will be reflected in the Menu Content list.

Specify the tool and its path, to be run when you choose the command from the menu.
A browse button is available for your convenience.

Optional: Specify an argument for the command.

Specify an initial working directory for the tool.

Redirect to Output window

Makes the IDE send any console output from the tool to the Tool Output page in the
message window. Tools that are launched with this option cannot receive any user input,
for instance input from the keyboard.

Tools that require user input or make special assumptions regarding the console that they
execute in, will not work at all if launched with this option.

IDE Project Management and Building Guide
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Prompt for Command Line
Makes the IDE prompt for the command line argument when the command is chosen
from the Tools menu.
Tool Available
Specifies in which context the tool should be available. Choose between:
o Always

o When debugging
o When not debugging.

Configure Viewers dialog box

The Configure Viewers dialog box is available from the Tools menu.

Configure Yiewers [ %]
Extensions | Ackion | Ok I
Explorer Default
.htm Explorer Default Cancel |

Mew. ..

Edit...

Ui

Remave

This dialog box lists overrides to the default associations between the document formats
that JAR Embedded Workbench can handle and viewer applications.

Display area
This area contains these columns:

Extensions
Explicitly defined filename extensions of document formats that IAR
Embedded Workbench can handle.

Action

The viewer application that is used for opening the document type. Explorer
Default means that the default application associated with the specified type in
Windows Explorer is used.

New

Displays the Edit Viewer Extensions dialog box; see Edit Viewer Extensions dialog
box, page 78.
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Edit

Delete

Displays the Edit Viewer Extensions dialog box; see Edit Viewer Extensions dialog
box, page 78.

Removes the association between the selected filename extensions and the viewer
application.

Edit Viewer Extensions dialog box

The Edit Viewer Extensions dialog box is available from the Configure Viewers

dialog box.
Edit Yiewer Extensions [ %]
File name extensians:
| bl
Cancel |
Action

€ Buile-in text editor
& st file explorer associations

 Command line

| |

Use this dialog box to specify how to open a new document type or edit the setting for
an existing document type.

File name extensions

Action

Specify the filename extension for the document type—including the separating
period (.).

Selects how to open documents with the filename extension specified in the Filename
extensions text box. Choose between:
Built-in text editor
Opens all documents of the specified type with the IAR Embedded Workbench
text editor.
Use file explorer associations

Opens all documents of the specified type with the default application
associated with the specified type in Windows Explorer.

IDE Project Management and Building Guide
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Command line

Opens all documents of the specified type with the viewer application you type
or browse your way to. You can give any command line options you would like
to the tool, for instance ....

Filename Extensions dialog box

The Filename Extensions dialog box is available from the Tools menu.

Taol chain

Cancel
Edit...

Use this dialog box to customize the filename extensions recognized by the build tools.
This is useful if you have many source files with different filename extensions.

qu

Toolchain
Lists the toolchains for which you have an IAR Embedded Workbench installed on your
host computer. Select the toolchain you want to customize filename extensions for.
Note the * character which indicates user-defined overrides. If there is no * character,
factory settings are used.

Edit

Displays the Filename Extension Overrides dialog box; see Filename Extension
Overrides dialog box, page 80.
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Filename Extension Overrides dialog box

The Filename Extension Overrides dialog box is available from the Filename
Extensions dialog box.

Filename Extension Overrides

Tool Factory Setting Override QK
C/C++ Com... <Maone

Azzembler <Maone
Output Con.... <Mones

Browse Info... <Maone

Linker <Maone
Library Builder <Mones

Browse Info... <Maone

This dialog box lists filename extensions recognized by the build tools.

Display area
This area contains these columns:

Tool
The available tools in the build chain.

Factory Setting
The filename extensions recognized by default by the build tool.

Override

The filename extensions recognized by the build tool if there are overrides to the
default setting.

Edit

Displays the Edit Filename Extensions dialog box for the selected tool.

IDE Project Management and Building Guide
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Edit Filename Extensions dialog box

Factory setting

Override

The Edit File Extensions dialog box is available from the Filename Extension
Overrides dialog box.

Edit Filename Extensions

Factaory setting

I.c:;.c:c:;.c:pp QK I
¥ Overide Cancel |
I.c;.cc;.cpp

This dialog box lists the filename extensions recognized by the IDE and lets you add
new filename extensions.

Lists the filename extensions recognized by default.

Specify the filename extensions you want to be recognized. Extensions can be separated
by commas or semicolons, and should include the leading period.

Product Info dialog box

The Product Info dialog box is available from the Help menu.
i o 25

# ° Product Info (overview)

Product Version Close

IAR Embedded Workbench for CPUNAME 7.60.1.11216 W
IAR. Embedded Workbench shared components 7.4.0.4219

-

Copyright 2002-2016 IAR Systems AB.

L5 S

This dialog box lists the version number of your IAR Embedded Workbench product
installation and the shared components. Note that the initial digit of the version number
of the shared components (in this screen shot 7) is reflected by the default installation
directory x: \Program Files\IAR Systems\Embedded Workbench 7.n\.
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Details

Argument variables

Opens a dialog box which lists the version numbers of the various components part of
your product installation.

You can use argument variables for paths and arguments, for example when you specify
include paths in the Options dialog box or whenever there is a need for a macro-like
expansion that depends on the current context, for example in arguments to tools. You
can use a wide range of predefined argument variables as well as create your own, see
Configure Custom Argument Variables dialog box, page 83. These are the predefined
argument variables:

Variable

Description

$COMPILER_ARGSS

$CONFIG_NAMES

$SCUR_DIRS
$CUR_LINES
$DATES

$EW_DIRS

$EXE_DIRS
$FILE_BNAMES
$FILE_BPATHS
$FILE_DIRS
$FILE_FNAMES
$FILE_PATHS
$LIST DIRS
$OBJ_DIRS
$PROJ_DIRS
$PROJ_FNAMES

$PROJ_PATHS

All compiler options except for the filename that is used when
compiling using the compiler. Note that this argument variable is
restricted to the Arguments text box in the External Analyzer
dialog box.

The name of the current build configuration, for examp